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ModelSim g
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raphic interface

While your operating system interface provides the window-management frame,
Model Sim controls all internal-window features including menus, buttons, and scroll bars.
The resulting simulator interface remains consistent within these operating systems:

SPARCstation with OpenWindows, OSF/Matif, or CDE

IBM RISC System/6000 with OSF/M otif

Hewlett-Packard HP 9000 Series 700 with HP VUE, OSF/Motif, or CDE
Redhat Linux with KDE or GNOME

Microsoft Windows 98/Me/NT/2000/XP

Because Model Sim’ s graphic interfaceisbased on Tcl/TK, you also have the toolsto build
your own simulation environment. Preference variables and configuration commands (see
"Preference variables located in INI files' (um-617) for details) give you control over the
use and placement of windows, menus, menu options, and buttons. See "Tcl and macros
(DO files)" (um-591) for more information on Tcl.

For anin-depth look at Model Sim’ sgraphicinterface, see Chapter 10- Graphicinterface.



ModelSim modes of operation

ModelSim modes of operation

Many users run Model Sim interactively—pushing buttons and/or pulling down menusin a
series of windows in the GUI (graphic user interface). But there are really three modes of
Model Sim operation, the characteristics of which are outlined in the following table.:

Model Sim use mode

Characteristics

How ModelSimisinvoked

GUI

interactive; has graphical
windows, push-buttons,
menus, and acommand linein
the transcript.

Default mode.

viaadesktop icon or from the OS command shell

prompt. Example:

OS> vsim

Command-line

interactive command line; no
GUI.

with -c argument at the OS command prompt. Example:

OS> vsim-c¢

Batch

non-interactive batch script;
no windows or interactive
command line.

at OS command shell prompt using "here document”
technique or redirection of standard input. Example:

C:\nodel tech> vsimvfiles.v <infile >outf

e

The Model Sim User’ s Manual focuses primarily on the GUI mode of operation. However,
this section provides an introduction to the Command-line and Batch modes.

Command-line mode

In command-line mode M odel Sim executes any startup command specified by the Startup
(UM-625) variable in the modelsim.ini file. If vaim (CR-357) isinvoked with the -do
<"command_string" > option, aDO file (macro) is called. A DO file executed in this
manner will override any startup command in the modelsim.ini file.

During simulation atranscript fileis created containing any messagesto stdout. A transcript
file created in command-line mode may be used asa DO file if you invoke the transcript
on command (CR-278) after the design loads (see the example below). The transcript on
command writes all of the commands you invoke to the transcript file. For example, the

following series of commandsresultsin atranscript file that can be used for command input
if top isre-simulated (remove the quit -f command from the transcript file if you want to

remain in the simulator).

vsim-c top

library and design |oading messages... then execute:

transcript on

force clk 1 50, 0 100 -repeat 100

run 500
run @000
quit -f

Rename transcript filesthat you intend to useas DO files. They will be overwritten the next
time you run vsim if you don’t rename them. Also, simulator messages are a ready
commented out, but any messages generated from your design (and subsequently written
to the transcript file) will cause the simulator to pause. A transcript file that contains only
valid simulator commands will work fine; comment out anything else with a"#".

UM-23
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Batch mode
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Stand-alonetools pick up project settings in command-line mode if they are invoked in the
project's root directory. If invoked outside the project directory, stand-alone tools pick up
project settings only if you set the MODEL SIM environment variable to the path to the
project file (<Project_Root_Dir>/<Project_Name>.mpf).

Batch mode is an operational mode that provides neither an interactive command line nor
interactive windows. In aUNIX environment, vsim can be invoked in batch mode by
redirecting standard input using the “ here-document” technique. In aWindows
environment, vsim is run from a Windows command prompt and standard input and output
arere-directed from and to files.

Hereis an example of the "here-document” technique:

vsimtop <<
log -r *
run 100

do test.do
quit -f

|

Hereis an example of abatch mode simulation using redirection of std input and output:

c:\nodel tech\vsimcounter < yourfile > outfile

where "yourfile" is a script containing various Model Sim commands.
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Standards supported

ModelSim VHDL implements the VHDL language as defined by |EEE Standards
1076-1987, 1076-1993, and 1076-2002. Model Sim also supports the 1164-1993 Standard
Multivalue Logic Systemfor VHDL Interoperability, and the 1076.2-1996 Standard VHDL
Mathematical Packages standards. Any design developed with Model Sim will be
compatible with any other VHDL system that is compliant with the 1076 specs.

Model Sim Verilog implementsthe V eril og language as defined by the | EEE Std 1364-1995
and 1364-2001. Model Sim Verilog also supports a partial implementation of System
Verilog 3.1, Accellera’ s Extensions to Verilog® (see/<install_dir>/modeltech/docs/
technotes/svlog.note for implementation details). The Open Verilog International Verilog
LRM version 2.0 is also applicable to alarge extent. Both PLI (Programming Language
Interface) and VCD (Vaue Change Dump) are supported for Model Sim PE and SE users.

In addition, all products support SDF 1.0 through 3.0, VITAL 2.2b, VITAL'95 — IEEE
1076.4-1995, and VITAL 2000 — |EEE 1076.4-2000.

Model Sim implements the SystemC language based on the Open SystemC Initiative
(OSCI) SystemC 2.0.1 reference simulator.

Assumptions

We assume that you are familiar with the use of your operating system and its graphic
interface.

We also assume that you have aworking knowledge of VHDL, Verilog, and/or SystemC.
Although Model Sim isan excellent tool to use whilelearning HDL concepts and practices,
this document is not written to support that goal.

Finally, we assume that you have worked the appropriate |essonsin the Model Sm Tutorial
and are familiar with the basic functionality of ModelSim. The ModelSm Tutorial is
availablefrom the Model Sim Help menu. The Model Sm Tutorial isalso availablefromthe
Support page of our web site: www.model.com.
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Sections in this document
In addition to thisintroduction, you will find the following major sectionsin this document:

2 - Projects (UM-31)
This chapter discusses Model Sim "projects’, a container for design files and their
associated simulation properties.

3 - Design libraries (UMm-53)
To simulate an HDL design using Model Sim, you need to know how to create,
compile, maintain, and delete design libraries as described in this chapter.

4 - VHDL simulation (UM-71)
This chapter is an overview of compilation and simulation for VHDL within the
Model Sim environment.

5 - Verilog simulation (UM-105)
This chapter is an overview of compilation and simulation for Verilog within the
Model Sim environment.

6 - Verilog PLI / VPI (UM-153)
This chapter describes the Model Sim implementation of the Verilog PLI and VPI.

7 - SystemC simulation (UM-187)
This chapter is an overview of preparation, compilation, and simulation for SystemC
within the Model Sim environment.

8 - Mixed-language simulations (UM-209)
This chapter outlines data mapping and the criteria established to instantiate design
units between VHDL, Verilog, and SystemC.

9 - WLFfiles (datasets) and virtuals (UM-239)
Thischapter describes datasets and virtuals - both methods for viewing and organizing
simulation datain Model Sim.

10- Graphic interface (UM-253)
This chapter describes the graphic interface available while operating Model Sim.
Model Sim’s graphic interface is designed to provide consistency throughout all
operating system environments.

11 - Performance Analyzer (UM-407)
This chapter describes how the Model Sim Performance Analyzer is used to easily
identify areas in your simulation where performance can be improved.

12 - Code Coverage (UM-419)
Thischapter describesthe Code Coverage feature. Code Coverage givesyou graphical
and report file feedback on how the source code is being executed.

13 - Waveform Compare (UM-455)
This chapter describes Waveform Compare, afeature that lets you compare simulations.
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14 - C Debug (UM-473)
This chapter describes C Debug, a graphic interface to the gdb debugger that can be used
to debug FLI/PLI/VPI/SystemC C/C++ source code.

15 - PSL Assertions (UM-493)
This chapter describes how to simulate and debug with PSL assertions.

16 - Signal Spy (UM-523)
Thischapter describes Signal Spy, aset of VHDL proceduresand Verilog system tasks
that let you monitor, drive, force, or release an item from anywhere in the hierarchy of
aVHDL or mixed design.

17 - Standard Delay Format (SDF) Timing Annotation (UM-543)
This chapter discusses Model Sim’ simplementation of SDF (Standard Delay Format)
timing annotation. Included are sectionson VITAL SDF and Verilog SDF, plus
troubleshooting.

18 - Value Change Dump (VCD) Files (UM-559)
This chapter explains Model Technology’s Verilog VCD implementation for
ModelSim. The VCD usage is extended to include VHDL designs.

19 - Logic Modeling SmartM odels (UM-575)
This chapter describes the use of the SmartModel Library and SmartModel Windows
with ModelSm.

20 - Logic Modeling hardware models (UM-585)
This chapter describes the use of the Logic Modeling Hardware Modeler with
ModelSim.

21 - Tcl and macros (DO files) (UM-591)
This chapter provides an overview of Tcl (tool command language) as used with
ModelSim.

A - ModelSim variables (UM-611)
This appendix describes environment, system, and preference variables used in
ModelSim.

B - Model Sim shortcuts (UM-637)
This appendix describes Model Sim keyboard and mouse shortcuts.

C - Model Sim messages (UM-645)
This appendix describes Model Sim error and warning messages.

D - System initialization (UM-655)
This appendix describes what happens during Model Sim startup.

UM-27

ModelSim SE User’s Manual



UM-28 1 - Introduction

What is an "ltem"

Because Model Sim works with VHDL, Verilog, and System C, an “item” refersto any
valid design element in VHDL, Verilog, or SystemC. Theword "item" isused whenever a
specific language reference is not needed. Depending on the context, “item” can refer to

any of the following:

VHDL block statement, component instantiation, constant, generate
statement, generic, package, signal, alias, or variable

Verilog function, module instantiation, named fork, named begin, net,
task, register, or variable

SystemC module instantiation, named fork, named begin, net, task,
register, or variable

Text conventions

Text conventions used in this manual include:

italic text

provides emphasis and sets off filenames, pathnames, and
design unit names

bold text

indicates commands, command options, menu choices,
package and library logical names, aswell as variables,
dialog box selections, and language keywords

monospace type

monospace typeisused for program and command examples

The right angle (>)

is used to connect menu choices when traversing menus as
in: File> Quit

path separators

examples will show either UNIX or Windows path
separators - use separators appropriate for your operating
system when trying the examples

UPPER CASE

denotes file types used by ModelSim (e.g., DO, WLF, INI,
MPF, PDF, etc.)
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Where to find our documentation

Where to find our documentation UM-29

Model Sim documentation is available from our website at www.model.com/support or in

the following formats and locations:

Document Format How to get it

ModelSmSEInstallation& | paper shipped with ModelSm

Licensing Guide

PDF select Main window > Help > SE Documentation; also available
from the Support page of our web site: www.model.com

ModelSm SE Quick Guide | paper shipped with ModelSm

(command and feature
quick-reference)

PDF select Main window > Help > SE Documentation, also available
from the Support page of our web site: www.model.com

ModelSm SE Tutorial PDF, HTML | select Main window > Help > SE Documentation; also available
from the Support page of our web site: www.model.com

ModelSm SE User’s PDF, HTML | select Main window > Help > SE Documentation

Manual

Model Sm SE Command PDF, HTML | select Main window > Help > SE Documentation

Reference
Foreign Language PDF, HTML | select Main window > Help > SE Documentation
Interface Reference
Std_DevelopersKit User's PDF www.model.com/support/documentation/BOOK /sdk _um.pdf
Manual
The Standard Developer’s Kit is for use with Mentor Graphics
QuickHDL.
Command Help ASCII typehel p [ conmand name] at the prompt in the Main window
Error message help ASCII typeverror <msgNume at the Main window or shell prompt
Tcl Man Pages (Tcl HTML select Main window > Help > Tcl Man Pages, or find
manual) contents.htm in \modeltech\docs\tcl_help_htm
Technotes HTML select Technotes dropdown on www.model.com/support

Download a free PDF reader with Search

Model Technology’s PDF documentation requires an Adobe Acrobat Reader for viewing.
The Reader may beinstalled from the Model Sim CD. It isalso available without cost from
Adobe at www.adobe.com. Be sure to download the Acrobat Reader with Search to take

advantage of the index file supplied with our documentation; the index makes searching for

keywords much faster.
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Technical support and updates

Support

Model Technology online and email technical support options, maintenancerenewal, and
linksto international support contacts:
www.model .com/support/default.asp

Mentor Graphics support:
www.mentor.com/supportnet

Updates

Access to the most current version of Model Sim:
www.model.com/downloads/default.asp

Latest version email

Place your name on our list for email notification of news and updates:
www.model.com/products/informant.asp
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2 - Projects

Chapter contents

Introduction . . . . . . . . . . . . . . . .UM-32
What areprojects?. . . . . . . . . . . . . .UM-32
What are the benefits of projects?. . . . . . . . . .UM-32
Project conversion betweenversons. . . . . . . . .UM-33

Getting started with projects . . . . . . . . . . . .UM-34
Step 1 — Creatinganewproject . . . . . . . . . .UM-34
Step 2— Adding itemsto theproject. . . . . . . . .UM-35
Step 3— Compiling thefiles. . . . . . . . . . .UM-35
Step 4 — Simulatingadesign. . . . . . . . . . .UM-35
Other basic project operations. . . . . . . . . . .UM-39

TheProjecttsb. . . . . . . . . . . . . . . .UM-40
Sorting thelist. . . . . . . . . . . . . . .UM-40
Projecttabcontextmenu . . . . . . . . . . . .UM-41

Changing compileorder . . . . . . . . . . . . .UM-42
Auto-generating compileorder . . . . . . . . . .UM-42
Grouping files. . . . . . . . . . . . . . .UM-43

Creating a Simulation Configuration . . . . . . . . . .UM-4

Organizing projectswithfolders . . . . . . . . . . .UM-46

Specifying file properties and project settings. . . . . . . .UM-48
Filecompilation properties . . . . . . . . . . .UM-48
Project settings . . . . . . . . . . . . . .UM-49

Accessing projectsfrom thecommandline . . . . . . . .UM-51

This chapter discusses Model Sim projects. Projects simplify the process of compiling and
simulating adesign and are a great tool for getting started with Model Sim.
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Introduction

What are projects?

Projects are collection entities for HDL/SystemC designs under specification or test. At a
minimum, projects have aroot directory, awork library, and "metadata’ which are stored
ina.mpf filelocated in a project's root directory. The metadata include compiler switch
settings, compile order, and file mappings. Projects may also include:

» HDL and SystemC source files or references to source files
* other files such as READMEs or other project documentation

local libraries
* referencesto global libraries

Simulation Configurations (see "Creating a Simulation Configuration” (UM-44))

Folders (see "Organizing projects with folders" (UMm-46))

A | mportant: Project metadata are updated and stored only for actions taken within the
project itself. For example, if you have afilein aproject, and you compilethat file from
the command line rather than using the project menu commands, the project will not
update to reflect any new compile settings.

What are the benefits of projects?

Projects offer benefits to both new and advanced users. Projects

» simplify interaction with Model Sim; you don’t need to understand the intricacies of
compiler switches and library mappings

* eliminate the need to remember a conceptual model of the design; the compile order is
maintained for you in the project. Compile order is maintained for HDL-only designs.

* remove the necessity to re-establish compiler switches and settings at each session; these
are stored in the project metadata as are mappings to HDL/SystemC source files

« alow usersto share libraries without copying filesto alocal directory; you can establish
references to source files that are stored remotely or locally

« alow you to changeindividual parameters across multiplefiles; in previousversionsyou
could only set parameters onefile at atime

* enable"what-if" analysis; you can copy a project, manipulate the settings, and rerun it to
observe the new results

* reload the initial settings from the project .mpf file every time the project is opened
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Project conversion between versions

Projects are generally not backwards compatible for either number or letter rel eases. When
you open aproject created in an earlier version (e.g, you’ re using 5.6 and you open aproject
created in 5.5), you' |l see amessage warning that the project will be converted to the newer
version. Y ou have the option of continuing with the conversion or cancelling the operation.

As stated in the warning message, a backup of the original project is created before the
conversion occurs. The backup fileis named < project name>.mpf.bak and is created in the
same directory in which the original project islocated.

P Note: Due to the significant changes, projects created in versions prior to 5.5 cannot be
converted automatically. If you created a project in an earlier version, you will need to
recreate it in versions later than 5.5. With the new interface even the most complex
project should take less than 15 minutes to recreate. Follow the instructionsin the
ensuing pages to recreate your project.
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Getting started with projects
This section describes the four basic steps to working with a project.

Step 1 — Creating a new project (UM-34)
This creates a.mpf file and aworking library.

Step 2 — Adding items to the project (UM-35)

Projects can reference or include HDL/SystemC source files, folders for organization,
simulations, and any other filesyou want to associate with the project. Y ou can copy files
into the project directory or simply create mappings to filesin other locations.

Step 3 — Compiling the files (UM-38)
This checks syntax and semantics and creates the pseudo machine code Model Sim uses
for simulation.

Step 4 — Simulating a design (UM-39)

This specifies the design unit you want to simulate and opens a structure tab in the Main
window workspace.

Step 1 — Creating a new project
Select File> New > Proj ect (Main window) to create anew project. Thisopensthe Create
Project diaog.

Create Projeck |

— Project Hame
|test

— Project Location

|E: /modeltech/eramples Browse. .. |

—Default Library Mame

|wu:|rk

] | Eancell

The dialog includes these options:

* Project Name
The name of the new project.

» Project Location
The directory in which the .mpf file will be created.
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» Default Library Name
Thename of theworking library. See"Working library versusresourcelibraries” (UM-54)
for more details on work libraries. Y ou can generally leave the Default Library Name
set to "work." The name you specify will be used to create aworking library subdirectory
within the Project Location.

After selecting OK, you will see ablank Project tab in the workspace area of the Main
window and the Add Itemsto the Project diaog.

IE]'r‘-h:m:h‘:lﬁim : =10 =]
File Edit Miew Compile Simulate Tools  Window  Help :
; S Add items ko the Project Ihe ElE
s || % Add items to the Project
| - ke ! @ @ — Click on the icon to add items of that bype:——

([¥]
T

Workspace

TIName ISte IType )D D I
workspace

\ Create New File Add Exizting File

Create Simulation Create Mew Folder

<] I v Cloze |

Froject | Library | =

The name of the current project is shown at the bottom left corner of the Main window.

Step 2 — Adding items to the project

The Add Itemsto the Project dialog includes these options:

» Create New File
Create anew VHDL, Verilog, SystemC, Tcl, or text file using the Source window. See
below for details.

* Add Existing File
Add an existing file. See below for details.
» Create Simulation

Create a Simulation Configuration that specifies source files and simulator options. See
"Creating a Simulation Configuration™ (UM-44) for details.

» Create New Folder
Create an organization folder. See "Organizing projects with folders' (um-46) for details.

UM-35
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Create New File

The Create New File command lets you create anew VHDL, Verilog, SystemC, Tcl, or
text file using the Source window. Y ou can a so access this command by selecting File >
Add to Project > New File (Main window) or right-clicking (2nd button in Windows; 3rd
button in UNIX) in the Project tab and selecting Add to Project > New File.

Create Project File £

— File Hame

|f|:n:|.v Browse. . |

— Addfile az type————— Falder
|‘-.r‘eri||:|g ZI ’7IT op Level ZI

] | Eancell

The Create Project File dialog includes these options:

* File Name
The name of the new file.

» Add fileastype
The type of the new file. Select VHDL, Verilog, SystemC, TCL, or text.

» Folder
The organization folder in which you want the new file placed. Y ou must first create
foldersin order to access them here. See "Organizing projects with folders" (um-46) for
details.

When you select OK, the fileislisted in the Project tab of the Main window workspace.
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Add Existing File

Y ou can also access this command by selecting File > Add to Project > Existing File
(Main window) or by right-clicking (2nd button in Windows; 3rd button in UNIX) in the
Project tab and selecting Add to Project > Existing File.

Add file to Projeck |

— File Hame

|tcu:uunter.\-' counter.y Browse. . |

—Add file az type Folder
|default EI ’;:up Lewvel ZI

{* Feference from current locatiors © iCopy to project direchong

k. | Eann::ell

The Add fileto Project dialog includes these options:

File Name
The name of the file to add. Y ou can add multiple files at one time.

Add file astype
The type of thefile. "Default” assigns type based on the file extension (e.g., .vistype
Verilog).

Folder

The organization folder in which you want the file placed. Y ou must first create folders
in order to access them here. See "Organizing projects with folders" (um-46) for details.

Reference from current location/Copy to project directory
Choose whether to referencethefile from its current location or to copy it into the project
directory.

When you select OK, the file(s) islisted in the Project tab of the Main window workspace.

UM-37
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Step 3 — Compiling the files

The question marks next to the files in the Project tab denote either the files haven't been
compiled into the project or the source has changed since the last compile. To compile the
files, select Compile > Compile All (Main window) or right click in the Project tab and

select Compile > Compile All.

lﬁ]‘lﬂu:m:h‘_ISim 10| x|
File Edit Miew Compile Simulate Tools  indow  Help
=B | smgs
Workzpace x|
*|N st |1 0 |k fist
I L I I LES o | ModelSims
: o o Edit
il ter. el
counter v ? erilog e
Compile L4 Compile Selected
Simat ) Cooieal ]
Add to Project L4 Compile Out-of-Date
Remove from Project Compile Order. .
Cloze Project Compile Report..
: Compile Summary...
Properties. ..
1 | | Project Settings... Compile Properties. ..
Praject | Library J| d
‘F’rnjen:t : test |<N|:| Design Loaded= |<N|:| Context= o

Oncecompilationisfinished, click the Library tab, expand library work by clicking the"+",
and you will see the compiled design units.

ﬁMDdElSin‘l ] |
File Edit Wiew Compile Simulate Tools window  Help
|zam|emg=

Wwiorkspace x|

TI P I Type I Path i AL D:nmpile of tocounter.v was successiul, ik

# Compile of counter.v was successiul,
= work Librany C:/modeltech. # 2 compiles, O failed with no emrors.
%J counter Module C:/Modeltech M )
[ test_counter fodule C:/Modeltech odelSim:

[Il wital2000 Libramy $WODEL_TEI

J:Il ieee Libramn $MODEL_TEL

.[Il modelzim_lib Libran $MODEL_TEL

m ztd Libramy FMODEL_TEL

m std_developerskit Library $MODEL_TEL

m PR 1 b e thAMMEL TES j

| | 3

Froject | Library 3
|F'rc:jeu:t : test |c:N|:| Design Loaded:> |<ND Contexts> /;
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Step 4 — Simulating a design

To simulate one of the designs, either double-click the name or right-click the name and
select Simulate. A new tab named sim appears that shows the structure of the active
simulation.

IE:|'r"h:n:lf_-l5in1 -0 =|
File Edit Wiew Compile Simulate  Tools  “Window  Help

2R || S || 4 onElEE B

Wirkzpace Xl :
¥ it Dosianurd 10| ||#09/24/2003 05:504M  <DIR> . =
|instance |Design uri_| # 09/04/2003 0734 PM 1,024 counter. v
te=s=t_':=':"-4r'lter e | |# 09/04/2003 07:34 P 358 tcounter. v
o dut caunter M| H 2 Filelz) 1,382 bytes
# 2 Dirfz] 15,339,933,696 bytes free

# Loading project test

# Compile of tcounter.y was successiul,
# Compile of counter. v waz successiul.
# 2 compiles, 0 failed with no ermrars.
wim work.test_counter

# waim work. test_counter

# Loading work. test_counter

# Loading work. counter

1 I | _,I
[F'ru:uieu:tl Library | =im FiIesJ WSIM 11 | =
[ R R 8 R R WA

At this point you are ready to run the simulation and analyze your results. Y ou often do this
by adding signals to the Wave window and running the simulation for a given period of
time. See the Model Sm Tutorial for examples.

Other basic project operations

Open an existing project

If you previoudly exited Model Sim with aproject open, Model Sim automatically will open
that same project upon startup. Y ou can open adifferent project by selecting File > Open
> Project (Main window).

Close a project

Select File > Close > Project (Main window) or right-click in the Project tab and select
Close Project. Thisclosesthe Project tab but leavesthe Library tab open in the workspace.
Note that you cannot close a project while asimulation isin progress.

Delete a project
Select File> Delete > Project (Main window). Y ou cannot delete a project whileit isopen.
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The Project tab

The Project tab contains information about the itemsin your project. By default thetabis
divided into five columns.

ﬁMDdElSin‘l ;|g|5|
File Edit View Compile Simulake Toaols  Window  Help
|s@a || suas
“workspace Ed|
"I R | S | Type | 0 | M adified # Comnpile of toounter. v was successful, =
- # Compile of counter. v waz succeszsful,
EH_1 ¥HDL files Falder # 2 compiles, 0 failed with no errors.
adder.vhd o WHDL 3 090403207 _
testadder. vhd 2 WHDL 2 09/04/03 07 ||ModelSime
EH ] Werlog files Folder
toounter. v " Werlog 0 071703 06"
counter.y " Werlog 1 05/20/0312:5
¥y erilog_sim Sirmulation
o T
Project | Libran j
|F'rn:ujen:t : test |<:N|:| Design Loaded= |<:N|:| Context= -

Sorting the list

Name — The name of afile or object.

Status — Identifies whether a source file has been successfully compiled. Appliesonly to
VHDL or Verilog files. A question mark meansthefile hasn’t been compiled or the source
file has changed since the last successful compile; an X means the compile failed; acheck
mark means the compile succeeded; a checkmark with ayellow triangle behind it means
the file compiled but there were warnings generated.

Type—Thefile type as determined by registered file types on Windows or the type you
specify when you add the file to the project.

Order — The order in which the file will be compiled when you execute a Compile All
command.

M odified — The date and time of the last modification to the file.

Y ou can hide or show columns by right-clicking on a column title and selecting or
deselecting entries.

Y ou can sort thelist by any of the five columns. Click on a column heading to sort by that
column; click the heading again to invert the sort order. An arrow in the column heading
indicates which field the list is sorted by and whether the sort order is descending (down
arrow) or ascending (up arrow).
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The Project tab

Like the other workspace tabs, the Project tab has a context menu that you access by
clicking your right mouse button (2nd button in Windows; 3rd button in UNIX) anywhere
in the tab. The context menu has the following commands:

Edit

open the selected file in an editor

Execute

execute the selected Verilog, VHDL, WLF, or DO file

Compile

provides these options:

Compile Selected — compile the selected file(s); note that if you select a
folder and select Compile Selected, it will compile al filesin the folder
and any sub-folders

Compile All —compile all sourcefilesincluded in the project

Compile Out-of-Date — compile source files that have been modified
since the last compile

Compile Order — set compile order for al filesin the project; see
"Changing compile order" (um-42) for more details. Compile Order isnot
supported for SystemC files.

Compile Report — show the compilation history of the selected file
Compile Summary — show the compilation history of the entire project
Compile Properties — view/change project compiler settings for the
selected source file(s)

Simulate

load the design unit(s) and associated simulation options from the
selected Simulation Configuration; see "Creating a Simulation
Configuration" (Um-44) for more details

Addto
Project

provides these options:

New File —add anew file to the project

Existing File — add an existing file to the project

Simulation Configuration — create anew Simulation Configuration; see
"Creating a Simulation Configuration" (um-44) for more details

Folder — add an organization folder to the project; see "Organizing
projects with folders' (uM-46) for more details

Remove
from Project

remove the selected item from the project

Close
Project

close the active project

Properties

view/change compiler settings for the selected source file(s)

Project
Settings

change settings for the project; see "Project settings” (UM-49)

UM-41
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Changing compile order

The Compile Order dialog box isfunctional for HDL-only designs. When you compile all
filesin aproject, Model Sim by default compiles the files in the order in which they were
added to the project. Y ou have two aternatives for changing the default compile order: 1)
select and compile each file individually; 2) specify a custom compile order.

To specify a custom compile order, follow these steps:

1 Select Compile > Compile Order (Main window) or select it from the context menuin
the Project tab.

Compile Order A
— Current Order

E TNEMOIY.
[ui] proc.y
;_,'j cache. v
;_ﬁl andz2 vhd
@ zet vhd

5] Ut vhd ad
;_ﬁl top.whd

‘ ] X7

Bt Eeneratel ........ I:Ikl Cancel

2 Dragthefilesinto the correct order or use the up and down arrow buttons. Note that you
can select multiple files and drag them simultaneoudly.

Auto-generating compile order

Auto Generate is supported for HDL-only designs. The Auto Gener ate button in the
Compile Order dialog (see above) "determines’ the correct compile order by making
multiple passes over the files. It starts compiling from the top; if afile failsto compile due
to dependencies, it moves that file to the bottom and then recompilesit after compiling the
rest of the files. It continues in this manner until all files compile successfully or until a
file(s) can't be compiled for reasons other than dependency.

Files can be displayed in the Project tab in al phabetical or compile order (using the Sort by
Alphabetical Order or Sort by Compile Order commands on the context menu). Keep
in mind that the order you see in the Project tab is not necessarily the order in which the
fileswill be compiled.
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Grouping files

Y ou can group two or more files in the Compile Order dialog so they are sent to the
compiler at the same time. For example, you might have one file with a bunch of Verilog
define statements and a second file that is a Verilog module. Y ou would want to compile
these two files together.

To group files, follow these steps:

1 Select the files you want to group.

Compile Order |

—Current Order

and2.vhd i
zet.vhd -
@ util. whd

;_,_'fl top.whd
K
Ar
<| [»]

Bt Eeneratel Ok | Cancel |

. 1" |
2 Click the Group button. H

. . L |
To ungroup files, select the group and click the Ungroup button. !
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Creating a Simulation Configuration

A Simulation Configuration associates a design unit(s) and its simulation options. For
example, say you routinely load a particular design and you have to specify the simulator
resolution, generics, and SDF timing files. Ordinarily you would have to specify those
optionseach timeyou load the design. With a Simulation Configuration, you would specify
the design and those options and then save the configuration with aname (e.g., top_config).
The name is then listed in the Project tab and you can double-click it to load the design
along with its options.

To create a Simulation Configuration, follow these steps:

1 Select File> Add to Project > Simulation Configuration (Main window) or select it
from the context menu in the Project tab.

: |
— Simulation Configuration Hame Flace in Folder—————
|Simulatinn 1 ’F:up Leswvel ZI
Diesign | WHOL | Yerilog | Libraries | SDF | Options |
"I"I M arme | Tope | Path Eest
m work, Library ok,
m wital2000 Library $MODEL_TECH/.. Avital2000
m-Ji ieee Library  $MODEL_TECH/. fieee
[Il modelzim_lib Library $MODEL_TECH,.. /modelzim_lit
=Y TEE Library  $MODEL_TECH/../std
mH[l] std_developerskit  Librany  $MODEL_TECH/./std_develo
[Il FPNOpEYs Library $MODEL_TECH/.. /synopays
J]l verilag Library  $MODEL_TECH/.. Averilog
4| | i
Simulate Fesolution
’r ’;ault ZI Dptimize |
8] 4 | Cancel |

2 Specify anamein the Simulation Configuration Name field.

3 Specify thefolder inwhichyou want to place the configuration (see " Organizing projects
with folders" (uMm-46)).

4 Select one or more design unit(s). Use the Control and/or Shift keysto select more than

one design unit. The design unit names appear in the Simulate field when you select
them.
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5 Usethe other tabsin the dialog to specify any required simulation options. All of the
optionsin this dialog are described under " Simulating with the graphic interface” (Um-

377).

Click OK and the simulation configuration is added to the Project tab.

ﬁMDdElSin‘l

=10l x|
File Edit Miew Compile Simulate Tools ‘Window Help
= BB || SHaR
Wiorkspace x|
'-I Marne I Gk I Type I 0 I b odified # Compile of teounter.y was successiul. iz
# Cornpile of counter. v waz succeszsful,
Folder # 2 compiles, O failed with no emors.
* WHDL 3 09404403 OF:2 )
< WHDL 2 oo/04/3 o7 ||ModelSime
Folder
«  Mellog 0 07A17/03 06
Verlog 1 05/2040312F
Sirnulation
‘ T H
Project | Library d
|F'r|:|jeu:t . test |<:N|:| Design Loaded= |<:N|:| Context= -

Double-click the Simulation Configuration item to load it.
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Organizing projects with folders

The more files you add to a project, the harder it can be to locate the item you need. Y ou
can add "folders" to the project to organize your files. These folders are akin to directories
in that you can have multiple levels of folders and sub-folders. However, no actual

directories are created via the file system—the folders are present only within the project

file.

Adding a folder

To add afolder to your project, select File> Add to Project > Folder or right-click in the

Project tab and select Add to Project > Folder.

— Folder Hame

— Folder Location

|T|:|p Level ZI

] | Eancell

Specify the Folder Name, the location for the folder, and click OK. The folder will be

displayed in the Project tab.

ﬁMDdE'SiI‘I‘I
File Edit Yew Compile Simulate Tools window  Help

=10l x|

SRR &g

Workspace ]
'-I fie | St I Type I o I b i # Compile of teaunter.y was sucoesshul, i
H# Compile of counter.y waz succeszhiul,
NI | # 2 compiles, 0 failed with no eraors.
09/04/03 072 )
09/04/03 07:;| | |MedeiSim>
071703 06"
Werilog 1 05/20/0312F
Simulation
< | ]
Froject | Libram d
‘F’rnject s test |<:N|:| Design Loaded= |::N|:| Context= p
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Y ou use the folders when you add new objects to the project. For example, when you add
afile, you can select which folder to placeit in.

Add file to Projeck El

— File Mame

|tu:u:uunter.v counter Browse. .. |

— Addfile aztppe—————— Folder
||:Iefault EI ’;:up Level ZI

* Feference from curent locatio © {Copy to project directon

ak. | Cancel

If you want to move afileinto afolder later on, you can do so using the Properties dialog
for thefile (right-click on the file and select Properties from the context menu).

Project Compiler Settings r £l

General] ‘JHDL] Eaverage]

— General Settings

[T DoMot Compile  Compils to libran: Iwnrk
Place in Folder: |vHDL

CACR

— File Properties

File: stimuluz. vid
Location: C:/Modeltech_5. Fb/examplesstimuluz. vhd
t5-005 name; C:hhodeltech_5. FEhexampleshatimuluiz. vhd

Type: WHOL Change Type |

Size: 2145 [3KB)]

Modification Time;  Sat Feb 01 134728 Pacific Standard Time 2003
Lazst Compile: Source haz not been compiled.

File Attributes: Archive

k. | Eann::ell

On Windows platforms, you can also just drag-and-drop afileinto afolder.
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Specifying file properties and project settings

Y ou can set two types of propertiesin a project: file properties and project settings. File
properties affect individual files; project settings affect the entire project.

File compilation properties

ModelSim SE User’'s Manual

The VHDL and Verilog compilers (vcom and vlog, respectively) have numerous options
that affect how adesign is compiled and subsequently simulated. Y ou can customize the
settings on individual files or a group of files.

A 'mportant: Any changes you make to the compile properties outside of the project,
whether from the command line, the GUI, or the modelsim.ini file, will not affect the
properties of files already in the project.

To customize specific files, select thefile(s) in the Project tab, right click on thefile names,
and select Properties. The resulting dialog varies depending on the number and type of
filesyou have selected. If you select asingle VHDL, Verilog file, you'll see the General
tab and the VHDL or Verilog tab, respectively. If you select a SystemC file, you will see
only the General tab. On the General tab, you’ll seefile properties such as Type, Location,
and Size. If you select multiple files, the file properties on the General tab are not listed.
Finaly, if you select bothaVHDL fileand aVerilogfile, you'll see all four tabshbut nofile
information on the General tab.

Project Compiler Settings £

General] "»-"HDL] Yerilog ] Coverage ]

— Project Propertiez

[T DoMotCompile Compile to libran: |wu:|rk

e

Flace in Folder: |T|:||:| Lewvel

— File Froperties

Multiple files selected

0Ok | Ear‘u::ell

The General tab includes these options:

» Do Not Compile
Determines whether the file is excluded from the compile.

» Compiletolibrary
Specifies to which library you want to compile the file; defaults to the working library.

* Placein Folder
Specifies the folder in which to place the selected file(s). See "Organizing projects with
folders' (um-46) for details on folders.



* File Properties
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A variety of information about the selected file (e.g, type, size, path). Displaysonly if a
singlefile is selected in the Project tab.

The definitions of the options on the VHDL and Verilog tabs can be found in the section
" Setting default compileoptions” (Um-370). The definitionsfor the options on the Coverage

tab can be found in the section "Enabling Code Coverage”' (UM-423).

When setting options on a group of files, keep in mind the following:

« If two or morefiles have different settingsfor the same option, the checkbox inthe dialog
will be"grayed out." If you changethe option, you cannot changeit back to a"multi- state
setting" without cancelling out of the dialog. Once you click OK, ModelSim will set the
option the same for all selected files.

* If you select acombination of VHDL and Verilog files, the options you set on the VHDL
and Verilog tabs apply only to those file types.

Project settings

To modify project settings, right-click anywhere within the Project tab and select Pr oj ect

Settings.

Project Settings

— Compile Output

[ Display compiler autput

¥ Save compile report

— Laocation map

[T Convert pathnames to softnames

— Double-click Behawvior

File Type |"-.-"eri|n:ug

Action | Edit

~|
~|

Cuztom |

k. | Ear‘u:ell

The Project Settings dialog includes these options:

* Display compiler output

Prints verbose compile output to the Transcript. By default verbose output is produced in

the Compile Report only.

» Save compilereport

Saves verbose compile output to disk. Y ou can access the report by right-clicking afile
and selecting Compile > Compile Report.
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L ocation map

Specifieswhether physical pathsfor the project files should be saved as soft pathsif they
are present in the location map. See "Referencing source files with location maps' (UM-
66) for more detail s on using location maps.

Double-click Behavior
Specifies the action to take when you double-click atype of file. If you select Custom,
you can specify a Tcl command in the text box below the file type.

Y ou can use %f for filename substitution. For example, if you wanted double click on a
Tcl file to open the file with Notepad, you would insert the following in the text box:

not epad %

Model Sim will substitute the %f with the filename that was clicked on, then execute the
string.
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Accessing projects from the command line

Generaly, projects are used from within the Model Sim GUI. However, standal one tools
will use the project fileif they are invoked in the project's root directory. If you want to
invoke outside the project directory, set the MODEL SIM environment variable with the
path to the project file (<Project_Root_Dir>/<Project_Name>.mpf).

Y ou can a'so use the project command (CR-227) from the command line to perform
common operations on projects.
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3 - Design libraries

Chapter contents

Designlibrary overview . . . . . . . . . . . . .UM-HA4
Design unit information . . .. . . . . .UM-H4
Working library versus resource I|brar|0£ .. . . . . .UM
Archives . . . . . . . . . . . . . . . .UM55

Working with design libraries. . . . . . . . . . . .UM-56
Credtingalibrary . . . . . . . . . . . . . .UM-56
Managing library contents . . .. . . . . .UM-57
Assigning alogical name to adwgn I|brary .. . . . . .UM-B9
Movingalibrary . . . . .« . . . . . .UM-60
Setting up librariesfor groupuse. . . . . . . . . .UM-60

Specifying the resourcelibraries . . . . . . . . . . .UM-61
Verilogresourcelibraries. . . . . . . . . . . .UM-61
VHDL resourcelibraries . . . . . . . . . . . .UM-61
Predefined libraries . . .. ... . . . .UM-62
AIternateIEEEllbran&esupphed .. . . . . . . .UM-62
Rebuilding supplied libraries. . . . . . . . . . .UM-63
Regenerating your design libraries . . .. .UM-63
Maintaining 32-bit and 64-bit versionsin the samellbrary .. .UM-64

Protecting source codeandusing-nodebug . . . . . . . .UM-65

Referencing source fileswith locationmaps . . . . . . . .UM-66

Importing FPGA libraries . . . . . . . . . . . . .UM-68

VHDL contains libraries, which are objects that contain compiled design units; libraries
are given names so they may be referenced. Verilog designs simulated within Model Sim
are compiled into libraries as well.
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Design library overview

A design library is adirectory or archive that serves as arepository for compiled design
units. The design units contained in adesign library consist of VHDL entities, packages,
architectures, and configurations; Verilog modules and UDPs (user-defined primitives);

and SystemC modules. The design units are classified as follows:

* Primary design units
Consist of entities, package declarations, configuration declarations, modules, UDPs,
and SystemC modules. Primary design units within a given library must have unique
names.

» Secondary design units
Consist of architecture bodies, package bodies, and optimized V erilog modul es.
Secondary design units are associated with a primary design unit. Architectures by the
same name can exist if they are associated with different entities or modules.

Design unit information

The information stored for each design unit in adesign library is:
* retargetable, executable code

* debugging information

* dependency information

Working library versus resource libraries

Design libraries can be used in two ways: 1) as alocal working library that contains the
compiled version of your design; 2) as aresource library. The contents of your working
library will change asyou update your design and recompile. A resourcelibrary istypically
static and serves as a parts source for your design. Y ou can create your own resource
libraries, or they may be supplied by another design team or athird party (e.g., asilicon
vendor).

Only one library can be the working library. In contrast any number of libraries can be
resource libraries during a compilation. Y ou specify which resource libraries will be used
when the design iscompiled, and there are rulesto specify in which order they are searched
(see " Specifying the resource libraries' (UM-61)).

A common example of using both aworking library and aresource library is one where
your gate-level design and testbench are compiled into the working library, and the design
references gate-level modelsin a separate resource library.

The library named work has specia attributes within ModelSim; it is predefined in the
compiler and need not be declared explicitly (i.e. library work). It isaso the library name
used by the compiler asthe default destination of compiled design units(i.e., it doesn’t need
to be mapped). In other words the work library is the default working library.
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Archives

By default, design libraries are stored in a directory structure with a sub-directory for each
design unit in thelibrary. Alternatively, you can configure adesign library to use archives.
In this case each design unit is stored in its own archive file. To create an archive, use the
-ar chive argument to the vlib command (CR-344).

Generally you would do this only in the rare case that you hit the reference count limit on
I-nodes due to the ".." entriesin the lower-level directories (the maximum number of sub-
directorieson UNIX and Linux is 65533). An example of an error message that is produced
when thislimitishit is:

nmkdi r: cannot create directory "65534': Too many |inks

Archives may also have limited value to customers seeking disk space savings.
Note that GMAKE won’t work with these archives on the IBM platform.

ModelSim SE User’s Manual



UM-56 3 - Design libraries

Working with design libraries

The implementation of adesign library is not defined within standard VHDL or Verilog.
Within Model Sim, design libraries are implemented as directories and can have any legal
name allowed by the operating system, with one exception; extended identifiers are not
supported for library names.

Creating a library

When you create a project (see "Getting started with projects’ (Um-34)), ModelSim
automatically creates aworking design library. If you don’t create a project, you need to
create aworking design library before you run the compiler. This can be done from either
the command line or from the Model Sim graphic interface.

From the Model Sim prompt or a UNIX/DOS prompt, use thisvlib command (CR-344):

vlib <directory_pat hnane>

To create anew library with the Model Sim graphic interface, select File> New > Library
(Main window).

Create a New Library i A

— Create

% {4 new libray and a logical mapping to it

" amap to an existing library

— Library Hame:

Iwnrk

— Librany Phyzical Mame:

|wu:urk

Cancel |

The Createa New Library dialog box includes these options:

» Createanew library and alogical mapping to it
Typethe new library name into the Library Namefield. This creates alibrary sub-
directory in your current working directory, initially mapped to itself. Once created, the
mapped library is easily remapped to adifferent library.

» Createamap to an existing library
Type the new library nameinto the Library Namefield, then typeinto the Library
Mapstofield or Browse to select alibrary name for the mapping.

» Library Name
Typethe logical name of the new library into this field.
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 Library Physical Name
Type the physical name of the new library into thisfield. Model Sim will create a
directory with this name.

e Library Mapsto
Type or Browse for a mapping for the specified library. Thisfield isvisible and can be
changed only when the Create a map to an existing library option is selected.

When you click OK, Model Sim creates the specified library directory and writesa
specialy-formatted file named _info into that directory. The _info file must remain in the
directory to distinguish it asaModelSim library.

The new map entry is written to the modelsim.ini filein the [Library] section. See
"[Library] library path variables" (um-617) for more information.

P Note: Remember that a design library is a specia kind of directory; the only way to
create alibrary isto usethe Model Sim GUI or the vlib command (CR-344). Do not create
libraries using UNIX or Windows commands.

Managing library contents

[Z]Modelsi
File  Edit

Library contents can be viewed, deleted, recompiled, edited and so on using either the
graphic interface or command line.

The Library tab in the Main window workspace provides access to design units
(configurations, modules, packages, entities, architectures, and SystemC modules) in a
library. Thelisting isorganized hierarchically, and the unit types areidentified both by icon
(entity (E), module (M), and so forth) and the Type column.

i =10l x|

m

Wi Compile Simulate  Tools  Window  Help

|| &

Wwiorkspace

| !
Tspe | Path ModelSims> &=
k. Library C:./dat

E nitity C:émo
E rtity C:/mo
E ritity CaDa,
E nitity C:émo
Module C:/dat d

a | = o
Library j
|~=:N|:| Design Loaded> | 4
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The Library tab has a context menu that you access by clicking your right mouse button
(Windows—2nd button, UNIX—3rd button) in the Library tab.

The context menu includes the following commands:

e Simulate
L oads the selected design unit and opens structure and Files tabs in the workspace.
Related command line command isvsim (CR-357).

» Edit
Opensthe selected design unit in the Source window, or if alibrary is selected, opensthe
Edit Library Mapping dialog (see "Library mappings with the GUI" (UM-59)).

» Refresh
Rebuilds the library image of the selected library without using source code. Related
command line command is vcom (CR-303) or vlog (CR-345) with the -r efr esh argument.

* Recompile
Recompiles the selected design unit. Related command line command isvcom (CR-303)
or vlog (CR-345).

* Optimize
Optimizes a Verilog design unit. Related command line command isvlog (CR-345) with
the +opt argument. See "Compiling with +opt" (Um-128) for further details.

» Update
Updates the display of available libraries and design units.

* Delete
Deletes the selected design unit. Related command line command isvdel (CR-315).

Deleting apackage, configuration, or entity will remove the design unit from thelibrary.
If you delete an entity that has one or more architectures or aVerilog module that has one
or more optimized versions, the entity and al its associated architectures or the module
and al its optimized versions will be deleted.

Y ou can a'so delete an architecture without deleting its associated entity. Expand the
entity, right-click the desired architecture name, and select Delete. Y ou are prompted for
confirmation before any design unit is actually deleted.

* New
Create anew library.

» Properties
Displays various properties (e.g., Name, Type, Source, etc.) of the selected design unit
or library.
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Assigning a logical name to a design library

VHDL useslogical library names that can be mapped to Model Sim library directories. By
default, Model Sim can find librariesin your current directory (assuming they havetheright
name), but for it to find libraries located el sewhere, you need to map alogical library name
to the pathname of the library.

Y ou can use the GUI, acommand, or a project to assign alogical nameto adesign library.

Library mappings with the GUI

To associate alogical name with alibrary, select the library in the workspace, right-click
and select Edit from the context menu. This brings up adialog box that allows you to edit
the mapping.

Edit Library Mapping £l

— Library Mapping Mame

|Sim|:urim

— Library Pathname
| C: Modeltech_5. 7 simprim

Browse. . |

ak. | Eancell

The dialog box includes these options:

» Library Mapping Name
Thelogical name of thelibrary.

* Library Pathname
The pathname to the library.

Library mapping from the command line

Y ou can issue a command to set the mapping between alogical library name and a
directory; itsformis:

vmap <l ogi cal _name> <di rectory_pat hname>

Y oumay invokethiscommand from either aUNIX/DOS prompt or from the command line
within ModelSim.

The vmap (CR-356) command adds the mapping to the library section of the modelsim.ini
file. Y ou can also modify modelsim.ini manually by adding a mapping line. To do this, use
atext editor and add aline under the [Library] section heading using the syntax:

<l ogi cal _nane> = <di rectory_pat hname>
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More than onelogical hame can be mapped to asingle directory. For example, suppose the
modelsim.ini filein the current working directory contains following lines:

[ Li brary]
work = /usr/rick/design
my_asic = /usr/rick/design

Thiswould allow you to use either the logical namework or my_asicinalibrary or use
clause to refer to the same design library.

Unix symbolic links

Y ou can also create a UNIX symboalic link to thelibrary using the host platform command:
I'n -s <directory_pat hname> <l ogi cal _nane>

The vmap command (CR-356) can also be used to display the mapping of alogical library

name to adirectory. To do this, enter the shortened form of the command:

vmap <l ogi cal _nane>

Library search rules
The system searches for the mapping of alogical name in the following order:
* First the system looks for a modelsim.ini file.

« |If the system doesn’t find a modelsim.ini file, or if the specified logical name does not
exist in the modelsim.ini file, the system searches the current working directory for a
subdirectory that matches the logical name.

An error isgenerated by the compiler if you specify alogical name that does not resolveto
an existing directory.

Moving a library

Individual design unitsin adesign library cannot be moved. An entire design library can
be moved, however, by using standard operating system commands for moving adirectory
or an archive.

Setting up libraries for group use

By adding an “ others’ clause to your modelsim.ini file, you can have ahierarchy of library
mappings. If the Model Sim tools don’t find a mapping in the modelsim.ini file, then they
will search thelibrary section of the initialization file specified by the “others’ clause. For
example:

[library]

asic_lib = /caelasic_lib

work = ny_work

others = /usr/nodel tech/ nodel simini
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Specifying the resource libraries

Verilog resource libraries

Model Sim supports and encourages separate compilation of distinct portions of aVerilog
design. The vlog (CR-345) compiler is used to compile one or more source filesinto a
specified library. The library thus contains pre-compiled modules and UDPs that are
referenced by the simulator asit loads the design. See "Library usage” (UM-111).

A mportant: Resource libraries are specified differently for Verilog and VHDL. For
Verilog you use either the -L or -Lf argument to vlog (CR-345).

VHDL resource libraries

Default binding

Within aVHDL sourcefile, you usethe VHDL library clause to specify logical names of
one or more resource librariesto be referenced in the subsequent design unit. The scope of
alibrary clauseincludesthetext region that startsimmediately after thelibrary clauseand
extendsto the end of the declarative region of the associated design unit. It does not extend
to the next design unit in the file.

Notethat thelibrary clauseisnot used to specify theworking library into which the design
unit is placed after compilation. The vcom command (CR-303) adds compiled design units
to the current working library. By default, thisis the library named wor k. To change the
current working library, you can use vcom -wor k and specify the name of the desired target
library.

rules for VHDL resource libraries

A common question related to VHDL resource libraries is how Model Sim handles default
binding for components. Model Sim addresses default binding at compile time. When
looking for an entity to bind with, Model Sim searches the currently visiblelibrariesfor an
entity with the same name asthe component. M odel Sim does thisbecause | EEE 1076-1987
contained a flaw that made it almost impossible for an entity to be directly visibleif it had
the same name as the component. In short, if acomponent was declared in an architecture,
any like-named entity above that declaration would be hidden because component/entity
names cannot be overloaded. As aresult we implemented the following rules for
determining default binding:

« If adirectly visible entity has the same name as the component, useit.

« |f the component is declared in a package, search the library that contained the package
for an entity with the same name.

If neither of these methods is successful, Model Sim will aso do the following:

» Search the work library.

* Search al other libraries that are currently visible by means of thelibrary clause.
Note that these second two searches are an extension to the 1076 standard.

UM-61
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Predefined libraries

Alternate |IEEE |

ModelSim SE User’'s Manual

Certain resource libraries are predefined in standard VHDL. The library named std
contains the packages standar d and textio, which should not be modified. The contents of
these packages and other aspects of the predefined language environment are documented
in the |IEEE Standard VHDL Language Reference Manual, Sd 1076. See also, "Using the
TextlO package" (UM-86).

A VHDL use clause can be specified to select particul ar declarationsin alibrary or package
that are to be visible within a design unit during compilation. A use clause references the
compiled version of the package—not the source.

By default, every VHDL design unit is assumed to contain the following declarations:

LI BRARY std, work;
USE std. standard. al |

To specify that al declarationsin alibrary or package can be referenced, add the suffix .all
to the library/package name. For example, the use clause above specifies that al
declarations in the package standard, in the design library named std, areto be visible to
the VHDL design unit immediately following the use clause. Other libraries or packages
are not visible unless they are explicitly specified using alibrary or use clause.

Another predefined library iswork, the library where adesign unit is stored after it is
compiled as described earlier. Thereis no limit to the number of libraries that can be
referenced, but only one library is modified during compilation.

ibraries supplied
Theinstallation directory may contain two or more versions of the |EEE library:

* ieeepure
Contains only |EEE approved packages (accelerated for Model Sim).

* ieee
Contains precompiled Synopsys and | EEE arithmetic packages which have been
accelerated by Model Technology including math_complex, math_real, numeric_bit,
numeric_std, std_logic 1164, std logic_misc, std_logic_textio, std_logic_arith,
std_logic_signed, std logic_unsigned, vital_primitives, and vital_timing.

Y ou can select which library to use by changing the mapping in the modelsim.ini file. The
modelsim.ini filein the installation directory defaults to the ieee library.
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Rebuilding supplied libraries

Resource libraries are supplied precompiled in the modeltech installation directory. If you
need to rebuild these libraries, the sources are provided in the vhdl_src directory; amacro
fileisalso provided for Windows platforms (rebldlibs.do). To rebuild the libraries, invoke
the DO file from within Model Sim with this command:

do rbldlibs.do

Make sure your current directory isthe modeltech install directory before you run thisfile.

P Note: Because accelerated subprograms require attributes that are available only under
the 1993 standard, many of the libraries are built using vcom (CR-303) with the -93
option.

Shell scripts are provided for UNIX (rebuild_libs.csh and rebuild_libs.sh). To rebuild the
libraries, execute one of the rebuild_libs scripts while in the modeltech directory.

Regenerating your design libraries

Depending on your current Model Sim version, you may need to regenerate your design
libraries before running a simulation. Check the installation README file to seeif your
libraries require an update. Y ou can regenerate your design libraries using the Refresh
command from the Library tab context menu (see "Managing library contents' (UM-57)), or
by using the -refr esh argument to vcom (CR-303) and vlog (CR-345).

From the command line, you would use vcom with the -r efr esh option to update VHDL
design unitsin alibrary, and vlog with the -r efr esh option to update Verilog design units.
By default, thework library is updated; use -work <library> to update adifferent library.
For example, if you have alibrary named mylib that contains both VHDL and Verilog
design units:

vcom -work nylib -refresh
vlog -work nylib -refresh

An important feature of -refresh isthat it rebuilds the library image without using source
code. This means that models delivered as compiled libraries without source code can be
rebuilt for a specific release of Model Sim (4.6 and later only). In general, thisworks for
moving forwards or backwards on arel ease. Moving backwards on arelease may not work
if the models used compiler switches or directives that do not exist in the older release.

P Note: Youdon't needto regeneratethe std, ieee, vital22b, and verilog libraries. Also, you
cannot use the -r efr esh option to update libraries that were built before the 4.6 release.
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Maintaining 32-bit and 64-bit versions in the same library

It is possible with Model Sim to maintain 32-bit and 64-bit versions of adesign in the same
library. To do this, compilethe design with the 32-bit version and "refresh” the design with
the 64-bit version. For example:

Using the 32-bit version of ModelSim:

vcom filel.vhd -work asic_lib
vcom file2.vhd -work asic_lib

Next, using the 64-hit version of ModelSim:

vcom -work asic_lib -refresh

This alows you to use either version without having to do arefresh.

Do not compile the design with one version, and then recompile it with the other. If you do
this, Model Sim will remove the first module, because it could be "stale.”
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Protecting source code and using -nodebug

The -nodebug argument for both vcom (CR-303) and viog (CR-345) hides internal model
data. This alowsamodel supplier to provide pre-compiled libraries without providing
source code and without revealing internal model variables and structure.

P Note: -nodebug encrypts entire files. The Verilog “protect compiler directive allows
you to encrypt regions within afile. See "Model Sim compiler directives' (um-152) for
details.

When you compilewith -nodebug, al sourcetext, identifiers, and line number information
are stripped from the resulting compiled object, so Model Sim cannot |ocate or display any
information of themodel except for the external pins. Specifically, the Source window will
not display the design units' source code, the Structure window will not display theinternal
structure, the Signalswindow will not display internal signals, the Process window will not
display internal processes, and the Variables window will not display internal variables. In
addition, none of the hidden objects may be accessed through the Datafl ow window or with
Model Sim commands.

Y ou can access the design units comprising your model viathelibrary, and you may invoke
vsim (CR-357) directly on any of these design units and see the ports. To restrict even this
accessinthelower levelsof your design, you can usethefollowing -nodebug optionswhen

you compile:
Command and switch Result
vcom -nodebug=ports makes the ports of aVHDL design unit invisible
vlog -nodebug=ports makes the ports of aVerilog design unit invisible
vlog -nodebug=pli preventsthe use of PLI functionsto interrogate the modulefor
information
vlog -nodebug=ports+pli combines the functions of -nodebug=ports and -nodebug=pli

Don't use the =ports option on a design without hierarchy, or on the top level of a
hierarchical design. If you do, no portswill be visible for simulation. Rather, compile al
lower portions of the design with -nodebug=portsfirst, then compile the top level with
-nodebug alone.

Design units or modules compiled with -nodebug can only instantiate design units or
modules that are also compiled -nodebug.
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Referencing source files with location maps

Pathnames to source files are recorded in libraries by storing the working directory from
which the compile isinvoked and the pathname to the file as specified in the invocation of
the compiler. The pathname may be either a complete pathname or a relative pathname.

Model Sim tools that reference source files from the library locate a source file as follows:

« |If the pathname stored in the library is complete, then thisis the path used to reference
thefile.

« If the pathnameis relative, then the tool looks for the file relative to the current working
directory. If thisfile does not exist, then the path relative to the working directory stored
in the library is used.

Thismethod of referencing sourcefiles generally worksfineif the libraries are created and
used on a single system. However, when multiple systems access alibrary across a
network, the physical pathnames are not alwaysthe same and the sourcefilereferencerules
do not always work.

Using location mapping

L ocation maps are used to replace prefixes of physical pathnamesin the library with
environment variables. The location map defines a mapping between physical pathname
prefixes and environment variables.

Model Sim tools open the location map file oninvocation if the MGC_LOCATION_MAP
(UM-613) environment variableis set. If MGC_LOCATION_MAP is not set, ModelSim
will look for afile named "mgc_location_map" in the following locations, in order:

* the current directory

* your home directory

» the directory containing the Model Sim binaries
 the Model Sim installation directory

Use these two steps to map your files:

1 Settheenvironment variable MGC_LOCATION_MAPto the path to your location map
file.

2 Specify the mappings from physical pathnames to logical pathnames:

$SRC
/ hone/ vhdl / src
lusr/vhdl /src

$I EEE
/usr/ nmodel tech/i eee
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Pathname syntax

Thelogical pathnames must begin with $ and the physical pathnames must begin with /.
Thelogical pathnameisfollowed by one or more equivalent physical pathnames. Physical
pathnames are equivalent if they refer to the same physical directory (they just have
different pathnames on different systems).

How location mapping works

When a pathname is stored, an attempt is made to map the physical pathname to a path
relative to alogical pathname. Thisis done by searching the location map file for the first
physical pathnamethat isaprefix to the pathnamein question. Thelogical pathnameisthen
substituted for the prefix. For example, "/usr/vhdl/src/test.vhd” is mapped to "$SRC/
test.vhd". If amapping can be madeto alogica pathname, then thisisthe pathnamethat is
saved. The path to a sourcefile entry for adesign unit in alibrary isagood example of a
typical mapping.

For mapping from alogical pathname back to the physical pathname, Model Sim expects
an environment variable to be set for each logical pathname (with the same name).

Model Sim reads the location map file when atool isinvoked. If the environment variables
corresponding to logical pathnames have not been set in your shell, Model Sim sets the
variablesto thefirst physical pathnamefollowing thelogical pathnamein thelocation map.
For example, if you don't set the SRC environment variable, Model Sim will automatically
set it to "/homefvhdl/src”.

Mapping with Tcl variables

Two Tcl variables may also be used to specify aternative source-file paths; SourceDir and
SourceMap. See"Preferencevariableslocatedin Tcl files' (Um-631) for moreinformation on Tcl
preference variables.
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Importing FPGA libraries

Model Sim includes an import wizard for referencing and using vendor FPGA libraries. The
wizard scans for and enforces dependenciesin the libraries and determines the correct
mappings and target directories.

A | mportant: The FPGA libraries you import must be pre-compiled. Most FPGA vendors
supply pre-compiled libraries configured for use with Model Sim.

To import an FPGA library, select File> Import > Library (Main window).

B ‘Import Library Wizard

The Impart Library wizard will step you through the tazks necessany
to reference and uze a librany.

A library can be either an exizting Model Technology libran or an
FPGA library that you received fram an FPGA vendor. |f the library
wasz received fram an FPGA vendor, it must be a precompiled
library.

Pleaze enter the location of the library to be imported below.

Impart Library Pathname

Browsee. . |

Mest » | Cancel

< Presious

Follow the instructions in the wizard to compl ete the import.
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Protecting source code using -nodebug

The -nodebug argument for both vcom (CR-303) and viog (CR-345) hides internal model
data. This alowsamodel supplier to provide pre-compiled libraries without providing
source code and without revealing internal model variables and structure.

P Note: -nodebug encrypts entire files. The Verilog “protect compiler directive allows
you to encrypt regions within afile. See "Model Sim compiler directives' (um-152) for
details.

When you compilewith -nodebug, al sourcetext, identifiers, and line number information
are stripped from the resulting compiled object, so Model Sim cannot |ocate or display any
information of the model except for the external pins. Specifically, this means that:

« the Source window will not display the design units’ source code
* the Structure window will not display the internal structure

» the Signals window will not display internal signals

» the Process window will not display internal processes

the Variables window will not display internal variables

none of the hidden objects may be accessed through the Dataflow window or with
Model Sim commands

Y ou can access the design units comprising your model viathelibrary, and you may invoke
vsim (CR-357) directly on any of these design units and see the ports. To restrict even this
accessinthelower levelsof your design, you can usethefollowing -nodebug optionswhen

you compile:
Command and switch Result
vcom -nodebug=ports makes the ports of aVHDL design unit invisible
vlog -nodebug=ports makes the ports of aVerilog design unit invisible
vlog -nodebug=pli preventsthe use of PLI functionsto interrogate the modulefor
information
vlog -nodebug=ports+pli combines the functions of -nodebug=ports and -nodebug=pli

Don't use the =ports option on a design without hierarchy, or on the top level of a
hierarchical design. If you do, no portswill be visible for simulation. Rather, compile al
lower portions of the design with -nodebug=portsfirst, then compile the top level with
-nodebug alone.

Design units or modules compiled with -nodebug can only instantiate design units or
modul es that are also compiled -nodebug.
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init signal_driver() . . . . . . . . . . . . .UM-95
init signal_ spy() . . . . . . . . . . . . . .UM-95
signa_force() . . . . . . . . . . . . . . .UM-9%
signal release() . . . . . . . . . . . . . .UM-9%
tored) . . . . . . . . . . . . . . . .UM-9%
totime() . . . . . . . . . . . . . . . .UM-97
Foreign language interface. . . . . . . . . . . . .UM-98
Modelingmemory . . . . . . . . . . . . . . .UM-99
Affecting performance by cancelling scheduledevents . . . . UM-102
Converting an integer into abit_vector . . . . . . . . UM-103

This chapter provides an overview of compilation and simulation for VHDL ; using the
TextlO package with Model Sim; Model Sim’ s implementation of the VITAL (VHDL
Initiative Towards ASIC Libraries) specification for ASIC modeling; and documentation
on ModelSim’s special built-in utilities package.

The TextlO package is defined within the VHDL Language Reference Manual, |EEE Std
1076; it allows human-readabl e text input from a declared source withina VHDL file
during simulation.
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Compiling VHDL designs

Creating a design library

Before you can compile your design, you must create alibrary in which to store the
compilation results. Use vlib (CR-344) to create anew library. For example:

vlib work

This creates alibrary named wor k. By default, compilation results are stored in the wor k
library.

Thework library is actually a subdirectory named work. This subdirectory contains a
specia file named _info. Do not create libraries using UNIX, MS Windows, or DOS
commands — always use the vlib command (CR-344).

See "Design libraries' (um-53) for additional information on working with libraries.

Invoking the VHDL compiler

M odel Sim compiles one or more VHDL design unitswith asingleinvocation of vcom (CR-
303), the VHDL compiler. The design units are compiled in the order that they appear on
the command line. For VHDL, the order of compilation isimportant — you must compile
any entities or configurations before an architecture that references them.

Y ou can simul ate a design containing units written with 1076 -1987, 1076 -1993, and
1076-2002 versions of VHDL. To do so you will need to compile units from each VHDL
version separately. The vcom (CR-303) command compiles using 1076 -2002 rules by
default; use the -87 or -93 argument to vcom (CR-303) to compile unitswritten with version
1076-1987 or 1076 -1993, respectively. Y ou can a so change the default by modifying the
VHDL93 variablein the modelsim.ini file (see "Preference variables located in INI files"
(uM-617) for more information).

Dependency checking

Dependent design units must be reanalyzed when the design units they depend on are
changed in the library. vcom (CR-303) determines whether or not the compilation results
have changed. For example, if you keep an entity and its architectures in the same source
file and you modify only an architecture and recompile the source file, the entity
compilation results will remain unchanged and you will not have to recompile design units
that depend on the entity.
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Range and index checking

A range check verifiesthat a scalar value defined with a range subtype is always assigned
avaue within its range. An index check verifies that whenever an array subscript
expression is evaluated, the subscript will be within the array's range.

Range and index checks are performed by default when you compile your design. Y ou can
disable range checks (potentially offering a performance advantage) and index checks
using arguments to the vcom (CR-303) command. Or, you can use the NoRangeCheck and
NolndexCheck variablesin the modelsim.ini file to specify whether or not they are
performed. See "Preference variables located in INI files' (UM-617).

Range checksin Model Sim are slightly more restrictive than those specified by the VHDL
LRM. Model Sim requires any assignment to asignal to also be in range whereasthe LRM
requires only that range checks be done whenever asignal is updated. Most assignmentsto
signals update the signal anyway, and the more restrictive requirement allows ModelSim

to generate better error messages.

Differences between language versions

Therearethreeversionsof thelEEE VHDL 1076 standard: VHDL-1987, VHDL-1993, and
VHDL-2002. The default language version for Model SimisVHDL-2002. If your code was
written according to the ' 87 or ' 93 version, you may need to update your code or instruct
ModelSim to use the earlier versions' rules.

To select a specific language version, do one of the following:
* Select the appropriate version from the compiler options menu in the GUI
* Invoke vcom (CR-303) using the argument -87, -93, or -2002

¢ Set the VHDL93 variable in the [vcom] section of the modelsim.ini file. Appropriate
valuesfor VHDL93 are:

- 0, 87, or 1987 for VHDL-1987
-1, 93, or 1993 for VHDL-1993
- 2,02, or 2002 for VHDL-2002

Thefollowing isalist of language incompatibilites that may cause problems when
compiling adesign.

» Theonly major problem between VHDL-93 and VHDL-2002 is the addition of the
keyword "PROTECTED". VHDL-93 programs which use this as an identifier should
choose a different name.

All other incompatibilities are between VHDL-87 and VHDL-93.
* VITAL and SDF

It isimportant to use the correct language version for VITAL. VITAL2000 must be
compiled with VHDL-93 or VHDL-2002. VITAL95 must be compiled with VHDL-87.
A typical error message that indicates the need to compile under language version
VHDL-87is:

"VI TALPat hDel ay Def aul t Del ay paranmeter nust be locally static"
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 Purity of NOW

In VHDL-93 the function "now" isimpure. Consequently, any function that invokes
"now" must also be declared to beimpure. Such callsto "now" occurin VITAL. A typical
error message:

"Cannot call inmpure function 'now frominside pure function '<nane>'"

* Files
File syntax and usage changed between VHDL-87 and VHDL-93. In many cases vcom
issues awarning and continues:
"Using 1076-1987 syntax for file declaration.”

In addition, when files are passed as parameters, the following warning messageis
produced:

" Subprogram paraneter nane is declared using VHDL 1987 syntax."

This message often involves calls to endfile(<name>) where <name> is afile parameter.
* Filesand packages

Each package header and body should be compiled with the same language version.
Common problemsin this areainvolve files as parameters and the size of type
CHARACTER. For example, consider a package header and body with a procedure that
has afile parameter:

procedure procl ( out_file : out std.textio.text) ...

If you compile the package header with VHDL-87 and the body with VHDL-93 or
VHDL-2002, you will get an error message such as:
"** Error: m xed_package_b.vhd(4): Paraneter kinds do not conform between
decl arations in package header and body: 'out_file'."

 Direction of concatenation

To solve some technical problems, the rules for direction and bounds of concatenation
were changed from VHDL-87 to VHDL-93. Y ou won't see any difference in simple
variable/signal assignments such as.

vl :=a &b;
But if you (1) have afunction that takes an unconstrained array as a parameter, (2) pass
a concatenation expression as aformal argument to this parameter, and (3) the body of
the function makes assumptions about the direction or bounds of the parameter, then you

will get unexpected results. Thismay beaproblemin environmentsthat assumeal arrays
have "downto" direction.

¢ Xnor

"xnor" isareserved word in VHDL-93. If you declare an xnor function in VHDL-87
(without quotes) and compile it under VHDL-2002, you will get an error message like
the following:

** Error: xnor.vhd(3): near "xnor": expecting: STRI NG | DENTI FI ER
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'FOREIGN attribute

InVHDL-93 package STANDARD declares an attribute 'FOREIGN. If you declare your
own attribute with that name in another package, then Model Sim issues awarning such
as the following:

-- Conpiling package foopack

** \Warning: foreign.vhd(9): (vcom 1140) VHDL-1993 added a definition of the
attribute foreign to package std.standard. The attribute is also defined in
package 'standard'. Using the definition from package 'standard'

Size of CHARACTER type

In VHDL-87 type CHARACTER has 128 values; in VHDL-93 it has 256 values. Code
which depends on thissizewill behaveincorrectly. This situation occurs most commonly
intest suitesthat check VHDL functionality. It'sunlikely to occur in practical designs. A
typical instance is the replacement of warning message:

"range nul downto del is null"

by

"range nul downto 'y' is null" -- range is nul downto y(um aut)

bit string literals

In VHDL-87 bit string literals are of type bit_vector. In VHDL-93 they can also be of
type STRING or STD_LOGIC_VECTOR. Thisimplies that some expressions that are
unambiguous in VHDL-87 now become ambiguousis VHDL-93. A typical error
messageis.
** Error: bit_string_literal.vhd(5): Subprogram'=' is anhiguous. Suitable
definitions exist in packages 'std_logic_1164" and 'standard'

In VHDL-87 when using individual subelement association in an association list,
associating individual subelements with NULL is discouraged. In VHDL-93 such
association isforbidden. A typical messageis:

"Formal '<nanme>'" nust not be associated with OPEN when subel enents are
associated individually."
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Simulating VHDL designs

After compiling the design units, you can simulate your designs with vsim (CR-357). This
section discusses simulation from the UNIX or Windows/DOS command line. Y ou can
also use a project to simulate (see " Getting started with projects’ (UM-34)) or the Simulate
dialog box (see "Simulating with the graphic interface” (Um-377)).

For VHDL invoke vsim (CR-357) with the name of the configuration, or entity/architecture
pair. Note that if you specify a configuration you may not specify an architecture.
This example invokes vsim (CR-357) on the entity my_asic and the architecture structure:

vsimmy_asic structure

vsim (CR-357) iscapabl e of annotating adesign using VITAL compliant modelswithtiming
datafrom an SDF file. Y ou can specify the min:typ:max delay by invoking vsim with the
-sdfmin, -sdftyp, or -sdfmax option. Using the SDF file f1.sdf in the current work
directory, the following invocation of vsim annotates maximum timing values for the
design unit my_asic:

vsi m -sdf max /ny_asic=f1l.sdf ny_asic

By default, thetiming checkswithin VITAL modelsare enabled. They can be disabled with
the +notimingchecks option. For example:

vsi m +noti m ngchecks topnod

Simulator resolution limit

The simulator internally represents time as a 64-bit integer in units equivaent to the
smallest unit of simulation time, aso known as the simulator resolution limit. The default
resolution limit is set to the value specified by the Resolution (UM-624) variable in the
modelsim.ini file. Y ou can view the current resolution by invoking the report command
(CR-238) with the simulator state option.

Overriding the resolution

Y ou can override Model Sim’ s default resolution by specifying the -t option on the
command line or by selecting adifferent Simulator Resol ution in the Simulate dialog box.
Availableresolutions are: 1x, 10x, or 100x of fs, ps, ns, us, ms, or sec.

For exampl e this command chooses 10 ps resol ution:

vsim-t 10ps topnod
Clearly you need to be careful when doing thistype of operation. If the resolution set by -t
islarger than adelay value in your design, the delay valuesin that design unit are rounded

to the closest multiple of the resolution. In the example above, a delay of 4 pswould be
rounded to O ps.

Choosing the resolution

Y ou should choose the coarsest resolution limit possible that does not result in undesired
rounding of your delays. The time precision should not be unnecessarily small because it
will limit the maximum simulation time limit, and it will degrade performance in some
cases.
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Delta delays

Event-based simulators such as Model Sim may process many events at a given simulation
time. Multiple signals may need updating, statements that are sensitive to these signals
must be executed, and any new events that result from these statements must then be
gueued and executed as well. The steps taken to eval uate the design without advancing
simulation time are referred to as "deltatimes’ or just "deltas.”

The diagram bel ow representsthe process for VHDL designs. This process continues until
the end of simulation time.

Execute
concurrent Advance
’ statements at P deltatime <
current time L
Advance No | Anytransactions
smulation[™® to process?
time
¢Y$
Any eventsto | No
process?
#Y&;
Executeconcurrent

statementsthatare| |
sensitive to events

This mechanism in event-based simulators may cause unexpected results. Consider the
following code snippet:

cl k2 <= clk;

process (rst, clk)

begi n
if(rst ='0")then
sO <="'0";
el sif(clk'event and clk="1") then
sO <= inp;
end if;

end process;

process (rst, clk2)

begi n
if(rst ='0")then
sl <='0";
el sif(clk2' event and clk2="1") then
sl <= sO0;
end if;

end process;
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In this example you have two synchronous processes, one triggered with clk and the other
with clk2. To your surprise, the signals change in the clk2 process on the same edge asthey
are set in the clk process. As aresult, the value of inp appears at sl rather than s0.

Hereiswhat’s happing. During simulation an event on clk occurs (from the testbench).
From this event Model Sim performs the "clk2 <= clk" assignment and the process which
is sensitive to clk. Before advancing the simulation time, Model Sim finds that the process
sensitive to clk2 can also be run. Since there are no delays present, the effect is that the
value of inp appears at sl in the same simulation cycle.

In order to get the expected results, you must do one of the following:
* Insert adelay at every output

» Make certain to use the same clock

* Insert adeltadelay

Toinsert a deltadelay, you would modify the code like this:

process (rst, clk)

begi n
if(rst ='0")then
s0 <='0";
elsif(clk'event and clk="1") then
sO <= inp;
s0_del ayed <= s0;
end if;

end process;

process (rst, clk2)
begi n
if(rst ="'0")then
sl <="'0";
el sif(cl k2" event and clk2="1") then
sl <= s0_del ayed;
end if;
end process;

The best way to debug delta delay problems is observe your signalsin the List window.
There you can see how values change at each deltatime.

Detecting infinite zero-delay loops

If alarge number of deltas occur without advancing time, it is usually a symptom of an
infinite zero-delay loop in the design. In order to detect the presence of these loops,
Model Sim defines alimit, the “iteration limit", on the number of successive deltasthat can
occur. When Model Sim reaches the iteration limit, it issues a warning message.

Theiteration limit default value is 5000. If you receive an iteration limit warning, first
increase theiteration limit and try to continue simulation. Y ou can set the iteration limit
from the Simulate > Simulation Options menu, by modifying the modelsim.ini file, or by
setting a Tcl variable called IterationLimit (UM-624). See "Preference variables located in
INI files" (um-617) for more information on modifying the modelsim.ini file.

If the problem persists, ook for zero-del ay loops. Run the simulation and | ook at the source
code when the error occurs. Use the step button to step through the code and see which
signals or variables are continuously oscillating. Two common causes are a loop that has
no exit, or a series of gates with zero delay where the outputs are connected back to the
inputs.

UM-79
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Simulating with an elaboration file

Overview

The Model Sim compiler generates alibrary format that is compatible across platforms.
This means the simulator can load your design on any supported platform without having
to recompile first. Though this architecture offers a benefit, it also comes with a possible
detriment: the simulator has to generate platform-specific code every time you load your
design. Thisimpacts the speed with which the design is |oaded.

Starting with Model Sim version 5.6, you can generate aloadable image (elaboration file)
which can be simulated repeatedly. On subsequent simulations, you |oad the elaboration
file rather than loading the design "from scratch.” Elaboration files load quickly.

Why an elaboration file?

In many cases design loading time is not that important. For example, if you're doing
"iterative design," where you simulate the design, modify the source, recompile and
resimulate, theload timeisjust asmall part of the overall flow. However, if your designis
locked down and only the test vectors are modified between runs, loading time may
materially impact overall simulation time, particularly for large designs loading SDF files.

Another reason to use elaboration files is for benchmarking purposes. Other simulator
vendors use elaboration files, and they distinguish between elaboration and run times. If
you are benchmarking Model Sim against another simulator that uses elaboration, make
sure you use an elaboration file with Model Sim as well so you're comparing like to like.

One caveat with elaboration files is that they must be created and used in the same
environment. The same environment means the same hardware platform, the same OS and
patch version, and the same version of any PLI/FLI code loaded in the simulation.

Elaboration file flow

We recommend the following flow to maximize the benefit of simulating elaboration files.

1 If timing for your design isfixed, include all timing datawhen you create the elaboration
file (using the -sdf<type> instance=<filename> argument). If your timing is not fixed
inaVerilog design, you'll have to use $sdf _annotate system tasks. Note that use of
$sdf _annotate causes timing to be applied after elaboration.

2 Apply al normal vsim arguments when you create the elaboration file. Some arguments
(primarily related to stimulus) may be superseded later during loading of the elaboration
file (see "Modifying stimulus' (um-82) below).

3 Load the elaboration file along with any arguments that modify the stimulus (see below).

ModelSim SE User’'s Manual



Simulating with an elaboration file ~ UM-81

Creating an elaboration file

Elaboration file creation is performed with the same vsim settings or switches asanormal
simulation plus an el aboration specific argument. The simulation settings are stored in the
elaboration file and dictate subsequent simulation behavior. Some of these simulation
settings can be modified at elaboration file load time, as detailed below.

To create an elaboration file, use the -elab <filename> or -elab_cont <filename>
argument to vsim (CR-357).

The-elab_cont argument is used to create the elaboration file then continue with the
simulation after the elaboration fileis created. Y ou can use the -c switch with -elab_cont
to continue the simulation in command-line mode.

A mportant: Elaboration files can be created in command-line mode only. Y ou cannot
create an elaboration file while running the Model Sim GUI.

Loading an elaboration file

Toload an elaboration file, usethe -load_elab <filename> argument to vsim (CR-357). By
default the elaboration file will load in command-line mode or interactive mode depending
on the argument (-c or -i) used during elaboration file creation. If no argument was used
during creation, the -load_elab argument will default to the interactive mode.

The vsim arguments listed below can be used with -load_elab to affect the simulation.
+<pl us_ar gs>
-c or -i
-do <do_file>
-vcdread <fil ename>
-vedstim <fil ename>
-filemap_el ab <HDLfil ename>=<NEW i | enanme>
-l <log_file>
-trace_foreign <level >
-qui et
-w f <fil ename>

Modification of an argument that was specified at elaboration file creation, in most cases,
causes the previous value to be replaced with the new value. Usage of the -quiet argument
at elaboration load causes the mode to be toggled from its elaboration creation setting.

All other vsim arguments must be specified when you create the elaboration file, and they
cannot be used when you load the elaboration file.

A 'mportant: The elaboration file must be |oaded under the same environment in which it
was created. The same environment means the same hardware platform, the same OS
and patch version, and the same version of any PLI/FLI code loaded in the simulation.
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Modifying stimulus

A primary use of elaboration filesis repeatedly simulating the same design with different
stimulus. The following mechanisms allow you to modify stimulus for each run.

* Use of the change command to modify parameters or generic values. This affects values
only; it has no effect on triggers, compiler directives, or generate statements that
reference either a generic or parameter.

» Useof the -filemap_elab <HDL filename>=<NEWfilename> argument to establish a
map between files named in the elaboration file. The <HDL filename> file name, if it
appearsin the design as afile name (for example, aVHDL FILE object aswell as some
Verilog sysfuncs that take file names), is substituted with the <NEWfilename> file
name. This mapping occurs before environment variable expansion and can’t be used to
redirect stdin/stdout.

» VCD stimulusfiles can be specified when you load the elaboration file. Both vedread and
vedstim are supported. Specifying adifferent VCD filewhen you load the elaborationfile
supersedes a stimulus file you specify when you create the elaboration file.

* InVerilog, the use of +ar gswhich are readable by the PLI routine mc_scan_plusar gs().
+ar gs values specified when you create the elaboration file are superseded by +args
values specified when you load the elaboration file.

Using with the PLI or FLI

Syntax
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PLI models do not require special code to function with an elaboration file aslong as the
model doesn't create simulation objectsin its standard tf routines. The sizetf, misctf and
checktf callsthat occur during elaboration are played back at -load_elab to ensure the PLI
model isin the correct simulation state. Registered user tf routines called from the Verilog
HDL will not occur until -load_elab is complete and PLI model's state is restored.

By default, FL1 modelsare activated for checkpoint during elaboration file creation and are
activated for restore during elaboration file load. (See the "Using checkpoint/restore with
the FLI" section of the FLI Reference manual for more information.) FLI model s that
support checkpoint/restore will function correctly with elaboration files.

FL1 models that don't support checkpoint/restore may work if simulated with the
-elab_defer_fli argument. When used in tandem with -elab, -elab_defer_fli deferscallsto
the FL1 modéel'sinitialization function until elaboration file load time. Deferring FLI
initialization skips the FLI checkpoint/restore activity (callbacks, mti_IsRestore(), ...) and
may allow these models to simulate correctly. However, deferring FL1 initialization also
causesFLI modelsin the design to beinitialized in order with the entire design loaded. FLI
models that are sensitive to this ordering may still not work correctly even if you use
-elab_defer_fli.

See the vsim command (CR-357) for details on -elab, -elab_cont, -elab_defer_fli,
-compress_elab, -filemap_elab, and -load_elab.
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Example

Upon first simulating the design, use vsim -elab <filename>
<library_name.design_unit> to create an elaboration file that will be used in subsequent
simulations.

In subsequent simulations you simply load the elaboration file (rather than the design) with
vsim -load_elab <filename>.

To change the stimulus without recoding, recompiling, and reloading the entire design,
Modelsim alows you to map the stimulus file (or files) of the original design unit to an
aternatefile (or files) with the -filemap_elab switch. For example, the VHDL code for
initiating stimulus might be:

FILE vector_file : text ISIN "vectors";

where vectorsisthe stimulus file.

If the alternate stimulusfileisnamed, say, alt_vectors, then the correct syntax for changing
the stimulus without recoding, recompiling, and reloading the entire design is as follows:

vsim -load_elab <filename> -filemap_elab vectors=alt_vectors
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Checkpointing and restoring simulations

The checkpoint (CR-99) and r estor e (CR-242) commands allow you to save and restore the
simulation state within the same invocation of vsim or between vsim sessions.

Action Definition Command used
checkpoint saves the simulation state checkpoint <filename>
"warm' restore restores a checkpoint file saved in a restore <filename>
current vsim session
"cold" restore restores a checkpoint file saved in a vsim -restore <filename>
previous vsim session (i.e., after
quitting Model Sim)

Checkpoint file contents
The following things are saved with checkpoint and restored with the restor e command:
» simulation kernel state

o vsimwif file

signalslisted in thelist and wave windows

file pointer positions for files opened under VHDL

file pointer positions for files opened by the Verilog $fopen system task

state of foreign architectures
state of PLI/VPI code

Checkpoint exclusions

Y ou cannot checkpoint/restore the following:

* state of macros

« changes made with the command-line interface (such as user-defined Tcl commands)
« state of graphical user interface windows

* toggle statistics

If you use the foreign interface, you will need to add additional function callsin order to
use checkpoint/restore. See the FLI Reference Manual or Chapter 6 - Verilog PLI / VPI
for more information.
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Controlling checkpoint file compression

The checkpoint fileisnormally compressed. To turn off the compression, usethefollowing
command:

set Checkpoi nt Conpressibde 0

To turn compression back on, use this command:

set Checkpoi nt Conpressibde 1

Y ou can also control checkpoint compression using the modelsim.ini file in the [vsim]
section (use the same 0 or 1 switch):

[vsinm
Checkpoi nt Conpr essivbde = <swi tch>

The difference between checkpoint/restore and restart

Therestart (CR-240) command resets the simulator to time zero, clears out any logged
waveforms, and closes any files opened under VHDL and the Verilog $fopen system task.
Y ou can get the same effect by first doing a checkpoint at time zero and later doing a
restore. Using restart, however, islikely to be faster and you don't have to save the
checkpoint. To set the simulation state to anything other than time zero, you need to use
checkpoint/restore.

Using macros with restart and checkpoint/restore

Therestart (CR-240) command resets and restarts the simulation kernel, and zeros out any
user-defined commands, but it does not touch the state of the macro interpreter. Thislets
you do restart commands within macros.

The pause mode indicates that a macro has been interrupted. That condition will not be
affected by arestart, and if therestart is done with an interrupted macro, the macro will still
be interrupted after the restart.

The situation is similar for using check point/restor e without quitting Model Sim; that is,
doing a checkpoint (CR-99) and later in the same session doing arestor e (CR-242) of the
earlier checkpoint. Therestor e does not touch the state of the macro interpreter so you may
also do checkpoint and restor e commands within macros.
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Using the TextlO package

To access theroutinesin Textl O, include the following statement in your VHDL source
code:

USE std.textio.all

A simple example using the package TextlOis:

USE std.textio.all
ENTITY sinmple_textio IS
END

ARCHI TECTURE si npl e_behavi or OF sinple_textio IS

BEGI N

PROCESS
VARI ABLE i: | NTEGER = 42;
VARI ABLE LLL: LI NE;

BEGI N
WRI TE (LLL, i);
WRI TELI NE ( OUTPUT, LLL);
VAI T;

END PROCESS;

END si npl e_behavi or

Syntax for file declaration
The VHDL' 87 syntax for afile declaration is:

fileidentifier : subtype_ indicationi S [ node | file_logical_nane

where "file_logical_name" must be a string expression.
In newer versions of the 1076 spec, syntax for afile declarationiis:

fileidentifier_list : subtype_indication [ file_open_information ] ;

where"fil e_open_i nformation" IS

[open fil e_open_kind_expression] is file_logical_nane

Y ou can specify afull or relative path asthe file_logical_name; for example (VHDL’ 87):
file filename : TEXT IS in "/usr/rick/nyfile";

Normally if afileis declared within an architecture, process, or package, thefileis opened
when you start the simulator and is closed when you exit fromiit. If afileisdeclared ina
subprogram, the file is opened when the subprogram is called and closed when execution
RETURNSs from the subprogram. Alternatively, the opening of files can be delayed until
thefirst read or write by setting the DelayFileOpen variable in the modelsim.ini file. Also,
the number of concurrently open files can be controlled by the ConcurrentFileL imit
variable. These variables help you manage alarge number of files during simulation. See
Appendix A - Model Sm variables for more details.
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Using STD_INPUT and STD_OUTPUT within ModelSim

The standard VHDL' 87 TextlO package contains the following file declarations:
file input: TEXT IS in "STD INPUT";
file output: TEXT i S out "STD OUTPUT";
Updated versions of the TextlO package contain these file declarations:
file input: TEXT open read_rode i S "STD | NPUT";
file output: TEXT open wite_node i S "STD OUTPUT";

STD_INPUT isafile_logical_name that refersto charactersthat are entered interactively
from the keyboard, and STD_OUTPUT refers to text that is displayed on the screen.

In Model Sim, reading from the STD_INPUT file allows you to enter text into the current
buffer from a prompt in the Main window. The lines written to the STD_OUTPUT file
appear in the Main window transcript.
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TextlO implementation issues

Writing strings and aggregates

A common error in VHDL source code occurs when acall to aWRITE procedure does not
specify whether the argument is of type STRING or BIT_VECTOR. For example, the
VHDL procedure:

WRI TE (L, "hello");

will cause the following error:

ERROR: Subprogram "WRI TE" is anbi guous.
In the TextlO package, the WRITE procedure is overloaded for the types STRING and
BIT_VECTOR. These lines are reproduced here:

procedure WRI TE(L: inout LINE, VALUE: in BIT_VECTOR,
JUSTIFIED: in SIDE:= RIGHT; FIELD: in WDTH : = 0);

procedure WRI TE(L: inout LINE, VALUE: in STRING
JUSTIFIED: in SIDE:= RIGHT; FIELD: in WDTH : = 0);

The error occurs because the argument "hello" could be interpreted as a string or a bit
vector, but the compiler isnot allowed to determine the argument type until it knowswhich
functionis being called.

The following procedure call also generates an error:

WRI TE (L, "010101");
This call is even more ambiguous, because the compiler could not determine, even if
allowed to, whether the argument "010101" should be interpreted as a string or a bit vector.
There are two possible solutions to this problem:
» Useaqualified expression to specify the type, asin:

WRI TE (L, string ("hello"));

 Call aprocedure that is not overloaded, asin:
WRI TE_STRING (L, "hello");

The WRITE_STRING procedure simply defines the value to be a STRING and calls the
WRITE procedure, but it serves as a shell around the WRITE procedure that solves the
overloading problem. For further details, refer to the WRITE_STRING procedure in the
io_utils package, which islocated in thefile <install_dir>/modeltech/examples/
io_utils.vhd.
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Reading and writing hexadecimal numbers

The reading and writing of hexadecimal numbersis not specified in standard VHDL. The
Issues Screening and Analysis Committee of the VHDL Analysis and Standardization
Group (ISAC-VASG) has specified that the Textl O package reads and writes only decimal
numbers.

To expand this functionality, Model Sim supplies hexadecimal routines in the package
io_utils, whichislocatedinthefile<install_dir>/modeltech/examples/io_utils.vhd. Touse
these routines, compile the io_utils package and then include the following use clausesin
your VHDL source code:

use std.textio.all;
use work.io_utils.all;

Dangling pointers

Dangling pointers are easily created when using the TextlO package, because
WRITELINE de-allocates the access type (pointer) that is passed to it. Following are
examples of good and bad VHDL coding styles:

Bad VHDL (because L1 and L2 both point to the same buffer):

READLI NE (infile, L1); -- Read and allocate buffer
L2 := L1, -- Copy pointers
WRI TELINE (outfile, L1); -- Deallocate buffer

Good VHDL (because L1 and L2 point to different buffers):

READLINE (infile, L1); -- Read and all ocate buffer
L2 := new string’ (L1.all); -- Copy contents
WRI TELINE (outfile, L1); -- Deallocate buffer

The ENDLINE function

The ENDLINE function described in the IEEE Sandard VHDL Language Reference
Manual, IEEE Sd 1076-1987 containsinvalid VHDL syntax and cannot be implemented
in VHDL. Thisis because access types must be passed as variables, but functions only
alow constant parameters.

Based on an ISAC-VASG recommendation the ENDLINE function has been removed
from the TextlO package. The following test may be substituted for this function:

(L = NULL) OR (L' LENGTH = 0)

The ENDFILE function
In the VHDL Language Reference Manuals, the ENDFILE function is listed as:
-- function ENDFILE (L: in TEXT) return BOOLEAN;

Asyou can see, this function is commented out of the standard TextlO package. Thisis
because the ENDFILE function isimplicitly declared, so it can be used with files of any
type, not just files of type TEXT.
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Using alternative input/output files

Y ou can usethe Textl O package to read and writeto your own files. Todothis, just declare
an input or output file of type TEXT. For example, for an input file:

The VHDL'’ 87 declaration is:
file nyinput : TEXT i S in "pathnane.dat";

The VHDL’ 93 declaration is:
file nyinput : TEXT open read_node i S "pathnane. dat";

Then include the identifier for thisfile ("myinput" in this example) in the READLINE or
WRITELINE procedure call.

Flushing the TEXTIO buffer
Flushing of the TEXTIO buffer is controlled by the UnbufferedOutput (Um-625) variablein
the modelsim.ini file.

Providing stimulus

Y ou can stimulate and test a design by reading vectors from afile, using them to drive
values onto signals, and testing the results. A VHDL test bench has been included with the
ModelSim install files as an example. Check for thisfile:

<install_dir>/modeltech/exampl es/stimulus.vhd
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VITAL specification and source code

VITAL ASIC Modeling Specification

The lEEE 1076.4 VITAL ASIC Modeling Specification is available from the Institute of
Electrical and Electronics Engineers, Inc.:

|EEE Customer Service
445 Hoes Lane
Piscataway, NJ 08854-1331

Tel: (732) 981-0060
Fax: (732) 981-1721
home page: http://www.ieee.org

VITAL source code

The source code for VITAL packagesis provided in the /<install_dir>/modeltech/
vhdl_src/vital2.2b, /vital 95, or /vital 2000 directories.

VITAL packages

VITAL 1995 accelerated packages are pre-compiled into the ieeelibrary in the installation
directory. VITAL 2000 accelerated packages are pre-compiled into the vital2000 library.
If you need to use the newer library, you'll need to add a use clause to your VHDL codeto
access the VITAL 2000 packages. For example:

LI BRARY vi t al 2000;
USE vi tal 2000. al |

ModelSim VITAL compliance

A simulator is VITAL compliant if it implements the SDF mapping and if it correctly
simulates designs using the VITAL packages, as outlined in the VITAL Model
Development Specification. Model Sim is compliant with the IEEE 1076.4 VITAL ASIC
Modeling Specification. In addition, Model Sim acceleratesthe VITAL_Timing,
VITAL_Primitives, and VITAL_memory packages. The optimized procedures are
functionally equivalent to the IEEE 1076.4 VITAL ASIC Modeling Specification (VITAL
1995 and 2000).

VITAL compliance checking

Compliance checking isimportant in enabling VITAL acceleration; to qualify for globa
acceleration, an architecture must be VITAL-level-one compliant. vcom (CR-303)
automatically checksfor VITAL 2000 compliance on all entitieswith the VITAL _LevelO
attribute set, and all architectureswith the VITAL LevelO or VITAL _Levell attribute set.

If you areusing VITAL 2.2b, you must turn off the compliance checking either by not
setting the attributes, or by invoking vcom (CR-303) with the option -novitalcheck. Y ou can
turn off compliance checking for VITAL 1995 and VITAL 2000 aswell, but we strongly
suggest that you leave checking on to ensure optimal simulation.
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VITAL compliance warnings

The following LRM errors are printed as warnings (if they were considered errors they
would prevent VITAL level 1 acceleration); they do not affect how the architecture
behaves.

» Starting index constraint to Dataln and PreviousDatal n parametersto VITAL StateTable
do not match (1076.4 section 6.4.3.2.2)

 Size of PreviousDatal n parameter islarger than the size of the Dataln parameter to
VITALStateTable (1076.4 section 6.4.3.2.2)

 Signal g wisread by the VITAL processbutisNOT inthe sensitivity list (1076.4 section
6.4.3)

Thefirst two warnings are minor caseswherethe body of the VITAL 1995 LRM isslightly
stricter than the package portion of the LRM. Since either interpretation will provide the
same simulation results, we chose to make these two cases warnings.

Thelast warning is arelaxation of the restriction on reading an internal signal that isnot in
the sensitivity list. Thisis relaxed only for the CheckEnabled parameters of the timing
checks, and only if they are not read elsewhere.

Y ou can control thevisibility of VITAL compliance-check warningsin your vcom (CR-303)
transcript. They can be suppressed by using the vcom -nowarn switch asin

vcom -nowar n 6. The 6 comes from the warning level printed as part of thewarning, i.e.,
** WARNING: [6]. You can also add the following line to your modelsim.ini filein the
[vcom] VHDL compiler control variables (UM-619) section.

[vconm
Show Vi t al ChecksWarnings = 0
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Compiling and simulating with accelerated VITAL packages

vcom (CR-303) automatically recognizesthat aVITAL function is being referenced from
theieeelibrary and generates code to call the optimized built-in routines.

Optimization occurs on two levels:

* VITAL Leve-0 optimization
Thisisafunction-by-function optimization. It appliesto al level-0 architectures, and any
level-1 architectures that failed level-1 optimization.

* VITAL Level-1 optimization
Performsglobal optimizationonaVITAL 3.0 level-1 architecture that passesthe VITAL
compliance checker. Thisis the default behavior. Note that your models will run faster
but at the cost of not being able to see the internal workings of the models.

Compiler options for VITAL optimization
Several vcom (CR-303) options control and provide feedback on VITAL optimization:

-novita
Causes vcom to use VHDL code for VITAL procedures rather than the accel erated and
optimized timing and primitive packages. Allows breakpointsto be set inthe VITAL
behavior process and permits single stepping through the VITAL procedures to debug
your model. Also, al of the VITAL datacan be viewed in the Variables or Signals
windows.

-0 | -0
L owers the optimization to a minimum with -OO0 (capital oh zero). Optional. Usethisto
work around bugs, increase your debugging visibility on a specific cell, or when you
want to place breakpoints on source lines that have been optimized out.

Enable optimizations with -O4 (default).

- debugVA
Printsaconfirmationif aVITAL cell was optimized, or an explanation of why it was not,
during VITAL level-1 acceleration.

ModelSim VITAL built-inswill be updated in step with new releases of the VITAL
packages.
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Util package

get_resolution

The util package, included in Model Sim versions 5.5 and later, serves as a container for
various VHDL utilities. The packageis part of themodelsim_lib library whichislocated in
the modeltech tree and is mapped in the default modelsim.ini file.

To accessthe utilitiesin the package, you would add lineslike the following to your VHDL
code:

library nodel simlib;
use nodelsimlib.util.all;

get_resolution returns the current simulator resolution as areal number. For example, 1
femtosecond corresponds to 1e-15.

Syntax

resval := get_resolution;

Returns

Name Type Description

resval real The simulator resolution represented as areal
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Arguments
None

Related functions
to_real() (UM-96)
to_time() (UM-97)

Example
If the simulator resolution is set to 10ps, and you invoke the command:

resval := get_resolution;

the value returned to resval would be 1e-11.




Util package

init_signal_driver()

Theinit_signal_driver() procedure drives the value of aVHDL signal or Verilog net onto
anexisting VHDL signal or Verilog net. Thisallowsyouto drivesignalsor netsat any level
of the design hierarchy from within aVHDL architecture (e.g., a testbench).

Seeinit_signal_driver (uM-525) in Chapter 16 - Signal Spy for complete details.

init_signal_spy()

signal_force()

Theinit_signal_spy() utility mirrorsthe value of aVHDL signal or Verilog register/net
onto an existing VHDL signal or Verilog register. This alows you to reference signals,
registers, or nets at any level of hierarchy from within aVVHDL architecture (e.g., a
testbench).

Seeinit_signa_spy (Um-528) in Chapter 16 - Signal Spy for complete details.

The signal_force() procedure forces the value specified onto an existing VHDL signal or
Verilog register or net. Thisallowsyouto force signals, registers, or nets at any level of the
design hierarchy fromwithinaVHDL architecture (e.g., atestbench). A signal_forceworks
the same as the for ce command (CR-176) with the exception that you cannot issue a
repeating force.

See signal_force (UM-530) in Chapter 16 - Sgnal Spy for compl ete details.

signal_release()

The signal_release() procedure releases any force that was applied to an existing VHDL
signal or Verilog register or net. This allows you to release signals, registers, or nets at any
level of the design hierarchy from within a VHDL architecture (e.g., atestbench). A
signal_release works the same as the nofor ce command (CR-204).

See signal_release (UM-532) in Chapter 16 - Sgnal Spy for complete details.

UM-95
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to_real()

to_real() converts the physical type time valueinto areal value with respect to the current
simulator resolution. The precision of the converted value is determined by the simulator
resolution. For example, if you were converting 1900 fsto areal and the simulator
resolution was ps, then the real value would be 2.0 (i.e., 2 ps).

Syntax
realval := to_real (timeval)

Returns

Name Type Description

realval rea The time value represented as areal with

respect to the simulator resolution

Arguments

Name Type Description

timeval time The value of the physical typetime

Related functions
get_resolution (UM-94)
to_time() (UM-97)

Example
If the simulator resolution is set to ps, and you enter the following function:
realval :=to_real (12.99 ns);
then the value returned to realval would be 12990.0. If you wanted the returned value to be

in units of nanoseconds (ns) instead, you would use the get_r esolution (UM-94) function to
recal culate the value:

realval := l1le+9 * (to_real (12.99 ns)) * get_resolution();

If you wanted the returned value to be in units of femtoseconds (fs), you would enter the
function this way:

realval := le+15 * (to_real (12.99 ns)) * get_resolution();
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to_time() converts areal value into atime value with respect to the current simulator
resolution. The precision of the converted value is determined by the simulator resolution.
For example, if you were converting 5.9 to atime and the simulator resolution was ps, then
the time value would be 6 ps.

Syntax
timeval := to_time(realval);

Returns

Name Type Description

timeval time Therea value represented as a physical type

time with respect to the simulator resolution

Arguments

Name Type Description

realval real The value of the type red

Related functions
get_resolution (UM-94)
to_real() (UM-96)

Example

If the simulator resolution is set to ps, and you enter the following function:

timeval := to_tinme(72.49);

then the value returned to timeval would be 72 ps.

UM-97
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Foreign language interface

Foreign language interface (FLI) routines are C programming language functions that
provide procedural access to information within Model Technology's HDL simulator,
vsim. A user-written application can use these functions to traverse the hierarchy of an
HDL design, get information about and set the values of VHDL objectsin the design, get
information about a simulation, and control (to some extent) a simulation run.

ModelSim’s FL1 interface is described in detail in the Model Sm FLI Reference. This
document is available from the Help menu within Model Sim or in the docs directory of a
Model Sim installation.
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Modeling memory

AsaVHDL user, you might be tempted to model a memory using signals. Two common
simulator problems are the likely result:

* You may get a"memory alocation error" message, which typically means the simulator
ran out of memory and failed to allocate enough storage.

 Or, you may get very long load, elaboration, or run times.

These problems are usually explained by the fact that signals consume a substantial amount
of memory (many dozens of bytes per bit), al of which needs to be loaded or initialized
before your smulation starts.

Modeling memory with variablesinstead provides some excellent performance benefits:

* storage required to model the memory can be reduced by 1-2 orders of magnitude

* startup and run times are reduced

« associated memory alocation errors are eliminated

In the example below, we illustrate three alternative architectures for entity "memory".
Architecture "style 87 _bad" uses avhdl signal to store the ram data. Architecture

"style 87" usesvariablesin the "memory" process, and architecture "style 93" uses
variablesin the architecture.

For large memories, architecture "style 87 _bad" runs many times longer than the other
two, and uses much more memory. This style should be avoided.

Both architectures"style 87" and "style 93" work with equal efficiently. Y ou'll find some
additional flexibility with the VHDL 1993 style, however, because the ram storage can be
shared between multiple processes. For example, asecond processis shown that initializes
the memory; you could add other processes to create a multi-ported memory.

To implement this model, you will need functions that convert vectorsto integers. To use
it you will probably need to convert integers to vectors.

Example functions are provided below in package "conversions".

library ieee;
use ieee.std_logic_1164.all;
use work. conversions. all;

entity menory is
generic(add_bits : integer := 12;

data_bits : integer := 32);
port(add_in : in std_ul ogic_vector(add_bits-1 downto 0);
data_in : in std_ulogic_vector(data_bits-1 downto 0);
data_out : out std_ul ogic_vector(data_bits-1 downto 0);
cs, mmite : in std_ul ogic;
do_init : in std_ulogic);
subtype word is std_ul ogi c_vector(data_bits-1 downto 0);
constant nwords : integer := 2 ** add_bits;
type ramtype is array(0 to nwords-1) of word;

end;

architecture style_93 of menory is

shared variable ram: ramtype;
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process (cs)
vari abl e address : natural;
begi n
if rising_edge(cs) then
address := sulv_to_natural (add_in);
if (mrite ="'1") then
ram(address) := data_in;
end if;
dat a_out <= ran(address);
end if;
end process nenory;
-- illustrates a second process using the shared variable
initialize:
process (do_init)
variabl e address : natural;
begi n
if rising_edge(do_init) then
for address in 0 to nwords-1 | oop
ram(address) := data_in;
end | oop;
end if;
end process initialize;
end architecture style_93;

architecture style 87 of menory is
begi n

nenory:

process (cs)

variable ram: ramtype;
variabl e address : natural;
begi n
if rising_edge(cs) then
address := sulv_to_natural (add_in);
if (mrite ="'1") then
ram(address) := data_in;
end if;
dat a_out <= ram(address);
end if;
end process;
end style_87;

architecture bad_style_87 of nenory is

begi n
menory:
process (cs)
variabl e address : natural := 0;
begi n
if rising_edge(cs) then
address := sulv_to_natural (add_in);

if (mrite ="'1") then
ram(address) <= data_in;
data_out <= data_in;
el se
dat a_out <= ramn(address);
end if;
end if;
end process;
end bad_styl e_87;
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library ieee
use ieee.std_|logic_1164.all

package conversions is
function sulv_to_natural (x : std_ulogic_vector) return
nat ur al
function natural _to_sulv(n, bits : natural) return
std_ul ogi c_vector
end conversions

package body conversions is

function sulv_to_natural (x : std_ulogic_vector) return
natural is

variable n : natural := 0
variable failure : boolean := fal se
begi n

assert (x'high - x'low + 1) <= 31
report "Range of sulv_to_natural argunent exceeds
natural range"
severity error

for i in x'range |oop
n:=n=*2
case x(i) is
when '1" | 'H =>n:=n+1
when '0" | 'L" => null
when ot hers => failure := true
end case
end | oop

assert not failure
report "sulv_to_natural cannot convert indefinite
std_ul ogi c_vector"
severity error

if failure then
return 0
el se
return n
end if;
end sul v_to_natural

function natural _to_sulv(n, bits : natural) return
std_ul ogic_vector is
variable x : std_ul ogic_vector(bits-1 downto 0) :=
(others =>"'0")

variable tenpn : natural :=n
begi n

for i in x'reverse_range | oop

if (tenpn nod 2) = 1 then
x(i) :="'1";

end if;
tenpn := tenpn / 2

end | oop

return x

end natural _to_sulv;

end conversi ons
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Affecting performance by cancelling scheduled events

Performance will suffer if events are scheduled far into the future but then cancelled before
they take effect. This situation will act like amemory leak and slow down simulation.

In VHDL thissituation can occur several ways. The most common are waits with time-out
clauses and projected waveformsin signal assignments.

The following code shows await with atime-out:
signals synch : bit :="'0";
p: process
begi n

wait for 10 ns until synch = 1;
end process;

synch <= not synch after 10 ns;

At time0, process p makesan event for time 10ms. When synch goesto 1 at 10 ns, the event
at 10 msis marked as cancelled but not deleted, and a new event is scheduled at 10ms +
10ns. The cancelled events are not reclaimed until time 10msis reached and the cancelled
event is processed. As aresult there will be 500000 (10ms/20ns) cancelled but undeleted
events. Once 10msis reached, memory will no longer increase because the simulator will
be reclaiming events as fast as they are added.

For projected waveforms the following would behave the same way:
signals synch : bit :="'0";
p: process(synch)
begi n

output <= '0', '1' after 10nms;
end process;

synch <= not synch after 10 ns;
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Converting an integer into a bit_vector

The following code demonstrates how to convert an integer into a bit_vector.

library ieee
use ieee.nuneric_bit.ALL

entity test is
end test;

architecture only of test is
signal sl : bit_vector(7 downto 0);

signal int : integer := 45
begi n

p: process

begi n

wait for 10 ns;
sl <= bit_vector(to_signed(int,8));
end process p
end only;

ModelSim SE User’'s Manual



UM-104 4 - VHDL simulation

ModelSim SE User’'s Manual



UM-105

5 - Verilog simulation

Chapter contents

Introduction . . . . . . . . . . . . . . . UM-107
Compilation . . .. . .. . . . . . . UM-108
Incremental compllatlon .. .. ... . . . . UM-109
Library usage . . . . . . . . uUmM-111
Verilog-XL compati bIecomp|Ier arguments . . . . . UM-113
Verilog-XL “uselib compiler directive . . . . . . . UM-114
Verilog configurations . . . . . . . . . . . UM-115
Simulation . . . .. . . . . . . . . . UM-116
Invoking the si mulator .o . . . . . . . . . UM-116
Simulator resolution limit. . . . . . . . . . . UM-117
Event orderingin Verilogdesigns . . . . . . . . UM-119
Negative timing check limits . . . .. . . . UM-123
Verilog-XL compatible simulator arguments .. . . . UM-126
Compiling for faster performance. . . . . . . . . . UM-127
Compilingwith-fast . . . . . . . . . . . . UM-127
Compiling with +opt . . . . . . . . . . UM-128
Compiling mixed desgnswnh fast .. . . . . . . UM-129
Compiling gate-level designswith-fast . . . . . . . UM-129
Referencing the optimized design. . . . . . UM-130
Enabling design object visibility with the +acc optlon . . . UM-133
Using pre-compiled libraries . . . . . . . . . . UM-134
Event order and optimizeddesigns . . . . . . . . UM-135
Timing checksinoptimizeddesigns . . . . . . . . UM-13%
Simulating with an elaborationfile . . . . . . . . . UM-136
Overview . . .. .. .. . . . . . . UM-136
Elaboration flleflow .. ... . . . . . . UM-136
Creating an elaborationfile . . . . . . . . . . UM-137
Loading an elaborationfile . . . . . . . . . . UM-137
Modifying stimulus . . . . . . . . . . . . UM-138
Using withthePLIOr FLI. . . . . . . . . . . UM-138
Checkpointing and restoring simulations . . . . . . . . UM-140
Checkpoint file contents . . . . . . . . . UM-140
Controlling checkpoint file comprmon .o .. . UM-141
The difference between checkpoint/restore and r&start . . . UM-141
Using macros with restart and checkpoint/restore . . . . UM-141
Cell libraries . . P O 11/ 5 2 4
SDF timing annotatlon e e e s s UM142
Delaymodes . . . . . . . . . . . . . . UM-142
Systemtasks . . . . ... . . . . UM-144
|EEE Std 1364 system tasks e U]/ e Y
Verilog-XL compatiblesystemtasks. . . . . . . . UM-147
ModelSim Verilog systemtasks . . . . . . . . . UM-149

ModelSim SE User’'s Manual



UM-106 5 - Verilog simulation

Compiler directives . . . . .
IEEE Std 1364 compiler directives

Verilog-XL compatible compiler directives .

Model Sim compiler directives

ModelSim SE User’'s Manual

UM-150
UM-150
UM-151
UM-152



Introduction UM-107

Introduction

This chapter describes how to compile and simulate Verilog designs with Model Sim
Verilog. Model Sim Verilog implements the Verilog language as defined by the IEEE
Standards 1364-1995 and 1364-2001. We recommend that you obtain these specifications
for reference.

In addition to the functionality described inthe | EEE Std 1364, Model Sim Verilog includes
the following features:

 Standard Delay Format (SDF) annotator compatible with many ASIC and FPGA
vendors' Verilog libraries

* Vaue Change Dump (VCD) file extensions for ASIC vendor test tools

» Dynamic loading of PL1/VPI applications (see Chapter 6 - Verilog PLI / VPI)
» Compilation into retargetabl e, executable code

* Incremental design compilation

» Extensive support for mixing VHDL and Verilog in the same design (including SDF
annotation)

* Graphic Interface that is common with Model Sim VHDL
» Extensionsto provide compatibility with Verilog-XL
The following functionality is partially implemented in Model Sim Verilog:

 Verilog Procedural Interface (VPI) (see/<install_dir>/modeltech/docs/technotes/
Verilog_VPI.note for details)

» System Verilog 3.1, Accellera s Extensions to Verilog® (see/<install_dir>/modeltech/
docs/technotes/sysvlog.note for implementation details)

Many of the examplesin this chapter are shown from the command line. For compiling and
simulating within a project or Model Sim’s GUI see:

¢ Getting started with projects (UM-34)
» Compiling with the graphic interface (UM-368)
» Simulating with the graphic interface (UM-377)
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Compilation

Before you can simulate a Verilog design, you must first create alibrary and compile the
Verilog source code into that library. This section provides detailed information on
compiling Verilog designs. For information on creating a design library, see Chapter 3 -
Design libraries.

The Model Sim Verilog compiler, viog, compiles Verilog source code into retargetable,
executable code, meaning that the library format is compatible across al supported
platforms and that you can simulate your design on any platform without having to
recompile your design specifically for that platform. Asyou compile your design, the
resulting object code for modules and UDPs is generated into alibrary. By default, the
compiler places resultsinto thework library. Y ou can specify an alternate library with the
-wor k argument. The following is a simple example of how to create awork library,
compile adesign, and simulate it:

Contents of top.v:

nmodul e top;
initial $display("Hello world");
endnodul e

Create the work library:

% vlib work

Compile the design:

% vl og top.v
-- Conpiling nodule top

Top | evel nodul es:
top

View the contents of the work library (optional):

% vdir
MODULE t op

Simulate the design:

% vsim-c top

# Loadi ng work.top
VSIM 1> run -all

# Hello world
VSIM 2> quit

In this example, the simulator was run without the graphic interface by specifying the -c
argument. After the design was loaded, the simulator command run -all was entered,
meaning to simulate until there are no more simulator events. Finally, the quit command
was entered to exit the simulator. By default, alog of the simulation is written to the
transcript filein the current directory.
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Incremental compilation

By default, Model Sim Verilog supports incremental compilation of designs, thus saving
compilation time when you modify your design. Unlike other Verilog smulators, thereis
no requirement that you compile the entire design in one invocation of the compiler
(although, you may wish to do so to optimize performance; see "Compiling for faster
performance” (UM-127)).

Y ou are not required to compile your design in any particular order because all module and
UDP instantiations and external hierarchica references are resolved when the design is
loaded by the simulator. Incremental compilation is made possible by deferring these
bindings, and as aresult some errors cannot be detected during compilation. Commonly,
these errorsinclude: modules that were referenced but not compiled, incorrect port
connections, and incorrect hierarchical references.

The following example shows how a hierarchical design can be compiled in top-down
order:

Contents of top.v:

nmodul e top;
or2 or2_i (ni1, a, b);
and2 and2_i (n2, nl, c);
endnodul e

Contents of and2.v:

nmodul e and2(y, a, b);
out put vy;
input a, b;
and(y, a, b)
endnodul e

Contents of or2.v:

modul e or2(y, a, b);
out put v;
input a, b;
or(y, a, b);
endnodul e

Compile the design in top down order (assumes work library already exists):

% vlog top.v
-- Conpiling nodule top

Top | evel nodul es:
top
% vl og and2.v
-- Conpiling nmodul e and2

Top | evel nodul es:
and2
% vlog or2.v
-- Conpiling nodule or2

Top | evel nodul es:
or2

UM-109
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Note that the compiler lists each module as atop level module, although, ultimately, only
topisatop-level module. If amoduleis not referenced by another module compiled in the
same invocation of the compiler, then it islisted asatop level module. Thisisjust an
informative message and can be ignored during incremental compilation. The messageis
more useful when you compile an entire design in one invocation of the compiler and need
to know the top-level module names for the simulator. For example,

% vlog top.v and2.v or2.v

-- Conpiling nodule top

-- Conpiling nmodul e and2

-- Conpiling nodule or2

Top | evel nodul es:
top

The most efficient method of incremental compilation isto manually compile only the
modules that have changed. Thisis not always convenient, especially if your source files
have compiler directive interdependencies (such as macros). In this case, you may prefer to
always compile your entire design in one invocation of the compiler. If you specify the
-incr argument, the compiler will automatically determine which modules have changed
and generate code only for those modules. Thisis not as efficient as manual incremental
compilation because the compiler must scan all of the source code to determine which
modules must be compiled.

The following is an example of how to compile a design with automatic incremental
compilation:

% vlog -incr top.v and2.v or2.v

-- Conpiling nodule top

-- Conpiling nodul e and2

-- Conpiling nodule or2

Top | evel nodul es:
top

Now, suppose that you modify the functionality of the or2 module:

% vlog -incr top.v and2.v or2.v
-- Ski pping nodul e top
-- Ski ppi ng nodul e and2
-- Conpiling nodule or2

Top | evel nodul es:
top

The compiler informs you that it skipped the modules top and and2, and compiled or2.

Automatic incremental compilation isintelligent about when to compile a module. For
exampl e, changing acomment in your source code does not result in arecompile; however,
changing the compiler command line arguments results in a recompile of all modules.

P Note: Changes to your source code that do not change functionality but that do affect
source code line numbers (such as adding a comment line) will cause all affected
modul esto be recompiled. This happens because debug information must be kept current
so that Model Sim can trace back to the correct areas of the source code.

ModelSim SE User’'s Manual



Compilation UM-111

Library usage

All modules and UDPsin aVerilog design must be compiled into one or more libraries.
Onelibrary is usually sufficient for a simple design, but you may want to organize your
modulesinto various libraries for a complex design. If your design uses different modules
having the same name, then you are required to put those modules in different libraries
because design unit names must be unique within alibrary.

Thefollowing isan example of how you may organizeyour ASIC cellsinto onelibrary and
the rest of your design into another:

% vlib work

%vlib asiclib

% vlog -work asiclib and2.v or2.v

-- Conpiling nmodul e and2

-- Conpiling nodule or2

Top | evel nodul es:
and2
or2
% vl og top.v
-- Conpiling nodule top

Top | evel nodul es:
top

Note that the first compilation uses the -work asiclib argument to instruct the compiler to
place the resultsin the asiclib library rather than the default work library.

Library search rules

Since instantiation bindings are not determined at compile time, you must instruct the
simulator to search your libraries when loading the design. The top-level modules are
loaded from the library named wor k unless you prefix the modules with the <library>.
option. All other Verilog instantiations are resolved in the following order:

 Search libraries specified with -L f arguments in the order they appear on the command
line.

 Search thelibrary specified in the "Verilog-XL “uselib compiler directive" (UM-114).

* Search libraries specified with -L argumentsin the order they appear on the command
line.

» Search the work library.
» Search thelibrary explicitly named in the special escaped identifier instance name.
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Handling sub-modules with common names

Thework library is not necessarily alibrary named wor k—rather, the work library refers
to the library containing the module that instantiates the module or UDP that is currently
being searched for. Thisdefinitionisuseful if you have hierarchical modulesorganizedinto
separate libraries, and you have commonly-named sub-modules in the libraries that have
different definitions. This may happen if you are using vendor-supplied libraries. For

example, say you have the following:

top

modA

modB

libl:

modA

cellXinliblisdefined differently than celIXinlib2. In this situation, you would specify -L
work first in the search library arguments: -L work -L lib1 -L lib2. If you just specify -L
libA -L libB, instantiations of cellX from modB resolve to the modA version of cellX.
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Verilog-XL compatible compiler arguments

The compiler arguments listed below are equivalent to Verilog-XL arguments and may
ease the porting of adesign to Model Sim. See the vlog command (CR-345) for adescription
of each argument.

+def i ne+<macr o_nanme>[ =<macr o_t ext >]

+del ay_node_di stri but ed

+del ay_node_pat h

+del ay_node_uni t

+del ay_node_zero

-f <fil ename>

+i ncdi r+<directory>

+m ndel ays

+maxdel ays

+nowar n<rmenoni c>

+t ypdel ays

-u

Arguments supporting source libraries

The compiler arguments listed below support source libraries in the same manner as
Verilog-XL. See the vlog command (CR-345) for a description of each argument.

Note that these source libraries are very different from the libraries that the Model Sim
compiler usesto store compilation results. Y ou may find it convenient to use these
arguments if you are porting a design to Model Sim or if you are familiar with these
arguments and prefer to use them.

Source libraries are searched after the source files on the command line are compiled. If
there are any unresolved references to modules or UDPs, then the compiler searches the
source libraries to satisfy them. The modules compiled from source libraries may in turn
have additional unresolved references that cause the source libraries to be searched again.
This processis repeated until all references are resolved or until no new unresolved
referencesarefound. Sourcelibrariesare searched in the order they appear on the command
line.

-v <fil enane>

-y <directory>
+l i bext +<suf fi x>
+l i brescan
+nol i bcel

-R [ <si mar gs>]
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Verilog-XL "uselib compiler directive

The "uselib compiler directive is an alternative source library management scheme to the
-v, -y, and +libext compiler arguments. It has the advantage that a design may reference
different modules having the same name. Y ou compile designs that contain "uselib
directive statements using the -compile_uselibs argument (described below) to vliog (CR-
345).

The syntax for the “uselib directiveis:

“uselib <library_reference>..

where <library_reference> is:

dir=<library_directory> | file=<library_file> | |ibext=<file_extension>
I'i b=<library_name>

Thelibrary references are equivalent to command line arguments as follows:

dir=<library_directory> -y <library_directory>
file=<library_file> -v <library_file>
I'i bext=<file_extension> +libext+<fil e_extension>

For example, the following directive

“uselib dir=/h/vendorA |ibext=.v

is equivalent to the following command line arguments:

-y /'h/vendor A +libext+.v

Since the "uselib directives are embedded in the Verilog source code, thereis more
flexibility in defining the source libraries for the instantiations in the design. The
appearance of a "uselib directive in the source code explicitly defines how instantiations
that follow it are resolved, completely overriding any previous "uselib directives.

-compile_uselibs argument

Use the -compile_uselibs argument to vlog (CR-345) to reference “uselib directives. The
argument finds the source files referenced in the directive, compiles them into
automatically created object libraries, and updates the modelsim.ini file with the logical
mappings to the libraries.

When using -compile_uselibs, Model Sim determines into which directory to compile the
object libraries by choosing, in order, from the following three values;

» The directory name specified by the -compile_uselibs argument. For example,
-conpi |l e_uselibs=./nydir

» Thedirectory specified by the MTI_USELIB_DIR environment variable (see
"Environment variables' (UM-613))

* A directory named mti_uselibs that is created in the current working directory

P Note: In ModelSim versions prior to 5.5, the library files referenced by the “uselib
directive were not automatically compiled by ModelSim Verilog. To maintain
backwards compatibility, thisis still the default behavior when -compile_uselibsis not
used. See www.model.com/support/documentation/BOOK /pre55 usdlib.pdf for a
description of the pre-5.5 implementation.
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The following code fragment and compiler invocation show how two different modules
that have the same name can be instantiated within the same design:
nmodul e top
“uselib dir=/h/vendorA |ibext=.v
NAND2 ul(nil, n2, n3);
“uselib dir=/h/vendorB |ibext=.v
NAND2 u2(n4, n5, n6);
endnodul e

This allows the NAND2 modul e to have different definitions in the vendorA and vendorB
libraries.

‘uselib is persistent

As mentioned above, the appearance of a "uselib directive in the source code explicitly
defines how instantiations that follow it are resolved. This may result in unexpected
consequences. For example, consider the following compile command:

vlog -conpile_uselibs dut.v srtr.v

Assume that dut.v contains a “uselib directive. Since srtr.v is compiled after dut.v, the
“uselib directiveis still in effect. When srtr isloaded it is using the “uselib directive from
dut.v to decide where to locate modules. If thisisnot what you intend, then you need to put
an empty "uselib at the end of dut.v to "close" the previous "uselib statement.

Verilog configurations

The Verilog 2001 spec added configurations. Configurations specify how adesignis
"assembled" during the elaboration phase of simulation. Configurations actually consist of
two pieces: the library mapping and the configuration itself. The library mapping is used at
compile time to determine into which libraries the source files are to be compiled. Hereis
an example of asimple library map file:

l'ibrary work .. ltop.v;

library rtliLib Irmex_top.v;

library gatelLib |rmex_adder.vg
library aLib | rm ex_adder. v;

Here is an example of alibrary map file that uses -incdir:

library libl src_dir/*.v -incdir ../include_dir2, ../, my_incdir
The name of the library map file is arbitrary. Y ou specify the library map file using the
-libmap argument to the viog command (CR-345). Alternatively, you can specify thefile

name as the first item on the viog command line, and the compiler will read it as alibrary
map file.

The library map file must be compiled along with the Verilog source files. Multiple map
files are allowed but each must be preceded by the -libmap argument.

The library map file and the configuration can exist in the same or different files. If they
are separate, only the map file needs the -libmap argument. The configuration istreated as
any other Verilog sourcefile.
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Simulation

TheModel Sim simulator can load and simulate both Verilog and VHDL designs, providing
auniform graphic interface and simulation control commandsfor debugging and analyzing
your designs. The graphic interface and simulator commands are described elsewhere in
this manual, while this section focuses specifically on Verilog simulation.

Invoking the simulator

A Verilog design is ready for simulation after it has been compiled into one or more
libraries. The simulator may then be invoked with the names of the top-level modules
(many designs contain only one top level module). For example, if your top level modules
are "testbench" and "globals’, then invoke the simulator as follows:

vsi m test bench gl obal s

After the simulator |oadsthe top-level modules, it iteratively loads theinstantiated modules
and UDPsin the design hierarchy, linking the design together by connecting the ports and
resolving hierarchical references. By default all modules and UDPs are loaded from the
library named wor k. Modules and UDPs from other libraries can be specified using the -L
or -Lf arguments to vsim (see "Library usage" (um-111) for details).

On successful loading of the design, the simulation timeis set to zero, and you must enter
arun command to begin simulation. Commonly, you enter run -all to run until there are
no more simulation events or until $finish is executed in the Verilog code. Y ou can also
run for specific time periods (e.g., run 100 ns). Enter the quit command to exit the
simulator.
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Simulator resolution limit

The simulator internally represents time as a 64-bit integer in units equivalent to the
smallest unit of simulation time, also known as the simulator resolution limit. The
resolution limit defaults to the smallest time precision found among all of the timescale
compiler directivesin the design. Hereis an example of a “timescale directive:

“tinescale 1 ns / 100 ps

Thefirst number isthetime unitsand the second number isthetime precision. Thedirective
above causes time values to be read as ns and to be rounded to the nearest 100 ps.

Modules without timescale directives

Y ou may encounter unexpected behavior if your design contains some modules with
timescale directives and others without. The time units for modules without atimescale
directive default to the simulator resolution. For example, say you have the two modules
shown in the table below:

Module 1 Module 2
“tinmescale 1 ns / 10 ps nmodul e nmod2 (set);
nodul e nodl (set); out put set;
reg set;
out put set; paranmeter d = 1.55;
reg set;
paraneter d = 1.55; initial
begi n
initial set = 1'bz;
begi n #d set = 1'bO;
set = 1'bz; #d set = 1'bl;
#d set = 1'bO; end
#d set = 1'bl;
end endnodul e
endnodul e

If youinvokevsim asvsi mnod2 nod1 then Module 1 setsthe simulator resolutionto 10 ps.
Module 2 has no timescale directive, so the time units default to the simulator resolution,
in this case 10 ps. If you watched /mod1/set and /mod2/set in the Wave window, you' d see
that in Module 1 it transitions every 1.55 ns as expected (because of the 1 nstime unitin
the timescale directive). However, in Module 2, set transitions every 20 ps. That’ s because
the delay of 1.55in Module 2 isread as 15.5 ps and is rounded up to 20 ps.

In such cases Model Sim will issue the following warning message during elaboration:

** \Warning: (vsim3010) [ TSCALE] - Mddul e 'npdl' has a “tinescale directive
in effect, but previous nodul es do not.
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If youinvoke vsim asvsi m nod1 nmod2, the simulation results would be the same but
Model Sim would produce a different warning message:

** \Warning: (vsim3009) [ TSCALE] - Modul e ' mbd2' does not have a “tinescale
directive in effect, but previous nodul es do

These warnings should ALWAY S be investigated.

If the design contains no “timescale directives, then the resolution limit and time units
default to the value specified by the Resolution (Um-624) variable in the modelsim.ini file.
(Thevariableis set to 1 ns by default.)

Multiple timescale directives

As alluded to above, your design can have multiple timescale directives. The timescale
directive takes effect where it appearsin a source file and applies to al source files which
follow in the same vlog (CR-345) command. Separately compiled modules can also have
different timescales. The simulator determines the smallest timescale of all the modulesin
adesign and uses that as the simulator resolution.

‘timescale, -t, and rounding

Theoptional vsim argument -t setsthe simulator resolution limit for the overall simulation.
If the resolution set by -t islarger than the precision set in amodule, the timevaluesin that
module are rounded up. If the resolution set by -t is smaller than the precision of the
module, the precision of that module remains whatever is specified by the “timescale
directive. Consider the following code:

“tinmescale 1 ns / 100 ps
nmodul e foo

initial
#12.536 $di spl ay

The list below shows three possibilities for -t and how the delays in the module would be
handled in each case:
* -t not set
The delay will be rounded to 12.5 as directed by the modul€’s ‘timescale directive.
o -tissettolfs

The delay will be rounded to 12.5. Again, the modul€’ s precision is determined by the
‘timescale directive. Model Sim does not override the modul€’ s precision.

e -tissettolns

The delay will be rounded to 12. The modul€’ s precision is determined by the -t setting.
Model Sim has no choice but to round the modul€’ s time values because the entire
simulation is operating at 1 ns.

Choosing the resolution

Y ou should choose the coarsest resolution limit possible that does not result in undesired
rounding of your delays. The time precision should not be unnecessarily small because it
will limit the maximum simulation time limit, and it will degrade performance in some
cases.
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Event ordering in Verilog designs

Event-based simulators such as Model Sim may process multiple events at a given
simulation time. The Verilog languageis defined such that you cannot explicitly control the
order in which simultaneous events are processed. Unfortunately, some designsrely on a
particular event order, and these designs may behave differently than you expect.

Event queues

Section 5 of the IEEE Std 1364-1995 L RM defines several event queues that determine the
order in which events are evaluated. At the current simulation time, the simulator has the
following pending events:

* active events
* inactive events
* non-blocking assignment update events
* monitor events
o future events
- inactive events
- non-blocking assignment update events

The LRM dictates that events are processed asfollows— 1) all active events are processed;
2) the inactive events are moved to the active event queue and then processed; 3) the
non-blocking events are moved to the active event queue and then processed; 4) themonitor
eventsare moved to the active queue and then processed; 5) simulation advancesto the next
time where there is an inactive event or a non-blocking assignment update event.

Within the active event queue, the events can be processed in any order, and new active
events can be added to the queue in any order. In other words, you cannot control event
order within the active queue. The example below illustrates potential ramifications of this
situation.

Say you have these four statements:
1 aways@(d) p=q;

2 aways @(q) p2=not q;

3 aways @(p or p2) clk = p and p2;

4 aways @(posedge clk)
and current values asfollows: =0, p=0, p2=1
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The tables below show two of the many valid evaluations of these statements. Eval uation
events are denoted by anumber where the number is the statement to be evaluated. Update
eventsare denoted < name> (ol d->new) where <name> indicatesthe reg being updated and
new is the updated value.

Table 1; Evaluation 1

Event being processed Active event queue
a0 - 1)

q0 - 1) 1,2

1 p(0 - 1),2

p(0 - 1) 3,2

3 ck(0 - 1),2

ck( - 1) 4,2

4 2

2 p2(1 - 0)

p2(1 - 0) 3

3 ck( - 0)

clk(1 - 0) <empty>

Table 2: Evaluation 2

Event being processed Active event queue
q0 - 1)
q0 - 1) 1,2
1 p(0 - 1),2
2 p2(1 - 0), p(0 - 1)
p(0 - 1) 3,p2(1 - 0)
p2(1 - 0) 3
3 <empty> (clk doesn’t change)

Again, both evaluations are valid. However, in Evaluation 1, clk hasaglitch onit; in
Evaluation 2, clk doesn’t. Thisindicates that the design has a zero-delay race condition on
clk.
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‘Controlling’ event queues with blocking/non-blocking assignments

The only control you have over event order isto assign an event to aparticular queue. You
do this via blocking or non-blocking assignments.

Blocking assignments

Blocking assignments place an event in the active, inactive, or future queues depending on
what type of delay they have:

* ablocking assignment without a delay goesin the active queue
« ablocking assignment with an explicit delay of 0 goesin the inactive queue
» ablocking assignment with a non-zero delay goes in the future queue

Non-blocking assignments

A non-blocking assignment goes into either the non-blocking assignment update event
gueue or the future non-blocking assignment update event queue. (Non-blocking
assignments with no delays and those with explicit zero delays are treated the same.)

Non-blocking assignments should be used only for outputs of flip-flops. This insures that
al outputs of flip-flops do not change until after al flip-flops have been evaluated.
Attempting to use non-blocking assignments in combinational logic paths to remove race
conditions may only cause more problems. (In the preceding example, changing all
statements to non-blocking assignments would not remove the race condition.) This
includes using non-blocking assignments in the generation of gated clocks.

The following is an example of how to properly use non-blocking assignments.

genl: always @nuaster)
clkl = master;

gen2: always @cl k1)
cl k2 = cl ki;

fl1: always @posedge clkl)
begi n
ql <= di;
end

f2: al ways @ posedge cl k2)
begi n
g2 <= ql;
end

If written thisway, avalue on d1 always takes two clock cyclesto get from d1 to g2.
If you change clkl = master and clk2 = clk1 to non-blocking assignmentsor g2 <= g1 and
g1 <= d1 to blocking assignments, then d1 may get to g2 isless than two clock cycles.

Debugging event order issues

Since many models have been devel oped on Verilog-XL, ModelSim tries to duplicate
Verilog-XL event ordering to ease the porting of those modelsto Model Sim. However,
Model Sim does not match Verilog-XL event ordering in all cases, and if amodel ported to
M odel Sim does not behave as expected, then you should suspect that there are event order
dependencies.

UM-121
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Model Sim helps you track down event order dependencies with the following compiler
arguments: -compat, -hazards, and -keep_delta.

See the viog command (CR-345) for descriptions of -compat and -keep_delta.

Hazard detection

The-hazar d argument to vsim (CR-357) detectsevent order hazardsinvol ving simultaneous
reading and writing of the same register in concurrently executing processes. vsim detects
the following kinds of hazards:

* WRITE/WRITE:
Two processes writing to the same variable at the same time.

« READ/WRITE:
One process reading avariable at the same timeit is being written to by another process.
ModelSim calls thisa READ/WRITE hazard if it executed the read first.

 WRITE/READ:
Same as a READ/WRITE hazard except that M odel Sim executed the write first.

vsim issues an error message when it detects a hazard. The message pinpointsthe variable
and the two processes involved. Y ou can have the simulator break on the statement where
the hazard is detected by setting the break on assertion level to Error.

To enable hazard detection you must invoke vlog (CR-345) with the -hazar ds argument
when you compile your source code and you must also invoke vsim with the -hazar ds
argument when you simul ate.

A | mportant: Enabling -hazar dsimplicitly enables the -compat argument. As aresult,
using this argument may affect your simulation results.

Limitations of hazard detection

» Reads and writesinvolving bit and part selects of vectors are not considered for hazard
detection. The overhead of tracking the overlap between the bit and part selectsistoo
high.

« AWRITE/WRITE hazard is flagged even if the same valueis written by both processes.

« AWRITE/READ or READ/WRITE hazard isflagged even if the write does not modify
the variable's value.

* Glitches on nets caused by non-guaranteed event ordering are not detected.
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Negative timing check limits

Verilog supports negative limit valuesin the $setuphold and $recrem system tasks. These
tasks have optional delayed versions of input signalsto insure proper eval uation of models
with negative timing check limits. Delay values for these delayed nets are determined by
the simulator so that valid datais available for evaluation before a clocking signal.

Example

$set uphol d(posedge cl k, negedge d, 5, -3, Notifier,,, clk_dly, d_dly)

d violation 5 3
regi on s

0
clk -1

Model Sim cal culates the delay for signal d_dly as 4 time unitsinstead of 3. It does thisto
prevent d_dly and clk_dly from occurring simultaneously when aviolation isn’t reported.

M odel Sim accepts negative limit checks by default, unlike current versions of Verilog-XL.
To match Verilog-XL default behavior (i.e., zeroing al negative timing check limits), use
the +no_neg_tcheck argument to vsim (CR-357).

Negative timing constraint algorithm

The agorithm Model Sim uses to cal culate delays for delayed netsisn’t described in IEEE
Std 1364. Rather, Model Sim matches Verilog-X L behavior. The algorithm attemptsto find
aset of delays so the data net is valid when the clock net transitions and the timing checks
are satisfied. The algorithm isiterative because a set of delays can be selected that satisfies
all timing checks for apair of inputs but then causes mis-ordering of another pair (where
both pairs of inputs share acommon input). When a set of delays that satisfies al timing
checksis found, the delays are said to converge.

When none of the delay sets cause convergence, the algorithm pessimistically changesthe
timing check limits to force convergence. Basically the algorithm zeroes the smallest
negative $setup/$recovery limit. If a negative $setup/$recovery doesn't exist, then the
algorithm zeros the smallest negative $hold/$removal limit. After zeroing anegative limit,
the delay calculation procedure is repeated. If the delays don’t converge, the algorithm
zeros another negative limit, repeating the process until convergence is found.
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A simple example will help clarify the algorithm. Assume you have the following timing
checks:
$set uphol d(posedge clk, posedge d, 3, -2, NOTIFIER,,, clk_dly, d_dly)
$set uphol d( posedge cl k, negedge d, 6, -5, NOTIFIER, ,, clk_dly, d_dly)
$set uphol d( posedge cl k, posedge t, 20, -12 , NOTIFIER,,, clk_dly, t_dly)
$set uphol d( posedge cl k, negedge t, 18, -11 , NOTIFIER ,, clk_dly, t_dly)

The violation regions for t and d in this example are:

. . 20 12
t violation
regi on /ST
18 11
AANANAN
d violation 3 2
regi ons 6 5 /)7
AAANANAN 0
cl k |

Note that the delays between clk/clk_dly, t/t_dly, and d/d_dly are not edge sensitive, and
they must be the same for both rising and falling transitions of clk, t,and d. A d =>d_dly
delay of 5 will satisfy the negedge case (transitions of d from 5 to 0 before clk won't be
latched), but valid transitions of posedge d, in the region of 5 to 3 before clk, won't latch
correctly. Therefore, to find convergence, the algorithm starts zeroing negative $hold
limits (-12, then -11, and then -5). The check limits ont are zeroed first because of their
magnitude.

Model Sim will display messages when limits are zeroed if you use the +ntc_warn
argument. Even if you don't set +ntc_warn, Model Sim displays a summary of any zeroed
limits.

Extending check limits without zeroing

If zeroing limitsistoo pessimistic for your design, you can usethevsim (CR-357) arguments
-extend_tcheck_data_limit and -extend_tcheck_ref_limit instead. These arguments
cause aone-time extension of qualifying dataor reference limitsin an attempt to provide a
solution prior to any limit zeroing. A limit qualifiesif it bounds a violation region which
does not overlap arelated violation region.

An examplewill help illustrate. Assume you have the following timing checks:

$set uphol d( posedge cl k, posedge d, 45, 70, notifier,,,dclk, dd)
$set uphol d( posedge cl k, negedge d, 216, -68, notifier,,,dclk,dd)

The violation regions for d in this example are:

d violation 45 70

regi ons 216 .68 Yy
NISEN 0

clk |
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The delay net delay analysisin this case does not provide a solution. The required negative
hold delay of 68 between d and dd could cause a non-violating posedge d transition to be
delayed on dd so that it could arrive after dclk for functional evaluation. By default the -68
hold limit is set pessimistically to 0 to insure the correct functional evaluation.

Alternatively, you could use -extend_tcheck _data_limit to overlap the regions. In this
example we must specify the percentage by which to "decrease” the negative hold limit in
order to overlap the positive setup limit. In other words, you must extend the 216, -68
region to 216, -44. Y ou would cal cul ate the percentage as follows:

1 Cdculate the size of the negative edge violation region:
216 - 68 = 148

2 Calculate the gap between the negative hold limit and the positive setup limit and add
one timing unit to allow for overlap:

68-45=23+1=24

3 Divide the gap size by the violation region size:
24/148=.16
Hence, you would set -extend_tcheck_data limit to 16.

P Note: Model Sim will extend the limit only as far asis needed to derive asolution. So if
you used 100 in the previous example, it would still only extend the limit 16 percent.
Indeed, in some casesit may be easiest to select alarge percentage number and not worry
about an exact calculation.

Using delayed inputs for timing checks

By default Model Sim performs timing checks on inputs specified in the timing check. If
you want timing checks performed on the delayed inputs, use the
+delayed_timing_checks argument to vsim.

Consider and example. This timing check:
$set uphol d( posedge cl k, posedge t, 20, -12, NOTIFIER,,, clk_dly, t_dly);

reports atiming violation when posedge t occurs in the violation region:

20 -12
t Y

cl k !

With the +delayed_timing_checks argument, the violation region between the delayed
inputsis:

7 1
t dly AN
0

clk dly |

UM-125
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Although the check is performed on the delayed i nputs, the timing check violation message
is adjusted to reference the undelayed inputs. Only the report time of the viol ation message
is noticeably different between the delayed and undelayed timing checks.

By far the greatest difference between these modesis evident when there are conditions on
adelayed check event because the condition is not implicitly delayed. Also, timing checks
specified without explicit delayed signalsare delayed, if necessary, when they reference an
input that is delayed for a negative timing check limit.

Verilog-XL compatible simulator arguments
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The simulator arguments listed below are equivalent to Verilog-XL arguments and may
ease the porting of adesign to Model Sim. Seethe vsim command (CR-357) for adescription
of each argument.

+al t _pat h_del ays

-1 <fil ename>

+maxdel ays

+m ndel ays

+mul ti source_int_del ays
+no_cancel | ed_e_nsg
+no_neg_t chk
+no_notifier

+no_pat h_edge

+no_pul se_nsg

+no_show _cancel | ed_e
+nosdf war n

+nowar n<rmenoni c>

+nt c_warn

+pul se_e/ <percent >
+pul se_e_styl e_ondet ect
+pul se_e_styl e_onevent
+pul se_i nt _e/ <percent >
+pul se_i nt _r/ <percent >
+pul se_r/ <percent >
+sdf _nocheck_cel I type
+sdf _verbose
+show_cancel | ed_e
+transport_int_del ays
+transport _pat h_del ays
+t ypdel ays



Compiling for faster performance UM-127

Compiling for faster performance

This section describes how to use the -fast compiler argument to analyze and optimize an
entire design for improved simulation performance. This argument improves performance
for RTL, behavioral, and gate-level designs (See below for important information specific
to gate-level designs.).

Model Sim's default mode of compilation defers module instantiations, parameter
propagation, and hierarchical reference resolution until the time that a design isloaded by
the simulator (see"Incremental compilation” (UM-109)). This has the advantage that a
design does not have to be compiled all at once, allowing independent compilation of
modul es without requiring knowledge of the context in which they are used.

Compiling modules independently provides flexibility to the user, but resultsin less
efficient simulation performance in many cases. For example, the compiler must generate
code for a modul e containing parameters as though the parameters are variables that will
receive their final values when the design is loaded by the simulator. If the compiler is
allowed to analyze the entire design at once, then it can determine the final values of
parameters and treat them as constants in expressions, thus generating more efficient code.
Thisisjust one example of many other optimizations that require analysis of the entire
design.

Compiling with -fast

The -fast compiler argument allows the compiler to propagate parameters and perform
global optimizations. A requirement of using the -fast argument is that you must compile
the source code for your entire design in asingle invocation of the compiler. The following
is an example invocation of the compiler and its resulting messages:

% vlog -fast cpu_rtl.v

-- Conpiling nmodule fp_unit
-- Conpiling nmodule nmult_56
-- Conpiling nodul e testbench
-- Conpiling nodule cpu

-- Conpiling nodule i_unit

-- Conpiling nmodul e mem nmux
-- Conpiling nmodul e menory32
-- Conpiling nodul e op_unit

Top | evel nodul es:

t est bench

Anal yzi ng design..

Optim zing 8 nodul es of which 6 are inlined
-- Inlining nodule i_unit(fast)

-- Inlining nodul e mem nux(fast)

-- Inlining nodule op_unit(fast)
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-- Inlining nodul e menory32(fast)
-- Inlining nmodule mult_56(fast)
-- Inlining nodule fp_unit(fast)
-- Optimzing nodul e cpu(fast)

-- Optimzing nodul e testbench(fast)

The"Analyzing design..." message indicates that the compiler is building the design
hierarchy, propagating parameters, and analyzing design object usage. Thisinformationis
then used in the final step of generating module code optimized for the specific design.
Note that some modules are inlined into their parent modul es.

Once the design is compiled, it can be simulated in the usual way:

% vsim -c testbench

# Loadi ng work.testbench(fast)
# Loadi ng work. cpu(fast)

VSIM 1> run -all

VSI M 2> quit

Asthe simulator loads the design, it issues messages indicating that the optimized modules
arebeing loaded. There are no messages for loading the inlined modul es because their code
isinlined into their parent modules.

Incremental compiles with -fast

Y ou can compile adesign incrementally by using the -incr argument in tandem with -fast.
By using -incr, only changed modul es are recompiled. Thismay decrease compilation time
significantly for large designs. Note, however, that if you change any other compiler
options, al modules are recompiled regardless if you use -incr.

Compiling with +opt

The +opt compiler argument may be used instead of -fast when it isundesirableto compile
the entire design in asingle invocation of the compiler (when using a Makefile, for
example, that only compilesfiles that have been modified). After compiling the design
without -fast, the design may then be optimized using +opt.

The optimizations performed by +opt areidentical to those performed by -fast. The only
difference between the two argumentsiis that +opt does not need to compile the source
code; +opt loads the design units from the libraries and regenerates optimized code for
them. If the design units reside in multiple libraries, then it may be necessary to use the -L
and -Lf arguments to specify the search libraries.

Any options that are appropriate for -fast are appropriate for +opt. Specificaly, you can
al so use the +acc option to enable PLI access.

See the vlog command (CR-345) for syntax.
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Compiling mixed designs with -fast

A Verilog design compiled with -fast or optimized with +opt allowsinstantiation of VHDL
components underneath the Verilog. The VHDL design units must be compiled into a
library before optimizing the Verilog design that references them. The Verilog compiler

i ssues awarning message to emphasize that the VHDL instantiations are not optimized. For
best performance with -fast and +opt, instantiate V erilog modules when possible.

A Verilog module compiled with -fast can be instantiated from VHDL aslong as the
VHDL does not need to modify the parameters of the module.

Compiling gate-level designs with -fast

Gate-level designs often have large netlists that are slow to compile with -fast. In most
cases we recommend the following flow for optimizing gate-level designs:

» Compilethe cell library using -fast and the -for cecode argument. The -for cecode
argument ensures that code is generated for inlined modules.

» Compilethe device under test and testbench without -fast.

One case where you wouldn’t follow this flow is when the testbench has hierarchical
references into the cell library. Optimizing the library alone would result in unresolved
references. In such acase, you'll have to compile the library, design, and testbench with
-fast in one invocation of the compiler. The hierarchical reference cells are then not
optimized.

Note too that as of Model Sim version 5.5b, several new switches to viog can be used to
further increase optimizations on gate-level designs. The +nocheck arguments are
described in the Command Reference under the viog command (CR-345).

Y ou can usethewrite cell_report command (CR-388) and the -debugCellOpt argument to
thevlog command (CR-345) to obtain information about which cells have and have not been
optimized. write cell_report produces atext file that lists all modules. Modules with
"(cel)" following their names are optimized cells. For example,

Modul e: top
Architecture: fast

Modul e: bottom (cell)
Architecture: fast

In this case, both top and bottom were compiled with -fast, but top was not optimized and
bottom was.

The-debugCellOpt argument is used with -fast when compiling thecell library. Using this
argument results in Main window transcript output that identifies why certain cells were
not optimized.

P Note: ModelSim versions 5.6 and later recognize amodule as a gate if the module
contains a non-empty specify block. Earlier versions identified gate cells using the
“celldefine directive.

ModelSim SE User’s Manual



UM-130 5 - Verilog simulation

Referencing the optimized design

The compiler automatically assigns a secondary name to distinguish the design-specific
optimized code from the unoptimized code that may coexist inthe samelibrary. The default
secondary name for optimized codeis "fast", and the default secondary name for
unoptimized code is "verilog". Y ou may specify an alternate name (other than "fast") for
optimized code using the -fast=<name> option. For example, to assign the secondary name
"optl" to your optimized code, you would enter the following:

% vlog -fast=optl cpu_rtl.v

If you have multiple designsthat use common modules compiledinto the samelibrary, then
you need to assign a different secondary name for each design so that the optimized code
for amodule used in one design context is not overwritten with the optimized code for the
same module used in another context. Thisistrue even if the designs are smdl variations
of each other, such as different testbenches. For example, suppose you have two
testbenches that instantiate and test the same design. Y ou might assign different secondary
names as follows:

% vlog -fast=t1 testbenchl.v design.v
-- Conpiling nodul e testbenchl
-- Conpiling nmodul e design

Top | evel nodul es:

test benchl

Anal yzi ng design...

Optimzing 2 nodul es of which 0 are inlined:
-- Optimzing nodul e design(tl)

-- Optimzing nodul e testbenchl(t1)

% vlog -fast=t2 testbed2.v design.v
-- Conpiling nodul e testbench2
-- Conpiling nmodul e design

Top | evel nodul es:

t est bench2

Anal yzi ng design...

Optimzing 2 nodul es of which 0 are inlined:
-- Optimzing nodul e design(t2)

-- Optimzing nodul e testbench2(t?2)

All of the modules within design.v compiled for testbenchl are identified by t1 within the
library, whereas for testbench?2 they are identified by t2. When the simulator |oads
testbenchl, the instantiations from testbenchl reference the t1 versions of the code.
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Likewise, theinstantiations from testbench2 reference the t2 versions. Therefore, you only
need to invoke the simulator on the desired top-level module and the correct versions of
code for the lower level instances are automatically loaded.

The only time that you need to specify asecondary nameto the simulator iswhen you have
multiple secondary names associated with atop-level module. If you omit the secondary
name, then, by default, the simulator loads the most recently generated code (optimized or
unoptimized) for the top-level module. Y ou may explicitly specify a secondary name to
load specific optimized code (specify "verilog" to load the unoptimized code). For
example, suppose you have atop-level testbench that works in conjunction with each of
several other top-level modules that only contain defparams that configure the design. In
this case, you need to compile the entire design for each combination, using a different
secondary name for each. For example,

% vlog -fast=cl testbench.v design.v configl.v
-- Conpiling nodul e testbench

-- Conpiling nodul e design

-- Conpiling nodul e configl

Top | evel nodul es:
t est bench

configl

Anal yzi ng design...

Optimzing 3 nodul es of which O are inlined:
-- Optim zing nodul e design(cl)

-- Optimzing nodul e testbench(cl)

-- Optimzing nodul e configl(cl)

% vl og -fast=c2 testbench.v design.v config2.v
-- Conpiling nodul e testbench

-- Conpiling nmodul e design

-- Conpiling nodul e config2

Top | evel nodul es:
test bench

config2

Anal yzi ng design...

Optimzing 3 nodul es of which 0 are inlined:
-- Optimzing nodul e design(c2)

-- Optimzing nodul e testbench(c2)

-- Optimzing nodul e config2(c2)

UM-131
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Since the module "testbench™ has two secondary names, you must specify which one you
want when you invoke the simulator. For example,

% vsim'testbench(cl)' configl

Notethat it isnot necessary to specify the secondary namefor configl, becauseit has only
one secondary name. If you omit the secondary name, the simulator defaults to loading the
secondary name specified in the most recent compilation of the module.

If you prefer to usethe Simulate dial og box to select top-level modules, then those modul es
compiled with -fast can be expanded to view their secondary names. Click on the one you
wish to simulate.

To view thelibrary contents viathe GUI, expand the library in the Library tab (Main
window) to see the modul es and their associated secondary names. From the command line,
execute the vdir command (CR-316) on a specific module. For example,

VSIM 1> vdir design

# MODULE desi gn

# Optimzed Module t1
# Optimzed Mdule t2

P Note: In some cases, an optimized module will have"__<n>" appended to its secondary
name. This happens when multiple instantiations of a module require different versions
of optimized code (for example, when the parameters of each instance are set to different
values).
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Enabling design object visibility with the +acc option

Some of the optimizations performed by the -fast argument impact design visibility to both
theuser interface and the PLI routines. Many of the nets, ports, and registersare unavailable
by name in user interface commands and in the various graphic interface windows. In
addition, many of these objects do not have PLI Access handles, potentially affecting the
operation of PLI applications. However, a handle is guaranteed to exist for any object that
is an argument to a system task or function.

In the early stages of design, you may choose to compile without the -fast argument so as
to retain full debug capabilities. Alternatively, you may use one or more +acc optionsin
conjunction with -fast to enable access to specific design objects. However, keep in mind
that enabling design object access may reduce simulation performance.

The syntax for the +acc option is as follows:

+acc[ =<spec>] [ +<nodul e>[ .]]

<spec> is one or more of the following characters:

<spec> Meaning

b Enable accessto individua bits of vector nets. Thisis necessary
for PLI applications that require handles to individual bits of
vector nets. Also, some user interface commands require this
access if you need to operate on net bits.

c Enable accessto library cells. By default any Verilog module
that contains a non-empty specify block may be optimized, and
debug and PL | access may be limited. This option keeps module
cell visibility.

Enable line number directives and process names for line
debugging, profiling, and code coverage.

n Enable access to nets.

p Enable access to ports. This disables the module inlining
optimization, and should be used for PLI applications that
require access to port handles, or for debugging (see below).

r Enable access to registers (including memories, integer,
time, and real types).

S Enable system tasks.

t Enable access to tasks and functions.

If <spec> is omitted, then accessis enabled for all objects.

<module> isamodule name, optionally followed by "." to indicate all children of the
module. Multiple modules are alowed, each separated by a"+". If no modules are
specified, then all modules are affected. We strongly recommend specifying moduleswhen
using +acc. Doing so will lessen the impact on performance.

If your design uses PLI applications that look for object handles in the design hierarchy,
then it islikely that you will need to use the +acc option. For example, the built-in
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$dumpvar s system task isan internal PLI application that requires handles to nets and
registerssothat it can call the PLI routine acc_vcl_add() to monitor changes and dump the
valuestoaVCD file. Thisrequiresthat accessisenabled for the netsand registerson which
it operates. Suppose you want to dump all nets and registersin the entire design, and that
you have the following $dumpvars call in your testbench (no arguments to $dumpvars
means to dump everything in the entire design):

initial $dunpvars
Then you need to compile your design as follows to enable net and register access for all
modulesin the design:

% vl og -fast +acc=rn testbench.v design.v

As another example, suppose you only need to dump nets and registers of a particular
instance in the design (the first argument of 1 meansto dump just the variablesin the
instance specified by the second argument):

initial $dumpvars(1, testbench.ul);

Then you need to compile your design as follows (assuming testbench.ul refersto the
module design):

% vl og -fast +acc=rn+design testbench.v design.v

Finally, suppose you need to dump everything in the children instances of testbench.ul (the
first argument of 0 meansto also include al children of the instance):

initial $dumpvars(0, testbench.ul);

Then you need to compile your design as follows:

% vl og -fast +acc=rn+design. testbench.v design.v

To gain maximum performance, it may be necessary to enable the minimum required
access within the design.

Using pre-compiled libraries

When using the -fast argument, if the source code is unavailable for any of the modules
referenced in adesign, then you must search libraries for the precompiled modules using
the-L or -Lf argument to vlog (CR-345). The compiler optimizes pre-compiled modulesthe
same asif the source code is available. The optimized code for a pre-compiled moduleis
written to the same library in which the module is found.

The compiler automatically searches libraries specified in the “uselib directive (see
Verilog-XL “uselib compiler directive (UM-114)). If your design exclusively uses “usdlib
directives to reference modules in other libraries, then you don't need to specify library
search arguments to the compiler.

P Note: If you use-L or -Lf with the compiler, you must also you use them with
vsim (CR-357) when you simulate the design.
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Event order and optimized designs

As mentioned earlier in the chapter, the Verilog language does not require that the
simulator execute simultaneous eventsin any particular order. Optimizations performed by
-fast may expose event order dependencies that cause a design to behave differently than
when compiled without -fast. Event order dependencies are considered errors and should
be corrected (see "Event ordering in Verilog designs' (Um-119) for details). Alternatively,
you may use the -keep_delta argument (see vlog (CR-345)) to disable most -fast
optimizations that potentially reorder events. Keep in mind this may reduce performance.

Timing checks in optimized designs

Timing checks are performed whether you compile the design with or without -fast. In
genera you'll seethe same resultsin either case. However, in a cell where there are both
interconnect delays and conditional timing checks, you might see different timing check
results.

Without -fast the conditional checks are evaluated with non-delayed values, complying
with the original |EEE Std 1364-1995 specification. With -fast the conditional checkswill
be evaluated with delayed values, complying with the new IEEE Std 1364-2001

specification.

Using -fast on cells with internal delay

Cellswith internal delays normally are not optimized by -fast. However, if you compile
withthe+delay_mode path switch (which iswhat we usually suggest), all internal delays
are set to zero automatically and only path delays are used. This allows ModelSim to

optimize the cell.
If acell relieson internal delaysto function correctly, you cannot optimize that cell.
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Simulating with an elaboration file

Overview

The Model Sim compiler generates alibrary format that is compatible across platforms.
This means the simulator can load your design on any supported platform without having
to recompile first. Though this architecture offers a benefit, it also comes with a possible
detriment: the simulator has to generate platform-specific code every time you load your
design. Thisimpacts the speed with which the design is |oaded.

Starting with Model Sim version 5.6, you can generate aloadable image (elaboration file)
which can be simulated repeatedly. On subsequent simulations, you |oad the elaboration
file rather than loading the design "from scratch.” Elaboration files load quickly.

Why an elaboration file?

In many cases design loading time is not that important. For example, if you're doing
"iterative design," where you simulate the design, modify the source, recompile and
resimulate, theload timeisjust asmall part of the overall flow. However, if your designis
locked down and only the test vectors are modified between runs, loading time may
materially impact overall simulation time, particularly for large designs loading SDF files.

Another reason to use elaboration files is for benchmarking purposes. Other simulator
vendors use elaboration files, and they distinguish between elaboration and run times. If
you are benchmarking Model Sim against another simulator that uses elaboration, make
sure you use an elaboration file with Model Sim as well so you're comparing like to like.

One caveat with elaboration files is that they must be created and used in the same
environment. The same environment means the same hardware platform, the same OS and
patch version, and the same version of any PLI/FLI code loaded in the simulation.

Elaboration file flow

We recommend the following flow to maximize the benefit of simulating elaboration files.

1 If timing for your design isfixed, include all timing datawhen you create the elaboration
file (using the -sdf<type> instance=<filename> argument). If your timing is not fixed
inaVerilog design, you'll have to use $sdf _annotate system tasks. Note that use of
$sdf _annotate causes timing to be applied after elaboration.

2 Apply al normal vsim arguments when you create the elaboration file. Some arguments
(primarily related to stimulus) may be superseded later during loading of the elaboration
file (see "Modifying stimulus' (Um-138) below).

3 Load the elaboration file along with any arguments that modify the stimulus (see below).
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Creating an elaboration file

Elaboration file creation is performed with the same vsim settings or switches asanormal
simulation plus an el aboration specific argument. The simulation settings are stored in the
elaboration file and dictate subsequent simulation behavior. Some of these simulation
settings can be modified at elaboration file load time, as detailed below.

To create an elaboration file, use the -elab <filename> or -elab_cont <filename>
argument to vsim (CR-357).

The-elab_cont argument is used to create the elaboration file then continue with the
simulation after the elaboration fileis created. Y ou can use the -c switch with -elab_cont
to continue the simulation in command-line mode.

A mportant: Elaboration files can be created in command-line mode only. Y ou cannot
create an elaboration file while running the Model Sim GUI.

Loading an elaboration file

Toload an elaboration file, usethe -load_elab <filename> argument to vsim (CR-357). By
default the elaboration file will load in command-line mode or interactive mode depending
on the argument (-c or -i) used during elaboration file creation. If no argument was used
during creation, the -load_elab argument will default to the interactive mode.

The vsim arguments listed below can be used with -load_elab to affect the simulation.
+<pl us_ar gs>
-c or -i
-do <do_file>
-vcdread <fil ename>
-vedstim <fil ename>
-filemap_el ab <HDLfil ename>=<NEW i | enanme>
-l <log_file>
-trace_foreign <level >
-qui et
-w f <fil ename>

Modification of an argument that was specified at elaboration file creation, in most cases,
causes the previous value to be replaced with the new value. Usage of the -quiet argument
at elaboration load causes the mode to be toggled from its elaboration creation setting.

All other vsim arguments must be specified when you create the elaboration file, and they
cannot be used when you load the elaboration file.

A 'mportant: The elaboration file must be |oaded under the same environment in which it
was created. The same environment means the same hardware platform, the same OS
and patch version, and the same version of any PLI/FLI code loaded in the simulation.
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Modifying stimulus

A primary use of elaboration filesis repeatedly simulating the same design with different
stimulus. The following mechanisms allow you to modify stimulus for each run.

* Use of the change command to modify parameters or generic values. This affects values
only; it has no effect on triggers, compiler directives, or generate statements that
reference either a generic or parameter.

» Useof the -filemap_elab <HDL filename>=<NEWfilename> argument to establish a
map between files named in the elaboration file. The <HDL filename> file name, if it
appearsin the design as afile name (for example, aVHDL FILE object aswell as some
Verilog sysfuncs that take file names), is substituted with the <NEWfilename> file
name. This mapping occurs before environment variable expansion and can’t be used to
redirect stdin/stdout.

» VCD stimulusfiles can be specified when you load the elaboration file. Both vedread and
vedstim are supported. Specifying adifferent VCD filewhen you load the elaborationfile
supersedes a stimulus file you specify when you create the elaboration file.

* InVerilog, the use of +ar gswhich are readable by the PLI routine mc_scan_plusar gs().
+ar gs values specified when you create the elaboration file are superseded by +args
values specified when you load the elaboration file.

Using with the PLI or FLI

Syntax
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PLI models do not require special code to function with an elaboration file aslong as the
model doesn't create simulation objectsin its standard tf routines. The sizetf, misctf and
checktf callsthat occur during elaboration are played back at -load_elab to ensure the PLI
model isin the correct simulation state. Registered user tf routines called from the Verilog
HDL will not occur until -load_elab is complete and PLI model's state is restored.

By default, FL1 modelsare activated for checkpoint during elaboration file creation and are
activated for restore during elaboration file load. (See the "Using checkpoint/restore with
the FLI" section of the FLI Reference manual for more information.) FLI model s that
support checkpoint/restore will function correctly with elaboration files.

FL1 models that don't support checkpoint/restore may work if simulated with the
-elab_defer_fli argument. When used in tandem with -elab, -elab_defer_fli deferscallsto
the FL1 modéel'sinitialization function until elaboration file load time. Deferring FLI
initialization skips the FLI checkpoint/restore activity (callbacks, mti_IsRestore(), ...) and
may allow these models to simulate correctly. However, deferring FL1 initialization also
causesFLI modelsin the design to beinitialized in order with the entire design loaded. FLI
models that are sensitive to this ordering may still not work correctly even if you use
-elab_defer_fli.

See the vsim command (CR-357) for details on -elab, -elab_cont, -elab_defer_fli,
-compress_elab, -filemap_elab, and -load_elab.
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Example

Upon first simulating the design, use vsim -elab <filename>
<library_name.design_unit> to create an elaboration file that will be used in subsequent
simulations.

In subsequent simulations you simply load the elaboration file (rather than the design) with
vsim -load_elab <filename>.

To change the stimulus without recoding, recompiling, and reloading the entire design,
Modelsim alows you to map the stimulus file (or files) of the original design unit to an
aternatefile (or files) with the -filemap_elab switch. For example, the VHDL code for
initiating stimulus might be:

FILE vector_file : text ISIN "vectors";

where vectorsisthe stimulus file.

If the alternate stimulusfileisnamed, say, alt_vectors, then the correct syntax for changing
the stimulus without recoding, recompiling, and reloading the entire design is as follows:

vsim -load_elab <filename> -filemap_elab vectors=alt_vectors
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Checkpointing and restoring simulations

The checkpoint (CR-99) and r estor e (CR-242) commands allow you to save and restore the
simulation state within the same invocation of vsim or between vsim sessions.

Action Definition Command used
checkpoint saves the simulation state checkpoint <filename>
"warm' restore restores a checkpoint file saved in a restore <filename>
current vsim session
"cold" restore restores a checkpoint file saved in a vsim -restore <filename>
previous vsim session (i.e., after
quitting Model Sim)

Checkpoint file contents
The following things are saved with checkpoint and restored with the restor e command:
» simulation kernel state

o vsimwif file

signalslisted in thelist and wave windows

file pointer positions for files opened under VHDL

file pointer positions for files opened by the Verilog $fopen system task

state of foreign architectures
state of PLI/VPI code

Checkpoint exclusions

Y ou cannot checkpoint/restore the following:

* state of macros

« changes made with the command-line interface (such as user-defined Tcl commands)
« state of graphical user interface windows

* toggle statistics

If you use the foreign interface, you will need to add additional function callsin order to
use checkpoint/restore. See the FLI Reference Manual or Chapter 6 - Verilog PLI / VPI
for more information.
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Controlling checkpoint file compression

The checkpoint fileisnormally compressed. To turn off the compression, usethefollowing
command:

set Checkpoi nt Conpressibde 0

To turn compression back on, use this command:

set Checkpoi nt Conpressibde 1

Y ou can also control checkpoint compression using the modelsim.ini file in the [vsim]
section (use the same 0 or 1 switch):

[vsinm
Checkpoi nt Conpr essivbde = <swi tch>

The difference between checkpoint/restore and restart

Therestart (CR-240) command resets the simulator to time zero, clears out any logged
waveforms, and closes any files opened under VHDL and the Verilog $fopen system task.
Y ou can get the same effect by first doing a checkpoint at time zero and later doing a
restore. Using restart, however, islikely to be faster and you don't have to save the
checkpoint. To set the simulation state to anything other than time zero, you need to use
checkpoint/restore.

Using macros with restart and checkpoint/restore

Therestart (CR-240) command resets and restarts the simulation kernel, and zeros out any
user-defined commands, but it does not touch the state of the macro interpreter. Thislets
you do restart commands within macros.

The pause mode indicates that a macro has been interrupted. That condition will not be
affected by arestart, and if therestart is done with an interrupted macro, the macro will still
be interrupted after the restart.

The situation is similar for using check point/restor e without quitting Model Sim; that is,
doing a checkpoint (CR-99) and later in the same session doing arestor e (CR-242) of the
earlier checkpoint. Therestor e does not touch the state of the macro interpreter so you may
also do checkpoint and restor e commands within macros.
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Cell libraries

Model Technology passed the ASIC Council’ sVerilog test suite and achieved the"Library
Tested and Approved" designation from Si2 Labs. This test suiteis designed to ensure
Verilog timing accuracy and functionality and isthefirst significant hurdle to complete on
the way to achieving full ASIC vendor support. As aconsequence, many ASIC and FPGA
vendors' Verilog cell libraries are compatible with Model Sim Verilog.

The cell models generally contain Verilog "specify blocks" that describe the path delays
and timing constraints for the cells. See section 13 in the |EEE Std 1364-1995 for details
on specify blocks, and section 14.5 for details on timing constraints. Model Sim Verilog
fully implements specify blocks and timing constraints as defined in |EEE Std 1364 along
with some Verilog-XL compatible extensions.

SDF timing annotation

Delay modes

Model Sim Verilog supports timing annotation from Standard Delay Format (SDF) files.
See Chapter 17 - Standard Delay Format (SDF) Timing Annotation for details.

Verilog models may contain both distributed delays and path delays. The delays on
primitives, UDPs, and continuous assignments are the distributed delays, whereas the port-
to-port delays specified in specify blocks are the path delays. These delays interact to
determine the actual delay observed. Most Verilog cells use path delays exclusively, with
the distributed delays set to zero. For example,

modul e and2(y, a, b);
input a, b;
out put vy;

and(y, a, b)

specify
(a =>1y)
(b =>1y)
endspeci fy
endnodul e

In the above two-input "and" gate cell, the distributed delay for the "and" primitiveis zero,
and the actual delays observed on the module ports are taken from the path delays. Thisis
typical for most cells, but acomplex cell may require non-zero distributed delays to work
properly. Even so, these delays are usually small enough that the path delays take priority
over the distributed delays. The ruleisthat if a module contains both path delays and
distributed delays, then the larger of the two delays for each path shall be used (as defined
by the IEEE Std 1364). Thisis the default behavior, but you can specify aternate delay
modes with compiler directives and arguments. These arguments and directives are
compatible with Verilog-XL. Compiler delay mode arguments take precedence over delay
mode directives in the source code.
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Distributed delay mode

In distributed delay mode the specify path delays are ignored in favor of the distributed
delays. Select this delay mode with the +delay_mode_distributed compiler argument or
the "delay_mode distributed compiler directive.

Path delay mode

In path delay mode the distributed delays are set to zero in any module that contains a path
delay. Select this delay mode with the +delay_mode_path compiler argument or the
“delay_mode_path compiler directive.

Note that this mode allows modules with non-zero delay to be optimized with -fast. See
"Using -fast on cellswith internal delay" (um-135) for further details.

Unit delay mode

In unit delay mode the distributed delays are set to one unit of simulation resolution
(determined by the minimum time_precision argument in all ‘timescale directivesin your
design or the val ue specified with the -t argument to vsim), and the specify path delaysand
timing constraints are ignored. Select this delay mode with the +delay_mode_unit
compiler argument or the "delay_mode_unit compiler directive.

Zero delay mode

In zero delay mode the distributed delays are set to zero, and the specify path delays and
timing constraints are ignored. Select this delay mode with the +delay_mode _zero
compiler argument or the "delay_mode_zero compiler directive.
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System tasks

The IEEE Std 1364 defines many system tasks as part of the Verilog language, and
Model Sim Verilog supports all of these along with several non-standard Verilog-XL
system tasks. The system tasks listed in this chapter are built into the simulator, although
some designs depend on user-defined system tasks implemented with the Programming
Language Interface (PL1) or Verilog Procedura Interface (VPI). If the simulator issues
warnings regarding undefined system tasks, then it islikely that these system tasks are

defined by aPLI1/VPI application that must be loaded by the simulator.

IEEE Std 1364 system tasks
The following system tasks are described in detail in the IEEE Std 1364.
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Timescale tasks

Sprinttimescale

$timeformat

Probabilistic
distribution
functions

$dist_chi_square
$dist_erlang
$dist_exponential
$dist_normal
$dist_poisson
$dist_t
$dist_uniform

$random

Simulator
control tasks

$finish
$stop

Conversion
functions

$hitstoreal
Sitor
$realtobits
$rtoi
$signed
$unsigned

Simulation time
functions

$realtime
$stime

$time

Stochastic
analysis tasks

$q_add
$q_exam
$q_full
$q_initiaize

$q_remove

Command line
input

PtestSplusargs
$value$plusargs

Timing check
tasks

$hold
$nochange
$period
$recovery
$setup
$setuphold
$skew
$width?
$removal

$recrem

aVerilog-XL ignores the threshold argument even though it is part of the Verilog
spec. ModelSim does not ignore this argument. Be careful that you don't set the
threshhold argument greater-than-or-egqual to thelimit argument asthat essentially dis-
ables the $width check. Note too that you cannot override the threshhold argument via

SDF annotation.



Display tasks

$display
S$displayb
$displayh
$displayo
$monitor
$monitorb
$monitorh
$monitoro
$monitoroff
$monitoron
$strobe
$strobeb
$strobeh
$strobeo
$write
$writeb
$writeh
$writeo

PLA modeling tasks

S$async$andsarray
$async$nand$array
$asyncSorarray
$async$norSarray
$asyncandsplane
$async$nand$plane
$asyncorsplane
$asyncnorplane
$sync$and$array
$syncSnand$array
$sync$or$array
$syncnorSarray
$syncSand$plane
$sync$nand$plane
$syncor$plane
$synchnor$plane

System tasks UM-145

Value change dump (VCD)
file tasks

$dumpall
$dumpfile
$dumpflush
$dumplimit
$dumpoff
$dumpon
$dumpvars
$dumpportson
$dumpportsoff
$dumpportsall
$dumpportsflush
$dumpports
$dumpportslimit
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File I/O tasks
$fclose
$fdisplay
$fdisplayb
$fdisplayh
$fdisplayo
$ferror
$fflush
$fgetc
P$fgets
$fmonitor
$fmonitorb
$fmonitorh

$fmonitoro

$fopen
$fread
$fscanf
$fseek
$fstrobe
$fstrobeb
$fstrobeh
$fstrobeo
$ftell
Sfwrite

$fwriteb

Sfwriteh
$fwriteo
$readmemb
$readmemh
$rewind
$sdf _annotate
$sformat
$sscanf
$owrite
$swriteb
$swriteh
$swriteo
$ungetc
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Verilog-XL compatible system tasks

Thefollowing system tasks are provided for compatibility with Verilog-XL. Although they
are not part of the |EEE standard, they are described in an annex of the |EEE Std 1364.

$countdrivers
$get pattern
$sreadnmenb
$sreadnmemnh

The following system tasks are also provided for compatibility with Verilog-XL; they are
not described in the |EEE Std 1364.

$deposi t (vari abl e, val ue);
This system task setsa Verilog register or net to the specified value. variableisthe
register or net to be changed; value is the new value for the register or net. The value
remains until thereis a subsequent driver transaction or another $deposit task for the
same register or net. This system task operates identically to the ModelSim
force -deposit command.

$di sabl e_war ni ngs(“ <keywor d>"[, <npodul e_i nstance>...]);
This system task instructs Model Sim to disable warnings about timing check violations
or triregs that acquire avalue of ‘X’ due to charge decay. <keyword> may be decay or
timing. Y ou can specify one or more module instance names. If you don’t specify a
module instance, Model Sim disables warnings for the entire simulation.

$enabl e_war ni ngs(“ <keywor d>"[, <nodul e_i nstance>...]);
This system task enables warnings about timing check violations or triregsthat acquire a
value of ‘X’ dueto charge decay. <keyword> may be decay or timing. Y ou can specify
one or more module instance names. If you don’t specify amodule_instance, Model Sim
enables warnings for the entire simulation.

$syst en( " <operating system shell command>");
Thissystem task executesthe specified operating system shell command and displaysthe
result. For example, to list the contents of the working directory on Unix:

$system("Is");

The following system tasks are extended to provide additional functionality for negative
timing constraints and an alternate method of conditioning, asin Verilog-XL.

$recovery(reference event, data_event, renpval _limt, recovery_limt
[notifier], [tstanp_cond], [tcheck_cond], [del ayed_reference],
[ del ayed_dat a] )

The $recovery system task normally takes arecovery limit asthe third argument and an
optional notifier as the fourth argument. By specifying alimit for both the third and
fourth arguments, the $recovery timing check istransformed into acombination removal
and recovery timing check similar to the $recrem timing check. The only differenceis
that the removal_limit and recovery_limit are swapped.

$setuphol d(cl k_event, data_event, setup_limt, hold_limt, [notifier],
[tstanp_cond], [tcheck_cond], [delayed_clk], [delayed_data])

The tstamp_cond argument conditions the data_event for the setup check and the
clk_event for the hold check. This aternate method of conditioning precludes specifying
conditionsin the clk_event and data_event arguments.
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The tcheck_cond argument conditions the data_event for the hold check and the
clk_event for the setup check. Thisalternate method of conditioning precludes specifying
conditionsin the clk_event and data_event arguments.

The delayed _clk argument is a net that is continuously assigned the value of the net
specified in the clk_event. The delay is non-zero if the setup_limit is negative, zero
otherwise.

The delayed _data argument is a net that is continuously assigned the value of the net
specified in the data_event. The delay is non-zero if the hold_limit is negative, zero
otherwise.

The delayed_clk and delayed data arguments are provided to ease the modeling of
devices that may have negative timing constraints. The model's logic should reference
the delayed clk and delayed_data nets in place of the normal clk and data nets. This
ensures that the correct datais latched in the presence of negative constraints. The
simulator automatically calculatesthe delaysfor delayed_clk and delayed _data such that
the correct datais latched as long as atiming constraint has not been violated. See
"Negative timing check limits' (um-123) for more details.

The following system tasks are Verilog-XL system tasks that are not implemented in
Model Sim Verilog, but have equivalent simulator commands.

$i nput ("fil enanme")
This system task reads commands from the specified filename. The equivalent ssmulator
command is do <filename>.

$li st[ (hierarchical _nane)]
This system task lists the source code for the specified scope. The equivalent
functionality is provided by selecting a module in the graphic interface Structure
window. The corresponding source code is displayed in the Source window.

$reset
This system task resets the simulation back to its time O state. The equivaent simulator
command isrestart.

$restart("fil ename")
This system task setsthe simulation to the state specified by filename, saved in aprevious
call to $save. The equivalent simulator command isrestore <filename>.

$save("fil ename")
This system task saves the current simulation state to the file specified by filename. The
equivalent simulator command is checkpoint <filename>.

$scope( hi erarchi cal _nane)
This system task sets the interactive scope to the scope specified by hierarchical_name.
The equivalent simulator command is environment <pathname>.

$showscopes
This system task displays alist of scopes defined in the current interactive scope. The
equivalent simulator command is show.

$showars
This system task displays alist of registers and nets defined in the current interactive
scope. The equivalent simulator command is show.
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ModelSim Verilog system tasks

The following system tasks are specific to ModelSim. They are not included in the IEEE
Std 1364 nor are they likely supported in other simulators. Their use may limit the
portability of your code.

$coverage_save(<fil ename>, [<instancepath>], [<xm _output>])
The $coverage_save() system task saves Code Coverage information to afile during a
batch run that typically would terminate via the $finish call. If you don't specify
<instancepath>, Model Sim saves all coverage datain the current design to the specified
file. If you do specify <instancepath>, M odel Sim saves data on that instance, and all
instances below it (recursively), to the specified file.

If set to 1, the [<xml_output>] argument specifies that the output be saved in XML
format.

See Chapter 12 - Code Coverage for more information on Code Coverage.

$init_signal _driver
The $init_signal_driver() system task drives the value of aVHDL signal or Verilog net
onto an existing VHDL signal or Verilog net. This allows you to drive signals or nets at
any level of the design hierarchy from within a VVerilog module (e.g., atestbench). See
$init_signal_driver (Um-534) in Chapter 16 - Signal Spy for complete details.

$i ni t_signal _spy
The $init_signal_spy() system task mirrors the value of aVHDL signal or Verilog
register/net onto an existing Verilog register or VHDL signal. This system task allows
you to reference signals, registers, or netsat any level of hierarchy fromwithinaVerilog
module (e.g., atestbench). See $init_signal_spy (Um-537) in Chapter 16 - Signal Spy for
complete details.

$signal _force
The $signal_force() system task forcesthe val ue specified onto an existing VHDL signal
or Verilog register or net. Thisallows you to force signals, registers, or nets at any level
of the design hierarchy from within aVerilog module (e.g., atestbench). A $signal_force
works the same as the for ce command (CR-176) with the exception that you cannot issue
arepeating force. See $signal_force (UM-539) in Chapter 16 - Signal Spy for complete
details.

$si gnal _rel ease
The $signal_release() system task releases a value that had previously been forced onto
an existing VHDL signal or Verilog register or net. A $signal_rel ease works the same as
the nofor ce command (CR-204). See $signal_release (UM-541) in Chapter 16 - Signal Spy.

$sdf _done
Thistask isa"cleanup” function that removesinternal buffers, called MIPDs, that have
adelay value of zero. These MIPDs are inserted in response to the -v2k_int_delay
argument to the vsim command (CR-357). In general the simulator will automatically
remove all zero delay MIPDs. However, if you have $sdf_annotate() callsin your design
that are not getting executed, the zero-delay M1PDs are not removed. Adding the
$sdf _done task after your last $sdf _annotate() will remove any zero-delay MIPDs that
have been created.
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Compiler directives

Model Sim Verilog supports all of the compiler directives defined in the |EEE Std 1364,
some Verilog-XL compiler directives, and some that are proprietary.

Many of the compiler directives (such as ‘timescale) take effect at the point they are
defined in the source code and stay in effect until the directiveisredefined or until it isreset
to its default by a ‘resetall directive. The effect of compiler directives spans source files,
so the order of source files on the compilation command line could be significant. For
example, if you have afile that defines some common macros for the entire design, then
you might need to placeit first in thelist of filesto be compiled.

The “resetall directive affects only the following directives by resetting them back to their
default settings (this information is not provided in the |EEE Std 1364):

“cel | define
‘defaul t _decay_tine
“default_nettype
“del ay_node_di stri buted
“del ay_node_path
“del ay_node_uni t
“del ay_node_zero
“protected
“tinmescal e
“unconnect ed_drive
“uselib

ModelSim Verilog implicitly defines the following macro:

“define MODEL_TECH

IEEE Std 1364 compiler directives
The following compiler directives are described in detail in the IEEE Std 1364.
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“cel | define
“default_nettype
“define

‘el se

“elsif
“endcel | defi ne
“endif

“ifdef

‘i fndef

“include

‘line

“nounconnect ed_drive
“resetal
“tinmescal e
“unconnect ed_drive
“undef



Compiler directives

Verilog-XL compatible compiler directives
The following compiler directives are provided for compatibility with Verilog-XL.

‘defaul t _decay_tine <tinme>
Thisdirective specifies the default decay timeto be used in trireg net declarationsthat do
not explicitly declare a decay time. The decay time can be expressed as areal or integer
number, or as"infinite" to specify that the charge never decays.

“del ay_node_di stri but ed
Thisdirective disables path delaysin favor of distributed delays. See"Delay modes' (UM-
142) for details.

“del ay_node_path
This directive sets distributed delaysto zero in favor of path delays. See "Delay modes'
(UM-142) for details.

“del ay_node_uni t
This directive sets path delays to zero and non-zero distributed delays to one time unit.
See "Delay modes' (UM-142) for details.

“del ay_node_zero
This directive sets path delays and distributed delays to zero. See "Delay modes' (UM-
142) for details.

“uselib
This directive is an aternative to the -v, -y, and +libext source library compiler
arguments. See"Verilog-XL “uselib compiler directive" (UM-114) for details.

The following Verilog-XL compiler directives are silently ignored by ModelSim Verilog.
Many of these directivesareirrelevant to Model Sim Verilog, but may appear in code being
ported from Verilog-XL.

“accel erate

“aut oexpand_vectornets
“disable_portfaults
“enabl e_portfaults
“expand_vectornets
“noaccel erat e
“noexpand_vectornets
‘ nor enpve_gat enanes
' nor enpbve_net nanes
“nosuppress_faults

' renpve_gat enanes
‘renove_net nanes
“suppress_faults

The following Verilog-XL compiler directives produce warning messagesin ModelSim
Verilog. These are not implemented in Model Sim Verilog, and any code containing these
directives may behave differently in ModelSim Verilog than in Verilog-XL.

“default_trireg_strength

“signed

“unsi gned

UM-151
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ModelSim compiler directives

The following directives are specific to Model Sim and are not compatible with other
simulators (see note below).

‘protect ... ‘endprotect

Thisdirective pair allows you to encrypt selected regions of your source code. The code
in “protect regions has all debug information stripped out. This behaves exactly as if
using the -nodebug argument except that it appliesto sel ected regions of code rather than
the whole file. This enables usage scenarios such as making module ports, parameters,
and specify blocks publicly visible while keeping the implementation private.

The "protect directiveisignored by default unlessyou usethe +pr otect argument to viog
(CR-345). Once compiled, the original sourcefileiscopiedtoanew filewitha".vp" suffix
in the current work directory. This new file can be delivered and used as a replacement
for the original sourcefile.

The +protect argument is not required when compiling .vp files because the “protect
directivesare converted to "protected directiveswhich are processed even if +protect is
omitted.

“protect and “protected directives cannot be nested.

If any “include directives occur within aprotected region, the compiler generates a copy
of the include file with a".vp" suffix and protects the entire contents of the include file.

If errors are detected in aprotected region, the error message always reportsthefirst line
of the protected block.

The $sdf _annotate() system task cannot be used to SDF-annotate code bracketed by
“protect.. endprotect.

Though other simulatorshave a " pr otect directive, the algorithm Model Sim usesto encrypt
source filesis different. Hence, even though an uncompiled source file with “protect is
compatible with another simulator, once the source is compiled in Model Sim, you could
not simulate it elsewhere.
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Introduction

This chapter describes the M odel Sim implementation of the Verilog PLI (Programming
Language Interface) and VPI (Verilog Procedural Interface). Both interfaces provide a
mechanism for defining system tasks and functions that communicate with the simulator
through a C procedural interface. There are many third party applications available that
interface to Verilog simulators through the PLI (see "Third party PLI applications’ (UMm-
175)). In addition, you may write your own PLI/V Pl applications.

Model Sim Verilog implementsthe PL1 asdefined inthe | EEE Std 1364, with the exception
of theacc_handle_datapath() routine. We did not implement theacc_handle_datapath()
routine because the information it returns is more appropriate for a static timing analysis
tool.

The VPI is partially implemented as defined in the IEEE Std 1364-2001. The list of
currently supported functionality can be found in the following file:

<install_dir>/nodel tech/docs/technotes/Veril og_VPI.note

The |IEEE Std 1364 is the reference that defines the usage of the PLI/VPI routines. This
manual only describes details of using the PLI/VPI with Model Sim Verilog.
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Registering PLI applications

Each PLI application must register its system tasks and functions with the simulator,
providing the name of each system task and function and the associated callback routines.
Since many PLI applications already interface to Verilog-XL, Model Sim Verilog PLI
applications make use of the same mechanism to register information about each system
task and function in an array of s _tfcell structures. This structure is declared in the
veriuser.h includefile asfollows:

typedef int (*p_tffn)();

typedef struct t_tfcell {
short type;/* USERTASK, USERFUNCTI ON, or USERREALFUNCTI ON */
short data;/* passed as data argunment of callback function */
p_tffn checktf; /* argunent checking callback function */

p_tffn sizetf; /* function return size callback function */
p_tffn calltf; /* task or function call callback function */
p_tffn msctf; /* mscell aneous reason call back function */

char *tfnane;/* name of systemtask or function */

/* The following fields are ignored by Mddel Sim Veril og */
int forwef;
char *tfveritool;
char *tferrnmessage;
int hash;
struct t_tfcell *left_p;
struct t_tfcell *right_p;
char *nanecel | _p;
int warning_printed,
} s_tfcell, *p_tfcell;

The various callback functions (checktf, sizetf, calltf, and misctf) are described in detail in
the |[EEE Std 1364. The simulator calls these functions for various reasons. All callback
functions are optional, but most applications contain at least the calltf function, whichis
called when the system task or function is executed in the Verilog code. The first argument
to the callback functionsisthe value suppliedin the datafield (many PLI applications don't
use thisfield). The type field defines the entry as either a system task (USERTASK) or a
system function that returns either aregister (USERFUNCTION) or ared
(USERREALFUNCTION). The tfname field is the system task or function name (it must
begin with $). The remaining fields are not used by ModelSim Verilog.

On loading of a PLI application, the simulator first looks for an init_usertfs function, and
then averiusertfs array. If init_usertfsisfound, the simulator calls that function so that it
can call mti_RegisterUserTF() for each system task or function defined. The
mti_RegisterUserTF() function is declared in veriuser.h as follows:

void nti_RegisterUserTF(p_tfcell usertf);
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The storage for each usertf entry passed to the simulator must persist throughout the
simulation because the simulator de-references the usertf pointer to call the callback
functions. We recommend that you define your entriesin an array, with the last entry set to
0. If thearray is named veriusertfs (asisthe case for linking to Verilog-XL ), then you don't
have to provide an init_usertfs function, and the simulator will automatically register the
entries directly from the array (the last entry must be 0). For example,

s_tfcell veriusertfs[] = {
{usertask, 0, 0, 0, abc_calltf, 0, "$abc"},
{usertask, 0, 0, 0, xyz_calltf, 0, "$xyz"},
{0} /* last entry nust be 0 */

s
Alternatively, you can add aninit_usertfsfunction to explicitly register each entry fromthe
array:
void init_usertfs()
{
p_tfcell usertf = veriusertfs
while (usertf->type)
nmti_Regi sterUser TF(usertf++);
}

Itisan error if aPLI shared library does not contain a veriusertfs array or an init_usertfs
function.

Since PLI applications are dynamically loaded by the simulator, you must specify which
applications to load (each application must be a dynamically loadable library, see
"Compiling and linking PLI/VPI C applications' (Um-159)). The PLI applications are
specified as follows (note that on a Windows platform the file extension would be .dll):

» Asalistinthe Veriuser entry in the modelsim.ini file:

Veriuser = pliappl.so pliapp2.so pliappn.so

» Asalistinthe PLIOBJS environment variable:
% setenv PLI OBJS "pliappl.so pliapp2.so pliappn.so"

» Asa-pli argument to the simulator (multiple arguments are allowed):
-pli pliappl.so -pli pliapp2.so -pli pliappn.so

The various methods of specifying PLI applications can be used simultaneously. The
libraries are loaded in the order listed above. Environment variable references can be used
in the pathsto the libraries in al cases.
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Registering VPI applications

Each VPI application must register its system tasks and functions and its callbacks with the
simulator. To accomplish this, one or more user-created registration routines must be called
at simulation startup. Each registration routine should make one or more calls to
vpi_register_systf() to register user-defined system tasks and functions and
vpi_register_ch() to register callbacks. The registration routines must be placed in atable
named vlog_startup_routines so that the simulator can find them. The table must be
terminated with a0 entry.

Example
PLI _I NT32 MyFuncCal | tf( PLI _BYTE8 *user_data )
{ ...}
PLI _I NT32 MyFuncConpil etf( PLI_BYTE8 *user_data )
... 1
PLI _I NT32 MyFuncSi zetf( PLI _BYTE8 *user_data )
... 1
PLI _I NT32 MyEndOrF ConpCB( p_cb_data cb_data_p )
... 1
PLI _INT32 MyStartOf Si nCB( p_cb_data cb_data_p )
{ ...}
voi d Regi ster MySystfs( void )

{

vpi Handl e t npH;
s_cb_data cal |l back;
S_vpi _systf_data systf_data;

systf_data.type vpi SysFunc;
systf_dat a. sysfunctype vpi Si zedFunc;
systf_data.tfnane "$nyfunc";

systf_data. conpiletf MyFuncConpi | et f;
systf_data. si zetf MyFuncSi zet f;
systf_data.user_data = 0;

tnpH = vpi _register_systf( &systf_data );
vpi _free_object (tnpH);

systf_data.calltf = MyFuncCal I tf;

cal | back. reason
cal I back. cb_rtn MyEndOF ConpCB;
cal | back. user_data 0;

tnpH = vpi _register_cb( &call back );
vpi _free_object (tnmpH);

cbEndCF Conpi | e;

cal | back. reason
cal I back. cb_rtn My St art OF Si nCB;
cal | back. user_data 0;

tnpH = vpi _register_cb( &callback );
vpi _free_object (tnmpH);

cbStart OF Si nul ati on;

}

void (*vlog_startup_routines[ ] ) () = {
Regi st er MySyst fs,
0 /* last entry nust be 0 */

}s
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Loading VPI applications into the simulator is the same as described in "Registering PLI
applications’ (UM-155).

PLI and VPI applications can co-exist in the same application object file. In such cases, the
applications are loaded at startup as follows:

« If aninit_usertfs() function exists, then it is executed and only those system tasks and
functions registered by callsto mti_RegisterUserTF() will be defined.

« If aninit_usertfs() function does not exist but a veriusertfs table does exist, then only
those system tasks and functions listed in the veriusertfs table will be defined.

* If aninit_usertfs() function does not exist and a veriusertfs table does not exist, but a
vlog_startup_routines table does exist, then only those system tasks and functions and
callbacks registered by functionsin the viog_startup_routines table will be defined.

Asaresult, when PLI and VPl applications exist in the same application object file, they
must be registered in the same manner. VPl registration functions that would normally be
listedin avlog_startup_routines table can be called from an init_usertfs() function instead.
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Compiling and linking PLI/VPI C applications

The following platform-specific instructions show you how to compile and link your
PLI/VPI C applications so that they can be loaded by Model Sim. Microsoft Visual C/C++
is supported for creating Windows DLLs while Gce and cc compilers are supported for
creating UNIX shared libraries.

The PLI/VPI routines are declared in the include files located in the Model Sim
<install_dir>/modeltech/include directory. The acc_user.hfile declaresthe ACC routines,
the veriuser.h file declares the TF routines, and the vpi_user.h file declares the VPI
routines.

Thefollowing instructions assume that the PL1 or VPI application isin asingle sourcefile.
For multiple source files, compile each file as specified in the instructions and link all of
the resulting object files together with the specified link instructions.

Although compilation and simulation switches are platform-specific, loading shared
librariesisthe samefor al platforms. For information on loading libraries, see " Specifying
the PLI/VPI fileto load" (UM-168).

Windows platforms

cl -c -I<install _dir>\nodeltech\include app.c
link -dll -export:<init_function> app.obj \
<install_dir>\nodeltech\win32\nmtipli.lib /out:app.dll

For the Verilog PLI, the <init_function> should be "init_usertfs'. Alternatively, if thereis
no init_usertfs function, the <init_function> specified on the command line should be
"veriusertfs'. For the Verilog VPI, the <init_function> should be "vlog_startup_routines".
These requirements ensure that the appropriate symbol isexported, and thus Model Sim can
find the symbol when it dynamically loadsthe DLL.

ThePLI and VPI have been tested with DL L sbuilt using Microsoft Visual C/C++ compiler
version 4.1 or greater.

The gcc compiler cannot be used to compile PLI/VPI applications under Windows. Thisis
because gcc does not support the Microsoft .lib/.dll format.

When executing cl commandsin aDO file, use the/NOLOGO switch to prevent the
Microsoft C compiler from writing the logo banner to stderr. Writing the logo causes Tcl
to think an error occurred.

If you need to run the "Performance Analyzer" (UM-407) on adesign that contains PLI/VPI
code, add these two switches to the link command shown above:

/ DEBUG / DEBUGTYPE: COFF

These switches add symbolsto the .dll that the profiler can use in its report.

32-bit Linux platform

If your PLI/VPI application uses anything from a system library, you will need to specify
that library when you link your PLI/VPI application. For example, to use the standard C
library, specify ‘-Ic’ to the‘|d’ command.

gcc compiler:

ModelSim SE User’s Manual



UM-160 6 - Verilog PLI/ VPI

gcc -c -l/<install_dir>/nodeltech/include app.c
Id -shared -E -Bsynbolic -o app.so app.o -lc

When using -Bsymbolic with Id, al symbols are first resolved within the shared library at
link time. Thiswill result in alist of undefined symbols. Thisis only awarning for shared
librariesand can beignored. If you are using Model Sim on Redhat version 6.0 through 7.1,
you also need to add the -noinhibit-exec switch when you specify -Bsymbolic.

The compiler switch -freg-struct-return must be used when compiling any FL1 application
code that contains foreign functions that return real or time values.

64-bit Linux for 1A64 platform
64-bit Linux is supported on RedHat Linux Advanced Workstation 2.1 for Itanium 2.

gcc compiler (gcc 3.2 or later)

gcc -c¢ -fPIC -I/<install _dir>/nodel tech/include app.c
Id -shared -Bsynbolic -E --all owshlib-undefined -o app.so app.o

If your PLI/VPI application requires a user or vendor-supplied C library, or an additional
system library, you will need to specify that library when you link your PLI/VPI
application. For example, to use the system math library libm, specify -Im'’ to the'ld'
command:

gcc -c¢ -fPIC -I/<install _dir>/nodeltech/include math_app.c
Id -shared -Bsynbolic -E --al |l owshlib-undefined -o math_app.so math_app.o -Im
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32-bit Solaris platform

If your PL1/VPI application uses anything from a system library, you will need to specify
that library when you link your PL1/VPI application. For example, to use the standard C
library, specify ‘-Ic’ to the ‘Id’ command.

gcc compiler
gcc -c -l/<install _dir>/nmodeltech/include app.c
ld -G -B synbolic -0 app.so app.o -lc

cc compiler
cc -c -I/<install _dir>/nodel tech/include app.c

Ild -G -B synbolic -0 app.so app.o -lc

When using -B symbolic with Id, all symbolsare first resolved within the shared library at
link time. Thiswill result in alist of undefined symbols. Thisis only awarning for shared
libraries and can be ignored.

If app.soisnot inyour current directory you must tell Solariswhereto search for the shared
object. You can do this one of two ways:

» Add apath before app.so in the foreign attribute specification. (The path may include
environment variables.)

 Put the path in aUNIX shell environment variable:
LD_LIBRARY_PATH= <library path without filename>

64-bit Solaris platform

gcc compiler

gcc -c -I<install _dir>/nodel tech/include -n64 -fpic app.c
gcc -shared -0 app.so -nb4 app.o

This was tested with gcc 3.2.2. Y ou may need to add the location of libgcc_s.so.1 to the
LD _LIBRARY_PATH environment variable.

cc compiler
cc -v -xarch=v9 -O -I<install _dir>/nodel tech/include -c app.c
Ild -G -B synbolic app.o -0 app.so

When using -B symbolic with Id, all symbolsare first resolved within the shared library at
link time. Thiswill result in alist of undefined symbols. Thisis only awarning for shared
libraries and can be ignored.
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32-bit HP700 platform

A shared library is created by creating object files that contain position-independent code

(usethe +z or -fpic compiler argument) and by linking as ashared library (usethe-b linker
argument).

If your PLI/VPI application usesanything from asystem library, you’ |l need to specify that
library when you link your PLI/VPI application. For example, to use the standard C library,
specify ‘-Ic’ to the ‘Id’ command.
gcc compiler

gcc -c -fpic -I/<install _dir>/nodel tech/include app.c

Id -b -0 app.sl app.o -lc
cc compiler

cc -c +z +DD32 -I1/<install_dir>/nodeltech/include app.c

Id -b -0 app.sl app.o -lc

Note that -fpic may not work with al versions of gcc.
64-bit HP platform

cc compiler
cc -v +DD64 -O -lI<install _dir>/ nodeltech/include -c app.c
Ild -b -0 app.so app.o -lc
64-bit HP for 1A64 platform

cc compiler (/opt/ansic/bin/cc, /usr/ccs/bin/ld)
cc -c +DD64 -I1/<install _dir>/nodeltech/include app.c

Id -b -0 app.sl app.o

If your PLI/VPI application requires a user or vendor-supplied C library, or an additional
system library, you will need to specify that library when you link your PLI/VPI
application. For example, to use the system math library, specify -Im’ to the'ld' command:

cc -c +DD64 -1/<install _dir>/nodeltech/include math_app.c
Id -b -0 math_app.sl math_app.o -Im

ModelSim SE User’'s Manual



Compiling and linking PLI/VPI C applications UM-163

32-bit IBM RS/6000 platform

Model Sim loads shared libraries on the IBM RS/6000 workstation. The shared library must
import Model Sim's PL1/VPI symbols, and it must export the PL1 or VPI application’s
initialization function or table. Model Sim's export file islocated in the Model Sim
installation directory in rs6000/mti_exports.

If your PLI/VPI application usesanything from asystem library, you’ |l need to specify that
library when you link your PL1/V Pl application. For example, to use the standard C library,
specify ‘-Ic’ to the ‘Id’ command. The resulting object must be marked as shared reentrant
using these gcc or cc compiler commands for AIX 4.x:

gcc compiler
gcc -c -l/<install_dir>/nodeltech/include app.c

Id -o app.sl app.o -bE: app.exp \
-bl:/<install_dir>/nodel tech/rs6000/nti_exports -bM SRE -bnoentry -lc

cc compiler
cc -c -l/<install_dir>/nodeltech/include app.c

Id -o app.sl app.o -bE:app.exp \
-bl:/<install_dir>/nodel tech/rs6000/nti_exports -bM SRE -bnoentry -lc

The app.exp file must export the PLI/VPI initialization function or table. For the PLI, the
exported symbol should be"init_usertfs®. Alternatively, if thereisnoinit_usertfsfunction,
then the exported symbol should be "veriusertfs'. For the VPI, the exported symbol should
be "vlog_startup_routines". These requirements ensure that the appropriate symbol is
exported, and thus Model Sim can find the symbol when it dynamically loads the shared
object.

When using Al X 4.3in 32-bit mode, you must add the -DUSE_INTTY PES switch to the
compile command lines. This switch prevents a name conflict that occurs between
inttypes.h and mti.h.

64-bit IBM RS/6000 platform

Only version 4.3 of AlX supportsthe 64-bit platform. A gcc 64-bit compiler isnot available
at thistime.

cc compiler

cc -c -g64 -l/<install_dir>/nodeltech/include app.c
Id -o app.sl app.o -b64 -bE: app. exports \
-bl:/<install_dir>/nodel tech/rs64/ mi_exports -bM SRE -bnoentry -lc
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Compiling and linking PLI/VPI C++ applications

Model Sim does not have direct support for any language other than standard C; however,
C++ code can be loaded and executed under certain conditions.

Since ModelSim's PLI/VPI functions have a standard C prototype, you must prevent the
C++ compiler from mangling the PLI/VPI function names. This can be accomplished by
using the following type of extern:

extern "C'

{

<PLI/VPI application function prototypes>

}

The header files veriuser.h, acc_user.h, and vpi_user.h aready include thistype of extern.
Y ou must also put the PLI/VPI shared library entry point (veriusertfs, init_usertfs, or
vlog_startup_routines) inside of thistype of extern.

The following platform-specific instructions show you how to compile and link your
PLI/VPI C++ applications so that they can be loaded by Model Sim. Microsoft Visual C++
is supported for creating Windows DLLs while GNU C++ and native C++ compilers are
supported for creating UNIX shared libraries.

Although compilation and simulation switches are platform-specific, loading shared
librariesisthe samefor al platforms. For information on loading libraries, see " Specifying
the PLI/VPI fileto load" (UM-168).

Windows platforms

Microsoft Visual C++:

cl -c [-GX] -I<install _dir>\nodeltech\include app.cxx
link -dll -export:<init_function> app.obj \
<install_dir>\nodeltech\win32\ntipli.lib /out:app.dll

The -GX argument enables exception handling.

For the Verilog PLI, the <init_function> should be"init_usertfs'. Alternatively, if thereis
no init_usertfs function, the <init_function> specified on the command line should be
"veriusertfs'. For theVerilog VPI, the<init_function> should be"vlog_startup_routines".
These requirements ensure that the appropriate symbol isexported, and thus Model Sim can
find the symbol when it dynamically loadsthe DLL.

The GNU C++ compiler cannot be used to compile PLI/VPI applications under Windows.
Thisis because GNU C++ does not support the Microsoft .lib/.dll format.

When executing cl commandsin aDO file, use the/NOLOGO switch to prevent the
Microsoft C compiler from writing the logo banner to stderr. Writing the logo causes Tcl
to think an error occurred.

If you need to run the "Performance Analyzer" (UM-407) on adesign that contains PLI/VPI
code, add these two switches to the link command shown above:

/ DEBUG / DEBUGTYPE: COFF

These switches add symbolsto the .dll that the profiler can use in its report.
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32-bit Linux platform

GNU C++ version 2.95.3

c++ -c -fPIC -I<instal | _dir>/nodeltech/include app.C
c++ -shared -fPIC -0 app.so app.o

64-bit Linux for IA64 platform
64-bit Linux is supported on RedHat Linux Advanced Workstation 2.1 for Itanium 2.

gcc version 3.2 or later
ct++ -c -fPIC -I/<install_dir>/include app.C
c++ -shared -fPIC -0 app.sl app.o

If your PLI/VPI application requiresauser or vendor-supplied C++ library, or an additional
system library, you will need to specify that library when you link your PLI/VPI
application.

32-bit Solaris platform

Sun WorkShop version 5.0
CC -c -Kpic -0 app.o -I<install _dir>/nodeltech/include app.C
CC -G -0 app.so app.o -1Cstd -1Crun

GNU C++ version 2.95.3

ct++ -c -fPIC -I<install_dir>/nodel tech/include app.C
c++ -shared -fPIC -0 app.so app.o

LD_LIBRARY_PATH must be set to point to the directory containing libstdc+ +.s0 so that
the simulator can find this shared object.

64-bit Solaris platform

Sun WorkShop version 5.0

CC -c -v -xcode=pic32 -xarch=v9 -0 app.o \
-I<install _dir>/nodeltech/include app.C
CC -G -xarch=v9 -0 app.so app.o -1Cstd -1Crun

UM-165
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32-bit HP-UX platform

C++ shared libraries are supported only on HP-UX 11.0 and later operating system
versions.

HP C++ version 3.25
aCC -c +DAportable +Z -0 app.o -I<install _dir>/nodeltech/include app.C
aCC -v -b -0 app.so app.o -lstd -lstream -1 Csup

HP C++ version 3.3 and above

For 1/0 streams such as cout to work correctly within shared objects, HP's new iostream
library must be used. Access the library by compiling all C++ source fileswith the -AA
option. When building the shared object, use -Istd_v2 instead of -Istd, and use -ICsup_v2
instead of -ICsup. See the release notes in /opt/aCC/newconfig for more details.

aCC -c +DAportable +Z -AA -0 app.o -I<install_dir>/nodeltech/include app.C
aCC -v -b -0 app.so app.o -lstd_v2 -Istream -1 Csup_v2

GNU C++ version 2.95.3

c++ -c -fPIC -I<instal |l _dir>/nodel tech/include app.C
c++ -shared -fPIC -0 app.so app.o

Exceptions are not supported.

When Model Sim loads GNU C++ shared libraries on HP-UX, it calls the constructors and
destructorsonly for the shared libraries that it loads directly. Libraries |oaded as aresult of
Model Sim loading a shared library do not have their constructors and destructors called.

64-bit HP-UX platform

HP C++ version 3.25

aCC -c +DA2. OW +z -0 app.o -I<install_dir>/nodeltech/include app.C
aCC -v +DA2.0W-b -0 app.so app.o -Istd -Istream-I|Csup

64-bit HP for 1A64 platform

HP C++ (/opt/aCC/bin/aCC)
aCC -c +DD64 -z -0 app.o -l/<install_dir>/include app.C
aCC -b +DD64 -z -0 app.sl app.o -lstd_v2 -ICsup

If your PLI1/VPI application requiresauser or vendor-supplied C++ library, or an additional
system library, you will need to specify that library when you link your PLI/VPI
application.
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32-bit IBM RS/6000 platform

IBM C++ version 3.6

xIC-c -0 app.o -I<install_dir>/nodeltech/include app.C
makeC++SharedLib -0 app.sl \
-bl:<install _dir>/nodel tech/rs6000/nti_exports -p 10 app.o

64-bit IBM RS/6000 platform

IBM C++ version 3.6

xI C-g64 -c -0 app.o -l<install_dir>/nodeltech/include app.C
makeC++SharedLib -0 app.sl -X64 \
-bl:<install_dir>/nmodeltech/rs64/ nti_exports -p 10 app.o
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Specifying the PLI/VPI file to load

ModelSim SE User’'s Manual

The PLI/VPI applications are specified as follows:

* Asalistinthe Veriuser entry in the modelsim.ini file:
Veriuser = pliappl.so pliapp2.so pliappn.so

* Asalistinthe PLIOBJS environment variable:
% setenv PLI OBJS "pliappl.so pliapp2.so pliappn.so”

» Asa-pli argument to the simulator (multiple arguments are allowed):
-pli pliappl.so -pli pliapp2.so -pli pliappn.so

P Note: On Windows platforms, the file names shown above should end with .dil rather
than .so.

The various methods of specifying PL1/VPI applications can be used simultaneously. The
libraries are loaded in the order listed above. Environment variable references can be used
in the pathsto the libraries in al cases.

See also Appendix A - ModelSm variables for more information on the modelsim.ini file.
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PLI example

The following exampleis atrivial, but complete PLI application.

hell o.c:

#i ncl ude "veriuser.h"
static PLI_INT32 hello()
{
io_printf("H there\n");
return O;
}
s_tfcell veriusertfs[] = {
{usertask, 0, 0, 0, hello, 0, "$hello"},
{0} /* last entry nust be 0 */
}s

hell 0. v:

nmodul e hel | o;
initial $hello;
endnodul e

Conpile the PLI code for the Solaris operating system

% cc -c -lI<install _dir>/nodeltech/include hello.c
%Ild -G-0 hello.sl hello.o

Conpil e the Veril og code:

% vlib work
% vlog hello.v

Si mul ate the design:

%vsim-c -pli hello.sl hello
# Loadi ng work. hello

# Loading ./hello.sl

VSIM 1> run -all

# H there

VSI M 2> quit

UM-169

ModelSim SE User’'s Manual



UM-170 6 - Verilog PLI / VPI

VPl example

The following exampleis atrivial, but complete VPI application. A general VPI example
can be found in <install_dir>/modeltech/examples/vpi.

hell o.c:

#i ncl ude "vpi _user.h"
static PLI_I NT32 hell o(PLI _BYTE8 * param

{
vpi _printf( "Hello world!\n" );
return O;

}

voi d Regi sterMTfs( void )

{
s_vpi _systf_data systf_data;
vpi Handl e systf_handl e;
systf_data.type = vpi SysTask;
systf_data. sysfunctype = vpi SysTask;
systf_data.tfnane = "$hel | 0";
systf_data.calltf = hell o;
systf_data. conpiletf = 0;
systf_data. si zetf = 0;
systf_data. user_data = 0;
systf_handl e = vpi _register_systf( &systf_data );
vpi _free_object( systf_handle );

}

void (*vlog_startup_routines[])() = {
Regi ster WTf s,
0

s

hell 0. v:

nmodul e hel | o;
initial $hello;
endnodul e

Conpile the VPl code for the Sol aris operating system

% gcc -c -I<install_dir>/include hello.c
%ld -G-0 hello.sl hello.o

Conpil e the Veril og code:

% vlib work
% vlog hello.v

Simul ate the design:

%vsim-c -pli hello.sl hello
# Loadi ng work. hello

# Loading ./hello.sl
VSIM 1> run -all

# Hello world!

VSI M 2> quit
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The PLI callback reason argument

The second argument to a PLI callback function is the reason argument. The values of the
various reason constants are defined in the veriuser.h include file. See IEEE Std 1364 for a
description of the reason constants. The following details relate to Model Sim Verilog, and
may not be obviousin the IEEE Std 1364. Specifically, the simulator passes the reason
values to the misctf callback functions under the following circumstances:

reason_endof conpi |l e
For the completion of loading the design.

reason_fini sh
For the execution of the $finish system task or the quit command.

reason_startofsave
For the start of execution of the checkpoint command, but before any of the simulation
state has been saved. This allows the PLI application to prepare for the save, but it
shouldn't save its datawith callsto tf_write_save() until it is called with reason_save.

reason_save
For the execution of the checkpoint command. Thisiswhen the PLI application must
save its state with callsto tf_write_save().

reason_startofrestart
For the start of execution of the restore command, but before any of the simul ation state
has been restored. This allows the PLI application to prepare for the restore, but it
shouldn't restore its state with callsto tf_read restart() until it is called with
reason_restart. Thereason_startofrestart valueis passed only for arestore command, and
not in the case that the simulator isinvoked with -restore.

reason_restart
For the execution of therestore command. Thisiswhen the PLI application must restore
its state with callsto tf_read restart().

reason_reset
For the execution of therestart command. Thisiswhen the PLI application should free
itsmemory and reset its state. We recommend that all PL1 applicationsreset their internal
state during arestart as the shared library containing the PL1 code might not be rel oaded.
(Seethe- keepl oaded (CR-360) and - keepl oadedr est art (CR-360) argumentsto
vsim for related information.)

reason_endof r eset
For the completion of therestart command, after the simulation state has been reset but
before the design has been rel oaded.

reason_i nteractive
For the execution of the $stop system task or any other timethe simulation isinterrupted
and waiting for user input.

reason_scope
For the execution of the environment command or selecting a scope in the Structure
window. Alsofor thecall toacc_set_interactive_scope() if the callback flag argumentis
non-zero.

reason_paranvc
For the change of value on the system task or function argument.
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reason_synch
For the end of time step event scheduled by tf_synchronize().

reason_rosynch
For the end of time step event scheduled by tf_rosynchronize().

reason_reactivate
For the simulation event scheduled by tf_setdelay().

reason_par andr c
Not supported in Model Sim Verilog.

reason_force

Not supported in Model Sim Verilog.

reason_r el ease

Not supported in Model Sim Verilog.

reason_di sabl e
Not supported in Model Sim Verilog.
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The sizetf callback function

A user-defined system function specifies the width of its return value with the sizetf
callback function, and the simulator calls this function while loading the design. The
following details on the sizetf callback function are not found in the IEEE Std 1364:

* If you omit the sizetf function, then areturn width of 32 is assumed.

 The sizetf function should return O if the system function return value is of Verilog type
"real".

* Thesizetf function should return-32if the system function return valueis of Verilog type
"integer".
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PLI object handles

Many of the object handles returned by the PL1 ACC routines are pointers to objects that
naturally exist in the simulation data structures, and the handles to these objects are valid
throughout the simulation, even after the acc_close() routine is called. However, some of
the objects are created on demand, and the handles to these objects become invalid after
acc_close() is called. The following object types are created on demand in Model Sim
Verilog:

accOperator (acc_handl e_condition)

accWrePath (acc_handl e_path)

accTerm nal (acc_handle_term nal, acc_next_cell_load, acc_next_driver, and

acc_next _| oad)
accPat hTermi nal (acc_next_input and acc_next _out put)

accTchkTerm nal (acc_handl e_tchkargl and acc_handl e_t chkar g2)
accPart Sel ect (acc_handl e_conn, acc_handl e_pathin, and acc_handl e_pat hout)

If your PLI application uses these types of objects, then it isimportant to call acc_close()
to free the memory allocated for these objects when the application is done using them.

If your PL1 application places val ue change callbacks on accRegBit or accTerminal objects,
do not call acc_close() while these callbacks are in effect.
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Third party PLI applications

Many third party PLI applications come with instructions on using them with ModelSim
Verilog. Even without the instructions, it is still likely that you can get it to work with
ModelSim Verilog as long as the application uses standard PLI routines. The following
guidelinesarefor preparing aVerilog-XL PLI application to work with Model Sim Verilog.

Generally, aVerilog-XL PLI application comes with a collection of object filesand a
veriuser.c file. The veriuser.c file contains the registration information as described above
in "Registering PLI applications" (Um-155). To prepare the application for ModelSim
Verilog, you must compile the veriuser.c file and link it to the object files to create a
dynamically loadable object (see "Compiling and linking PLI/VPI C applications" (Um-
159)). For example, if you have a veriuser.c file and alibrary archive libapp.a file that
contains the application’s object files, then the following commands should be used to
create adynamically loadable object for the Solaris operating system:

% cc -c -l<install _dir>/nodeltech/include veriuser.c
%ld -G -0 app.sl veriuser.o |ibapp.a

The PLI application is now ready to be run with ModelSim Verilog. All that's left isto
specify the resulting object file to the simulator for loading using the Veriuser entry inthe
modesim.ini file, the -pli simulator argument, or the PLIOBJS environment variable (see
"Registering PL| applications’ (UM-155)).

P Note: Onthe HP700 platform, the object files must be compiled as position-independent
code by using the +z compiler argument. Since, the object files supplied for Verilog-XL
may be compiled for static linking, you may not be able to use the object files to create
adynamically loadable object for Model Sim Verilog. In this case, you must get the third
party application vendor to supply the object files compiled as position-independent
code.
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Support for VHDL objects

The PLI ACC routines aso provide limited support for VHDL objectsin either an all
VHDL design or amixed VHDL/Verilog design. The following table lists the VHDL
objects for which handles may be obtained and their type and fulltype constants:

Type

Fulltype

Description

accArchitecture

accArchitecture

instantiation of an architecture

accArchitecture

accEntityVitalLevelO

instantiation of an architecture whose entity is marked
with the attribute VITAL LevelO

accArchitecture

accArchVitalLevelO

instantiation of an architecture which is marked with the
attribute VITAL _LevelO

accArchitecture

accArchVitalLevell

instantiation of an architecture which is marked with the
attribute VITAL Levell

accArchitecture accForeignArch instantiation of an architecture which is marked with the
attribute FOREIGN and which does not contain any
VHDL statements or objects other than ports and generics

accArchitecture accForeignArchMixed instantiation of an architecture which is marked with the
attribute FOREIGN and which contains some VHDL
statements or objects besides ports and generics

accBlock accBlock block statement

accForLoop accForLoop for loop statement

accForeign accShadow foreign scope created by mti_CreateRegion()

accGenerate accGenerate generate statement

accPackage accPackage package declaration

accSignal accSignd signal declaration

The type and fulltype constants for VHDL objects are defined in the acc_vhdl.h include
file. All of these objects (except signals) are scope objectsthat definelevels of hierarchy in
the Structure window. Currently, the PLI ACC interface has no provision for obtaining
handles to generics, types, constants, variables, attributes, subprograms, and processes.
However, some of these objects can be manipul ated through the Model Sm VHDL foreign
interface (mti_* routines). See the FLI Reference Manual for more information.
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Model Sim Verilog supports the following ACC routines, described in detail in the IEEE

Std 1364.

IEEE Std 1364 ACC routines

UM-177

acc_append_delays

acc_append_pulsere

acc_close

acc_collect

acc_compare_handles

acc_configure

acc_count

acc_fetch_argc

acc_fetch_argv

acc_fetch_attribute

acc_fetch_attribute int

acc fetch attribute str

acc_fetch_defname

acc_fetch_delay_mode

acc_fetch_delays

acc_fetch_direction

acc_fetch_edge

acc_fetch fullname

acc_fetch_fulltype

acc_fetch index

acc_fetch_location

acc_fetch_name

acc_fetch_paramtype

acc_fetch_paramval

acc_fetch_polarity

acc_fetch precision

acc_fetch pulsere

acc fetch_range

acc fetch size

acc fetch tfarg

acc_fetch_itfarg

acc_fetch_tfarg_int

acc_fetch_itfarg_int

acc fetch_tfarg str

acc_fetch itfarg_str

acc_fetch timescale info

acc fetch_type

acc fetch type str

acc_fetch value

acc_free

acc_handle_by name

acc_handle _calling_mod m

acc_handle_condition

acc_handle_conn

acc_handle_hiconn

acc_handle_interactive_scope

acc_handle_loconn

acc_handle_modpath

acc_handle_natifier

acc_handle_object

acc_handle_parent

acc_handle_path

acc_handle_pathin

acc_handle_pathout

acc_handle_port

acc_handle_scope

acc_handle simulated net

acc_handle_tchk

acc_handle_tchkargl

acc_handle_tchkarg2

acc_handle_terminal

acc_handle tfarg

acc_handle itfarg

acc_handle_tfinst

acc_initialize

acc_next

acc_next_hit

acc_next_cell

acc_next_cell_load

acc_next_child

acc_next_driver

acc_next_hiconn

acc_next_input

acc_next_load

acc_next_loconn

acc_next_modpath

acc_next_net

acc_next_output

acc_next_parameter

acc_next_port

acc_next_portout
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acc_next_primitive acc_next_scope acc_next_specparam
acc_next_tchk acc_next_terminal acc_next_topmod
acc_object_in_typelist acc_object_of type acc_product_type
acc_product_version acc_release object acc_replace_delays
acc_replace pulsere acc_reset buffer acc_set_interactive_scope
acc_set_pulsere acc_set_scope acc_set_value
acc_vcl_add acc_vcl_delete acc_version

acc_fetch_paramval() cannot be used on 64-bit platforms to fetch a string value of a
parameter. Because of this, the function acc_fetch _paramval_str() has been added to the
PLI for this use. acc_fetch_paramval_str() is declared in acc_user.h. It functionsin a
manner similar to acc_fetch_paramval () except that it returns a char *.
acc_fetch_paramval_str() can be used on all platforms.
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IEEE Std 1364 TF routines

Model Sim Verilog supports the following TF routines, described in detail in the |EEE Std

UM-179

io_mcdprintf io_printf mc_scan_plusargs
tf_add long tf_asynchoff tf_iasynchoff
tf_asynchon tf_iasynchon tf_cleardldelays
tf_iclearalldelays tf_compare_|long tf_copypvc_flag
tf_icopypvc_flag tf_divide_long tf_dofinish
tf_dostop tf_error tf_evaluatep
tf_ievaluatep tf_exprinfo tf_iexprinfo
tf_getcstringp tf_igetcstringp tf_getinstance
tf_getlongp tf_igetlongp tf_getlongtime

tf_igetlongtime

tf_getnextlongtime

tf_getp

tf_igetp tf_getpchange tf_igetpchange
tf_getrealp tf_igetreap tf_getrealtime
tf_igetrealtime tf_gettime tf_igettime
tf_gettimeprecision tf_igettimeprecision tf_gettimeunit

tf_igettimeunit tf_getworkarea tf_igetworkarea
tf_long_to_real tf_longtime_tostr tf_message
tf_mipname tf_imipname tf_movepvc_flag
tf_imovepvc_flag tf_multiply_long tf_nodeinfo
tf_inodeinfo tf_nump tf_inump
tf_propagatep tf_ipropagatep tf_putlongp
tf_iputlongp tf_putp tf_iputp
tf_putrealp tf_iputrealp tf_read restart
tf_real_to_long tf_rosynchronize tf_irosynchronize
tf_scale longdelay tf_scale realdelay tf_setdelay
tf_isetdelay tf_setlongdelay tf_isetlongdelay
tf_setrealdelay tf_isetrealdelay tf_setworkarea
tf_isetworkarea tf_sizep tf_isizep

ModelSim SE User’s Manual



UM-180 6 - Verilog PLI/ VPI

tf_spname

tf_ispname

tf_strdelputp

tf_istrdel putp

tf_strgetp

tf_istrgetp

tf_strgettime

tf_strlongdel putp

tf_istrlongdel putp

tf_strrealdelputp

tf_istrrealdel putp

tf_subtract_long

tf_synchronize tf_isynchronize tf_testpvc flag
tf_itestpvc _flag tf_text tf_typep

tf_itypep tf_unscale longdelay tf_unscale realdelay
tf_warning tf_write save
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Verilog-XL compatible routines

The following PLI routines are not defined in IEEE Std 1364, but Model Sim Verilog
provides them for compatibility with Verilog-XL.

char *acc_deconpil e_exp(handl e condition)
This routine provides similar functionality to the Verilog-XL acc_decompile_expr
routine. The condition argument must be a handle obtained from the acc_handle_condition

routine. The value returned by acc_decompile_exp isthe string representation of the
condition expression.

char *tf_dunpfil ename(void)

This routine returns the name of the VCD file.
voi d tf_dunpflush(void)

A cdll to thisroutine flushesthe VCD file buffer (same effect as calling $dumpflush in the
Verilog code).

int tf_getlongsintine(int *aof_hightinme)

This routine gets the current simulation time as a 64-bit integer. The low-order bits are
returned by the routine, while the high-order bits are stored in the aof _hightime argument.
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Using 64-bit ModelSim with 32-bit PLI/VPI Applications

If you have 32-bit PL1/VPI applications and wish to use 64-bit Model Sim, you will need to
port your code to 64 bits by moving from the ILP32 data model to the L P64 data model.
We strongly recommend that you consult the 64-bit porting guides for Sun and HP.

64-bit support in the PLI

ThePLI function acc_fetch_paramval () cannot be used on 64-bit platformsto fetch astring
value of a parameter. Because of this, the function acc_fetch paramval_str() has been
added to the PLI for this use. acc_fetch_paramval_str() is declared in acc_user.h. It
functionsin amanner similar to acc_fetch_paramval () except that it returns a char *.
acc_fetch_paramval_str() can be used on al platforms.
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PLI/VPI tracing

The foreign interface tracing feature is available for tracing PLI and VPI function calls.
Foreign interface tracing creates two kinds of traces. a human-readable log of what
functions were called, the value of the arguments, and the results returned; and a set of
C-language files that can be used to replay what the foreign interface code did.

The purpose of tracing files

The purpose of the logfileisto aid you in debugging PLI or VPI code. The primary purpose
of thereplay facility isto send thereplay filesto MTI support for debugging co-simulation
problems, or debugging PL1/VPI problems for which it isimpractical to send the PLI/VPI
code. We still need you to send the VHDL /Verilog part of the design to actually execute a
replay, but many problems can be resolved with the trace only.

Invoking a trace

To invoke thetrace, call vsim (CR-357) with the -trace foreign argument:

Syntax

vsim
-trace_foreign <action> [-tag <name>]

Arguments

<action>
Specifies one of the following actions:

Value Action Result

1 create log only writesalocal file called
"mti_trace <tag>"

2 create replay only writeslocal files called
"mti_data_<tag>.c",
"mti_init_<tag>.c",
"mti_replay_<tag>.c" and
"mti_top_<tag>.c"

3 create both log and replay

-tag <name>
Used to give distinct file names for multiple traces. Optional.
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Examples

vsim-trace_foreign 1 nydesign
Creates alodfile.

vsim-trace_foreign 3 nydesign
Creates both alogfile and a set of replay files.

vsim-trace_foreign 1 -tag 2 nydesign
Creates alogfile with atag of "2".

The tracing operations will provide tracing during al user foreign code-calls, including
PLI/VPI user tasks and functions (calltf, checktf, sizetf and misctf routines), and Verilog
VCL callbacks.
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Debugging PLI/VPI application code

ModelSim Versions 5.7 and later offer the optional C Debug feature. Thistool allowsyou
to interactively debug SystemC/C/C++ source code with the open-source gdb debugger.
See Chapter 14 - C Debug for details. If you don’t have accessto C Debug, continue
reading for instructions on how to attach to an external C debugger.

In order to debug your PLI/VPI application code in adebugger, your application code must
be compiled with debugging information (for example, by using the -g option) and without
optimizations (for example, don’t use the -O option). Y ou must then load vsim into a
debugger. Even though vsim is stripped, most debuggers will still executeit. You can
invoke the debugger directly on veimk, the simulation kernal where your application code
isloaded (for example, "ddd " whi ch vsi nk* "), or you can attach the debugger to an already
running vsim process. In the second case, you must attach to the PID for vsimk, and you
must specify the full path to the vsimk executable (for example, "gdb $Mr1 _HOVE/ sunos5/
vsi mk 1234").

On Solaris, AlX, and Linux systems you can use either gdb or ddd. On HP-UX systems
you can use the wdb debugger from HP. Y ou will need version 1.2 or later.

Since initially the debugger recognizes only vsim's PLI/VPI function symbols, when
invoking the debugger directly on vsim you need to place a breakpoint in the first PL1/VPI
function that is called by your application code. An easy way to set an entry point isto put
acall to acc_product_version() as the first executable statement in your application code.
Then, after vsim has been |oaded into the debugger, set a breakpoint in thisfunction. Once
you have set the breakpoint, run vsim with the usual arguments (e.g., "run -c top").

On HP-UX you might see some warning messages that vsim does not have debugging
information available. Thisis normal. If you are using Exceed to access an HP machine
from Windows NT, it is recommended that you run vsim in command line or batch mode
because your NT machine may hang if you run vsim in GUI mode. Click on the "go"
button, or use F5 or the go command to execute vsim in wdb.

When the breakpoint is reached, the shared library containing your application code has
been loaded. In some debuggers you must use the share command to load the PLI/VPI
application's symbols.

On HP-UX you might seeawarning about not finding"__dld_flags" inthe object file. This
warning can beignored. You should see alist of libraries|oaded into the debugger. It
should include the library for your PLI/VPI application. Alternatively, you can use share
toload only asingle library.

At thispoint al of the PLI/VPI application's symbols should be visible. Y ou can now set
breakpoints in and single step through your PLI/V Pl application code.
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This chapter describes how to compile and simulate SystemC designs with Model Sim.
Proper name-binding is critical for your success. Read "Name association (binding)" (UM-
204) for information on correctly haming signals, ports and modules in your SystemC
design. Model Sim implements the SystemC language based on the Open SystemC
Initiative (OSCI) SystemC 2.0.1 reference simulator. It isrecommended that you obtain the
OSCI functional specification as areference manual. Visit http://www.systemc.org for
details.

Inaddition to thefunctionality described in the OSCI specification, Model Sim for SystemC
includes the following features:

* Single common Graphic Interface for SystemC and HDL languages.

 Extensive support for mixing SystemC, VHDL, and Verilog in the same design (SDF
annotation for HDL only). For detailed information on mixing SystemC with HDL see
Chapter 8 - Mixed-language simulations.
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Supported platforms and compiler versions

SystemC runs on a subset of Model Sim supported platforms. The table below shows the
currently supported platforms and compiler versions:

Platform Supported compiler versions
HP-UX 11.0 or later aCC 3.45 with associated patches
RedHat Linux 7.2 gcc 3.2.3

RedHat Linux Enterprise version 2.1

RedHat Linux 7.3 or later gcc 3.2 or gec 3.2.3

SunOS 5.6 or later gcc 3.2

A 'mportant: ModelSim SystemC has been tested with the gcc versions available from
ftp.model .comy/pub/gcc. Customized versions of gcc may cause problems. We strongly
encourage you to download and use the gcc versions available on our FTP site (login as
anonymous).

Building gcc with custom configuration options

We only test with our default options. I f you use advanced gec configuration options, we
cannot guar antee that M odelSim will work with those options.

To use a custom gec build, set the CppPath variable in the modelsim.ini file. Thisvariable
specifies the pathname to the compiler binary you intend to use.

When using a custom gcc, Model Sim requires that the custom gcc be built with severa
specific configuration options. These vary on a per-platform basis as shown in the
following table:

Platform Mandatory configuration options
Linux none
Solaris --with-gnu-1d --with-ld=/path/to/binutils-2.14/bin/ld --with-gnu-as

--with-as=/path/to/binutils-2.14/bin/as

HP-UX N/A

If you don't have a GNU binutils2.14 assembler and linker handy, you can use the as and
Id programsdistributed with Model Sim. They arelocated insidethe built-in gccin directory
<install_dir>/modeltech/gcc-3.2-<mtiplatfor m>/lib/gcc-lib/< gnuplatform>/3.2.

By default Model Sim a so uses the following options when configuring built-in gcc.
o —-disable-nls

* --enable-languages=c,c++

These are not mandatory, but they do reduce the size of the gcc installation.
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Usage flow for SystemC-only designs

Model Sim allows users to simulate SystemC, either alone or in combination with other
VHDL/Verilog modules. The following is an overview of the usage flow for strictly
SystemC designs. More detailed instructions are presented in the sections that follow.

1 Create and map the working design library with the vlib and vmap statements, as
appropriate to your needs.
2 Modify the SystemC source code as follows:

* Replace sc_main() with an SC_MODULE, and potentially add a process to contain
any testbench code

* Replace sc_start() by using the run (CR-246) command in the GUI

Remove callsto sc_initialize()

» Export the top level SystemC design unit(s) using the SC MODULE_EXPORT
macro

Verify that SystemC signal, ports and modules are explicitly named to avoid port
binding and debugging errors. See "Name association (binding)" (Um-204).

3 Analyze the SystemC source using sccom (CR-248). sccom invokes the native C++
compiler to create the C++ object filesin the design library.
See "Using sccom vs. raw C++ compiler” (uM-195) for information on when you are
required to use sccom vs. another C++ compiler.

4 Perform afinal link of the C++ source using sccom -link (UM-197). This process creates
ashared object filein the current work library which will be loaded by vsim at runtime.
sccom -link must be re-run before simulation if any new sccom compiles were
performed.

5 Simulate the design using the standard vsim command.

6 Simulate the design using the run command, entered at the vsim command prompt.

7 Debug the design using Model Sim GUI features, including the Source and Wave
windows.
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Compiling SystemC designs

To compile SystemC designs, you must

* create adesign library

» make afew modifications to the SystemC source code
* run the sccom (CR-248) SystemC compiler.

* run the sccom (CR-248) SystemC linker (sccom -link)

Creating a design library

Before you can compile your design, you must create a library in which to store the
compilation results. Use vlib (CR-344) to create anew library. For example:

vlib work

This creates alibrary named wor k. By default, compilation results are stored in the wor k

library.

Thework library is actually a subdirectory named work. This subdirectory contains a
specia file named _info. Do not create libraries using UNIX commands — always use the
vlib command (CR-344).

See "Design libraries’ (um-53) for additional information on working with libraries.

Modifying SystemC source code

Several modifications are required to your original SystemC source code.
» Convert sc_main() to amodule.

In order for Model Sim to run the SystemC/C++ source code, the control function of
sc_main() must be replaced by a constructor placed within a module at the top level of
the design. The example shown below uses a module called mytop. Any testbench code
inside sc_main() should be moved to a process, normally an SC_THREAD process.
Also, any sc_clock() functions must be moved into the constructor.

Replace the sc_start() function with the run command and options.

Model Sim uses the run command and its optionsin place of the sc_start() function. If
sc_main() has multiple sc_start() mixed in with the testbench code, then use an
SC_THREAD() with wait statements to emulate the same behavior. An example of this
is shown below

Remove callsto sc_initialize().
vsim cals sc_initialize() by default at the end of elaboration.

Export all top SystemC modules.

For SystemC designs, you must export all top level modulesin your designto Model Sim.
Y ou do thiswiththeSC_M ODULE_EXPORT (<sc_module_name>) macro. SystemC
templates are not supported astop level or boundary modules. See " Templatized
SystemC modules’ (UM-196). Thesc_module_nameisthe name of thetop level module
to besimulated in Model Sim. Y ou must specify thismacroin any C++ source (.cpp) file.
If themacrois contained in aheader fileinstead of a C++ sourcefile, an error may result.
See "sccom -link errors' (UM-197) for more information.

* Replace any VCD dump file generation functions with appropriate GUI commands.
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Thefollowing isasimple example of how to convert sc_main to amodule and elaborate it

with vsim.

Compiling SystemC designs UM-191

Original code (partial)

Modified code (partial)

int sc_main(int argc, char* argv[])

{
sc_si gnal <bool > nysi g;
mynod nod( " mod");
nmod. out p(nysi ) ;
sc_start (100, SC NS);
}

SC_MODULE( nyt op)
{

sc_si gnal <bool > nysi g;
mynod nod;
SC_CTOR( myt op)
mysi g("nysig"),
nmod( " nod")
nmod. out p(nmysi g) ;
s

SC_MODULE_EXPORT( nyt op) ;

The run command equivalent to thesc_start (100, SC_NS) statement is:

run 100 ns
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This next example is dightly more comple, illustrating the use of sc_main() and signa
assignments, and how you would get the same behavior using Model Sim.

Original OSCI code (partial)

Modified ModelSim code (partial)

int sc_main(int, char**)
{

sc_si gnal <bool > reset;

counter_top top("top");

sc_clock CLK("CLK", 10, SC_NS, 0.5,
0.0, SC Ns, false);

top.reset(reset);

reset.wite(l);
sc_start(5, SC_NS);
reset.wite(0);
sc_start (100, SC NS);
reset.wite(1);
sc_start(5, SC_NS);
reset.wite(0);
sc_start (100, SC NS);

SC_MODULE( new_t op)

{
sc_si gnal <bool > reset;
counter_top top;
sc_cl ock CLK;

voi d sc_mai n_body();

SC_CTOR( new_t op)
reset("reset"),
top("top”)
{ CLK("CLK", 10, SC_NS, 0.5, 0.0, SC_NS,
fal se)
top.reset(reset);
SC_THREAD( sc_nmi n_body) ;

}s

voi d

new_t op: : sc_mai n_body()

{
reset.write(l);
wait (5, SC_NS);
reset.write(0);
wai t (100, SC_NS);
reset.wite(1l);
wai t (5, SC_NS);
reset.wite(0);
wai t (100, SC_NS);

}

SC_MODULE_EXPORT( new_t op) ;

Invoking the SystemC compiler

Model Sim compiles one or more SystemC design units with a single invocation of sccom
(CR-248), the SystemC compiler. The design unitsare compiledin the order that they appear
on the command line. For SystemC designs, al design units must be compiled just as they
would be for any C++ compilation. An example of an sccom command might be:

sccom -1 ../ nyincludes nmytop.cpp nydut.cpp

Compiling optimized and/or debug code

By default, sccom invokes the C++ compiler (g++ or aCC) without any optimizations. If
desired, you can enter any g++/aCC optimization arguments at the sccom command line.

Also, source level debug of SystemC codeis not available by default in ModelSim. To
compile your SystemC code for debug, use the g++/aCC -g argument on the sccom

command line.
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Specifying an alternate g++ installation

We recommend using the version of g++ that is shipped with Model Sim on its various
supported platforms. However, if you want to use your own installation, you can do so by
setting the CppPath variable in the modelsim.ini file to the g++ executable location.

For example, if your g++ executableisinstalled in /u/abc/gee-3.2/bin, then you would set
the variable as follows:

CppPat h /u/ abc/ gcc-3. 2/ bin

Maintaining portability between OSCI and ModelSim

If you intend to simul ate on both Model Sim and the OSCI reference simulator, you can use
the MTI_SY STEMC macro to execute the Model Sim specific code in your design only
when running ModelSim. The MTI_SY STEMC macro is defined in the systemc.h header
file, read automatically upon compile. By including #ifdef/el se statementsin the code, you
can avoid having two copies of the design.

Using the original and modified code shown in the example shown on page 191, you might
write the code as follows:

#i fdef MII_SYSTEMC //1f using the Mdel Sim sinulator, sccomconpiles this
SC_MODULE( myt op)
{

sc_si gnal <bool > nysi g;
mynmod nod;

SC_CTOR( myt op)
© nysig("nysig"),
nmod( " nod")

nmod. out p(nysi g) ;
H
SC_MODULE_EXPORT( t op) ;

#else [/ Otherwise, it conpiles this
int sc_main(int argc, char* argv[])
{

sc_si gnal <bool > nysi g;

mynmod nod( " mod") ;

nmod. out p(nysi Q) ;

sc_start (100, SC_NS);

}
#endi f
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Restrictions on compiling with HP aCC

Model Sim uses the aCC -AA option by default when compiling C++ fileson HP-UX. It
doesthis so cout will function correctly in the systemc.sofile. The -AA option tellsaCC to
use ANSI-compliant <iostream> rather than cfront-style <iostream.h>. Thus, all C++-
based objectsin a program must be compiled with -AA. This means you must use
<iostream> and "using" clausesin your code. Also, you cannot use the -AP option, which
isincompatible with -AA.

Switching platforms and compilation

Compiled SystemC libraries are platform dependent. If you move between platforms, you
must remove al SystemC files from the working library and then recompile your SystemC
source files. To remove SystemC files from the working directory, use the vdel (CR-315)
command with the -allsystemc argument.

If you attempt to load a design that was compiled on adifferent platform, an error such as
the following occurs:

# vsi mwork.test_ringbuf
# Loadi ng work/systent. so

# ** Error: (vsim3197) Load of "work/systent.so" failed:
wor k/ systenc.so: ELF file data encoding not little-endian.

# ** Error: (vsim3676) Could not |oad shared library
wor k/ systenct.so for SystenC nodule 'test_ringbuf'.

# Error |oading design

Y ou can typeverror 3197 at the vsim command prompt and get detail s about what caused
the error and how to fix it.
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Using sccom vs. raw C++ compiler

When compiling complex C/C++ testbench environments, it is common to compile code
with many separate runs of the compiler. Often users compile code into archives (.afiles),
and then link the archives at the last minute using the -L and -I link options.

When using ModelSim's SystemC, you may wish to compile a portion of your C design
using raw g++ or aCC instead of sccom. Perhaps you have somelegacy code or some non-
SystemC utility code that you want to avoid compiling with sccom. Y ou can do this,
however, some cavests and rules apply.

Rules for sccom use
The rules governing when and how you must use sccom are as follows:

1 You must compile all code that references SystemC types or objects using sccom (CR-
248).

2 When using sccom, you should not use the -I compiler option to point the compiler at
any search directories containing OSCI SystemC header files. sccom does this for you
accurately and automatically.

3 If you do use the raw C++ compiler to compile C/C++ functionality into archives or
shared objects, you must then link your design using the-L and -I optionswith the sccom
-link command. These options effectively pull the non-SystemC C/C++ codeinto a
simulation image that is used at runtime.

Failure to follow the above rules can result in link-time or elaboration-time errors due to
mismatches between the OSCI SystemC header files and the Model Sim SystemC header
files.

Rules for using raw g++ to compile non-SystemC C/C++ code
If you use raw g++ to compile your non-systemC C/C++ code, the following rules apply:

1 The-fPIC option to g++ should be used during compilation at the sccom command line.

2 For C++ code, you must use the built-in g++ delivered with ModelSim, or (if using a
custom g++) use the one you built and specified with the CppPath .ini variable.

Otherwise binary incompatibilities may arise between code compiled by sccom and code
compiled by raw g++.

Rules for using raw HP aCC to compile non-SystemC C/C++ code

If you use HP' s aCC compiler to compile your non-systemC C/C++ code, the following
rules apply:

1 For C++ code, you should use the +Z and -AA options during compilation

2 You must use HP aCC version 3.45 or higher.
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Issues with C++ templates

Templatized SystemC modules
Templatized SystemC modules are not supported for use at:
* thetop level of the design

* the boundary between SystemC and higher level HDL modules (i.e. the top level of the
SystemC branch)

To convert atop level templatized SystemC module, you can either specialize the module
to remove the template, or you can create a wrapper module that you can use as the top
module.

For example, let’ s say you have atemplatized SystemC module as shown below:

tenpl ate <class T>
class top : public sc_nodule

{

sc_si gnal <T> si g1,

h
Y ou can specialize the module by setting T = int, thereby removing the template, as
follows:

class top : public sc_nodule

{

sc_signal <int> sig 1;

H
Or, dternatively, you could write awrapper to be used over the template module;

class nodel simtop : public sc_nodule

{

top<i nt> actual _top;

3

SC_MODULE_EXPORT( nodel si m top);

Organizing templatized code

Suppose you have a class template, and it contains a certain number of member functions.
All those member functions must be visible to the compiler when it compiles any instance
of the class. For classtemplates, the C++ compiler generates code for each unique instance
of the class template. Unlessit can see the full implementation of the class template, it
cannot generate code for it thus leaving the invisible parts as undefined. Sinceit islegal to
have undefined symbolsin a.so, sccom -link will not produce any errors or warnings.

To make functions visible to the compiler, you should move them to the .h file. Model Sim
requires all functions defined in a.h fileto beinlined. For relevant information on inlining
functions, see "Multiple symbol definition errors' (UM-208).
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Linking the compiled source

Once the design has been compiled, it must be linked using the sccom (CR-248) command
with the -link argument.

sccom -link

The sccom -link command ar gument collects the object files created in the different
design libraries, and uses them to build a shared library (.so) in the current work library. If
you have changed your SystemC source code and recompiled it using sccom, then you must
relink the design by running sccom -link before invoking vsim. Otherwise, your changes
to the code are not recognized by the simulator. Remember that any dependent .aor .ofiles
should be listed on the sccom -link command line before the .a or .0 on which it depends.
For more details on dependencies and other syntax issues, see sccom (CR-248).

sccom -link errors

Most errors occurring during sccom -link are due to multiple symbol definitions caused by
incorrect symbol definitions in header files or by Model Sim’s name association. For
information on fixing errors encountered during linking, see "Errors during loading" (UM-
206)
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Simulating SystemC designs

After compiling the SystemC source code, you can simulate your design with vsim (CR-
357). This section discusses simulation from the operating system command prompt.

For SystemC, invoke vsim (CR-357) with the top-level module of the design. Thisexample
invokes vsim (CR-357) on adesign:

vsi mtop_| evel _nodul e

When the GUI comes up, you can expand the hierarchy of the design to view the SystemC
modules. SystemC objects are denoted by a green diamond.

Fi

e Edit Wew Compile  Simulate  Tools  Window Help

=RR|| L E EEER B R

Wiorkspace L3

*| Inst Design Unit Design Unit Ty # sim top

e e 2 e Z e # Loading Aworkfsystemne so
top top Schociule # Loading top
test test SecModule # WARMING: Default time step is used for VCD tracing.
ting_INST ting_INST Schodule WEIM 1> wm title . "Model Sim 5E

block1 block1 Schdodule WEIM 23 |
hlacka hlocka Sehdodule
hlock3 hlock3 Sehdodule

Library | sim [ Files |

Mow: Ons Delta: 0 sim:ftop

Simulator resolution limit

The simulator internally represents time as a 64-bit integer in units equivalent to the
smallest unit of simulation time, also known as the simulator resolution limit. The default
resolution limit is set to the value specified by the Resolution (UM-624) variable in the
modelsim.ini file. Y ou can view the current resolution by invoking the report command
(CR-238) with the simulator state option.

Overriding the resolution

Y ou can override Model Sim’s default resol ution by specifying the -t option on the
command line or by selecting adifferent Simulator Resol ution in the Simulate dialog box.
Availableresolutions are: 1x, 10x, or 100x of fs, ps, ns, us, ms, or sec.

For example this command chooses 10 ps resolution:

vsim-t 10ps topnod
Y ou need to be careful when doing thistype of operation. If the resolution set by -t islarger
than adelay valuein your design (i.e. sc_wait (4,SC_PS);), the delay valuesin that design

unit are rounded to the closest multiple of the resolution. In the example above, a delay of
4 pswould be rounded to O ps.
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In addition, you must keep in mind the relationship between the simulator’ s resolution and
the SystemC time units specified in the source code. For example, with atime unit usage of :

sc_wai t (10, SC_PS)
asimulator resolution of 10pswould be fine. No rounding off of the ones digitsin the time
units would occur. However, a specification of:

sc_wait(9, SC_PS);

requires setting the resolution limit to 1psin order to avoid inaccuracies caused by
rounding.

SystemC defaultsto 1ps resolution. That meansit is possible for the source code to contain
callswhich don’t explicitly specify units. In such cases the SystemC resolution is 1ps. For
example:

sc_clock("cl k", 9);
In SystemC, the sc_set time resolution() function is used to change the default units
during or after elaboration. This function is not supported in Model Sim, since by the time

it could be called from an executing SystemC model, it would be too late to change the
simulator resolution.

Choosing the resolution

Y ou should choose the coarsest resolution limit possible that does not result in undesired
rounding of your delays. The time precision should not be set unnecessarily small because
in some cases performance will be degraded.
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Initialization and cleanup of SystemC state-based code

Constructors and Destructors should be reserved for creating and destroying SystemC
design objects, such assc_nodul es Of sc_si gnal s. The following 2.1 virtual functions
should be used to initialize and clean up state-based code, such aslogfiles or the VCD trace
functionality of SystemC:

» end_of_construction ()
Called after al constructors are called, but before port binding.

» end_of elaboration ()
Cadlled at the end of elaboration after port binding. This function isavailable in the
SystemC 2.0.1 reference simulator.

* start_of_simulation ()
Called before simulation starts. Simulation specific initialization code can be placed in
this function.

» end_of_simulation ()
Cadlled before ending the current simulation session.

The call sequence for these functions with respect to the SystemC object construction and
destruction is asfollows:

1 Constructors

2 end_of_construction ()
3 end_of _elaboration ()
4 start_of_simulation ()
5 end_of_simulation ()

6 Destructors

ModelSim SE User’'s Manual



Debugging the design UM-201

Debugging the design

All Model Sim’s GUI debugging features within all windows, with the exception of
Dataflow, are fully available for use with SystemC.

[¥] Modetsim SE =]

Fle  Edit Mew Compile  Sirulate  Tools  'Sincow Help
BB | SHQH 4 0slEAEBI BPR
Workspane =|
¥ Inst Design unit | Design uni # X
¥ nstance | Design unit_| Desigr uri [ #* NOTICE * at 59800 ns: Data valus not expected.
= test_ringhut test_ringbuf  Schocule #
ting_IMST ringbuf Sehodule #** RESTORED ** at 202800 ns: Data returned to expected valu
- i
W5k 5 run -all
# Break key hit

# Simulation stop requested.

# 0:x420d3b2e in select (O frorm AibAEEENbE 30 6
# Disable C Breakpoint .1

# dizable breakpoints 1

# 042003k 2e in select (O from AibAEEGENRE 506
# C breakpoint id ¢.2 has true location at

,"Ir # file usddale/MThexamplessSYSTEMC _DEMOQSsc_vhdl _viogise
_sriftest_ringbuf b line "97"
R -
Likrary | sim [ Files | /
|Now:1,515,?92,?un fs Delta:0 |sim:nest_ringbuf p

Source-level debug

In order to debug your SystemC source code, you must compile the design for debug using
the -g C++ compiler option. Y ou can add this option directly to the sccom (CR-248)
command line on a per run basis, with acommand such as:

sccom nmytop -g
Or, if you plan to use it every time you run the compiler, you can specify it in the

modelsim.ini file with the SccomCppOptions variable. See "[sccom] SystemC compiler
control variables' (UM-620) for more information.

The source code debugger, C Debug, isautomatically invoked when the designis compiled
for debug in this way.
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Y ou can set breakpointsin the Source window, and single-step through your SystemC/C++
source code. .

source - test_ringbuf.h

File  Edit Mew Tools Hindow

; ! Wig o mid 3 A i :
S YRR DM O T HEEERE B
B M £
& |In #l sim:itest_ringhuf IuIddaJeIMTIIexamplesfS\-‘STEME_DEMDJ’sc_\-'hdl_vlu:ng!sc_srcftest_ringbuf.h| j.

a3 static bool first = tiue;

94 if {first || sec_simulation_time{) == 03

9t

9k first = false;

& 97 clock. write (0); —
EES +
319 elze
100 {
101 bool nextclockvalue = {clock.read(} == tme) ¥ false : true,
102 clock. write (nextclockValue);
10% 3 /
ﬂpl test_ringhuf h | H |
| | fn: 8 Col: 0 |Read | y:

The gdb debugger has a known bug that makes it impossible to set breakpoints reliably in
constructors or destructors. Try to avoid setting breakpoints in constructors of SystemC
objects; it may crash the debugger.
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Y ou can view and expand SystemC items in the Signals window.

signals =] B4
File  Edit “iew Add Tools  Window
‘ dh B B ‘ Contains: Clear
| Mame Walue #Togale | % Togole I
=
|3im:.f‘test_ringbuf | L

Y ou can also view the processes in the Process window.

File  Edit ‘iew Window

L =

F- =

sim:itest_ringhut

B
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Differences between ModelSim and the OSCI simulator

Model Sim is based upon the 2.0.1 reference simulator provided by OSCI. However, there
are some minor but key differences to understand:

» vsim cals sc_initialize() by default at the end of elaboration. The user hasto explicitly
call sc_initialize() in the reference simulator. Y ou should remove callsto sc_initialize()
from your code.

 The default time resolution of the reference simulator is 1ps. For vsim it is 1ns. The user
can set the time resol ution by using vsim command with the -t option or by modifying
the value of the resolution variable in the modelsim.ini file.

* All SystemC processes without adont_initialize() modifier are executed once at the end
of elaboration. This can cause print messages to appear from user models before the first
V SIM> prompt occurs. This behavior is normal and necessary in order to achieve
compliance with both the SystemC and HDL LRM’s.

» Therun command in ModelSim is equivalent to sc_start(). In the reference simulator,
sc_start() runsthe simulation for the duration of time specified by its argument. In
Model Sim the run command (CR-246) runs the simulation for the amount of time
specified by its argument.

» Thedelta_count() function in the reference simulator returns the cumul ative delta count.
Invsim, it returns the delta count since the last time advance. The deltacount invsim is
reset after every time advance.

» Thesc_cycle(), sc_start(), sc_main() & sc_set_time_resolution() functions are not
supported in Model Sim.

Name association (binding)

SystemC simulation objects such asmodul es, primitive channelsand ports can be explicitly
named by passing aname to the constructors of said objects. If an object is not constructed
with an explicit name, then the OSCI reference simulator generates an internal namefor it,
using names such as"s0", "sl1", etc..

M odel Sim hasimplemented its own name association technology for SystemC, attempting
to give reasonable namesto the child objects of SC_MODULES, i.e. namesthat match the
C++ source code names. Model Sim’ s name associ ation automatically bindsthe C++ object
name to any unnamed object.

For example, if the design has a primitive channel sc_si gnal <bool > foo; that is
constructed without an explicit name, it is named f oo in the simulator's database.
Automatic name bindingisenabled for each sc_modulewhich makesuse of theSC_CTOR
constructor macro. If amodulein the design doesn't usethe SC_CTOR constructor macro,
name binding can be enabled by adding the SC_MTI_BIND_NAME macro anywhere
inside a public: access area of the modul€'s declaration. See the following sample code:
SC_MODULE( mod_b )
E)ubl ic:
sc_in<int> in;
sc_out <i nt> out;

SC_MTI _BI ND_NAME;
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private:
int a;
publi c:

mod_b(sc_nodul e_nane nane);
}s

Automatic name binding is supported only for modules declared in header (.h, .hxx) files.
It is not supported when modules are declared in C++ sourcefiles (.cpp, .cxx, .cc, €tc.).

Disabling automatic name binding

If a C++ sourcefile contains a module that uses an SC_CTOR (or the
SC_MTI_BIND_NAME) macro, you must disable automatic name binding. Otherwise, an
sccom error results. Y ou can disable automatic name binding when you compile your C++
source code using the -nonamebind argument to the sccom (CR-248) command. Disabling
the name binding can also be useful as aworkaround to symbol collisions at the time of
linking the compiled source (see "sccom -link errors' (UM-197).

Fixed point types

Contrary to OSCI, Model Sim compiles the SystemC kernel with support for fixed point
types. If you want to compile your own SystemC code to enable that support, you' Il need
to define the compile time macro SC_INCLUDE_FX. Y ou can do thisin one of two ways:

* enter the g++/aCC argument -DSC_INCLUDE_FX on the sccom (CR-248) command
line, such as:

sccom - DSC_I NCLUDE_FX t op. cpp
* add a define statement to the C++ source code before the inclusion of the systemc.h, as
shown below:

#defi ne SC_I NCLUDE_FX
#i ncl ude "systent. h"

OSCI 2.1 features supported

ModelSim is fully compliant with the OSCI version 2.0.1. In addition, the following 2.1
features are supported:

» end_of _construction()
o start_of_simulation()
» end_of_simulation()

For moreinformation regarding these functions, see "I nitialization and cleanup of SystemC
state-based code" (UM-200).
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Troubleshooting SystemC

In the process of modifying your SystemC design to run on Model Sim, you may encounter
several common errors. This section highlights some actions you can take to correct such
errors.

Errors during compilation

Model Sim’s name association feature (gensr ¢) runs primarily at sccom -link time. A key
element of the featureis that C++ source files are generated in the work library. The C++
source filesinclude user header files that define user sc_ module classes. Thesefiles are
compiled by the C++ compiler during sccom -link operation. Occasionally, this
compilation phase generates errors, such as the following:

| _sc/ gensrc_obj/gensrc_0. cpp: 4:\

gates. h:8: redefinition of “struct nmy_gate

gates. h:8: previous definition of “struct nmy_gate
** Error: (sccom6142) Conpilation failed

All known gensrc compilation errors occur due to lack of include guards in user header
files. Aninclude guardisaconstruct used to guard against redundant text inclusionina.cpp
file during compilation.

A typical include guard for a header file named filename.h would look like this:

#i f ndef | NCLUDED_FI LENAVE_H

#defi ne | NCLUDED_FI LENAME_H

<mai n body of filename.h goes here>

typedef unsigned long u_long; // Exanple contents
#endi f

When this construct isused, it makesit OK for usersto "#include" in their header filemore
than once during the same compilation, e.g.:

#i nclude "fil enane. h"
#i nclude "fil enane. h"

However, thistypically doesn't happen. More often something like this happens:

#i ncl ude "foo.h"
#i ncl ude "bar.h"

in which both foo.h and bar.h have a#include filename.h directive.

Errors during loading

When simulating your SystemC design, you might get a "failed to load sc lib" message
because of an undefined symbol, looking something like this:

# Loadi ng / hone/ cng/ newport 2_syst ent/ chi p/ vhdl / wor k/ systent. so

# ** Error: (vsim 3197) Load of "/home/cng/ newport?2_systenc/chip/vhdl /work/
systenc.so" failed: ld.so.1

[ home/ i cds_nut/ nodel si M 5. 8a/ sunos5/vsink: fatal: relocation error: file

[ horme/ cng/ newport 2_syst enc/ chi p/ vhdl / wor k/ syst ent. so: synbo
_Z28host _respond_t o_vhdl _request Pm
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ref erenced synbol not found.

# ** Error: (vsim3676) Could not |oad shared library /home/cng/
newport 2_systenc/ chi p/ vhdl / wor k/ systent. so for SystenC nodul e ' host_xtor'.
Source of undefined symbol message
The causes for such an error could be:
* missing definition
* bad link order specified in sccom -link
» multiply defined symbols

Missing definition
If the undefined symbol isa C function in your code or alibrary you are linking with, be
sure that you declared it as an extern "C" function:

extern "C' void nyFunc();

This should appear in any header filesinclude in your C++ sources compiled by sccom. It
tellsthe compiler to expect aregular C function; otherwise the compiler decoratesthe name
for C++ and then the symbol can't be found.

Also, be surethat you actually linked with an object file that fully definesthe symbol. Y ou
can use the "nm" utility on Unix platformsto test your SystemC object files and any
librariesyou link with your SystemC sources. For example, assume you ran the following
commands:

sccom test.cpp

sccom -link |ibSupport.a
If thereisan unresolved symbol and it is not defined in your sources, it should be correctly
defined in any linked libraries:

nm | i bSupport.a | grep "nySynbol "

Misplaced "-link" option

The order in which you place the -link option within the sccom -link command iscritical.
There is abig difference between the following two commands:

sccom-link liblocal.a

and

sccom | i bnystuff.a -1ink

Thefirst command ensures that your SystemC object files are seen by the linker before the
library "liblocal.a" and the second command ensures that "liblocal .a" is seen first. Some
linkers can look for undefined symbols in libraries that follow the undefined reference
while others can look both ways. For more information on command syntax and
dependencies, see sccom (CR-248).
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Multiple symbol definition errors

The most common type of error found during sccom -link operation isthe multiple symbol
definition error. Thistypically arises when the same global symbol is present in more than
one .o file. The error message looks something like this:

wor k/ sc/ gensrc/test _ringbuf.o: In function
“test_ringbuf::clock_generator(void)’

wor k/ sc/ gensrc/test _ringbuf.o(.text+0x4): multiple definition of
“test_ringbuf::clock_generator(void)

wor k/ sc/test _ringbuf.o(.text+0x4): first defined here

A common cause of multiple symbol definitions involvesincorrect definition of symbols
in header files. If you have an out-of-line function (one that isn’t preceded by the "inline"
keyword) or avariable defined (i.e. not just referenced or prototyped, but truly defined) in
a.hfile, you can't include that .h file in more than one .cpp file.

Textin.hfilesisincluded into .cpp filesby the C++ preprocessor. By thetimethe compiler
seesthetext, it'sjust asif you had typed the entire text from the .h fileinto the .cpp file. So
a.hfileincluded into two .cpp files resultsin lots of duplicate text being processed by the
C++ compiler when it starts up. Include guards are acommon technique to avoid duplicate
text problems. See "Errors during compilation” (uM-206) for more information on include
guards.

If an .h file has an out-of-line function defined, and that .h fileis included into two .cfiles,
then the out-of-line function symbol will be defined in the two corresponding. ofiles. This
leads to a multiple symbol definition error during sccom -link.

To solve this problem, add the "inline" keyword to give the function "internal linkage".
This makes the function internal to the .o file, and prevents the function's symbol from
colliding with asymbol in another .o file.

For free functions or variables, you could modify the function definition by adding the
"static" keyword instead of "inlineg", although "inline" is better for efficiency.

Sometimes compilers do not honor the "inling" keyword. In such cases, you should move
your function(s) from a header file into an out-of-line implementation in a.cpp file.

Multiple symbol definitions caused by ModelSim’s name association

Another cause of errorsis due to Model Sim’s name association feature. It isimportant to
realize that the name association feature automatically generates .cpp files in the work
library. Thesefiles"include" your header files. Thus, while it might appear as though you
have included your header file in only one .cpp file, from the linker’s point of view, itis
included in multiple .cpp files.

If name association is causing multiple symbol definition errors, you should eliminate the
errors by using the techniques mentioned above (i.e. adding the "inline" or "static"
keywords, as appropriate). Another solution isto use the sccom -nonamebind argument to
turn off name association. However, thisis not recommended, since design debug will be
heavily compromised without name association.

For related information, see "Name association (binding)" (UM-204).

ModelSim SE User’'s Manual



UM-209

8 - Mixed-language simulations

Chapter contents

Usage flow for mixed-language ssimulations . . . . . . . UM-210
Separate compilers, common design libraries. . . . . . . UM-211
Access limitationsin mixed-language designs . . . . . UM-211
Simulator resolution limit. . . . . . . . . . . UM-211
Runtime modeling semantics. . . . . . . . . . UM-212
Mapping datatypes . . . . . . . . . . . UM-213
Verilog to VHDL mappmgs . . . . . . . . . UM-213
VHDL to Verilog mappings . . . . . . UM-216
Verilog and SystemC signal interaction and mappl ngs .. . UM-217
VHDL and SystemC signal interaction and mappings . . . UM-221
VHDL: instantiating Verilog . . . . . . . . . . . UM-225
Verilog instantiation criteria . . . . . . . . . . UM-225
Component declaration . . ... . . . . . UM-22%
vgencomp component declaration . . . . . . . . UM-226
Moduleswithunnamed ports. . . . . . . . . . UM-228
Veilog: instantiatingvVHbDL . . . . . . . . . . . UM-229
VHDL instantiation criteria . . . . . . . . . . UM-229
SDF annotation . . . . . . . . . . . . . UM-230
SystemC: instantiating Verilog . . . . . . . . . . UM-231
Verilog instantiation criteria . . . . . . . . . . UM-231
SystemC foreign module declaration. . . . . . . . UM-231
Verilog: instantiating SystemC . . . . . . . . . . UM-234
SystemC instantiation criteria. . . . . . . . . . UM-234
Exporting SyssemCmodules . . . . . . . . . . UM-234
sccom-link . . . . . . . . . . . . . . UM-234
SystemC: instantiatingvHDL . . . . . . . . . . . UM-23%5
VHDL instantiation criteria . . . . . . . . . . UM-23%5
SystemC foreign module declaration. . . . . . . . UM-235
VHDL: instantiating SysslemC. . . . . . . . . . . UM-237
SystemC instantiation criteria. . . . . . . . . . UM-237
Component declaration . . e ... ... UM-237
vgencomp component declaration . . . . . . . . UM-238
Exporting SyssemCmodules . . . . . . . . . . UM-238
sccom-link . . . . . . . . . . . . . . UM-238

Model Sim single-kernel simulation allows you to simulate designs that are written in
VHDL, Verilog, and/or SystemC. The boundaries between languages are enforced at the
level of adesign unit. This meansthat although a design unit itself must be entirely of one
language type, it may instantiate design units from another language. Any instance in the
design hierarchy may be adesign unit from another language without restriction.
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Usage flow for mixed-language simulations
The usage flow for mixed-language designsis as follows:

1 Anayze HDL source code using vcom or vlog and C++ source code using sccom.
Analyze all modulesin the design following order-of-analysis rules.

» For SystemC designs with HDL instances:
Y ou must create a SystemC foreign module declaration for al Verilog and VHDL

instances (UM-234).

* For Verilog/VHDL designs with SystemC instances:
Y ou must export any SystemC instances that will be directly instantiated by Verilog/
VHDL using the SC_EXPORT_MODULE macro. Exported SystemC modules can be
instantianted just as you would instantiate any Verilog/VHDL module or design unit.

2 Simulate the design by invoking vsim.

* For designs containing SystemC code:
Y ou must first prepare the design by running sccom -link (Um-234) prior to running
simulation.

3 Issuerun commands from the Model Sim GUI.

4 Debug your design using ModelSim GUI features. Note that objects inside SystemC
modules are unavailable for viewing in the Dataflow window.
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Separate compilers, common design libraries

VHDL source codeis compiled by vcom (CR-303) and the resulting compiled design units
(entities, architectures, configurations, and packages) are stored in the working library.
Likewise, Verilog source code is compiled by vlog (CR-345) and the resulting design units
(modules and UDPs) are stored in the working library.

SystemC/C++ source code is compiled with the sccom command (CR-248). The resulting
object code is compiled into the working library.

Design libraries can store any combination of design units from any of the supported
languages, provided the design unit names do not overlap (VHDL design unit names are
changed to lower case). See "Design libraries" (UM-53) for more information about library
management.

Access limitations in mixed-language designs

The Verilog language allows hierarchical access to objects throughout the design. Thisis
not the case with VHDL or SystemC. Y ou cannot directly read or change a VHDL or
SystemC object (signal, variable, generic, etc.) with a hierarchical reference within a
mixed-language design. Furthermore, you cannot directly access a Verilog object up or
down the hierarchy if thereis an interceding VHDL or SystemC block.

Y ou have two options for accessing VHDL objects or Verilog objects "obstructed” by an
interceding block: 1) propagate the value through the ports of all design unitsin the
hierarchy; 2) use the Signal Spy procedures or system tasks (see Chapter 16 - Sgnal Spy
for details).

To access obstructed SystemC objects, propagate the value through the ports of al design
unitsin the hierarchy.

Simulator resolution limit

If the root of the mixed design is VHDL, then VHDL simulator resolution rules are used
(see"Simulator resolution limit" (um-211) for VHDL details). If the root of the mixed
designisVerilog, Verilog rules are used (see "Simulator resolution limit" (um-117) for
Verilog details), but no Verilog modules that are instantiated under VHDL models are
considered when looking for the minimum simulation precision.

Note that the OSCI SystemC simulator alows usersto dynamically changethe simulator’s
resolution by using the sc_set_time _resolution() API. Thisis not permitted in ModelSim.
Y ou must be aware of your required SystemC resolution in advance, and then make sure

Model Sim is running with aresolution at least as fine as the SystemC resolution.

If adesign contains SystemC modules and V erilog modules, the default resolution
(specified in modelsim.ini or by using the vsim -t command line option) must be at least as
fine asthe finest Verilog ‘timescale setting in the design. Otherwise an elaboration error
occurs.
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Runtime modeling semantics

The Model Sim simulator is compliant with all pertinent Language Reference Manuals. To
achieve this compliance, the sequence of operationsin one simulation iteration (i.e. delta
cycle) isasfollows:

» SystemC processes are run
 Signal updates are made

* HDL processes arerun
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Mapping data types

Cross-language (HDL) instantiation does not require any extra effort on your part. As
Model Sim loads a design it detects cross-language instantiations — made possible because
adesign unit's language type can be determined asit is loaded from alibrary — and the
necessary adaptations and data type conversions are performed automatically. SystemC
and HDL cross-languageinstanti ation requires minor modification of SystemC source code
(addition of SC_EXPORT_MODULE, sc_foreign_module, etc.).

A VHDL instantiation of Verilog may associate VHDL signals and values with Verilog
ports and parameters. Likewise, a Verilog instantiation of VHDL may associate Verilog
nets and values with VHDL ports and generics. The same holds true for SystemC and
VHDL/Verilog ports. However, SystemC does not support cross-language generic/
parameter propagation at thistime.

Model Sim automatically maps between the language data types as shown in the sections
below.

Verilog to VHDL mappings

VHDL generics

VHDL type Verilog type
integer integer or real
real integer or rea
time integer or real
physical integer or real
enumeration integer or real
string string literal

When ascalar type receives areal value, thereal is converted to an integer by truncating
the decimal portion.

Typetimeistreated specially: the Verilog number is converted to atime value according
to the ‘timescale directive of the module.

Physical and enumeration types receive avalue that corresponds to the position number
indicated by the Verilog number. In VHDL thisis equivalent to T'VAL(P), where T isthe
type, VAL isthe predefined function attribute that returns avalue given aposition number,
and P isthe position number.

Verilog parameters

VHDL type Verilog type
integer integer
real real
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VHDL type Verilog type

string string

Thetype of aVerilog parameter is determined by itsinitial value.

Verilog ports

The allowed VHDL typesfor ports connected to Verilog nets and for signals connected to
Verilog ports are;

Allowed VHDL types

bit

bit_vector

std_logic

std_logic_vector

vl_logic

vl_logic_vector

Thevl_logictypeisan enumeration that definesthefull state set for Verilog nets, including
ambiguous strengths. The bit and std_logic types are convenient for most applications, but
thevl_logic typeis provided in case you need accessto the full Verilog state set. For
example, you may wish to convert between vl_logic and your own user-defined type. The
vl_logic typeis defined in the vl_types package in the pre-compiled verilog library. This
library is provided in the installation directory along with the other pre-compiled libraries
(std and ieee). The source code for the vl_types package can be found in thefilesinstalled
with Model Sim. (See <install_dir>\modeltech\vhdl_src\verilog\vitypes.vhd.)

Verilog states

Verilog states are mapped to std_logic and bit as follows:

Verilog std_logic bit
Hiz VA ‘0
Smo L ‘0
Sml 'H' 1
SmX ‘W' ‘0
Me0 L' 0
Mel 'H' T
MeX ‘W' ‘0
We0 L' ‘0
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Verilog std_logic bit
Wel 'H' T
WeX ‘W' ‘0
La0 L' ‘0
Lal 'H' 1
LaX ‘W' ‘0
PuO L' ‘0
Pul 'H' 1
PuX ‘W' ‘0
S0 ‘0 0
Stl 1 1
StX X' ‘0
Su0 ‘0 ()
Sul 1 1
SuX X' ‘0

For Verilog states with ambiguous strength:

* hit receives'0’

Mapping data types UM-215

* std_logic receives X' if either the O or 1 strength component is greater than or equal to

strong strength

« std_logic receives 'W' if both the 0 and 1 strength components are less than strong

strength
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VHDL to Verilog mappings
VHDL type bit is mapped to Verilog states as follows:

bit Verilog
() S(0)
1 St1

VHDL type std_logic is mapped to Verilog states as follows:
std_logic Verilog
U StX
X' StX
{0 S0
1 St1
'z HiZz
‘W PuX
L Pu0
'H' Pul
- StX
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Verilog and SystemC signal interaction and mappings

SystemC has a more complex signal-level interconnect scheme than Verilog. Design units
are interconnected via hierarchical and primitive channels. An sc_signal<> is one type of
primitive channel. The following section discusses how various SystemC channel types
map to Verilog wires when connected to each other across the language boundary.

Channel and Port type mapping

The following port type mapping table listsal channels. Three types of primitive channels
and 1 hierarchical channel are supported on the language boundary (SystemC modules
connected to Verilog modules).

Channels Ports Verilog mapping

sc_signal<type> sc_in<type> Depends on type. Seetable
SC_out<type> entitled "Data type mapping" (UM-
sC_inout<type> 218).

sc_signal_rv<width> SC_in_rv<width> wire [width-1:0]

sC_out_rv<width>
SC_inout_rv<width>

sc_signal_resolved sc_in_resolved wire [width-1:0]
sc_out_resolved
sC_inout_resolved

sc_clock sc in clk wire
sc_out_clk
sc_inout_clk
SC_mutex N/A Not supported on language
boundary
sc fifo sc_fifo_in Not supported on language
sc_fifo_out boundary
sc_fifo_inout
sc_semaphore N/A Not supported on language
boundary
sc_buffer N/A Not supported on language
boundary
user-defined user-defined Not supported on language
boundary
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Data type mapping
SystemC’s sc_signal<> types are mapped to Verilog types as follows:

SystemC Verilog

bool, sc_hit wire

sc_logic wire
sc_bv<width> wire [width-1:0]
sc_lv<width> wire [width-1:0]

sc_int<width>, sc_uint<width>

wire [width-1:0]

char, unsigned char wire[7:0]
int, unsigned int wire [31:0]
long, unsigned long wire[31:0]

sc_bigint<width>,
sc_biguint<width>

Not supported on language boundary

sc_fixed<W,,Q,0,N>,
c_ufixed<W,1,Q,0,N>

Not supported on language boundary

short, unsigned short

Not supported on language boundary

long long, unsigned long long

Not supported on language boundary

float Not supported on language boundary
double Not supported on language boundary
enum Not supported on language boundary
pointers Not supported on language boundary
class Not supported on language boundary
struct Not supported onlanguage boundary
union Not supported on language boundary
bit fields Not supported on language boundary
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Port direction

Verilog port directions are mapped to SystemC as follows:

Mapping data types UM-219

Verilog SystemC

input SC_in<type>, sc_in_resolved, sc_in_rv<width>

output SC_out<type>, sc_out_resolved, sc_out_rv<width>
inout sC_inout<type>, sc_inout_resolved, sc_inout_rv<width>

Verilog to SystemC state mappings

Verilog states are mapped to sc_logic, sc_bit, and bool as follows:

Verilog sc_logic sc_hit bool
Hiz 'z 0 false
Smo ‘0 ‘0 fase
Sml T T true
SmX X' ‘0 fase
Me0 ‘0 ‘0 fase
Mel T T true
MeX X' 0 false
We0 ‘0 () fase
Wel T T true
WeX X' (o) false
La0 ‘0 ‘0 fase
Lal 1 1 true
Lax X' 0 false
PuO ‘0 0 fase
Pul T T true
PuX X' ‘0 false
Sto 0 ‘0 fase
St1 1 T true
StX X' ‘0 fase
Su0 (0 () fase
Sul T T true

ModelSim SE User’s Manual



UM-220 8 - Mixed-language simulations

Verilog sc_logic sc_hit bool

SuX X' 0 false

For Verilog states with ambiguous strength:
» sc_hit receives'1' if the value component is 1, else it receives’ 0’
* bool receivestrueif the value component is 1, else it receives false

* sc_logic receives X' if the value component is X, H, or L

» sC_logic receives'0' if the value component is O

» sC _logic receives’1’ if the value component is 1

SystemC to Verilog state mappings

SystemC type bool is mapped to Verilog states as follows:

bool Verilog
false S0
true St

SystemC type sc_bit is mapped to Verilog states as follows:

sc_bit Verilog
‘0 Sto
1 St1

SystemC type sc_logic is mapped to Verilog states as follows:

sc_logic Verilog
‘0 StO
T Stl
'Z' Hiz
X' StX
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VHDL and SystemC signal interaction and mappings

SystemC has a more complex signal-level interconnect scheme than VHDL. Design units
are interconnected via hierarchical and primitive channels. An sc_signal<> is one type of
primitive channel. The following section discusses how various SystemC channel types
map to VHDL types when connected to each other across the language boundary.

Port type mapping

The following port type mapping table listsal channels. Three types of primitive channels
and 1 hierarchical channel are supported on the language boundary (SystemC modules
connected to VHDL modules)..

Channels Ports VHDL mapping
sc_signal<type> SC_in<type> Depends on type. See table entitled
SC_out<type> "Datatype mapping” (UM-221)

sC_inout<type>

below.

sc_signal_rv<width>

SC_in_rv<width>
SC_out_rv<width>
SC_inout_rv<width>

std_logic_vector(width-1 downto 0)

sc_signal_resolved

sc_in_resolved
sc_out_resolved
SC_inout_resolved

std_logic

sc_clock sc in clk bit/std_logic/boolean
sc_out_clk
sc_inout_clk
SC_mutex N/A Not supported on language boundary
sc_fifo sc_fifo_in Not supported on language boundary
sc_fifo_out
sc_fifo_inout
sc_semaphore N/A Not supported on language boundary
sc_buffer N/A Not supported on language boundary
user-defined user-defined Not supported on language boundary

Data type mapping
SystemC’s sc_signal types are mapped to VHDL types as follows

SystemC VHDL

bool, sc_hit bit/std_logic/boolean

sc _logic std_logic

sc_bv<width> bit_vector(width-1 downto 0)
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SystemC

VHDL

sc_lv<width>

std_logic_vector(width-1 downto 0)

SC_int<W>, sc_uint<width>

bit_vector(width-1 downto 0)

char, unsigned char

bit_vector(7 downto 0)

int, unsigned int

bit_vector(31 downto 0)

long, unsigned long

bit_vector(31 downto 0)

sc_bigint<width>,
sc_biguint<width>

Not supported on language boundary

sc_fixed<W,|,Q,0,N>,
sc_ufixed<W,1,Q,0,N>

Not supported on language boundary

short, unsigned short

Not supported on language boundary

long long, unsigned long

Not supported on language boundary

float Not supported on language boundary
double Not supported on language boundary
enum Not supported on language boundary
pointers Not supported on language boundary
class Not supported on language boundary
structure Not supported onlanguage boundary
union Not supported on language boundary
bit_fields Not supported on language boundary

Port direction mapping

VHDL port directions are mapped to SystemC as follows:

VHDL SystemC

in SC_in<type>, sc_in_resolved, sC_in_rv<w>

out SC_out<type>, sc_out_resolved, sc_out_rv<w>

inout SC_inout<type>, sc_inout_resolved,
SC_inout_rv<w>

buffer SC_out<type>, sc_out_resolved, sc_out_rv<w>
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VHDL to SystemC state mapping

VHDL states are mapped to sc_logic, sc_bit, and bool as follows:

std_logic sc_logic sc_bit bool
‘U’ X' ‘0 false
X' X' (0 fase
‘0 (0 ‘0 fase
7 1 T true

VA VA ‘0 fase
‘W' X' ‘0 false
L' ‘0 ‘0 false
'H' T 1 true

X ‘0 fase

Mapping data types UM-223
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SystemC to VHDL state mapping
SystemC type bool is mapped to VHDL boolean as follows:

bool VHDL
false false
true true

SystemC type sc_hit is mapped to VHDL bit asfollows:

sc_bit VHDL
0 0
1 "

SystemC type sc_logic is mapped to VHDL std_logic states as follows:

sc_logic std_logic
0 0
1 1
7 7
' '
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VHDL.: instantiating Verilog

Once you have generated a component declaration for a Verilog module, you can
instantiate the component just like any other VHDL component. Y ou can reference a
Verilog module in the entity aspect of a component configuration —all you needtodois
specify amodule name instead of an entity name. Y ou can also specify an optional
secondary name for an optimized sub-module. Further, you can reference a Verilog
configuration in the configuration aspect of a VHDL component configuration - just
specify a Verilog configuration name instead of aVHDL configuration name.

Verilog instantiation criteria

A Verilog design unit may beinstantiated within VHDL if it meets the following criteria
» Thedesign unit isamodule or configuration. UDPs are not allowed.
» The ports are named ports (see "M odules with unnamed ports' (UM-228) below).

» Theportsare not connected to bidirectional passswitches (it isnot possibleto handle pass
switchesin VHDL).

Component declaration

A Verilog modulethat iscompiledinto alibrary can be referenced fromaVHDL design as
though the moduleisaVHDL entity. Likewise, aVerilog configuration can be referenced
asthough it were a VHDL configuration.

The interface to the module can be extracted from the library in the form of a component
declaration by running vgencomp (CRr-318). Given alibrary and module name, vgencomp
(CR-318) writes a component declaration to standard output.

The default component port types are:
* std_logic

* std_logic_vector

Optionally, you can choose:

* bit and bit_vector

* vl_logicand vl_logic_vector

VHDL and Verilog identifiers

The VHDL identifiers for the component name, port names, and generic names are the
same as the Verilog identifiers for the module name, port names, and parameter names. If
aVerilog identifier isnot avalid VHDL 1076-1987 identifier, it is converted to aVHDL
1076-1993 extended identifier (in which case you must compile the VHDL with the -93 or
higher switch). Any uppercase lettersin Verilog identifiers are converted to lowercase in
the VHDL identifier, except in the following cases:

* The Verilog module was compiled with the -93 switch. This means vgencomp (CR-318)
should use VHDL 1076-1993 extended identifiersin the component declaration to
preserve case in the Verilog identifiers that contain uppercase letters.
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» TheVerilog module, port, or parameter names are not unique unless caseis preserved. In
this event, vgencomp (CR-318) behaves as if the module was compiled with the -93
switch for those names only.

If you use Verilog identifiers where the names are unique by case only, use the -93
argument when compiling mixed-language designs.

Examples
Verilog identifier VHDL identifier
topmod topmod
TOPMOD topmod
TopMod topmod
top_mod top_mod
_topmod \_topmod\
\topmod topmod
\\topmod\ \topmod\

If the Verilog module is compiled with -93:

Verilog identifier VHDL identifier
topmod topmod
TOPMOD \TOPMOD\
TopMod \TopMod\
top_mod top_mod
_topmod \_topmod\
\topmod topmod
\\topmod\ \topmod\

vgencomp component declaration

vgencomp (CR-318) generates a component declaration according to these rules:

Generic clause

A generic clause is generated if the module has parameters. A corresponding genericis
defined for each parameter that has an initial value that does not depend on any other
parameters.
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The generic type is determined by the parameter'sinitial value as follows:

Parameter value

Generic type

integer integer
real real
string literal string

The default value of the generic is the same as the parameter'sinitial value.

Examples

Verilog parameter

VHDL generic

parameter p1=1- 3;

pl:integer :=-2;

parameter p2 = 3.0;

p2 : rea := 3.000000;

parameter p3 = "Hello";

p3: string :="Hello";

Port clause

A port clauseis generated if the module has ports. A corresponding VHDL port is defined

for each named Verilog port.

You can set the VHDL port typeto bit, std_logic, or vl_logic. If the Verilog port has a

range, then the VHDL port typeis bit_vector, std_logic_vector, or vl_logic_vector. If the
range does not depend on parameters, then the vector type will be constrained accordingly,
otherwise it will be unconstrained.

Examples
Verilog port VHDL port
input p1; pl:instd logic;

output [7:0] p2;

p2 : out std_logic_vector(7 downto 0);

output [4:7] p3;

p3 : out std_logic_vector(4 to 7);

inout [width-1:0] p4;

p4 : inout std_logic_vector;

Configuration declarations are allowed to reference Verilog modules in the entity aspects
of component configurations. However, the configuration declaration cannot extend into a
Verilog instance to configure the instantiations within the Verilog module.

UM-227

ModelSim SE User’s Manual



UM-228 8 - Mixed-language simulations

Modules with unnamed ports

Verilog allows modules to have unnamed ports, whereas VHDL requiresthat all portshave
names. If any of the Verilog ports are unnamed, then all are considered to be unnamed, and
it is not possible to create amatching VHDL component. In such cases, the module may
not be instantiated from VHDL.

Unnamed ports occur when the module port list contains bit-selects, part-selects, or
concatenations, as in the following example:
nmodul e m(a[3:0], b[1], b[0], {c,d});
input [3:0] a;
input [1:0] b;
input c, d;
endnodul e

Notethat a[ 3:0] is considered to be unnamed even though it isafull part-select. A common
mistake is to include the vector boundsin the port list, which has the undesired side effect
of making the ports unnamed (which prevents the user from connecting by name even in
an al Verilog design).

Most modules having unnamed ports can be easily rewritten to explicitly name the ports,
thus allowing the module to be instantiated from VHDL. Consider the following example:
nodul e n(y[1], y[0], a[1], a[0]);
output [1:0] vy;
input [1:0] a;
endnodul e

Hereisthe same module rewritten with explicit port names added:
modul e n(.y1(y[1]), .yO(y[0]). .al(a[1]), .a0(a[0]));
output [1:0] vy;
input [1:0] a;
endnodul e

"Empty" ports

Verilog modules may have "empty" ports, which are also unnamed, but they are treated
differently from other unnamed ports. If the only unnamed portsare"empty", then the other
ports may still be connected to by name, as in the following example:

nmodule m(a, , b);

input a, b;
endnodul e

Although this module has an empty port between ports"a' and "b", the named portsin the
module can still be connected to from VHDL.
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Verilog: instantiating VHDL

Y ou can reference a VHDL entity or configuration from Verilog as though the design unit
isamodule or a configuration of the same name.

VHDL instantiation criteria

A VHDL design unit may be instantiated within Verilog if it meets the following criteria
» The design unit is an entity/architecture pair or a configuration.

» The entity ports are of type bit, bit_vector, std_ulogic, std_ulogic_vector, vl_ulogic,
vl_ulogic_vector, or their subtypes. The port clause may have any mix of these types.

» Thegenericsare of typeinteger, real, time, physical, enumeration, or string. String isthe
only composite type allowed.

Entity/architecture names and escaped identifiers

Anentity nameisnot case sensitivein Verilog instantiations. Theentity default architecture
is selected from the work library unless specified otherwise. Since instantiation bindings
are not determined at compile timein Verilog, you must instruct the simulator to search
your librarieswhen loading the design. See"Library usage”" (Um-111) for more information.

Alternatively, you can employ the escaped identifier to provide an extended form of
instantiation:

\nylib.entity(arch) ul (a, b, c);
\nylib.entity ul (a, b, ¢);
\entity(arch) ul (a, b, c);

If the escaped identifier takes the form of one of the above and is not the name of adesign
unit in the work library, then the instantiation is broken down as follows:

* library = mylib

* design unit = entity

* architecture = arch

Named port associations

Port associations may be named or positional. Use the same port names and port positions
that appear in the entity.

Named port associations are not case sensitive unlessa VHDL port name is an extended
identifier (1076-1993). If the VHDL port nameis an extended identifier, the association is
case sensitive and the VHDL identifier’ s leading and trailing backslashes are removed
before comparison.

Generic associations

Generic associations are provided via the modul e instance parameter value list. List the
valuesin the same order that the generics appear in the entity. Parameter assignment to
genericsis not case sensitive.

The defparam statement is not allowed for setting generic values.

ModelSim SE User’s Manual



UM-230 8 - Mixed-language simulations

SDF annotation

A mixed VHDL/Verilog design can a so be annotated with SDF. See "SDF for mixed
VHDL and Verilog designs' (Um-554) for more information.
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SystemC: instantiating Verilog

To instantiate Verilog modules into a SystemC design, you must first create a" SystemC
foreign module declaration™” (Um-231) for each Verilog module. Once you have created the
foreign module declaration, you can instantiate the foreign module just like any other
SystemC module.

Verilog instantiation criteria

A Verilog design unit may beinstantiated within SystemC if it meetsthe following criteria:
» The design unit isamodule (UDPs and Verilog primitives are not allowed).

» The ports are named ports (Verilog allows unnamed ports).

» The Verilog module name must be avalid C++ identifier.

» Theportsare not connected to bidirectional passswitches (it isnot possibleto handle pass
switchesin SystemC).

The current release does not allow usersto perform parameter overrides when instantiating
Verilog from SystemC.

A Verilog modulethat is compiled into alibrary can beinstantiated in a SystemC design as
though the modul e were a SystemC module by passing the Verilog module name to the
foreign module constructor. For anillustration of this, see "Example #1" (UM-232).

SystemC and Verilog identifiers

The SystemC identifiers for the module name and port names are the same as the Verilog
identifiers for the module name and port names. Verilog identifiers must be valid C++
identifiers. SystemC and Verilog are both case sensitive.

SystemC foreign module declaration

In cases where you want to run amixed simulation with SystemC and Verilog, you must
generate and declare aforeign module that stands in for each Verilog module instantiated
under SystemC. The foreign modules can be created in one of two ways.

* running scgenmod, autility that automatically generates your foreign module declaration
(much like vgencomp generates a component declaration)

» modifying your SystemC source code manually

Using scgenmod

After you have analyzed the design, you can generate aforeign module declaration with an
scgenmod command (CR-251) similar to the following:

scgennod nodl

wheremodlisaVerilog module. A foreign module declaration for the specified moduleis
written to stdout.
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Guidelines for manual creation
Apply the following guidelinesto the creation of foreign modules. A foreign module:

* contains ports corresponding to VHDL or Verilog ports. These ports must be explicitly
named in the foreign modul€e’s constructor initializer list.

» must not contain any internal design elements such as child instances, primitive channels,
OF Processes.

» must pass a secondary constructor argument denoting the module’s HDL nameto the
sc_f orei gn_nodul e base class constructor. For VHDL, the HDL name can bein the
format [<lib>.]<primary>[(<secondary>)] or [<lib>.]<conf>. For Verilog, the HDL
name is simply the Verilog module name corresponding to the foreign module, or
[<lib>].<module>.

Example #1
A sample Verilog module to be instantiated in a SystemC design is:

nodul e vcounter (clock, topcount, count);

i nput clock
i nput topcount;
out put count;

reg count;

endnodul e

The SystemC foreign module declaration for the above Verilog moduleis:

class counter : public sc_foreign_nodule {
publi c:

sc_i n<bool > cl ock
sc_in<sc_l ogi c> topcount;
sc_out <sc_| ogi c> count;

count er (sc_nodul e_nanme nm
. sc_foreign_nodul e(nm "lib.vcounter"),
cl ock("cl ock")
topcount ("topcount"),
count ("count")

{}
3

The Verilog module is then instantiated in the SystemC source as follows:

counter dut("dut");

where the constructor argument (dut) is the SystemC instance name.
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Example #2

Another variation of the SystemC foreign module declaration for the same Verilog module
might be:

class counter : public sc_foreign_nodule {
public:

count er (sc_nodul e_name nm char* hdl _nane)
sc_forei gn_modul e(nm hdl _nane),
cl ock("cl ock"),

{}
}s

The instantiation of this module would be:

counter dut("dut", "lib.counter");
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Verilog: instantiating SystemC

Y ou can reference a SystemC module from Verilog as though the design unit isamodule
of the same name.

SystemC instantiation criteria

A SystemC module can be instantiated in Verilog if it meets the following criteria:

» SystemC module names are case sensitive. The module name at the SystemC
instantiation site must match exactly with the actual SystemC module name.

» SystemC modules are exported using the SC_MODULE_EXPORT macro. See
"Exporting SystemC modules’ (UM-234).

» The module ports are as listed in the table shown in "Channel and Port type mapping"
(UM-217).

« Port data type mapping must match exactly. See the table in "Data type mapping” (Um-
218).

Port associations may be named or positional. Use the same port names and port positions
that appear in the SystemC modul e decl aration. Named port associations are case sensitive.

Since there is no concept of "parameters’ in SystemC, it isillegal to place parameter
overrides on instantiations of sc_modules.

Exporting SystemC modules

sccom -link

To be ableto instantiate a SystemC module from Verilog (or use a SystemC module as a
top level module), the module must be exported.

Assume a SystemC module named transceiver exists, and that it is declared in header file
transceiver.h. Then the module is exported by placing the following code in a.cpp file:

#i ncl ude "transcei ver. h"

SC_MODULE_EXPORT(transcei ver);

The sccom -link command collects the object files created in the work library, and uses
them to build a shared library (.so) in the current work library. If you have changed your
SystemC source code and recompiled it using sccom, then you must run sccom -link before
invoking vsim. Otherwise your changes to the code are not recognized by the ssimulator.
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SystemC: instantiating VHDL

To instantiate VHDL design unitsinto a SystemC design, you must first generate a
SystemC foreign module declaration (um-231) for each VHDL design unit you want to
instantiate. Once you have generated the foreign module declaration, you can instantiate
the foreign module just like any other SystemC module.

VHDL instantiation criteria

A VHDL design unit may be instantiated from SystemC if it meets the following criteria:
» The design unit is an entity/architecture pair or a configuration.

» The entity ports are of type hit, bit_vector, std_ulogic, std_ulogic_vector, or their

subtypes. The port clause may have any mix of these types.

Port associations may be named or positional. Use the same port names and port positions
that appear in the entity.

SystemC foreign module declaration

In cases where you want to run amixed simulation with SystemC and VHDL, you must
create and declare aforeign module that standsin for each VHDL design unit instantiated
under SystemC. The foreign modules can be created in one of two ways.

* running scgenmod, autility that automatically generatesyour foreign modul e declaration

(much like vgencomp generates a component declaration)

» modifying your SystemC source code manually

Using scgenmod

After you have analyzed the design, you can generate aforeign module declaration with an
scgenmod command similar to the following:

scgennod nodl

Where mod1 is either a Verilog module or aVHDL entity. A foreign module declaration
for the specified module is written to stdout.

Guidelines for manual creation

Apply the following guidelinesto the creation of foreign modules. A foreign module:

contains ports corresponding to VHDL or Verilog ports. These ports must be explicitly
named in the foreign module’s constructor initializer list.

must not contain any internal design elements such as child instances, primitive channels,
Or Processes.

must pass a secondary constructor argument denoting the module’'s HDL name to the
sc_forei gn_nodul e base class constructor. For VHDL, the HDL name can bein the
format [<lib>.]<primary>[(<secondary>)] or [<lib>.]<conf>. For Verilog, the HDL
name is simply the Verilog module name corresponding to the foreign module, or
[<lib>].<module>.

UM-235
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Example
A sample VHDL design unit to be instantiated in a SystemC designis:

entity counter is
port (count : buffer bit_vector(8 downto 1);
cl k cin bit;
reset : in bit);
end;

architecture only of counter is

end only;

The SystemC foreign module declaration for the above VHDL moduleis:

class counter : public sc_foreign_nodule {
publi c:

sc_i n<bool > cl k;
sc_i n<bool > reset;
sc_out <sc_| ogi c> count;

count er (sc_nodul e_nanme nm
sc_forei gn_nodul e(nm "work.counter(only)"),
clk("clk"),
reset ("reset")
count ("count")

{}
}s

The VHDL module isthen instantiated in the SystemC source as follows:

counter dut("dut");

where the constructor argument (dut) is the SystemC instance name.
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VHDL.: instantiating SystemC

Toinstantiate SystemC inaVHDL design, you must create acomponent declaration for the
SystemC module. Once you have generated the component declaration, you can instantiate
the SystemC component just like any other VHDL component.

SystemC instantiation criteria

A SystemC design unit may be instantiated within VHDL if it meets the following criteria:

» SystemC module names are case sensitive. The module name at the SystemC
instantiation site must match exactly with the actual SystemC module name.

» The SystemC design unit is exported using the SC_MODULE_EXPORT macro.
» The module ports are aslisted in the table in "Data type mapping” (UM-221)

« Port data type mapping must match exactly. See the table in "Port type mapping” (UM-
221).

Port associations may be named or positional. Use the same port names and port positions
that appear in the SystemC module. Named port associations are case sensitive.

Model Sim does not support generic overrides across SystemC language boundaries.

Component declaration

A SystemC design unit can be referenced from a VHDL design as though it isaVHDL
entity. The interface to the design unit can be extracted from the library in the form of a
component declaration by running vgencomp. Given alibrary and a SystemC module
name, vgencomp writes a component declaration to standard output.

The default component port types are:
 std logic

* std_logic_vector

Optionally, you can choose:

* bit and bit_vector

VHDL and SystemC identifiers

TheVHDL identifiersfor the component name and port names are the same asthe SystemC
identifiers for the module name and port names. If a SystemC identifier is not avalid
VHDL 1076-1987 identifier, it is converted to aVHDL 1076-1993 extended identifier (in
which case you must compile the VHDL with the -93 or later switch).

Examples
SystemC identifier VHDL identifier
topmod topmod
TOPMOD topmod
TopMod topmod
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SystemC identifier VHDL identifier

top_mod top_mod

_topmod \_topmod\

vgencomp component declaration

vgencomp (CR-318) generates a component declaration according to these rules:

Port clause

A port clauseis generated if the module has ports. A corresponding VHDL port is defined
for each named SystemC port.

Y ou can set the VHDL port type to bit or std_logic. If the SystemC port has a range, then
the VHDL port typeis bit_vector or std_logic_vector.

Examples
SystemC port VHDL port
SC_in<sc_logic>p1l; pl:instd logic;
SC_out<sc_Iv<8>>p2; p2 : out std_logic_vector(7 downto 0);
sc_inout<sc_lv<8>>p3; p3 : inout std_logic_vector(7 downto 0)

Configuration declarations are all owed to reference SystemC modulesin the entity aspects
of component configurations. However, the configuration declaration cannot extend into a
SystemC instance to configure the instantiations within the SystemC module.

Exporting SystemC modules

sccom -link

To be ableto instantiate a SystemC module within VHDL (or use a SystemC module as a
top level module), the module must be exported.

Assume a SystemC module named transceiver exists, and that it is declared in header file
transceiver.h. Then the module is exported by placing the following code in a.cpp file:

#i ncl ude "transceiver. h"

SC_MODULE_EXPORT(transcei ver);

The sccom -link command collects the object files created in the work library, and uses
them to build a shared library (.so) in the current work library. If you have changed your
SystemC source code and recompiled it using sccom, then you must run sccom -link before
invoking vsim. Otherwise your changes to the code are not recognized by the ssimulator.
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Chapter contents

WLFfiles (datasets) . . . . . . . . . . UM-240
Saving asimulation to aWLFf|Ie . .. . UM-241
Hiding library cell signals when saving awaveformflle. .. UmM-241
Openingdatasets . . . . . . . . . . . . . UM-242
Viewing dataset structure. . . . . . . . . . . UM-243
Managing multiple datasets . . .. . . . . UMm-244
Saving at intervals with Dataset Snapshot .. . . . . UM-246

Virtual Objects (User-defined buses,andmore) . . . . . . UM-248
Virtual signals . . . . . . . . . . . . . UM-248
Virtua functions . . . . . . . . . . . . . UM-249
Virtual regions . . . . . . . . . . . . . UM-250
Virtual types . . . . . . . . . . . . . . UM-250

Dataset, WLF file, and virtual commands. . . . . . . . UM-251

A ModelSim simulation can be saved to awave log format (WLF) file for future viewing
or comparison to a current simulation. We usetheterm "dataset" to refer toaWLF filethat
has been reopened for viewing.

Y ou can open more than one WLF file for simultaneous viewing. Y ou can also create
virtual signalsthat are smplelogical combinations of, or logical functions of, signalsfrom
different datasets.
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WLF files (datasets)

Wave Log Format (WLF) files are recordings of simulation runs. The files contain data
from logged items (e.g., signalsand variables) and the design hierarchy in which thelogged
items are found. Y ou can record the entire design or choose specific items.

The WLF file provides you with precise in-simulation and post-simul ation debugging
capability. Any number of WLF files can be reloaded for viewing or comparing to the
active simulation.

A dataset is a previoudy recorded simulation that has been loaded into Model Sim. Each
dataset has alogical name to let you indicate the dataset to which any command applies.
Thislogical nameis displayed as a prefix. The current, active simulation is prefixed by
"sim:", while any other datasets are prefixed by the name of the WLF file by default.

Two datasets are displayed in the Wave window below. The current simulationisshownin
the top pane and isindicated by the "sim" prefix. A dataset from aprevious simulation is
shown in the bottom pane and isindicated by the "gold" prefix.

===t wave - default : i |EI|5|
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The simulator resolution (see "Simulator resolution limit" (UM-67)) must be the same for
all datasetsyou’ re comparing, including the current simulation. If you havea WLF filethat
isin adifferent resolution, you can use the wifman command (CR-370) to change it.
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Saving a simulation to a WLF file

If you add itemsto the Dataflow, List, or Wave windows, or log items with the log
command, the results of each simulation run are automatically saved to a WLF file called
vsim.wlif in the current directory. If you run a new simulation in the same directory, the
vsimwif file is overwritten with the new results.

If you want to save the WLF file and not have it overwritten, select File > Save> sim
dataset (Main window) or File> Save Dataset > sim (Wave window). Or, you can usethe
-wlif <filename> argument to the vsim command (CR-357) or the dataset save command
(CR-148).

A 'mportant: If you do not use dataset save or dataset snapshot, you must end a
simulation session with a quit or quit -sim command in order to produce avalid WLF
file. If you don’t end the simulation in this manner, the WLF file will not close properly,
and Model Sim may issue the error message "bad magic number" when you try to open
an incompl ete dataset in subsequent sessions. If you end up with a"damaged’ WLFfile,
you can try to "repair” it using the wifrecover command (CR-387).

Hiding library cell signals when saving a waveform file

Gate-level simulations may result in large waveform files because the internal signal's of
your library cells are saved. The following method will prevent these signals from being
saved in a Verilog design.

If your cellsare enclosed in Verilog “celldefine and “endcelldefine preprocessor directives,
you can specify -fast on the viog command line when compiling the cell library. Thiswill
basically hide the internal signals so they will not be saved. A further benefit of this
methodology is that the cells compiled with -fast will consume less memory.

See "Compiling with -fast” (um-127) for further details on using -fast.
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Opening datasets

To open a dataset, select either File > Open > Dataset (Main window) or use the dataset
open command (CR-146).

Open D atazet

—Datazet Pathnare
| LI Browsze... |

— Logizal Mame for D ataset

Ok Cancel

The Open Dataset dialog includes the following options.

» Dataset Pathname
I dentifies the path and filename of the WLF file you want to open.

» Logical Namefor Dataset
Thisisthe name by which the dataset will be referred. By default thisis the name of the

WLFfile.
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Viewing dataset structure

Each dataset you open creates a Structure tab in the Main window workspace. Thetab is
labeled with the name of the dataset and displays the same data as the " Structure window"
(UM-331).

The graphic below shows three Structure tabs: one for the active simulation (sim) and one
each for two datasets (gold and test).

[ ModelSim -0 =|
File Edit Wiew Compile Simulate Tools  Window  Help
=B || SHE || odELEIEN S B T
Wiork space A :
s | Diesign Urit | Design | _* # Loading C:/modelechAwind2d . Arodelzm_libu j
— — il body]
] toplanly) Architec # Loading C: /miodeltechAwind2d . Averlog.v_type
dr proc todule s(body]
D - cache M odule B Lnad!ng wark. toplonly]
# Loading wark.proc
& m PREMTY tadule # Loading wark. cache
B std_logic_utl  std_logic_utl Package # Loading work. ztd_logic_util{body]
[t | t Pack # Loading wark. cache_zet{only]
M v types viWReE ackagy j # Loading work. rmermon
i & | -
[ Library(l gu:ulu:ll testl im 1)’iles] VSIM 3 B
|NDWZ Ons Delta: O |5|m:ft|:|p >

If you have too many tabs to display in the avail able space, you can scroll the tabs left or
right by clicking and dragging them.

Each Structure tab has a context menu that you access by clicking the right mouse button
anywhere within the Structure tab. See " Structure window context menu" (Um-333) for
details.
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Managing multiple datasets

GUI

When you have one or more datasets open, you can manage them using the Dataset
Browser. To open the browser, select View > Datasets (Main window).

Dataset Browser B #]
Dratazet Cortest ode Fathrame
1] qald Mtop Wi C: Adataflow/gold. wif
1] gim Atop Simulation Mo sighals logged

C: /dataflowtest wif

< | B

Open... Cloze M ake Active Rename... Done

The Dataset Browser dialog box includes the following options.

* Open
Opens the Open Dataset dialog box (see "Opening datasets" (UM-242)) SO you can open
additional datasets.

* Close
Closes the selected dataset. Thiswill aso remove the dataset’ s Structuretab inthe Main
window workspace.

* MakeActive
Makes the selected dataset "active." Y ou can a so effect this change by double-clicking
the dataset name. Active dataset means that if you type aregion path as part of a
command and omit the dataset prefix, the active dataset will be assumed. It is equivalent
totypingenv <dat aset >: at the VSIM prompt. The active dataset is displayed at the
bottom of the Main window.

* Rename
Allows you to assign anew logical name for the selected dataset.

Command line

Y ou can open multiple datasets when the simulator isinvoked by specifying more than one
vsim -view <filename> option. By default the dataset prefix will be the filename of the
WLF file. You can specify a different dataset name as an optional qualifier to the

vsim -view switch on the command line using the following syntax:

-vi ew <dat aset >=<fi | ename>
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For example: vsim -view foo=vsim.wif

Model Sim designates one of the datasets to be the "active" dataset, and refers all names
without dataset prefixes to that dataset. The active dataset is displayed in the context path
at the bottom of the Main window. When you select a design unit in a dataset’ s Structure
tab, that dataset becomes active automatically. Alternatively, you can use the Dataset
Browser or the environment command (CR-166) to change the active dataset.

Design regions and signal names can be fully specified over multiple WLF files by using
the dataset name as a prefix in the path. For example:

sim/top/al u/out
vi ew: / t op/ al u/ out

gol den: . t op. al u. out

Dataset prefixes are not required unless more than one dataset isopen, and you want to refer
to something outside the active dataset. When more than one dataset is open, Model Sim
will automatically prefix namesin the Wave and List windows with the dataset name. Y ou
can change this default by selecting Tools > Window Pr efer ences (Wave and List
windows).

Model Sim also remembers a " current context" within each open dataset. Y ou can toggle
between the current context of each dataset using the environment command (CR-166),
specifying the dataset without a path. For example:

env foo:

sets the active dataset to foo and the current context to the context last specified for foo.
The context is then applied to any unlocked windows.

The current context of the current dataset (usually referred to as just "current context") is
used for finding objects specified without a path.

The Signals window can be locked to a specific context of a dataset. Being locked to a
dataset means that the window will update only when the content of that dataset changes.
If locked to both a dataset and a context (e.g., test: /top/foo), the window will update only
when that specific context changes. Y ou specify the dataset to which the window islocked
by selecting File > Environment (Signals window).

Restricting the dataset prefix display

The default for dataset prefix viewing is set with avariablein pref.tcl,

PrefM ain(DisplayDatasetPr efix). Setting the variable to 1 will display the prefix, setting
it to Owill not. It is set to 1 by default. Either edit the pref.tcl file directly or use the Tools
> Edit Preferences (Main window) command to change the variable value.

Additionally, you can restrict display of the dataset prefix if you use the environment
-nodataset command to view a dataset. To display the prefix use the environment
command (CR-166) with the -dataset option (you won’t need to specify this option if the
variable noted aboveis set to 1). The environment command line switches override the
pref.tcl variable.

UM-245
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Saving at intervals with Dataset Snapshot

Dataset Snapshot lets you periodically copy data from the current simulation WLF file to
another file. Thisisuseful for taking periodic "snapshots" of your simulation or for clearing
the current simulation WLF file based on size or elapsed time.

Once you have logged the appropriate items, select Tools > Dataset Snapshot (Wave
window).

Dataset snapshok E #

— Datazet Snapshot State

* Enabled i~ Dizabled

— Snapzhat Type
@ Simulation Time | 1000000 [ rs | w]

" WLF File Size I 100 Megabytes

— Snapzhot Contentz

" Shapshot containe only data since previous shapshat.

¥ Shapshot containe all previous data.

— Snapzhot Directom and File

— Directory File Frefis
|I:: Adataflow Browse... | ’rvsim_snapshnt

— Owenarites ncrement

¥ Always replace snapshot file.

™ Use incrementing suffix on snapshot files.

— Selected Snapzhat Filename

: /dataflowvegim_shapehob wif

ok Cancel

The Dataset Snapshot dialog includes these options:

Dataset Snapshot State

» Enabled/Disabled
Enable or disable Dataset Snapshot. All other dialog options are unavailable if Disabled

is selected.
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Snapshot Type

» Simulation Time
Specifiesthat datais copied to the specified snapshot file every <x> time units. Default
is 1000000 time units.

* WLF FileSize
Specifies that datais copied to the specified snapshot file whenever the current
simulation WLF file reaches <x> megabytes. Default is 100 MB.

Snapshot Contents

 Snapshot contains only data since previous snapshot
Specifiesthat each snapshot containsonly datasincethe last snapshot. Thisoption causes
Model Sim to clear the current simulation WLF file each time a snapshot is taken.

» Snapshot containsall previous data
Specifiesthat each snapshot containsall datafrom thetime signalswerefirst logged. The
entire contents of the current simulation WLF file are saved each time a snapshot is taken.

Snapshot Directory and File

* Directory
The directory in which Model Sim saves the snapshot files.

* FilePrefix
The name of the snapshot files. Model Sim adds .wif to the snapshot files.

Overwrite / Increment

» Alwaysreplace snapshot file
Specifiesthat asinglefileis created for all snapshots. Each new snapshot overwrites the
previous.

» Useincrementing suffix on snapshot files
Specifies that anew file is created for each snapshot. Each new snapshot creates a
separate file (e.g., vsim_snapshot_1.wif, vsim_snapshot_2.wif, etc.).
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Virtual Objects (User-defined buses, and more)

Virtual objects are signal-like or region-like objects created in the GUI that do not exist in
the Model Sim simulation kernel. M odel Sim supports the following kinds of virtual objects:

* Virtual signals (Um-248)

* Virtual functions (UM-249)

* Virtua regions (UM-250)

* Virtua types (UM-250)

Virtual objects areindicated by an orange diamond as illustrated by bus below:

==+t wave - default ] -|O] x|
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Virtual signals

Virtual signals are aliases for combinations or subelements of signals written to the WLF
file by the simulation kernel. They can be displayed in the Signals, List, and Wave
windows, accessed by the examine command, and set using the for ce command. Y ou can
create virtual signals using the Tools > Combine Signals (Wave and List windows)
command or usethevirtual signal command (CR-339). Once created, virtual signals can be
dragged and dropped from the Signals window to the Wave and List windows.

Virtual signals are automatically attached to the design region in the hierarchy that

corresponds to the nearest common ancestor of al the elements of the virtual signal. The
virtual signal command hasan -install <region> option to specify wherethevirtua signal
should beinstalled. This can be used to install the virtual signal in auser-defined regionin
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order to reconstruct the original RTL hierarchy when simulating and driving a
post-synthesis, gate-level implementation.

A virtual signal can be used to reconstruct RTL-level design buses that were broken down
during synthesis. Thevirtual hide command (CR-330) can be used to hide the display of the
broken-down bitsif you don't want them cluttering up the Signals window.

If the virtual signal has elements from more than one WLF file, it will be automatically
installed in the virtual region virtuals:./Signals.

Virtual signals are not hierarchical —if two virtual signals are concatenated to become a
third virtual signal, the resulting virtual signal will be a concatenation of all the scalar
elements of the first two virtual signals.

The definitions of virtuals can be saved to a macro file using the virtual save command
(CR-337). By default, when quitting, Model Sim will append any newly-created virtual s (that
have not been saved) to the virtuals.do file in the local directory.

If you have virtual signals displayed in the Wave or List window when you save the Wave
or List format, you will need to execute the virtuals.do file (or some other equivalent) to
restore the virtual signal definitions before you re-load the Wave or List format during a
later run. Thereisone exception: "implicit virtuals' are automatically saved with the Wave
or List format.

Implicit and explicit virtuals

Animplicit virtual isavirtual signal that was automatically created by Model Sim without
your knowledge and without you providing aname for it. An example would be if you
expand abus in the Wave window, then drag one bit out of the busto display it separately.
That action creates a one-bit virtual signal whose definition is stored in a special location,
and is not visible in the Signals window or to the normal virtual commands.

All other virtual signals are considered "explicit virtuals'.

Virtual functions

Virtual functions behave in the GUI like signals but are not aliases of combinations or
elements of signalslogged by the kernel. They consist of logical operations on logged
signals and can be dependent on simulation time. They can be displayed in the Signals,
Wave, and List windows and accessed by the examine command (CR-167), but cannot be
set by the for ce command (CR-176).

Examples of virtual functions include the following:

+ afunction defined as the inverse of agiven signa

« afunction defined as the exclusive-OR of two signals

« afunction defined as arepetitive clock

« afunction defined as "the rising edge of CLK delayed by 1.34 ns"

Virtual functions can also be used to convert signal types and map signal values.

Theresult type of avirtual signal can be any of the types supported in the GUI expression
syntax: integer, real, boolean, std_logic, std_logic_vector, and arrays and records of these
types. Verilog types are converted to VHDL 9-state std_logic equivalents and Verilog net
strengths are ignored.
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Virtual regions

Virtual types

ModelSim SE User’'s Manual

Virtual functions can be created using the virtual function command (CR-327).

Virtual functions are also implicitly created by Model Sim when referencing bit-selects or
part-selects of Verilog registersin the GUI, or when expanding Verilog registersin the
Signals, Wave, or List window. Thisis necessary because referencing Verilog register
elements requires an intermediate step of shifting and masking of the Verilog "vreg" data
structure.

User-defined design hierarchy regions can be defined and attached to any existing design
region or to the virtuals context tree. They can be used to reconstruct the RTL hierarchy in
agate-level design andtolocatevirtual signals. Thus, virtual signalsand virtual regionscan
be used in a gate-level design to allow you to use the RTL test bench.

Virtual regions are created and attached using the virtual region command (CR-336).

User-defined enumerated types can be defined in order to display signal bit sequences as
meaningful alphanumeric names. The virtual typeis then used in a type conversion
expression to convert asignal to values of the new type. When the converted signal is
displayed in any of the windows, the value will be displayed as the enumeration string
corresponding to the value of the original signal.

Virtual types are created using the virtual type command (CR-342).



Dataset, WLF file, and virtual commands

Dataset, WLF file, and virtual commands

The table below provides a brief description of the actions associated with datasets, WLF
files, and virtual commands. For complete details about syntax, arguments, and usage, refer
to the Model Sm Command Reference.

Command name

Action

dataset alias (CR-141)

assigns an additional name (alias) to a dataset

dataset clear (CR-142)

removes all event data from the current simulation WLF file while keeping
al currently logged signals logged

dataset close (CR-143)

closes the specified dataset

dataset info (CR-144)

reports avariety of information about a dataset

dataset list (CR-145)

lists al open datasets

dataset open (CR-146)

opensaWLFfile

dataset rename (CR-147)

assigns a new logical name to the specified dataset

dataset save (CR-148)

saves the current simulation to aWLF file

dataset snapshot (CR-149)

saves the current simulation to aWLF file at regular intervals

log (CR-187)

creates aWLF file for the current simulation

nolog (CR-205)

suspends writing of data to the WLF file for the specified signals

searchlog (CR-255)

searches one or more of the currently open WLF filesfor aspecified condition

virtual function (CR-327)

createsanew signal that consists of logical operationson existing signalsand
simulation time

virtual region (CR-336)

creates a new user-defined design hierarchy region

virtual signal (CR-339)

creates a new signal that consists of concatenations of signals and
subelements

virtual type (CR-342)

creates a new enumerated type

vsim (CR-357) -wlf <filename>

creates a WLF file for the simulation which can be reopened as a dataset

wlif2log (CR-381)

translates aModel Sim WLF file (vsim.wif) to a QuickSim 11 logfile

wlfman (CR-384)

alows you to get information about and manipulate WLF files

wifrecover (CR-387)

attemptsto "repair* WLF filesthat are incomplete due to a crash or the file
being copied prior to completion of the simulation

UM-251
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10 - Graphic interface

Chapter contents

Window overview . . . . . . . . . . . . . . UM-2%4
Common window features. . . . . . . . . . . . UM-255
Mainwindow . . . . . . . . . . . . . . . UM-262
Dataflow window . . . . . . . . . . . . . . UM-270
Lisswindow . . . . . . . . . . . . . . . UM-286
Memory window . . . . . . . . . . . . . . UM-302
Processwindow . . . . . . . . . . . . . . UM-314
Signaswindow . . . . . . . . . . . . . . UM-316
Sourcewindow. . . . . . . . . . . . . . . UM-3%
Structurewindow . . . . . . . . . . . . . . UM-331
Variableswindow . . . . . . . . . . . . . . UM-334
Wavewindow . . . . . . . . . . . . . . . UM-337
Compiling with the graphicinterface . . . . . . . . . UM-368
Simulating with the graphicinterface . . . . . . . . . UM-377
Creating and managing breskpoints . . . . . . . . . UM-391
Miscellaneoustoolsandadd-ons . . . . . . . . . . UM-39%

The example graphicsin this chapter illustrate Model Sim'’ s graphic interface within a
Windows environment; however, Model Sim’ s interface remains consistent across all
supported platforms. Y our operating system provides the basic window-management
frames, while Model Sim controls all internal window features such as menus, buttons, and
scroll bars.

Because Model Sim’s graphic interfaceis based on Tcl/Tk, you are able to customize your
simulation environment. Easily-accessible preference variables and configuration
commands give you control over the use and placement of windows, menus, menu options,
and buttons.
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Window overview

The Model Sim simulation and debugging environment consists of many windows.
Multiple windows of each type can be used during simulation (with the exception of the
Main window). To make an additional window select File > New > Window. A brief
description of each window follows:

ModelSim SE User’'s Manual

Main window (UM-262)

The initial window that appears upon startup. All subsequent Model Sim windows are
opened from the Main window. This window contains the session transcript and the
Workspace, which can contain Project, Library, Structure, and Filestabs.

Dataflow window (UM-270)
Displaysthe "physical" connectivity of your VHDL/Verilog design and lets you trace
events (causality).

List window (UM-286)
Shows the simulation values of selected VHDL signals and variables; Verilog nets,
registers, and variables, and SystemC primitive channels (signals) in tabular format.

Memory window (UM-302)
Displays memoriesin the current design context.

Process window (UM-314)
Displaysalist of processes and SystemC method and thread processes in the region
currently selected in the Structure window.

Signals window (UM-316)

Shows the names and current values of VHDL signals, and Verilog nets, registers, and
variablesin the region currently selected in the Structure window. For a selected
SystemC module, SystemC primitive channels are shown.

Source window (UM-325)
Displaysthe HDL or C++ source code for the design. (Y our source code can remain
hidden if you wish.

Structure window (UM-331)

Displaysthe hierarchy of structural elements such as VHDL component instances,
packages, blocks, generate statements; Verilog module instances, named blocks, tasks
and functions; and SystemC modules. In versions 5.5 and later, this same information is
displayed in the Main window workspace.

Variables window (UM-334)
DisplaysVHDL constants, generics, variables, and Verilog registers and variablesin the
current process and their current values.

Wave window (UM-337)

Displays waveforms, and current values for the VHDL signals and variables; Verilog
nets, registers, and variables; and SystemC primitive channels (signals) you have
selected. Current and past simulations can be compared side-by-side in one Wave
window.



Common window features

Common window features

Model Sim’s graphic interface provides many features that add to its usability; features
common to many of the windows are described below.

UM-255

Feature

Feature applies to these windows

Quick access toolbars (UM-256)

Dataflow, Main, Source, and Wave windows

Drag and drop (UM-258)

Dataflow, List, Process, Signals, Source, Structure,
Variables, and Wave windows

Automatic window updating (UM-258)

Dataflow, Memory Process, Signals, and Structure
windows

Finding names and searching for values (UM-259)

various windows

Sorting items (UM-259)

Process, Signals, Source, Structure, Variables and Wave
windows

Multiple window copies (UM-259)

all windows except the Main window

Menu tear off (UM-259)

al windows

Customizing menus and buttons (UM-260)

all windows

Combining itemsin the List window (UM-292),
Combining items in the Wave window (UM-345)

List and Wave windows

Tree window hierarchical view (UM-261)

Structure, Signals, Variables, and Wave windows

* Cut/Copy/Paste/Delete into any entry box by clicking the right
mouse button in the entry box.

« Standard cut/copy/paste shortcut keystrokes —*X/AC/"V —will

work in al entry boxes.

» When the focus changes to an entry box, the contents of that box
are selected (highlighted). This allows you to replace the current

Cut
Copy
Fazte
Delete

Select All

contents of the entry box with new contents with a simple paste
command, without having to delete the old value.

 Dialog boxeswill appear on top of their parent window (instead of the upper left corner

of the screen).

* You can change thetitle of any window with the -title switch of the view command. See
view command (CR-320) for details.
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» The middle mouse button will allow you to paste the following into the transcript
window:

—text currently selected in the transcript window,
—acurrent primary X-Windows selection (can be from another application), or
—contents of the clipboard.

Selecting text in the transcript window makes it the current primary X-Windows
selection. Thisway you can copy transcript window selections to other X-Windows
windows (xterm, emacs, etc.).

» The Edit > Paste operation in the Transcript pane will ONLY paste from the clipboard.
« All menus highlight their accelerator keys.

Quick access toolbars

Toolbar buttonsin several windows provide access to commonly used commands and
functions. These toolbars can be docked and undocked (moved to or from the main toolbar
area) by clicking and dragging on the vertical bar at the |eft-edge of atoolbar.

Y ou can aso hide/show the various toolbars. To hide or show atoolbar, right-click on a
blank spot of the main toolbar area and select atoolbar from the list.

Drag on the vertical bar File= Edit Wiew A&dd Tools ‘Window

to dock/undock or ;
Bpy - RS
rearrange a toolbar \‘J ﬂ - EE]. J Contairs: /{_EL/'

Right-click here to 2l Ot

hide/show toolbars |
n

Ot
Ot
Ot

3]
Intermal

1 Intermal

1 |Hternal

|sim:ft}{_prncess P

To reset the toolbars to their origina state, right-click on a blank spot of the main toolbar
areaand select Reset.
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Columnar information display

Many windows (e.g., Main, Signals, Structure) display information in a columnar format.
Y ou can sort by any of the columns by clicking the column heading. Click once to sort in
ascending order; click again to sort in descending order.

Also, you can hide or show columns by either right-clicking a column heading and
selecting an item from the context menu or by clicking the column-list drop down arrow
and selecting an item.

=10 x|

Click a column heading File Edit W“iew Add Tools ‘Window

to sort the list by that ~_|| ., T s

field SEo J Cartains: 7]
v|Name Y alug tode o

Click the down arrow to/v Ot
hide/show columns -

3]
Ot R
Clut
Ot
Ir
Internal
] Intermal

retime_crc_rize 1 Intermal

Docking and undocking panes

Several windows are made up of multiple "panes." When you see a double bar at the top
edge of awindow area, it means you can click and drag the pane to "undock" it from the
parent window. Once the pane is undocked, it becomes a free-floating window.

To redock afloating pane, click on the double bar at the top of the window and drag it back
into the parent window.
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Drag and drop

Drag and drop of itemsis possible between the following windows. Using the left mouse

button, click and release to select an item, then click and hold to drag it.

» Drag itemsfrom these windows:

Dataflow, List, Process, Signals, Source, Structure, Variables, and Wave windows

* Drop itemsinto these windows:

Dataflow, List, Structure, and Wave windows

Drag and drop works to rearrange items within the List and Wave windows as well.

Automatic window updating

Selecting an item in the foll owing windows automatically updates other related Model Sim

windows as indicated bel ow:

Select an item in this window

To update these windows

Dataflow window (UM-270)

Memory window (UM-302)

Process window (UM-314)

Signals window (UM-316)

Source window (UM-325)

Structure window (UM-331)

Variables window (UM-334)

Process window (UM-314)

Dataflow window (UM-270)

Signals window (UM-316)

Source window (UM-325)

Variables window (UM-334)

Signals window (UM-316)

Dataflow window (UM-270)

Structure window (UM-331) or structure
pane in Main window Workspace

Memory window (UM-302)

Process window (UM-314)

Signals window (UM-316)

Source window (UM-325)

Variables window (UM-334)
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Finding names and searching for values

Sorting items

Find item names with the Edit > Find menu selection in these windows:
Dataflow, List, Process, Signals, Source, Structure, Variables, and Wave windows.

A Find request that starts with abackslash (\) forces case sensitivity. Elsewherein the
pattern backslashes are used to escape specia interpretation of basic regular expression
characters. To search explicitly for abackslash character, it is necessary to escape the
character. For example, to match \Arch Signal 1\, the pattern \\Arch... is required.

Sear ch for item values with the Edit > Sear ch menu selection in these windows: List
and Wave windows.

Use the View > Sort menu selection in the Process, Signals, Structure, Variables, and
Wave windows to sort items in ascending, descending or declaration order.

Names such asnet_1, net_10, and net_2 will sort numericaly in the Signals and Wave
windows.

Multiple window copies

Select File > New Window to create multiple copies of the same window type. The new
window will become the default window for that type.

Saving window layout

Context menus

Menu tear off

Y ou can save the current positions and sizes of Model Sim windows as a default. Follow
these steps to save the layout as a default:

1 Position and size the windows the way you want them to display.

2 Select Tools > Save Preferences (Main window) and save the modelsim.tcl fileinto the

desired directory.

3 Modify the "Working Directory" of your Model Sim shortcut to point at the directory, or

set the MODELSIM_TCL environment variable to point at the modelsim.tcl file (see
"Creating environment variables in Windows" (Um-615) for more details).

Context menus refer to menus that "pop-up” in the middle of the interface by clicking the
right mouse button. The commands on the menu change depending on wherein the
interface you click. In other words, the menus change based on the context of their use.
These menus are available in the following windows: Dataflow, List, Main, Memory,
Signals, Source, Structure, and Wave.

All window menus can be "torn off " to create a separate menu window. To tear off, click
on the menu, then select the dotted-line button at the top of the menu.

UM-259
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Customizing menus and buttons

Controlling font

ModelSim SE User’'s Manual

Menus can be added, deleted, and modified in all windows. Custom buttons can also be
added to window toolbars. See

» "The Button Adder" (UM-400) for more information.

s in an X-session

When executed viaan X-session (e.g., Exceed, VNC), Model Sim usesfont definitionsfrom
the .Xdefaults file. To ensure that the fonts look correct, create a . X defaults file with the
following lines:

vsi mFFont: -adobe-courier-nmediumr-normal --*-120-*-*-*-*.%*

vsi ntSyst enfFont : - adobe-courier-nmedi umr-normal --*-120-*-*-*-*._*

vsi n* St andar dFont : - adobe-couri er-medi umr-normal --*-120-*-*-*-*_*
vsi mfMenuFont : -adobe-courier-nmedi umr-normal --*-120-*-*-*-*_*

Alternatively, you can choose adifferent font. Usethe program "xlsfonts" toidentify which
fonts are available on your system.

Also, the following command can be used to update the X resourcesif you make changes
to the .Xdefaults and wish to use those changes on a Linux/UNIX machine;

xrdb -merge . Xdefaults
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Tree window hierarchical view

Model Sim provides ahierarchical, or "tree view" of your design in various windows (e.g.,
Main, Signals, Structure).

B structur il
File  Edit  “iew ‘'Window
¥ Instance Design Unit | Design Unit
test_ringhbut test_ringhbuf  ScModule
ring_IMNST ringgbouf Schodule
H blockt contrallrtly  Architecture
hlack2 stare Mociule
W Storer store Staterment
[ block3 retriese Mociule
b retriever retrieve Staterment
— il standard standard Package
— Ml std_logic_1164 std_logic_...  Package
— @l std_logic_arith stod_logic_ar... Package
Wl std_logic_unsigned  std_logic_u... Package

|]=<N|:| Context: =[I

Depending on which window you are viewing, you will see various design items. Icons
denote the item type as follows:

 Bluecircle—Verilog item

» Blue square—VHDL item

» Green diamond — SystemC item

* Orange diamond — Virtua item

* Yellow triangle — Comparison item

Seetheindividual window descriptions|ater in the chapter for which itemsare viewablein
which windows.

Viewing the hierarchy

Whenever you see atree view, you can use the mouse to collapse or expand the hierarchy.
Select the symbols as shown below to change the view of the structure.

Symbol Description
[+] click a plus box to expand the item and view the structure
[-] click aminus box to hide a hierarchy that has been expanded
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Main window

The Main window is pictured below as it appears when Model Sim isfirst invoked. Note
that your operating system graphic interface provides the window-management frame only;
Model Sim handles all internal-window features including menus, buttons, and scroll bars.

ﬁMDdElSin‘l - 10| x|
File Edit %ew Comple Simulate Tools ‘Window Help

|zen|caags

Click and Mlkspees = : : — '
drag here to/M I Tupe I Path | ||# reading C:/maodeltech vwin32/.. /madelsim.ini fig
reposition M vk, Library C: Aot bodelSim: |
panes wital2000 Library $MOD

=[] ieee Library  $MOD

&+l modetzim_lib Library  $MOD

a-Jli std Library  $MOD

m ztd_developerzkit Library w00 3

< | i

Library 3

|<N|:| Design Loaded= ‘ o

Y ou can customize the Main window layout—click and drag on the bars noted in the graphic
above to change the position of the panes and toolbars. Y ou can aso change the relative
size of each pane by dragging on its border. The graphic below shows acustomized layout.

ﬁMDdElSin‘l -10O] x|
File Edit Mew Compile Simulate Tools  Sindow  Help
|zmn|cugs
Wiorkspace A
TI M arme IType IF'ath I 3
= [l work Library C:/modetechsexamplesdwork
MvitaIEDDD Library $MODEL_TECH/.. fvital2000 d
Libramy

# reading C:/modeltech/win32/.. /modelzim.ini i
b oddelSirn

=Mo Design Loaded=

i
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The graphic bel ow showsthe Main window asit might appear when you have aproject and

adesign loaded.
ﬁMDdElSin‘l o ]
File Edit Mew Compile Simulate Tools  Window  Help
=Rals | 4 (ER oonssfELEEEL B
Wiorkspace 12 | Active Processes |
‘Fl Instance | Design unil I = ﬂ
= t|:||:|[|:|r'||_|r|]
Workspace —p = prac
& C cache J
o | =
Library | =im | Files 1| | »
# Loading C: /modeltechwing2s . Avenlog.v_typesbody] j
# Loading work.toplonly]
# Loading wirk, proc
# Loading wark. cache
T int # Loading wiark,. std_logic_util{body)
ranscrip > 4 Loading work. cache_set(only)
# Loading work.mermorny
WSk B> -
Mow: O ns Delta: O sim:ftop >
active processes
The menu bar at the top of the window provides access to awide variety of simulation
commands and Model Sim preferences. The toolbar provides buttonsfor quick accessto the
many common commands. The status bar at the bottom of the window gives you
information about the data in the active Model Sim window. The panes display different
parts of your design or different features of Model Sim. The panes, menu bar, toolbar, and
status bar are described in detail below.
Workspace

The Workspace is available in Model Sim versions 5.5 and | ater. It provides convenient
access to projects, libraries, design files, compiled design units, simulation/dataset
structures, and Waveform Comparison objects. It can be hidden or displayed by selecting
View > Workspace (Main window).

The Workspace can display five types of tabs as shown in the graphic above.

* Project tab
Shows all files that are included in the open project. See Chapter 2 - Projectsfor details.
e Library tab
Shows design libraries and compiled design units. See "Managing library contents” (Um-
57) for details.
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» Structuretabs
Shows a hierarchical view of the active simulation and any open datasets. Thisisthe
same data that is displayed in the " Structure window" (Um-331). There is one tab for the
current simulation (named "sim™") and one tab for each open dataset. See "Viewing
dataset structure" (um-243) for details.

» Filestab
Shows the source files for the loaded design.

» Comparetab
Shows comparison objects that were created by doing a waveform comparison. See
Chapter 13 - Waveform Compare for details.

Transcript

The Transcript portion of the Main window maintains arunning history of commands that
are invoked and messages that occur as you work with Model Sim. When asimulation is
running, the Transcript displaysaVSIM prompt, allowing you to enter command-line
commands from within the graphic interface.

Y ou can scroll backward and forward through the current work history by using the vertical
scrollbar. Y ou can aso use arrow keysto recall previous commands, or copy and paste
using the mouse within the window (see "Mouse and keyboard shortcuts" (Um-269) for
details).

Saving the Main window transcript file

Variable settings determine the filename used for saving the Main window transcript. If
either PrefM ain(file) in the modelsim.tcl file or TranscriptFilein the modelsim.ini fileis
set, then the transcript output islogged to the specified file. By default the TranscriptFile
variablein modelsim.ini is set to transcript. If either variableis set, the transcript contents
are always saved and no explicit saving is necessary.

If youwould like to save an additional copy of the transcript with a different filename, you
can use the File > Transcript > Save Transcript As, or File> Transcript > Save
Transcript menu items. Theinitial save must be made with the Save Transcript As
selection, which stores the filename in the Tcl variable PrefM ain(saveFile). Subsequent
saves can be made with the Save Transcript selection. Since no automatic saves are
performed for thisfile, it iswritten only when you invoke a Save command. Thefileis
written to the specified directory and recordsthe contents of the transcript at the time of the
save.

Using the saved transcript as a macro (DO file)
Saved transcript files can be used as macros (DO files). See the do command (CR-156) for

more information.
Active processes

This pane displays all processes that are scheduled to run during the current simulation
cycle. You can hide or display this pane by selecting View > Active Processes (Main
window). This same data can be displayed in the "Process window" (UM-314).

ModelSim SE User’'s Manual



Main window UM-265

The Main window menu bar

This section provides information on select menu commands available in the Main
window. Many of the commands are also available from a context menu (click right or 3rd
mouse button within the window panes).

File menu
New Folder — create a new folder in the current directory
Library — create a new design library and mapping; see "Creating a
library" (UM-56)
Open Exclusion File —open an exclusion filter file; see "Excluding items from
coverage' (UM-443)
Import Library —import FPGA libraries; see"Importing FPGA libraries’ (UM-68)
Save Exclusion File—savesan exclusion filter file; see "Excluding itemsfrom
coverage' (UM-443)
Change this command is disabled if you have a project or dataset open or a
Directory simulation running
Transcript Save Transcript — save the Main window transcript; see" Saving the Main
window transcript file" (UM-264)
Addto these commands are only available if you have a project open; see
Project Chapter 2 - Projects
View menu
Coverage provides these options:
Current Exclusions — hide or show the Exclusions pane
Missed Coverage — hide or show the Missed Coverage pane
Instance Coverage — hide or show the Instance Coverage pane
Details — hide or show the Details pane
See Chapter 12 - Code Coverage for details on these panes.
Encoding select from al phabetical list of encoding namesthat enable proper
display of character representations used by various operating
systems or file systems, such as Unicode, ASCII, or Shift-JIS.
Properties show information about the item selected in the Workspace
Project Settings show information about the open project; disabled if you don’'t
have a project open
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Compile menu

Compile

compile source files; disabled if you have a project open

Compile Options

set various compile options; see " Setting default compile options®
(UM-370); disabled if you have a project open

SystemC Link collects the object files created in the different design libraries,
and uses them to build a shared library (.so0) in the current work
library

Compile All compile all filesin the open project; disabled if you don’t have a
project open

Compile Selected compile thefiles selected in the project tab; disabled if you don’t
have a project open

Compile Order set the compile order of the filesin the open project; see

"Changing compile order" (Um-42) for details; disabled if you
don’'t have a project open

Compile Report

report on the compilation history of the selected file(s) in the
project; disabled if you don’t have a project open

Compile Summary

report on the compilation history of all filesin the project;
disabled if you don’t have a project open

Simulate menu

Simulate

load the selected design unit with the specified options; see
"Simulating with the graphic interface” (UM-377)

Simulation Options

set various simulation options; see " Setting default simulation
options' (UM-386)

Run

Restart —reload the design elements and reset the simulation time
to zero; only design elementsthat have changed are rel oaded; you
specify whether to maintain the following after restart—List and
Wave window environment, breakpoints, logged signals, virtual
definitions, and assertion settings; see also the restart command
(CR-240)
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(all options are set
for the current
session only)

Tools menu

Waveform see "Waveform Compare menu" (UM-468)

Compare

Coverage load, merge, report on, or clear coverage data

Profile see "Profile menu" (UM-417)

C Debug (available see " C Debug menu reference” (UM-488)

only on Unix)

Breakpoints open the Breakpoints dialog box; see "Setting file-line
breakpoints® (UM-329) for details

Execute Macro call and execute a .do or .tcl macro file

Macro Helper UNI X only - invoke the Macro Helper tool; see also "The Macro
Helper" (um-401)

Tcl Debugger invoke the Tcl debugger, TDebug; see also "The Tcl Debugger”
(UM-402)

TclPro Debugger invoke TclPro Debugger by Scriptics®, if installed. TclPro
Debugger can be acquired from Scriptics.

Options provides these options:

Transcript File — set atranscript file to save for this session only
Command History — set afile for saving command history only,
no comments

Save File —set filename for Save Transcript, and Save Transcript
As

Saved Lines— limit the number of lines saved in the transcript
(default is 5000)

Line Prefix — specify the comment prefix for the transcript
Update Rate — specify the update frequency for the Main window
status bar

Model Sim Prompt — change the title of the Model Sim prompt
VSIM Prompt — change thetitle of the VSIM prompt

Paused Prompt — change the title of the Paused prompt

HTML Viewer — specify the path to your browser; used for
displaying online help

PDF Viewer — specify the path to your PDF viewer; used to
display documentation

Edit Preferences

set various preference variables; see " Preference variableslocated
inTcl files' (um-631) for more information

Save Preferences

save current Model Sim settings to a Tcl preferencefile; see
"Preference variables located in Tcl files' (um-631) for more
information
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Window menu

Initial Layout

restore al windows to the size and placement of the initial full-
screen layout

Layout Style?

provides these options:

Default - restore the windows to version 5.5 layout
Millennium - restore the windows to version 5.6 layout
Classic - restore the windows to pre-5.5 layout
Cascade - cascade all open windows

Horizontal - tile all open windows horizontally
Vertica - tile al open windows vertically

Customize

use The Button Adder (Um-400) to define and add abutton to either
the tool or status bar of the specified window

a.Y ou can specify aLayout Style to becomethe default for Model Sim. After choosing
the Layout Style you want, select Tools > Save Prefer ences and the layout style will
be saved to the PrefMain(layoutStyle) preference variable.
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The Main window status bar

Froject : rl Mow: O ns Delta: O sim:ftop/p y

Fields at the bottom of the Main window provide the following information about the
current simulation:

Field Description
Project name of the current project
Now the current simulation time, using the default resolution units

(see "Simulating with the graphic interface” (Um-377)), or a
larger time unit if one can be used without afractional remainder

Delta the current simulation iteration number

environment name of the current context (item selected in the Structure
window (UM-331))

Mouse and keyboard shortcuts

See "Main and Source window mouse and keyboard shortcuts" (UM-639).
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Dataflow window

The Dataflow window allowsyou to explore the "physical” connectivity of your design; to
trace events that propagate through the design; and to identify the cause of unexpected
outputs.

»¢ dataflow - O] =]

Eile Edit “iew Mavigate Trace Tools MWindow

GNP LBRBOOMH v 2 RIHX 22O ]

Q@ ol

| Extended mode enabled | |Keep| 1] ftop/pistrh )

Items you can view

The Dataflow window displays processes; signals, nets, and registers; and interconnect.
Thewindow has built-in mappingsfor all Verilog primitivegates(i.e., AND, OR, etc.). For
components other than Verilog primitives, you can define a mapping between processes
and built-in symbols. See " Symbol mapping" (Um-283) for details.

P Note: You cannot view SystemC items in the Dataflow window.
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Adding items to the window

Y ou can use any of the following methods to add items to the Dataflow window:
* drag and drop items from other windows

« use the Navigate menu options in the Dataflow window

« usethe add dataflow command (CR-54)

* double-click any waveform in the Wave window display

The Navigate menu offers four commands that will add items to the window. The
commands include:

View region — clear the window and display all signals from the current region

Add region — display all signals from the current region without first clearing window
View all nets— clear the window and display al signals from the entire design

Add ports— add port symbols to the port signalsin the current region

When you view regions or entire nets, the window initially displays only the drivers of the
added itemsin order to reduce clutter. Y ou can easily view readers by selecting anitem and
invoking Navigate > Expand net to readers.

A small circle above an input signal on a block denotes atrigger signal that is on the
process’ sensitivity list.

Links to other windows

The Dataflow window has links to other windows as described below:

Window Link
Main window (UM-262) select asignal or processin the Dataflow window, and
the Structure pane updatesiif that item isin adifferent
design unit
Process window (UM-314) select aprocessin either window, and that processis

highlighted in the other

Signals window (UM-316) select asignal in either window, and that signal is
highlighted in the other

Wave window (UM-337) « trace through the design in the Dataflow
window, and the associated signal sare added to
the Wave window

* move acursor in the Wave window, and the
values update in the Datafl ow window

Source window (UM-325) select an item in the Dataflow window, and the
Source window updates if that itemisin a
different source file
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Dataflow window menu bar

This section provides information on select menu commands available in the Dataflow
window. Many of the commands are also available from the context menu (click right or

3rd mouse button).

Edit menu
Erase selected clear the selected object from the window
Erase highlight remove green highlighting from interconnect lines
Regenerate clear and redraw the display using an optimal layout
View menu
Show Wave open the embedded wave viewer pane
Select set left mouse button to select mode and middle mouse button to
zoom mode
Zoom set left mouse button to zoom mode and middle mouse button to
pan mode
Pan set left mouse button to pan mode and middle mouse button to
zoom mode
Default set mouse to default mode

Navigate menu
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Expand net to display driver(s) of the selected signal, net, or register

drivers

Expand net to display reader(s) of the selected signal, net, or register

readers

Expand net display driver(s) and reader(s) of the selected signal, net, or
register

Expand to design display thetop-level driver of the net, whichwill most likely bein

inputs atestbench or in the top entity or module

Expandto hierarchy display the primary driver (port) of the net within its level of

inputs hierarchy

Hide selected remove the selected component and all other components from
the same region and replace them with a single component
representing that region

Show selected expand the selected component to show all underlying

components




Dataflow window

View region clear the window and display al signals from the current region
Add region display all signals from the current region without first clearing
the window

View al nets clear the window and display all signals from the entire design
Add ports add port symbols to the port signalsin the current region

Trace menu
TraceX ™ step back to the last driver of an unknown (X) value
Chasex ™ jump to the source of an unknown (X) value
TraceX Delay step back in timeto the last driver of an unknown (X) value
ChaseX Delay jump back in time to the point where the output value transitions

to X

Trace next event

move the next event cursor to the next input event driving the
selected output

Trace event set

jump to the source of the selected input event

Trace event reset

return the next event cursor to the selected output

Tools menu
Load built-in load a .bsm file for mapping symbol instances; see " Symbol
symbol map mapping” (UM-283)

Load symlib library

load a user-defined symbol library

Create symlib index

create an index for a user-defined symbol library

Options

configure Dataflow window preferences

Window menu

The Window menu isidentical in al windows. See "Window menu" (Um-268) for a
description of the commands.

UM-273
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Exploring the connectivity of your design

A primary use of the Dataflow window is exploring the "physical" connectivity of your
design. One way of doing thisis by expanding the view from process to process. This
allows you to see the drivers/receivers of a particular signal, net, or register.

Y ou can expand the view of your design using menu commands or your mouse. To expand
with the mouse, simply doubleclick asignal, register, or process. Depending on the specific
item you click, the view will expand to show the driving process and interconnect, the

reading process and interconnect, or both.

Alternatively, you can select asignal, register, or net, and use one of the toolbar buttons or
menu commands described below:

¢

Expand net to all drivers
display driver(s) of the selected signal, net, or
register

Navigate > Expand net
to drivers

Expand net to all driversand readers
display driver(s) and reader(s) of the selected
signal, net, or register

Navigate > Expand net

+£

Expand net to all readers
display reader(s) of the selected signal, net, or
register

Navigate > Expand net
to readers

Asyou expand the view, note that the "layout" of the design may adjust to best show the
connectivity. For example, the location of an input signal may shift from the bottom to the
top of a process.

Tracking your path through the design

Y ou can quickly traverse through many componentsin your design. To help mark your
path, the items that you have expanded are highlighted in green.

Y ou can clear this highlighting using the Edit > Erase highlight command. il
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The embedded wave viewer

Another way of exploring your design is to use the Dataflow window’ s embedded wave
viewer. Thisviewer closely resembles, in appearance and operation, the stand-alone Wave
window (see "Wave window" (UM-337) for more information).

The wave viewer is opened using the View > Show Wave command. ﬂ

One common scenario isto place signals in the wave viewer and the Dataflow panes, run
the design for some amount of time, and then use time cursorsto investigate val ue changes.
In other words, as you place and move cursors in the wave viewer pane (see "Using time

cursorsinthe Wavewindow" (Um-358) for details), the signal values update in the Dataflow
pane.

&= dataflow =10l x|
File Edit Miew Mavigate Trace Tools window

G Nmdp sBRBOCM e +¥%¥A€L D220 G
Q@ B [w

o Atopdpdie

& fopdpdshib

o ftopdpidata
A topdpdadd_r
W Mtopdpddata_r

Another scenario isto select a processin the Dataflow pane, which automatically adds to
the wave viewer pane dl signal s attached to the process.

See"Tracing events (causality)" (UM-277) for another exampl e of using the embedded wave
viewer.
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Zooming and panning

The Dataflow window offers several tools for zooming and panning the display.

Zooming with toolbar buttons
These zoom buttons are available on the toolbar:

Zoom In Zoom Out

(ﬂ zoomin by afactor El zoom out by a
of two from the factor of two from
current view current view
Zoom Full

% Z0oom out to view
the entire
schematic

Zooming with the mouse

To zoom with the mouse, you can either use the middle mouse button or enter Zoom Mode
by selecting View > Zoom and then use the left mouse button.

Four zoom options are possible by clicking and dragging in different directions:
«  Down-Right: Zoom Area (In)

* Up-Right: Zoom Out (zoom amount is displayed at the mouse cursor)

» Down-Left: Zoom Selected

e Up-Left: Zoom Full

The zoom amount is displayed at the mouse cursor. A zoom operation must be more than
10 pixelsto activate.

Panning with the mouse

Y ou can pan with the mouse in two ways: 1) enter Pan Mode by selecting View > Pan and
then drag with the left mouse button to move the design; 2) hold down the <Ctrl> key and
drag with the middle mouse button to move the design.

ModelSim SE User’'s Manual



Dataflow window UM-277

Tracing events (causality)

One of the most useful features of the Datafl ow window istracing an event to seethe cause
of an unexpected output. This feature uses the Dataflow window’ s embedded wave viewer
(see "The embedded wave viewer" (UM-275) for more details).

In short you identify an output of interest in the Dataflow pane and then usetime cursorsin
the wave viewer pane to identify events that contribute to the output.

The process for tracing eventsis as follows:
1 Log al signals before starting the simulation (add log -r /*).

2 After running asimulation for some period of time, open the Dataflow window and the
wave viewer pane.

3 Addaprocessor signal of interest into the Dataflow window (if adding asignal, find its
driving process). Select the process and all signals attached to the selected process will
appear in the wave viewer pane.

4 Placeatime cursor on an edge of interest; the edge should be on asignal that isan output
of the process.

5 Select Trace > Trace next event. J-i-

A second cursor is added at the most recent input event.

6 Keepselecting Trace> Tracenext event until you've reached an input event of interest.
Note that the signals with the events are selected in the wave pane.

7 Now select Trace> Traceevent set. | 4=

The Dataflow display "jumps’ to the source of the selected input event(s). The operation
follows all signals selected in the wave viewer pane. Y ou can change which signals are
followed by changing the selection.

8 To continue tracing, go back to step 5 and repeat.
If you want to start over at the originally selected output, select Trace > Trace event reset.
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Tracing the source of an unknown (X)

Another useful debugging option is locating the source of an unknown (X). Unknown
values are most clearly seen in the Wave window—the waveform displaysin red when a
value is unknown.

¥ wave - default

Eile Edit “iew Insert Format Tools Window

SES|| s =@ KK ||\ QQ @ | IR

———————— 0 |-||-||-|1 T I_HT'IT'IT'I 00..J00.. J00... J0o.. oo

_______ U = = U = = L

Ty | I
The procedure for tracing an unknown is as follows:
1 Load your design.

2 Logal signalsinthe design or any signalsthat may possibly contribute to the unknown
value (log -r /* will log all signalsin the design).

3 Add signalsto the Wave window or wave viewer pane, and run your design the desired
length of time.

4 Put a cursor on the time at which the signal value is unknown.

5 Add thesignal of interest to the Dataflow window, making sure the signal is selected.

6 Select Trace> TraceX, Trace> TraceX Delay, Trace> ChaseX, or Trace > ChaseX
Delay.

These commands behave as follows:

TraceX / TraceX Delay— Step back to thelast driver of an X value. TraceX Delay works
similarly but it steps back in time to the last driver of an X value. TraceX should be used
for RTL designs; TraceX Delay should be used for gate-level netlists with backannotated
delays.
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ChaseX / ChaseX Delay — "Jumps" through a design from output to input, following X
values. ChaseX Delay acts the same as ChaseX but also moves backwards in timeto the
point where the output value transitions to X. ChaseX should be used for RTL designs;
ChaseX Delay should be used for gate-level netlists with backannotated delays.

Finding items by name in the Dataflow window

Select Edit > Find to search for signal, net, or register names or an instance of a

component.

Find in dataflow

Find: ||

Type
& Ay
= Instance

" Signal

[T Ewact

[~ ZoomTo

Find

Find Hest

Cloze |

Enter an item name and specify whether it is an instance of a process (Instance); asignal,
net, or register (Signal); or either (Any).

Specify Exact if you only want to find items that match your search exactly. For example,
searching for "clk" without Exact will find /top/clk and clk1.

If you want to zoom in on the located item, select Zoom To. Y ou can continue searching
using the Find Next button.
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Printing and saving the display

Saving a .eps file and printing under UNIX

Select File> Print Postscript to print the Dataflow display in UNIX, or save thewaveform

asa.epsfileon any platform.

Print Postscript

— Printer

™ File name: |dataf|u:uw.ps Browse. . |

—Paper

Faper zize: |Letter

Border width: | 0.4

TR

Fort: |He|‘-.=etiu:a

k. | LCancel

* Print command; |I|:| -d |p1 1' =
etup. . |
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The Print Postscript dialog box includes these options:

Printer

* Print command
Enter aUNIX print command to print the display in a UNIX environment.

» Filename
Enter afilename for the encapsulated Postscript (.eps) file to create; or browse to a
previously created .epsfile and use that filename.

Paper

» Paper size
Select the paper size used by the printer.

» Border width
Specify the border in inches.

* Font
Specify the font to use for printing.

Setup button
See "Printer Page Setup” (UM-366).
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Printing on Windows platforms
Select File> Print to print the Dataflow display or to save the display to afile.

2=

Froperties. .. |

— Printer

M ame:

Statusg: Ready
Tope: HF Lazer)et AL

Where:  LPTI:
Commett: [ Pint ta file
— Print range — Copies
Lo | Mumnber of copies: 1 :

e Fages  from: |0

e |0
" Selection @
] I Cancel

The Print dialog box includes these options:

Printer

* Name
Choose the printer from the drop-down menu. Set printer properties with the Properties
button.

» Status
Indicates the availability of the selected printer.

* Type
Printer driver name for the selected printer. The driver determines what type of fileis
output if "Print to file" is selected.

* Where
The printer port for the selected printer.

» Comment
The printer comment from the printer properties dialog box.

* Printtofile
Make this selection to print the display to afileinstead of a printer. The printer driver
determines what type of fileis created. Postscript printers create a Postscript (.ps) file,
non-Postscript printers create a.prn or printer control language file. To create an
encapsulated Postscript file (.eps) use the File > Print Postscript menu selection.
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Configuring page setup

Clicking the Setup button in the Print Postscript or Print dialog box allows you to define
the following options (thisis the same dialog that opens via File > Page setup).

Dataflow Page Setup £l
B — —Highlight

= Full & Oif

* Cumrent Yiew = On
—Color Mode————— — Orientation

" Colar

i ™ Puolrait
" Irvert Color
* Landscape

&+ Mono

—Paper

Faont; |Helvetica ZI

ok | LCancel

The Dataflow Page Setup dialog box includes these options:
* View
Specifies Full (everything in the window) or Current View (only that which isvisible).
» Highlight
Specifiesthat highlighting (see " Tracking your path through the design” (um-274)) isOn
or Off.

» Color Mode
Specifies Color (256 colors), Invert Color (gray-scale) or Mono (monochrome) color
mode.

» Orientation
Specifies Landscape (horizontal) or Portrait (vertical) orientation.

* Paper
Specifies the font to use for printing.
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Symbol mapping

The Dataflow window has built-in mappingsfor all Verilog primitivegates(i.e., AND, OR,
etc.). For components other than Verilog primitives, you can define a mapping between
processes and built-in symbols. This is done through afile containing name pairs, one per
line, where the first name is the concatenation of the design unit and process names,
(DUname.Processname), and the second name is the name of a built-in symbol. For
example:

xorg(only).pl XOR

org(only).pl OR
andg(only).pl AND

Entities and modules are mapped the same way:

AND1 AND

AND2 AND # A 2-input and gate
AND3 AND

AND4 AND

AND5 AND

AND6 AND

xnor (test) XNOR

Note that for primitive gate symbols, pin mapping is automatic.

The Dataflow window looks in the current working directory and inside each library
referenced by the design for the file datafl ow.bsm (.bsm stands for "Built-in Symbol Map).
It will read al files found.

User-defined symbols

Y ou can a'so define your own symbols using an ASCII symbol library file format for
defining symbol shapes. This capability isdelivered via Concept Engineering’ s Nlvi ew™
widget Symlib format. For more specific details on this widget, see www.model.com/
support/documentation/BOOK /nlviewSymlib.pdf.

The Dataflow window will search the current working directory, and inside each library
referenced by the design, for thefile dataflow.sym. Any and all filesfound will be given to
the NIview widget to use for symbol lookups. Again, aswith the built-in symbols, the DU
name and optional process name is used for the symbol lookup. Here's an example of a
symbol for afull adder:

synbol adder(structural) * DEF \
port ain -loc -12 -15 0 -15 \
pinattrdsp @ane -cl 2 -15 8 \
port bin-loc -12 15 0 15\
pinattrdsp @ane -cl 2 15 8 \
port cinin -loc 20 -40 20 -28 \
pinattrdsp @ane -uc 19 -26 8 \
port cout out -loc 20 40 20 28 \
pinattrdsp @ane -1c 19 26 8 \
port sumout -loc 63 0 51 O
pinattrdsp @ane -cr 49 0 8
path 10 0 0 7 \
path 0 7 0 35\
path 0 35 51 17 \
path 51 17 51 -17 \
path 51 -17 0 -35 \
path 0 -35 0 -7\
path 0 -7 10 O

\
\
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Port mapping isdone by namefor these symbols, so the port namesin the symbol definition
must match the port names of the Entity|M odule]Process (in the case of the process, it’ sthe
signal names that the process reads/writes).

A | mportant: When you create or modify a symlib file, you must generate a file index.
Thisindex is how the Nlview widget finds and extracts symbols from thefile. To
generate theindex, select Tools> Create symlib index (Dataflow window) and specify
the symlib file. The file will be rewritten with a correct, up-to-date index.

Configuring window options

Y ou can configure several optionsthat determine how the Dataflow window behaves. The
settings affect only the current session.

Select Tools > Optionsto open the Dataflow Options dialog box.

Dataflow Dptions |

General optionz ] YW arning options ]

¥ Hide cell:

¥ FKeep Dataflow

K.eep previous contents .
when adding new nets ar I™ Show Hierarchy
inztances to the

v ataflon wind o, IV Battam inout pins

[T Dizable S prout
[T Select equivalent nets

[T Lognets

¥ Select Environment

¥ Automatic Add to \wave

ok LCancel

The General options tab includes these options:

» HideCells
By default the Dataflow window automatically hides instances that have either
‘celldefine, VITAL_LEVELDO, or VITAL_LEVEL1 attributes. Unchecking this disables
automatic cell hiding.

» Keep Dataflow
K eeps previous contents when adding new signals or processes to the window.

» Show Hierarchy
Displaysconnectivity using hierarchical references. Notethat selecting thiswill erasethe
current contents of the window.

» Bottom inout pins
Places inout pins on the bottom of components rather than on the right with output pins.
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 Disable Sprout
Displays only the selected signal or process with itsimmediate fanin/fanout. Configures
window to behave like the Dataflow window of versions prior to 5.6.

» Select equivalent nets
If the item you select traverses hierarchy, then Model Sim selects all connected items
across the hierarchy.

e Log nets
L ogs signals when they are added to the window.

» Select Environment
Updates the Structure, Signals, and Source windows to reflect the net selected in the
Dataflow window.

» Automatic Add to Wave
Adds signals automatically to the Wave pane or window when executing ChaseX or
TraceX.

Dataflow Dptions ' A

General ophionz ) wiarning options ]

¥ Enable diverging i fanin warning
¥ Enable depth limit warring

W Enable ¥ event at time 0 warning

ok Cancel

The War ning optionstab includes these options:

» Enablediverging X fanin warning
Enablesthe warning message, "ChaseX: diverging X fanin. Reduce the selection list and
try again.”

» Enabledepth limit warning

Enables the warning message, "ChaseX: Stop because depth limit reached! Possible
loop?!

» Enable X event at time O warning
Enables the warning message, ""Driving X event at time 0."
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List window

The List window displaysthe results of your simulation run in tabular format. The window
isdivided into two adjustable panes, which allow you to scroll horizontally through the
listing on the right, while keeping time and delta visible on the | eft.

Fil= Edit

View Taoaols  \Window

=10 x|

ns—

delta—
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1560 +0
1520 +0
152t +0
1530 +0
le0o  +0
1&zZ0  +0
leZt  +0

1640 40

ftopfolk—, ftopSpaddr—,

fLop/pru—.
foopipstrb—
ftopfprdy—

(=T S S = R S S =
e R e e = W
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[P T = = T S P S

ooooo1l1l
ooooo0111
ooooo0111
ooooo0111
ooooolll
ooooo0111
ooooo0111
oooo1o00
oooo1o00

Stopfpdata—,

ftopssruw—,
ftopfsstrbh—

ftop/szaddr—, j

foopfsrdy—

oooooooooo000111
gooooooo000000111
gooooooo000000111
gooooooo000000111
ooooooo0o0000111
gooooooo000000111
gooooooo000000111
ZZEEEEZEEEEEEEEZE
EEEEEEEZEEEEEEEER

oo oo oo ooo

FHEREFERFERRERE
FHOOOOR R R

0000011l
Q0000111
Q0000111
Q0000111 J
Q0000111
Q0000111
Q0000111
Q0000111
ooo0olll d

-

ltems you can v

iew

The following type of items can be viewed in the List window:

VHDL

signals, aliases, process variables, and shared variables

Verilog

nets, registers, and variables

SystemC

primitive channels and ports

Comparisons

comparison regionsand comparison signal s, see Chapter 13 - Waveform Comparefor more

information

Virtuals

Virtual signals and functions

ModelSim SE User’'s Manual

Constants, generics, and parameters are not viewable in the List or Wave windows.




List window UM-287

Adding items to the List window

Before adding itemsto the List window you may want to set the window display properties
(see"Setting List window display properties’ (UM-293)). You can add itemsto the List
window in several ways.

Adding items with drag and drop

Y ou can drag and drop itemsinto the List window from the Signals, Source, Process,
Variables, Wave, or Structure window. Select theitemsin thefirst window, then drop them
into the List window. Depending on what you select, al items or any portion of the design
may be added.

Adding items from the Main window command line

Invoke the add list (CR-55) command to add one or more individual items; separate the
names with a space:

add |ist <itemname> <item name>

Y ou can add al theitemsin the current region with this command:
add list *

Or add all theitemsin the design with:
add list -r /*

Adding items with a List window format file

To use aList window format file you must first save aformat file for the design you are
simulating. The saved format file can then be used asa DO file to recreate the List window
formatting. Follow these steps:

» Additemsto your List window.

+ Edit and format the items to create the view you want (see "Editing and formatting items
in the List window" (UM-290)).

» Savetheformat to afile by selecting File > Save Format (List window).

To use the format file, start with ablank List window, and run the DO file in one of two
ways:
« Invoke the do (Cr-156) command from the command line:

do <ny_list_format>

» Select File> L oad Format from the List window menu bar.

List window format files are design-specific; use them only with the design you were
simulating when they were created. If you try to use the wrong format file, Model Sim will
advise you of the items it expectsto find.
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The List window menu bar

This section provides information on sel ect menu commands availablein the List window.

File menu

Write List savetheList window datato atext filein one of threeformats; see
"Saving List window datato afile" (Um-301) for details

Save Format save the current List window display and signal preferencesto a
DO (macro) file; running the DO file will reformat the List
window to match the display asit appeared when the DO filewas
created

Load Format run aList window format DO file previously saved with Save
Format

Edit menu

Add Marker add atime marker at the currently selected line; see" Setting time
markersin the List window" (UM-300)

Delete Marker delete the selected marker from the listing

Find find the specified item label within the List window; see "Finding
items by name in the List window" (UM-297)

Search search the List window for aspecified value, or the next transition
for the selected signal; see " Searching for item valuesin the List
window" (UM-298)

View menu

Signal Properties set item properties; see "Editing and formatting items in the List
window" (UM-290)

Goto choose the time marker to go to from alist of current markers

Tools menu

Combine Signals combinethe selected fiel dsinto a user-defined bus; keep copies of
theorigina itemsrather than moving them; see" Combining items
in the List window" (UM-292)

Window set display properties for items in the window; see " Setting List

Preferences window display properties' (UM-293)
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Window menu

The Window menu isidentical in al windows. See "Window menu" (UM-268) for a
description of the commands.

The List window context menu

Some commands like the following are available by clicking the right mouse button on an
entry in the right-hand pane:

Examine display the value of the item at the time selected

Annotate Diff Add anote to explain a comparison difference. See Chapter 13 -
Waveform Compare for further information.

Ignore Diff Disregard the selected comparison difference. See Chapter 13 -
Waveform Compare for further information.
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Editing and formatting items in the List window

Once you have the items you want in the List window, you can edit and format the list to
create the view you find most useful. (See also, "Adding itemsto the List window" (UM-
287))

To edit an item:

Select the item’ s label at the top of the List window or one of its values from the listing.
Move, copy or remove the item by selecting commands from the List window Edit menu
(UM-288) menu.

Y ou can a'so click+drag to move items within the window.

To format an item:

Select theitem’ s label at the top of the List window or one of its values from the listing,
then select View > Signal Properties (List window). The resulting List Signal Properties
dialog box allows you to set the item’ s label, label width, triggering, and radix.

E ‘List Signal Properties o ] |

Signal:

Dizplay Marme: I

—  Radix

&+ Symbolic fidth: I Characters
Binary
Octal

Decimal

Unzigned Trigger:
Hexadecimal " Triggers line

A5 ' Dioes naot tigger line

¥ L F L1 YY)

Drefaul

ok Cancel Apply

The List Signal Properties dialog box includes these options:

* Signal
Shows the full pathname of the selected signal.

» Display Name
Specifies the label that appears at the top of the List window column.
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List window UM-291

Specifies the radix (base) in which the item value is expressed. The default radix is
symbolic, which means that for an enumerated type, the List window lists the actual
values of the enumerated type of that item. Y ou can change the default radix for the
current simulation using either Simulate > Simulation Options (Main window) or the
radix command (CR-235). Y ou can change the default radix permanently by editing the
DefaultRadix (Um-623) variable in the modelsim.ini file.

For the other radixes- binary, octal, decimal, unsigned, hexadecimal, or ASCII - theitem
value is converted to an appropriate representation in that radix. In the system
initialization file, modelsim.tcl, you can specify the list translation rules for arrays of
enumerated types for binary, octal, decimal, unsigned decimal, or hexadecimal item

valuesin the design unit.

Changing the radix can make it easier to view information in the List window. Compare
the image below (with decimal values) with the image on page um-286 (with symbolic

values).
; =10l x|
File Edit Yiew Tools ‘Window
ns— feopfelk—~y seopipdata~y YRR, -
delta—, FLop/pru—, fLop/srw—
ftopspstrb—, ftopsfsstrb—,
ftopfprdy—, Jtopferdy—
ftopfpaddr—. ftopfsaddr—
lE40 40 1011 7 7011 7 K
0011 7 7011 7 7 T
1530 +0 1011 7 7011 7 7
1585 +0 1011 7 7010 7 7
1550 +0 10140 7 7010 7 K
ledd  +0 oa1l1a 7 Tao1a0 7 K
laz0  +0 10140 7 7010 7 K
laz5 +0 1001 =] z 011 7 I d
. |+l 2
* Width

Allows you to specify the desired width of the column used to list the item value. The
default is an approximation of the width of the current value.

» Trigger: Triggersline

Specifiesthat achangein the value of the selected item causes anew lineto be displayed

inthe List window.

» Trigger: Doesnot trigger line

Specifies that a change in the value of the selected item does not affect the List window.

The trigger specification affects the trigger property of the selected item. See also,

"Setting List window display properties* (UM-293).
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Combining item

ModelSim SE User’'s Manual

s in the List window

Y ou can combine signalsin the List window into busses. A busisacollection of signals
concatenated in a specific order to create anew virtual signal with a specific value. To
create a bus, select one or more signalsin the List window and then choose Tools >
Combine Signals.

Combine Selected Signals a2 A

—FRezult Mame

—Order to combine selected items

f* Topdown € Bottom up

—Order of Rezult Indexes

" Azcending % Descending

The Combine Selected Signals dialog box includes these options:

* Name
Specifies the name of the newly created bus.

* Order of Indexes
Specifiesin which order the selected signals are indexed in the bus. If set to Ascending,
the first signal selected in the List window will be assigned an index of 0. If set to
Descending, thefirst signal selected will be assigned the highest index number. Notethat
the signals are added to the bus in the order that they appear in the window. Ascending
and descending affect only the order and direction of the indexes of the bus.

» Remove selected signals after combining
Specifieswhether you want to remove the selected signalsfrom the List window oncethe
busis created.
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Setting List window display properties

Before you add items to the List window you can set the window’ s display properties. To
change when and how a signal is displayed in the List window, select T ools > Window
Preferences (List window). The resulting Modify Display Properties dialog box contains
tabs for Window Properties and Triggers.

Window Properties tab

A 'Mudify Display Properties {list} ._ L |EI|E|

Wfindo F'ru:uperties] Triggers]

Signal Mames: IEI Path Elementz [ for Full Path)

bdaw Title B ows: |5

— Datazet Prefix

" Alwaps Show Datazet Prefizes

{*' Show Datazet Prefises if 2 or more

" iMever Show Datazet Frefizes

ok Cancel Apply

The Window Properties tab includes these options:

» Signal Names
Sets the number of path elements to be shown in the List window. For example, "0"
shows the full path. "1" shows only the leaf element.

* Max Title Rows
Sets the maximum number of rows in the name pane.

» Dataset Prefix: Always Show Dataset Prefixes
Displays the dataset prefix associated with each signal pathname. Useful for displaying
signals from multiple datasets.

» Dataset Prefix: Show Dataset Prefix if 2 or more
Displays dataset prefixesif there are signalsin the window from 2 or more datasets.
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» Dataset Prefix: Never Show Dataset Prefixes
Turns off display of dataset prefixes.

Triggers tab

The Triggers tab controls the triggering for the display of new linesin the List window.
Y ou can specify whether an item trigger or a strobe trigger is used to determine when the
List window displaysanew line. If you choose Trigger on: Signal Change, then you can
choose between collapsed or expanded delta displays. Y ou can also choose a combination
of signal and strobe triggers. To use gating, Signal Change or Strobe or both must be
selected.

|5 'Mudiﬁr Display Properties (list) i |I:I|i|

—Deltas:
{* Expand Deltas " Collapse Deltaz " Mo Deltas

— Trigger On:
¥ Signal Change

[T Strobe First Strobe at: IEI g

Strobe Peniod: |0 nz

— Trnigger Gating:

[T Use Gating Expression |lze Exprezsion Builder

Expreszsion: |

0On Duration: |EI nz

ok LCancel Apply

The Triggers tab includes the following options:

» Expand Deltas
When selected with the Trigger on: Signal Change check box, displays a new line for
each time step on which items change, including deltas within a single unit of time
resolution.

» Collapse Deltas
Displays only the final value for each time unit.

* No Deltas
Hides the simulation cycle (delta) column.
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» Trigger On Signal Change
Triggerson signal changes. Defaults to al signals. Individual signals can be excluded
from triggering by using the View > Signal Properties dialog box or by originaly
adding them with the -notrigger option to the add list command (CR-55).

» Trigger On Strobe
Triggerson the Strobe Period you specify; specify the first strobewith First Strobe at:.

» Use Gating Expression
Enablestriggersto be gated on (avaue of 1) or off (avaue of 0) by the specified
Expression, much like ahardware signal analyzer might be set up to start recording data
on a specified setup of address bits and clock edges. Affects the display of data, not the
acquisition of the data.

» Use Expression Builder (button)
Opensthe Expression Builder to help you write a gating expression. See "The GUI
Expression Builder" (UM-395)

» Expression
Enter the expression for trigger gating into thisfield, or usethe Expression Builder (select
the Use Expression Builder button). The expression is evaluated when the List window
would normally have displayed arow of data (given the trigger on signals and strobe
settings above).

* On Duration
The duration for gating to remain open after the last list row in which the expression
evaluates to true; expressed in x number of default timescale units. Gating is
level-sensitive rather than edge-triggered.

List window gating information is saved as configuration statements when the list format
is saved. The gating portion of a configuration statement might look like this:
configure list -usegating 1

configure list -gateduration 100
configure |ist -gateexpr {<expression>}

UM-295
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Configuring a List trigger with the Expression Builder

This example shows you how to set a List window trigger based on a gating expression
created with the Model Sim Expression Builder. Here is the procedure:

1 Select Tools> Window Preferences to access the Triggers tab.

2 Check the Use Gating Expression check box and click Use Expression Builder.

B 'Expression Builder

FEHpressiDn

— Ex=pression Builder
Inzert Selected Signal | [ ] ==
'event 'iging 'falling el I I=
sMD | OR 1] 1 b r= <
#0OR| SLL * z ¢= +
SEL| SRha H L * ¢ %
Clear Save Test Ok Cancel

3 Sdlect thesignal inthe List window that you want to be the enable signal by clicking on
its name in the header area of the List window.

4 Click Insert Selected Signal and then 'rising in the Expression Builder.

5 Click OK to close the Expression Builder.

Y ou should see the name of the signal plus"'rising" added to the Expression entry box of
the Modify Display Properties dialog box.

6 Click OK to closethediaog.

If you already have simulation datain the List window, the display should immediately
switch to showing only those cycles for which the gating signal isrising. If that isn't quite
what you want, you can go back to the expression builder and play with it until you get it
the way you want it.

If you want the enable signal to work like a"One-Shot" that would display all values for
the next, say 10 ns, after the rising edge of enable, then set the On Duration valueto 10
ns.
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Sampling signals at a clock change

Y ou can sample signals at a clock change easily using the add list command (CR-55) with
the-notrigger argument. -notrigger disablestriggering the display on the specified signals.
For example:

add list clk -notrigger a b c

When you run the simulation, List window entriesfor clk, a, b, and ¢ appear only when clk
changes.

If you want to display on rising edges only, you have two options:

1 Turn off the List window triggering on the clock signal, and then define arepesting
strobe for the List window.

2 Define a"gating expression” for the List window that requires the clock to bein a
specified state. See "Configuring a List trigger with the Expression Builder" (Um-296).

Finding items by name in the List window

The Find dialog box =
dlowsyoutosearchfor LR B
text stringsin the List _ _
window. Select Edit > Find: | Find Mext
Find (List window) to Field Directi
bring up the Find dialog e irection Close
box. N %' Right
e < [” Exact
Enter atext string and * Label  Left
Find it by searching [V Autowrap
Right or L eft through the

List window display.
Specify Name to search the real pathnames of the items or L abel to search their assigned
names (see "Setting List window display properties’ (UM-293)).

Check Exact if you only want to find items that match your search exactly. For example,
searching for "clk" without Exact will find /top/clk and clk1.

Check Auto Wrap to continue the search at the beginning of the window.
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Searching for item values in the List window

Select anitemin the List window. Select Edit > Sear ch (List window) to bring up the List
Signal Search dialog box.

|1:-.__1'List Signal 5earch [window list]

—Signal Hamelz]
Mo Sighalzs Selected

—Search Type
Ay Transition

" Pising Edge

™ Falling Edge

% Search for Signal Value \-’alue:l

" Search for Expression E:-:pressi-:un:l Builder

—Search Oplions

|1 tateh Caunt [T Ignore Glitches

Search Fomward

Search Reverse

—Search Results
Status:

Time: Lz

Signal Name(s) showsalist of theitems currently selected inthe List window. Theseitems
are the subject of the search. The search is based on these options:

e Search Type: Any Transition
Searches for any transition in the selected signal(s).

» Search Type: Rising Edge

Searches for rising edgesin the selected signal(s).
* Search Type: Falling Edge

Searches for falling edges in the selected signal(s).
» Search Type: Search for Signal Value

Searches for the value specified in the Value field; the value should be formatted using
VHDL or Verilog numbering conventions; see "Numbering conventions' (CR-21).

P Note: If your signal valuesare displayed in binary radix, see" Searching for binary signal
valuesinthe GUI" (CR-30) for details on how signal val ues are mapped between abinary
radix and std_logic.
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» Search Type: Search for Expression
Searches for the expression specified in the Expression field evaluating to a boolean
true. Activatesthe Builder button so you can use"The GUI Expression Builder" (Um-395)
if desired.
The expression can involve more than one signal but is limited to signals logged in the
List window. Expressions can include constants, variables, and DO files. If no expression

is specified, the search will give an error. See "Expression syntax™ (CR-24) for more
information.

» Search Options. Match Count
Indicates the number of transitions or matches to search.Y ou can search for the nth
transition or the nth match on value.

» Search Options: Ignore Glitches
Ignores zero width glitchesin VHDL signals and Verilog nets.

The Search Results are indicated at the bottom of the dialog box.

UM-299
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Setting time markers in the List window

Select Edit > Add Marker (List window) to tag the selected list line with amarker. The
marker isindicated by athin box surrounding the marked line. The selected line uses the
same indicator, but its values are highlighted. Delete markers by first selecting the marked
line, then selecting Edit > Delete Marker.

Finding a marker

=10 x|

File Edit | Yigw Tools  Window

ns l feopspaddr—, feopspdata—, d

d Signal Properties. .. ftop/sru—g
ftopsSsstrb—
AR oo stopssrd
| 1740 40 1] 3 1268ns | ZEECEZEZEZEEEZZZZZ 0
1260 +0 1 2 1300 s P _EZE2ESZZZEEZZEZE22 0 L
| 1265 +0 1 J._J. OO L L Q0000000000001 10 0O
1230 +0 00 1 1 00000110 0000000000000110 0
1300 1 0 1 1 00000110 0000000000000 u]
1300 +1 1 0 1 1 00000110 0000000000000110 O
1z0& 40 1 0 1 1 00000110 0000000000oo01llo o _J

| I oz

Choose a specific marked lineto view by selecting View > Goto. The marker name (on the
Goto list) corresponds to the simulation time of the selected line.
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Saving List window data to a file

Select File> WriteList (List window) to save the List window datain one of these
formats:

» Tabular
writes atext file that looks like the window listing

ns delta /a /b /cin / sum / cout
0 +0 X X U X U
0 +1 0 1 0 X U
2 0 1 0 X U

* Events
writes atext file containing transitions during simulation

@ +0
/a X

/b X
/cin U
/sum X
/cout U
@ +1
/a0

/b 1
/cin 0

e TSSI
writes afilein standard TSSI format; see also, the write tssi command (CR-395)

4 00000000000000010000000010
100 00000001000000010000000010

You can aso save List window output using the writelist command (CR-391).

List window keyboard shortcuts
See "List window keyboard shortcuts® (Um-642) .
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Memory window

The memory window lists and displays the contents of the memoriesin your design. The
window is divided into two adjustable panes, alowing you to scroll vertically through the
memory contents displayed on the right, while keeping the memory list browser visible on
theleft.

|::.,:j1'n1en1ury - default -0l x|
File Edit Wiew Window

bemony List x| Address Data e |
Instance [Fange 00000000 110 110 110 110 110 110 -
aooooooe 110 110 110 110 aood Qoo
aooooo0e 000 000 oo 0ooo ooo ooo
ooooo0iz 000 000 Qoo Qoo oo ooo
aoooo01s 000 000 Qo0 ood ood ooo
aoooo0le OO0 Q00

Stopdedmiu_mem

B Atopdods0dine_ 347 [0ta 3]
W Nopdods0dine_ 34/ [0ta 3]
B Atopdods0dine_ 347 [0ta 3]
W Mopdodsldine__34/ [0t 31)
B Atopdodsldine__342 . [0ta 3]
W Mopdodsldine__34/ [0t 31)
B Atopdods2dline__347 . [0ta 3]
B Nopdods2dine__34/.. [0t 31)
B Atopdods2Aline__ 342 [0ta 3]
B Mopdocds3line__34/. [0t 3]
B Nopdodsdline_ 344 [0ta 3]
B Atopdods3dine_ 347 [0ta 3]
o /top/mimern [0:258]

4|l‘| mru_mem| [ = | *lT

< | ~l

Instance: Aopfc/mru_mem |Address: hexadecimal Data: symbolic .

Memories you can view

The memory browser identifies and lists the following types of arrays as memories:
* reg, wire, bit, and std_logic arrays

Any signal or variablethat is an array of two dimensions (including arrays of arrays) are
identified asmemoriesand listed if the basetypeisaVerilog reg or wiretype, or aVHDL
enumerated type with valuesin std_ulogic, bit, and all related sub-types.

* Integer arrays

Single dimensional arrays of integers are interpreted as 2D memory arrays. In these
cases, the word width listed in the Memory List paneis equal to theinteger size, and the
depth is the size of the array itself. The appearance of this type of array in the memory
list can be disabled viathe View menu or the ShowlntMem (uM-625) variable in the
modelsim.ini.

» Singledimensional arrays of VHDL enumerated types other than std_logic or bit

These enumerated type value sets must have values that are longer than one character.
The listed width isthe number of entriesin the enumerated type definition and the depth
isthe size of the array itself. The appearance of this type of array in the memory list can
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be disabled viathe View menu or the ShowEnumMem (um-625) variable in the
modelsim.ini.

» 3D or greater arrays

Memorieswith three or more dimensions display with aplussign’+' next to their names
inthe Memory List. Click the’+" to show the array indices under that level. When you
finally expand down to the 2D level, you can click on the index, and the data for the
selected 2D dlice of the memory will appear in the memory contents pane.The
appearance of thistype of array in the memory list can be disabled viathe View menu or
the Show3DMem (uUM-625) variable in the modelsim.ini.

The Memory window menu bar

This section provides information on select menu commands available in the Memory
window. Several commands are also available on a context menu by right-clicking within
the content or address pane.

File menu
Load load memory data to the currently displayed memory instance
from afile; see "Loading files and patterns' (UM-309)
Save save currently displayed memory data(all or arange) to afile; see
"Saving memory datato afil€" (Um-312)
Environment set the environment of the memory being viewed either to follow
context selection or to the current context
Edit menu
Goto go to specific memory address in currently displayed memory
instance; see "Using the Goto dialog" (UM-307)
Change change the memory contents for al addresses or a range of
addressesin the currently displayed memory instance; see
"Interactive memory initialization" (UM-311)
Find find the specified text string within the Memory window; see
"Finding a memory instance" (UM-308)
Data Search searches for a specified memory data pattern in the currently
displayed memory instance; see " Searching for a data pattern"
(UM-307)
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View menu

Memory open up the Source window to theline of codewherethe currently

Declaration displayed memory instance is defined

Split Screen split the address pane horizontally into two identically-sized
panes, one upper and one lower; see " Splitting the Data Screen”
(UM-3086).

Memory List toggle on and off the display of the Memory List pane

ShowIntMem toggle on and off the display in the Memory List pane of single
dimensional arrays of integers

ShowEnumMem toggle on and off the display in the Memory List pane of single
dimensional arrays of VHDL enumerated types other than
std_logic or bit

Show3DMem toggle on and of f the display in the Memory List pane of arrays of
3 or more dimensions

Display Options set various window display options; see "Modifying the memory
window display" (UM-305).

Window menu

The Window menu isidentical in al windows. See "Window menu" (UM-268) for a
description of the commands.

Viewing memory contents

To bring up aMemory window, either select View > Memory from the menu bar, or enter
view memory at the command prompt. Multiple memory windows can be viewed
simultaneoudly.

Selecting memory instances
To select amemory instance for viewing its contents, you can:
* Click on one of the memory instances appearing in the Memory List pane.

* Drag and drop any instance shown in the other Model Sim windows, such as Structure or
Waveinto the Address/ Data pane. All memory instances in that level of hierarchy are

displayed.
 Enter the command add mem <instance> at the vsim command prompt.

Viewing multiple memory instances

Y ou can view multiple memory instances. A tab appears at the bottom of the Address/ Data
pane corresponding to each memory instancethat isadded to the view, as shown below. To
close oneinstance or al instances, select File > Close I nstance or Close All, respectively.
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Memory window UM-305

When you have added memory instances to the view, the Memory window appears as

follows:
|+ memory - default -0 =|
Fil=  Edit Wiew ‘window
b ernony List | address Data |
T | Range 00000000 0000000000000000 i’
& ‘topde/mi_mem (3] oooooool oooQooaooooooool
W topde/siine_ 34/ (0t 31) ooooooos oooQooaoooooool1a
B oo o ||| saasaass ooz
- j:npjcjs?j:me_iij[g :Dg::] aoooooas oooQooaoooooo1ol
W topio/slfine a4/ [Ota 31) 00000006 0000000000000110
M /top/cis1/line__34/... [0 ta 31 00000007 0000000000000111
W /top/c/sl/line_34/.. [Dto 31) 00000008 0000000000001000
Wl ftop/c/s2iline_ 34/ (0t 31) 00000009 0000000000001001
W Mtopdo/e2iline__34/. [0 to 21) DO00000E MXEHNXXEHNXKEHNKKAN
W Atopdods2dline_ 34/ (0to 31] 0000000k XXEMXXXEXEEHXHXNE
Bl Aopicds3ine_ 347 [0to 31) DO00000C MEXHXXEXXEKEHXKEX
W Aopicde3line_ 347 [0to 31) QO000000d HEXHHNEMNEENMNILHEN
Bl Aopicds3ine_ 344 [0t 31 0000000 HHHHXXXHHAHHHXKE
1 top/mdmem [0: 25 OO00000f MEMEHMHEMXMNNMNMX
1|P||mru_mem|mem| | & | *|T|
«| | |
Instance: Aopfmimem |Addresa: hexadecimal Data: symbalic .

The display can be modified by setting different display options and splitting the Data/
Address pane.
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Setting display options

To change the display’ s address and data radix, or line wrapping of the selected memory,
select View > Display Options. You can aso right-click anywhere in thein the Address/
Data pane to bring up a pop-up menu containing Display Options.

The Display Options dialog box
includes these options:

* Address Radix
Theradix for the address. Can be ¥ Hexadecimal
Hexadecimal or Decimal.

'y
r
» Data Radix
The radix for the data. Non- " Octal
r-
i
r-

Display Dptions #
— Addess Badie— [ Data Radix

Spmbalic

= Decimal Biriary

enumerated type memories can be
Symbolic, Binary, Octal, Decimal,
Unsigned, and Hexadecimal .
Enumerated type memories are only
symbolic data types, and all other
options are grayed out.

e LineWrap — Line "#rap
The number of words per line can be & Erod
set, or arbitrarily determined based on Fit in Windav

the size of the window. " ‘words per Line |g

Decimal
Unzigned

Heradecimal

ok, Cancel

Splitting the Data Screen

Tosplitthe Address
/ Datapaneinto two
screens displaying
the contents of a
single memory

Address D ata |
Qooooo00 ooo0o00o00oo0oooon 3
Qooooo01 o0000o00oo0oo001

Qooooo00z o0o0o00000oo0oo01o

Qooooo03 o0o0o00oo00oo0oo011

instance, select
View > Split Oo000004 0000000000000100
Screen (or right- Oo0000005 0000000000000101 ﬂ

clickinthepaneand I
select Split Screen
from the pop-up
menu). This allows
you to view

Qoooo0o0s 000000000000 1000 i
ooooooo9 oooooooooo0o01001 -
00000008 XMXEMMXEXMXEXNNX
different address OO00000E MMM MMEIEMMEEENT
. - OO00000C XMXEMMXENMXEXNNX
locations within the
DOOO000E MMM T

same memory ﬂ_l‘” MOLL_MEm | e | | B | *l "|

instance
simultaneoudly.
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Navigating to memory locations within a memory instance

Other than using the scroll bar to scroll up and down through the memory, you can navigate
to specific memory locations within an instance in several ways.

Using the Goto dialog m
oto: Memory b

Select Edit > Goto to bring up the Goto Memory
dialog. Y ou can also right-click on the address Siefip chlizss
columninthe Address/ Datadisplay area, and select m
Goto from the pop-up menu. When selected, it

brings up the Goto dialog box, shown here. Enter the

desired address location into the field, select OK, ok |
and the data view shifts to display the datain that —
location.

Cancel |

Direct address navigation

Address Data

Y ou can navigate to any address

location directly by editing the address
inthe address column. Double-click on
any address, typeinthedesired address,

o0aoooas o000o000000000101
oo0oooods 0000000000000110

IDDDDDDIEI oooooooooooooniill

- 3 oopooons 9000000000001000

and hit Enter. The address display qonooooe 0000000000001001
scrolls to the specified location.

Sp 0o00000a A R A

Searching for a data

pattern Data Search in: Memory _ x|

To find a particular data
pattern, select Edit > Data
Sear ch or right-click in the
data area of the pane, and
select Data Sear ch. The
Data Search in Memory
dialog box appears as
shown here. Specify the
pattern you want to find in
the Search for: field and,
optionally, a replacement
pattern in the a the Replace with: field. The Search Next button performs the search and
replace operation. Select Search backward to search and/or replace backward through the
memory for the specified pattern. Select Close to close the Data Search dial og box.

Search for: |11110101] Search Mext

Feplace with: Feplace

Feplace Al

[ Search backwards

Example Search Fatterns:
1234,101 011, *057, 'hfa3d.

g

Cloze
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Finding a memory e —
instance II'I i memony

Tofind aparticular data Findt: | Find Mest |
pattern, select Edit > Find or

right-click in the dataareaof Direction = Clase |
the pane, and select Find. i+ Down

The Find dialog box appears & L Es

as shown here, containing a [w 2urto WWrap
search pattern definition

field and aFind Next button.

Select Exact match to search for patterns exactly matching the specified pattern. Select
Search backward to search backward through the memory for the specified pattern. Select

Closeto close the Find dialog box.
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Initializing memories

Y ou caninitialize memoriesin your design by either loading the contents from afile, or by
an interactive command. An entire memory, a specific range of addresses, or an individual
word can be overwritten. Choose the type of Load operation to be performed in the Load
Type area. The default load type is File Only. When either File Only or DataOnly is
selected, the unused section of the dialog box is grayed out.

Loading files and patterns

To initialize amemory from afile:

Select File > L oad. The Load Memory dialog box appears, as follows:

Load Memory E
— Instance Name
framn_thsprarn3imen
— Load Tyvpe Adddress Range
(" File Only Al
I Data Oy O Addresses (in hexadecimal )
" Both File and Data Start (00000000 End (00007
—File Load — Data Load
File Forrnat Fill Tiepae:
[ ierilog Hesx o alle
I Merilag Binary ™ Increment
e MTI ™ Decrement
—File Browser £ Rancom
Ay Fill Data
Audddale/M Tl memorytutorial/ex<amplessvlog_test™.mem I
Directoties Files
data_mem.mem Ll
. J reloc.mem J IU wardis )
ark.

! 4
i~ R |-

File: riarne

|ddalefMTlfmemnryﬂutnrialfexamplesfulng_te stidata_mem.mer|

Ok LCancel

The Load Memory dialog box includes these options:

* Instance Name
Displays the name of the memory instance being |oaded.
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ModelSim SE User’'s Manual

Load Type
Defines the type of load function you will perform. Y our choices for loading data are;
File Only, Data Only or Both File and Data.

Address Range
Specifies all addresses or arange of addresses in the memory that you want to load. The
address radix of the displayed memory is shown in parentheses.

File Load
Contains all inputsrelated to loading from afile. Thiswhole area of the dialog is grayed
out if Load Typeis specified as Data Only.

File Format

Specifiestheformat of thefileto beloaded. Verilog Hex, Verilog Binary, or MTI format
can be explicitly set, or the format can be determined automatically from the file (if the
file was created with the mem save command).

Filter
Filtersthefilelist.

File name
The name of the memory fileto load. Y ou can manually edit thisfield, or select afile
from the Fileslist, and it will fill in automatically.

Data L oad

Contains al inputs related to loading memory data. This area of the dialog is grayed out
if Load Typeis specified as File Only.

Fill Data

Specifies thefill data for addresses not contained in the load file.

Fill Type

Specifies how to apply thefill data, either directly asavalue, or algorithmically. Seethe
mem load command (CR-195) for more information on Fill Type and Fill Data.

Skip

Specifies the number of words to skip when applying afill pattern sequence.



Memory window

Interactive memory initialization

Memory contents can be modified interactively during simulation for greater easein
debugging your design. Y ou can change the data values in multiple addressesin the
memory by using the Change Memory dialog, or change individual data values by editing
them directly in the data area of the Address/ Data pane.

Changing data for multiple addresses

Select Edit > Change to open the Change Memory dialog box.

Change Memory
—Instance Mame

frarn_th/sprarm3imenn

— &ddress Range — Fill Type
W Al o alue
[ Addresses (in hexadecimal) O Increment
" Decrement
Start |DDDDDDDD End |0000f
" Random
—Fill Data — Skip
q a word(s)

The Change Memory dialog box includes the following:

* Instance Name
Displays the name of the memory instance being loaded.

» Address Range
Specifiesal addresses or a starting and ending address to be changed. The address radix
of the currently displayed memory is shown in parentheses.

* Fill Data
Specifiesthe fill data for specified addresses.

» Fill Type
Specifies how to apply thefill data, either directly asavalue, or algorithmically. Seethe
mem load command (CR-195) for more information on Fill Type and Fill Data.

* Skip

Specifies the number of wordsto skip after applying afill pattern sequence.
Changing data for individual addresses
To edit memory datain

place, Double click (or dress Data
rlght—CIICkandseleCt Editin 0oo0nons
Place) on any word in the goooaaog
00000003 i
Address/Data pane of the goooonns N00000000000MMeLrl010101010101d

; 00000000000000000000000000000011
Memory window. Thedata | {0000 agoagosoosoonaooaoanonoononneiiy

ishighlighted. Typein the Q0000000000000001100101011111110
desired change. Pressing <Enter> commitsthe change; <Esc> abortsit. <Tab> scrollsdown
thelist of dataentries, while <Shift>-<Tab> scrolls up thelist. Asashort-cut, after editing

UM-311
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Save Memory

one data value, you can double-click on another data value to commit the change and edit

the second value.

Saving memory data to a file

To save the current memory datato afile, select File > Save.

 Instance Mame

Jram_thispram3imem

—File Browser —Address Range
Filter
JfudddaleMTI memorysutorialéexamples/viog_test™ mem oAl
Directories Files i Addresses (in hexadecimal )
'S data_mem.mem 'S Start (00000000 End |0000ffF
.. reloc.mem
ork
—File Format
" Werilog Hex
" Werilog Binary
& MTI
— Address Radix r— Data Radi=——
[ Hexadlecimal " Symbolic
" Decimal " Binary
" Octal
_ _ " Decimal
i’r u'f " Unsigned
I.\] |- N |- " Hexadecimal
File riame [ Mo addresses
|fufddalefMTIfmemnryftuturiala’examplesmIng_testfreInc.merrl [ Compress
Ok LCancel

The Save Memory File dialog box includes the following:

* Filename
Name of file to be saved.

« Address Range
Specifies all or arange of addresses to be saved into the file. The address radix

» File Format

Specifieswhether memory isto be saved in Verilog Hex, Verilog Binary, or MTI format.

Also, specify the Address and Data radix for MTI format.

» No addresses
Specifies that no addresses are to appear in the saved file. This enables the file to be
reloaded anywhere in the memory.
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e Compress
Appliesasimple ASCII compression to the saved file. The compression algorithm
replaces repeating lines with asingle asterisk, likeis done with the Unix “od” command.

MTI memory data file format
The MTI memory datafile format is asillustrated in the following example:

/1l mermory data file
/1 (do not edit the following line - required for mem | oad use)

/1 format=nti addressradi x=d dataradi x=s direction=ascendi ng
0: 110 110 110 110 110 110
6: 110 110 110 110 000 000
12: 000 000 000 00O 000 000
18: 000 000 000 000 000 000
24: 000 000 000 000 000 000
30: 000 000
The possible format, addressradix, dataradix, and direction settings are as specified by the

corresponding options in the mem save and mem load commands. See the mem save
command (CR-198) and the mem load command (CR-195) for more information.

UM-313
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Process window

The Process window displays alist of processes, and SystemC method and thread
processes. In Model Sim versions 5.7 and | ater, the information contained in the Process
window can also be displayed in the Main window Workspace (UM-263).

If View > Activeis selected then all processes, and SystemC methods and thread processes
scheduled to run during the current simulation cycle are displayed al ong with the pathname
of the instance in which each processislocated. If View > In Region is selected then only
the processes in the currently selected region are displayed.

Understanding process status

Each item in the scrollbox is
preceded by one of the following
indicators:

* <Ready>
Indicates that the processis
scheduled to be executed within
the current deltatime.

o <Wait>
Indicates that the processis
waiting for aVHDL signal or
Verilog net or variable to change
or for aspecified time-out period.
SystemC items cannot beinaWait
state.

e <Done>

Epmcess Mi=] E3
File Edit “iew ‘Window

=

4| Ir

gim:Aopde

Indicates that the process has executed a VHDL wait statement without atime-out or a
sensitivity list. The process will not restart during the current simulation run. SystemC

items cannot be in a Done state.

If you select a"Ready" process, it will be executed next by the ssmulator.

Links to other windows

When you click on a process in the Process window, the following windows are updated:

Window updated

Result

Dataflow window (UM-270)

highlights the selected process

Memory window (UM-302)

shows the memory instances in that process

Signals window (UM-316)

showsthe signalsin theregion in which the processis
located

Source window (UMm-325)

shows the associated source code

Structure window (UM-331)
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Process window UM-315

Window updated Result

Variables window (UM-334) showsthe VHDL variables and Verilog registers and
variablesin the process

The Process window menu bar

This section provides information on select menu commands available in the Process

window.
File menu
SavelList save the processtree to atext file
Environment Follow Context Selection: update the window based on the
selection in the Structure window (UM-331);
Fix to Current Context: maintain the current view, do not update
View menu
Active display all the processes that are scheduled to run during the
current simulation cycle
In Region display any processesthat exist in theregion that isselectedinthe
Structure window
Sort sort the process list in either ascending, descending, or
declaration order

Window menu

The Window menu isidentical in al windows. See "Window menu" (UM-268) for a
description of the commands.
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Signals window

The Signals window shows the names and current values of items in the current region
(which is selected in the Structure window). The datain this paneis similar to that shown
in the Wave window (Um-337), except that the values do not change dynamically with
movement of the selected Wave window cursor.

Clicking on asigna namein the Signalswindow highlightsthat signal in the Dataflow and
Wave windows. Double-clicking a signal highlights that signal in the Source window
(opening a Source window if one is not open already). Y ou can also right click asignal
name and add it to the List or Wave window, or the current log file.

Theitems can be sorted in ascending, descending, or declaration order.

File Edit Wiew Add Tools Sindow

J 2 Yot J Contains: | @

L Cluat
1] Ir

L Cluat
I ]¥3
1l Ot

] I
Internal

1 Internal
i Internal

|5im:ft}{_prc|cess P

Iltems you can view

Oneentry is created for each of the following itemsin the design:

VHDL items

signals, aliases, generics, shared variables

Verilog items

nets, registers, variables, named events, and module parameters

SystemC items
primitive channels and ports
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Signals window

virtual signals and virtual functions; see "Virtual signals' (um-248) for more information

VHDL compositetypes (arrays and record types) and Verilog vector nets, vector registers,
and memories are shown in ahierarchical fashion. Model Sim indicates hierarchy with plus
(expandable), minus (expanded), and blank (single level) boxes. See " Tree window
hierarchical view" (um-261) for more information.

The Signals window menu bar

This section provides information on select menu commands availablein the Signals
window. Several commands are also available on a context menu by right-clicking on a

signal name.

File menu

Savelist

savethe signalstree to atext file

Environment

allow the window contents to change based on the current
environment, or fix to a specific context or dataset

Close

close this copy of the Signals window; you can create a new
window with File> New > Window from the " The Main window
menu bar" (UM-265)

Edit menu

Force

apply stimulusto the specified signal; see "Forcing signal and net
values' (UM-321)

Noforce

remove the effect of an active force

Clock

define clock signals; see"Defining clock signalsin HDL designs®
(UM-323)

UM-317
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View menu

Signal Declaration

open the sourcefilein the Source window and highlight the signal
declaration

Sort

sort thesignalstreein either ascending, descending, or declaration
order

Filter

choose the port and signal types to view; see "Filtering by signal
type" (UM-319)

Add menu

Allows you to add the specified signals to the Wave or List windows or the current WLF

file

Tools menu

Breakpoints

open the Breakpoints dialog; see " Creating and managing
breakpoints® (UM-391)

Toggle Coverage

add or reset toggle coverage; see Chapter 12 - Code Coveragefor
details

Window menu

The Window menu isidentical in al windows. See "Window menu" (UM-268) for a
description of the commands.

ModelSim SE User’'s Manual




Filtering the signal list

Y ou can filter the signal list by name or by signal type.

Filtering by name

Signals window

To filter by name, start typing lettersin the Containsfield on the toolbar. Asyou type
letters, the signals list filters to show only those signals that contain those | etters.

_ o] x|
File Edit Wiew add Toals ‘Window
Jﬁﬁ EE. J Containg:  |reset @ L
¥ | Hame W alue tode %

4]

Ot
Intermal
|nternal

|mternal

|sim:ft}{_prncess

Search Found B p

To display all signalsagain, click the Eraser icon to clear the entry.

— The signals list

filters dynamically
as you type letters
in the Contains:
field. Click the
erasericon to clear
the field.

Filters are stored rel ative to the region selected in the Structure window. If you re-select a
region that had afilter applied, that filter is restored. This allows you to apply different

filters to different regions.

Filtering by signal type

The View > Filter menu selection allows you to specify which

signal typesto display in the Signals window. Multiple options

can be selected.

%, Filter =] E3

[nput Ports
Cutput Ports
[nOut Ports
Internal Signals

UM-319
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Finding items in the Signals window

Tofind the specified text string within the Signal swindow, choosethe Nameor Valuefield
to search and the search direction: Down or Up.

Find in .signals 5
Find: | Find Mest
Field Direction Close
© Nome Do [ Exact
 Walue = Up
¥ Auto Wrap

Check Exact if you only want to find items that match your search exactly. For example,
searching for "clk" without Exact will find /top/clk and clk1.

Check Auto Wrap to continue the search at the beginning of the window.

Y ou can aso do aquick find from the keyboard. When the Signals window is active, each
time you type aletter the signal selector (highlight) will move to the next signal whose
name begins with that letter.
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Forcing signal and net values

The Edit > For ce command (unavailable for SystemC) displays a dialog box that allows
you to apply stimulus to the selected signal or net. Multiple signals can be selected and
forced; the force dialog box remains open until all of the signals are either forced, skipped,
or you close the dialog box. To cancel aforce command, use the Edit > NoForce
command. See also the for ce command (CR-176).

Force Selected Signal

Signal Name:lm

"Iul"alue:ll:l

Kind
’7 {* Freeze = Diive ™ Depozit

Delay Fur:IEI
Cancel After:l

ak. | Cancel

The For ce dialog box includes these options:

» Signal Name
Specifies the signal or net for the applied stimulus.

* Value
Initially displays the current value, which can be changed by entering a new value into
thefield. A value can be specified in radixes other than decimal by using the form (for
VHDL and Verilog, respectively):

base#val ue -or- b|o|d|h’val ue

16#EE or h' EE, for example, specifies the hexadecimal value EE.

» Kind: Freeze
Freezesthesignal or net at the specified value until itisforced again or until it isunforced
with anofor ce command (CR-204).

Freezeisthe default for Verilog nets and unresolved VHDL signals and Driveisthe
default for resolved signals.

If you prefer Freeze as the default for resolved and unresolved signals, you can change
the default force kind in the modelsim.ini file; see Appendix A - Model Sm variables.

» Kind: Drive
Attaches adriver to the signal and drives the specified value until the signal or net is
forced again or until it is unforced with anofor ce command (CR-204). Thistype of force
isillegal for unresolved VHDL signals.

» Kind: Deposit
Setsthe signal or net to the specified value. The value remains until there is a subsequent

driver transaction, or until the signal or net isforced again, or until it is unforced with a
nofor ce command (CR-204).
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» Delay For
Allows you to specify how many time units from the current time the stimulusis to be

applied.

» Cancel After
Cancels the for ce command (CR-176) after the specified period of simulation time.

* OK
When you click the OK button, afor ce command (CR-176) isissued with the parameters
you have set, and is echoed in the Main window. If more than one signal is selected to
force, the next signal down appearsin the dialog box each timethe OK buttonis selected.
Unique force parameters can be set for each signal.

Adding items to the Wave and List windows or a WLF file

Usethe Add menu to add itemsfrom the

Signals window to the Wave window T _|olx
(UM-337), List window (UM-286), or log m X

file (WLF file). Y ou can also access u—_”fave L I_ = ; T I_ =
these same commands by right-clicking List b Sencd songl
Liog »  Signals in Region

asignal in the window.

Signals in Design

TheWLFfileiswritten asan archivefile
in binary format and is used to drive the
List and Wave windows at a later time.
Once signals are added to the WLF file they cannot be removed (though you can turn off
logging with the nolog command (CR-205)). If you begin a simulation by invoking vsim
(CR-357) with the-view <WLF_fileame> argument, Model Sim readsthe WLF fileto drive
the Wave and List windows.

Choose one of the following options from the Add sub-menus:

» Selected Signals
Adds only the item(s) selected in the Signals window.

» Signalsin Region
Adds dl itemsin the region that is selected in the Structure window.

» Signalsin Design
Adds dl itemsin the design.
Adding items from the Main window command line

Another way to add itemsto the Wave or List window or the WLF fileisto enter one of the
following commands at the VSIM prompt (choose either the add list (CR-55), add wave
(CR-64), or log (CR-187) command):

add list | add wave | log <item name> <item nanme>

You can add all theitemsin the current region with this command:

add list | add wave | log *

If the target window (Wave or List) is closed, Model Sim opens it when you when you
invoke the command.
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Setting signal breakpoints in HDL designs

Signals window UM-323

Y ou canset "Signal breakpoints' (UM-391) in the Signalswindow. When asignal breakpoint
is hit, a message appears in the Main window Transcript stating which signal caused the

breakpoint.

Toinsert asignal breakpoint, right-click asignal name and select I nsert Breakpoint. See
"Creating and managing breakpoints" (UmM-391) for more information.

Defining clock signals in HDL designs

Select Edit > Clock to define clock signals by Name, Period, Duty Cycle, Offset, and
whether thefirst edgeisrising or faling. You can also specify a simulation period after
which the clock definition should be cancelled.

Define Clock |
Clock Mame
m:ﬂaps’clk
—offset — Dty
[i |50
— Pernod — LCancel
{100 |
Logic alues
ﬁigh: |1 Lo IEI
First Edge———
F Rising © Falling
] | Cancel |

For clock signals starting on the rising edge, the definition for Period, Offset, and Duty

Cycleisasfollows:

Period

High Value

Low Value

Offset

High Time

Duty Cycle = High Time/Period
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If the signal typeisstd logic, std_ulogic, bit, verilog wire, verilog net, or any other logic
type where 1 and O are valid, then 1 is the default High Value and O is the default Low
Value. For other signal types, you will need to specify aHigh Value and aLow Vaue for

the clock.

ModelSim SE User’'s Manual



Source window

Source window

SOUFCE - Proc.¥ 10| =
|

File Edit Wiew Toals ‘Window

The Source window allows you to view and edit your source code. When you first load a
design, the source file will display automatically if the Source window is open.
Alternatively, you can select anitem in a Structure tab of the Main window or use the File
> Open command (Source window) to add afile to the window. (Y our source code can
remain hidden if you wish.

The window displays your source code with line numbers. As shown in the picture below,
you may also see the following:

* Blue line numbers — denote lines on which you can set a breakpoint

* Blue arrow —denotes a process that you have selected in the Process window (Um-314) or
the line corresponding to a breakpoint at which the simulator is currently stopped

» Red diamonds — denote file-line breakpoints; hollow diamonds denote breakpoints that
are currently disabled

* File tabs — represent each open file
» Templates pane — displays HDL language templates (Um-397)

EEHS L 2R OAYXOK [ wHEEEE weE x

'Ilnﬂl

C:/modeltech/examples/mizedHDL proc. I d Templates

o
-

75
-
77
=
73
20
2l
82
83
o4
=3
=1
87
28
29

A uncomment for wawvecompare

£

endmodile

F4 Bead back 10 locations ﬁ\ MHew Deszign Wizard &
for {a =07 a < 10; a=a+ 1} Language Constiucts

Stimulus Generators
10 readia, d);

readia, d);
if (d == a)
("(#t: Read/Mri
end

if (werbose) [ "Read/WMr
11y
erud
ernd

1|Ir| prnc.vltup.vhd] |;u _Pl ‘| | +|

||

|Ln: 85, Col 0 - read-only s

Note that files open by default in read-only mode. Y ou can toggle this mode by selecting
Edit > read only.

UM-325
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The Source window menu bar

This section provides information on select menu commands available in the Source
window. Several commands are also available on a context menu by right-clicking in the

body of the window.

File menu
Open Design open adialog that lists al source files for the current design
Source
Use Source specify an aternative file to use for the current source file; this

alternative source mapping exists for the current simulation only

Source Directory

add to alist of directories to search for source files; you can set
thispermanently using the Sour ceDir variablein themodelsim.tcl
file

Edit menu

To edit asource file, make sureread only is not selected on the Edit menu.

Clear highlights clear highlightsthat result from double-clicking an error message
or alinein a Performance Analyzer report

Comment Selected turn the selected lines into comments by inserting the correct
language comment character at the beginning of each line

Uncomment removes comment characters from the selected lines

Selected

Previous Coverage
Miss

when simulating with Code Coverage (UM-419), find the previous
line of code that was not used in the simulation

Next Coverage Miss

when simulating with Code Coverage (UM-419), find the next line
of code that was not used in the simulation

read only

toggle the read-only status of the current sourcefile

View menu

Show line numbers

toggle line numbers

Show language
templates

toggle display of the HDL language templates (UM-397) pane

Show coverage data

toggle display of line hits when simulating with Code Coverage
(UM-419)
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Source window

Show coverage

toggle display of coverage numbers versus checkmarks when

numbers simulating with Code Coverage (UM-419)

Show coverage By toggle display of coverage numbers as sum of all instances or for

Instance each individual instance when simulating with Code Coverage
(UM-419)

Properties list avariety of information about the sourcefile; for example, file
type, file size, file modification date

Tools menu

Examine display the current value of the selected item; same asthe
examine (CR-167) command; the item name is shown in the title
bar

Describe display information about the selected item; same asthe describe
command (CR-152); the item name is shown in the title bar

Compile compile the currently active sourcefile

Readers list the names of all readers of the selected signal or net

Drivers list the names of al drivers of the selected signal or net

C Debug commands for using "C Debug" (UM-473); available on UNIX
platforms only

Breakpoints add, edit, or delete file-line and signal breakpoints; see " Creating
and managing breakpoints" (UM-391)

Options set various Source window options; see Options sub-menu bel ow

UM-327
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Options sub-menu

Colorize Source

colorize key words, variables, and comments

Highlight
Executable Lines

highlight the line numbers of executable lines

Middle Mouse enable/disable pasting by pressing the middle-mouse button
Button Paste

Verilog specify Verilog-style colorizing

Highlighting

VHDL Highlighting

specify VHDL-style colorizing

C Highlighting specify C-style colorizing

Freeze File maintain the same sourcefile in the Source window (useful when
you have two Source windows open; one can be updated from the
Structure window (UM-331), the other frozen)

Freeze View disable updating the source view from other windows

Auto-Indent Mode

indent code automatically when editing the file

Tab Stops set tab stop distance in Source window (see " Setting tab stopsin
the Source window" (UM-330))
Examine Now examine selected item at the current simulation time; this option

affects the behavior of the Examine and Describe commands as
well as the examine popup; see " Checking item values and
descriptions” (UM-329)

Examine Current
Cursor

examine selected item at the time of the current cursor in the
Wave window; this option affects the behavior of the Examine
and Describe commands as well as the examine popup; see
"Checking item values and descriptions' (UM-329)

Window menu

The Window menu isidentical in al windows. See "Window menu" (Um-268) for a
description of the commands.
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Setting file-line breakpoints

You can easily set "File-line breakpoints" (UM-391) in the Source window using your
mouse. Click on ablueline number at theleft side of the Source window, and ared diamond
denoting a breakpoint will appear. The breakpoints are toggles — click once to create the
colored diamond; click again to disable or enable the breakpoint.

To delete the breakpoint completely, click the red diamond with your right mouse button,
and select Remove Breakpoint. Other options on the context menu include:

» Disable/Enable Breakpoint
Deactivate or activate the selected breakpoint.

 Edit Breakpoint
Open the File Breakpoint dialog to change breakpoint arguments; see "Adding a
breakpoint” (um-393) for a description of the dialog.

 Edit All Breakpoints
Open the M odify Breakpoints dialog; see "Breakpoints dialog" (UM-392).

Checking item values and descriptions

There are two quick methods to determine the value and description of an item displayed
in the Source window:

» select an item, then choose Tools > Examine or Tools > Describe from the Source
window menu

* pause over an item with your mouse pointer to see an examine pop-up

Select Tools> Options> Examine Now or Tools> Options > Examine Current Cur sor
to determine at what simulation time the item is examined or described.

Y ou can also invoke the examine (CR-167) and/or describe (CR-152) command on the
command line or in a macro.

Finding and replacing in the Source window

The Find dialog box

alows you to find Find in: source - top.vhd 25 E|
and replace text _ _

strings or regular Find: ] Find Mest

expressionsin the
Source window.
Select Edit > Find
or Edit > Replaceto
bring up the Find ™ Regular expression
dialog box. If you

select Edit > Find,

the Replacefield is absent from the dialog.

Replace: | Replace

[T Caze sensitive [T Search backwards Cloze

Enter the value to search for in the Find field. If you are doing a replace, enter the
appropriate value in the Replace field. Optionally specify whether the entries are case
sensitive and whether to sear ch backwar ds from the current cursor location. Check the
Regular expression checkbox if you are using regular expressions.
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Setting tab stops in the Source window
Y ou can set temporary tab stopsin the Source window by selecting Tools> Options>Tab
Stops. Follow these steps:
1 Select Tools > Options> Tab Stops (Source window).

2 Inthe dialog that appears, enter either a single number "n" and units, which sets a tab
stop every n units, or enter alist of numberswhich setsatab at each location. Available
units and their abbreviations are as follows:

Units Abbreviations
centimeters c,cm
millimeters m, mm

inches i,in

points p

pixels (screen units) u

characters char, chars

If you don’t specify units, they default to characters.
Here are three examples:

» Enter 5to set atab stop every 5 characters.

» Enter 10c to set atab stop every 10 centimeters.

 Enter alist of numbers like the following to set tab stops at specific character locations:
21 49 77 105 133 161 189 217 245 273 301 329 357 385 413 441 469

A mportant: Do not use quotes or bracesin thelist (i.e., "21 49" or {21 49}); thiswill
cause the GUI to hang.

If you want to set permanent tab stops, you have to edit the Pref Source(tabs) preference
variable and then save a modelsim.tcl file. See "Preference variables located in Tcl files"
(Um-631) for further details.
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Structure window

The Structure window provides a hierarchical view of the structure of your design. In
Model Sim versions 5.5 and | ater, the information contained in the Structure window isalso
shown in the structure tabs of the Main window Workspace (UM-263). The Structure
window does not display by default. Y ou can display the Structure window at any time by
selecting View > Structure (Main window).

An entry is created by each item within the design. (Y our design structure can remain
hidden if you wish. When you select aregion in the Structure window, it becomes the
current region and is highlighted. The Source window (UM-325) and Signal s window (UMm-
316) change dynamically to reflect the information for that region. This feature provides a
useful method for finding the source code for a selected region because the system keeps
track of the pathname where the sourceislocated and displaysit automatically, without the
need for you to provide the pathname.

Also, when you select aregion in the Structure window, the Process window (UM-314) is
updated if In Region is selected in that window. The Process window will in turn update
the Variables window (Um-334).

Items you can view

Thefollowing items are

represented by hierarchy within d
the Structure window. Ble  Eelit - Mew  Wincow
¥| Instance Design Unit | Design Unit
VHDL items test_ringhuf test_ringhuf  ScMocule
P ririg_IMNST ritwgkauf Sehodule
.(mdlcated by adark blue Square ﬂgalcu:kl cu:ur?tru:ul(rtl) Architecture
ICOﬂ) . L hlockz2 store Wodule
component Instantiations, o Storer store Staternent
generate statements, block block3 retrieve Mocule
statements, and packages W retriever retrieve Staternent
W standard stancard Package
Verilog items H 3td_|cng?c_1 1_64 std_lcngic_... Fackage
Wl sto_logic_arith stel_logic_ar... Package
(indicated by alighter blue circle il sto_logic_unsigned  std_logic_u. Package
icon)
modul e instantiations, named
forks, named begins, tasks, and
functions

|]=<IN|:| Contests =ﬂ

(indicated by a green diamond icon)
SystemC module instantiations, primitive channels, method and thread processes

SystemC items
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Structure window menu bar

rface

Virtual items

(indicated by an orange diamond icon)
virtual regions; see "Virtual Objects (User-defined buses, and more)" (Um-248) for more

information.

Y ou can expand and contract the display to view the hierarchical structure by clicking on
the boxes that contain "+" or "-". Clicking "+" expands the hierarchy so the sub-elements
of that item can be seen. Clicking "-" contracts the hierarchy.

This section provides information on select menu commands availablein the Signals
window. Several commands are also available on a context menu by right-clicking in the
right-hand pane of the window (see " Structure window context menu" (UM-333) for some

details).
File menu

SaveList save the structure tree to a text file viewable with the ModelSim
notepad (CR-207)

Environment 1) specify that the window contents change when the active
dataset is changed; 2) fix the window contents to a specific
dataset; or 3) change to a new root context

View menu
Sort sort the structure tree in either ascending, descending, or

declaration order
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Structure window UM-333

Structure window context menu

Accessthe following commands by clicking the right mouse button on an entry in theright-

hand pane:

View Source opens the source file in the Source window (UM-325); double-
clicking will also open the sourcefile

Add adds the selected item to the Dataflow, List, or Wave window or
to the current log file

Save List writes the item names in the Structure tab to atext file

Coverage provides accessto the Coverage Reportsand Clear Coverage Data
commands; see Chapter 12 - Code Coverage for more details

Finding items in the Structure window
The Find dialog

box allowsyouto Find in .structure =]
search for text Find Fird M
stringsin the inct ] e e
Structure Field ~Direction | Close
window. Select

Edit > Find ¥ |nstance -

(Structure . ! Lol

window) to bring £ Entity/Module “ up [~ Ewact

up the Find " Architecture

diaog box. ¥ Autowrap
Enter the valueto

search for in the
Find field. Specify whether you are looking for an I nstance, Entity/M odule, or
Architecture. Also specify which direction to search.

Check Exact if you only want to find items that match your search exactly. For example,
searching for "clk" without Exact will find /top/clk and clk1.

Check Auto Wrap to continue the search at the beginning of the window.
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Variables window

The Variables window is divided into two window panes. The left pane lists the names of
items within the current process. The right pane lists the current value(s) associated with
each name. The pathname of the current process is displayed at the bottom of the window.
(Theinternal variables of your design can remain hidden if you wish.

Items you can view
E wariables

File Edit Wiew &dd \Window

The following types of items
can beviewed inthe Variables

window: — oy ——————

VHDL items tpd_clk_ta_count

constants, generics, and — inerement

variables wal 011710001
inpt 071717100071

Verilog items result 011100071

registers and variables (EETiR

— |oop

SystemC items

SystemC variables are not
supported for viewing. sim:/counterfctr y

VHDL composite types (arrays and record types) and Verilog vector registers and
memories are shown in a hierarchical fashion. Modd Sim indicates hierarchy with plus
(expandable), minus (expanded), and blank (single level) boxes. See "Tree window
hierarchical view" (UM-261) for more information.

To change the value of aVHDL variable, constant, or generic or a Verilog register or
variable, move the pointer to the desired name and click to highlight the selection. Select
Edit > Change (Variables window) to bring up a dialog box that lets you specify a new
value. You can enter any value that isvalid for the variable. An array value must be
specified as a string (without surrounding quotation marks). To modify the valuesin a
record, you need to change each field separately.

Click on a process in the Process window to change the Variables window.
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The Variables window menu bar

This section provides information on select menu commands available in the Variables

window.
File menu
SaveList save the variable tree to atext file viewable with the Model Sim
notepad (CR-207)
Environment Follow Process Selection: update the window based on the
selection in the Process window (UM-314)
Fix to Current Process: maintain the current view, do not update
Close close this copy of the Variables window
Edit menu
Change change the value of the selected item(s)
View menu
Sort sort the variables tree in either ascending, descending, or
declaration order
Justify Values justify valuesto the left or right margins of the window pane
Add menu

Add variables to the Wave or List windows or the current WLF file.

Window menu

The Window menu isidentical in al windows. See "Window menu" (UM-268) for a
description of the commands.
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Finding items in the Variables window

To find the specified text string within the Variables window, choose the Name or Value
field to search and the search direction: Down or Up.

Find in .¥ariables |
Find: | Fird Mest
Field Direction Cloze
&+ MName £+ Down ™ Exact
" Walue i Up
¥ At wWiap

Check Exact if you only want to find items that match your search exactly. For example,
searching for "clk" without Exact will find /top/clk and clk1.

Check Auto Wrap to continue the search at the beginning of the window.

Y ou can also do aquick find from the keyboard. When the V ariableswindow isactive, each
timeyou type aletter the highlight will move to the next item whose name beginswith that
letter.
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Wave window

TheWavewindow, likethe List window, allowsyou to view the results of your simulation.
In the Wave window, however, you can see the results as waveforms and their values.

The Wave window is divided into a number of window panes. All window panesin the
Wave window can be resized by clicking and dragging the bar between any two panes.

pathnames values waveforms

===t wave - default

File Edit M“iew| Insert Format Tools  Window

e
1

1]

| 3140 ns to 4001 ns |

cursors names and values cursors

Pathname pane

The pathname pane displays signal pathnames. Signals can be displayed with full
pathnames, as shown here, or with only the leaf element displayed. Y ou can increase the
size of the pane by clicking and dragging on the right border. The selected signal is
highlighted.

The white bar along the left margin indicates the selected dataset (see " Splitting Wave
window panes’ (UM-344)).
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Value pane

The value pane displays the values of the displayed signals.

Theradix for each signal can be symbolic, binary, octal, decimal, unsigned, hexadecimal,
ASCII, or default. The default radix can be set by selecting Simulate > Simulation
Options (Main window) (see "Setting default simulation options' (UM-386)).

The datain this paneis similar to that shown in the Signals window (Um-316), except that
the values change dynamically whenever a cursor in the waveform pane is moved.

Waveform pane

The waveform pane displays the waveforms that correspond to the displayed signal
pathnames. It also displays up to 20 cursors. Signal values can be displayed in analog step,
analog interpolated, analog backstep, literal, logic, and event formats. Each signal can be
formatted individually. The default format islogic.

If you rest your mouse pointer on asignal in the waveform pane, a popup displays with
information about the signal. Y ou can toggle this popup on and off in the Wave Window
Properties dialog (see " Setting Wave window display properties’ (UM-352)).

Cursor panes

There are three cursor panes-the left pane shows the cursor names; the middle pane shows
the current simulation time and the value for each cursor; and the right pane shows the

absol ute time value for each cursor and relative time between cursors. Up to 20 cursors can
be displayed. See"Using time cursorsin the Wave window" (UM-358) for more information.

Items you can view

The following types of items can be viewed in the Wave window

VHDL items

(indicated by adark blue square)

signals, aliases, process variables, and shared variables
Verilog items

(indicated by alight blue circle)

nets, registers, variables, and named events

SystemC items

(indicated by a green diamond)

primitive channels and ports

Virtual items

(indicated by an orange diamond)
virtual signals, buses, and functions, see; "Virtual Objects (User-defined buses, and more)"
(UM-248) for more information
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Comparison items

(indicated by ayellow triangle)
comparison region and comparison signal's; see Chapter 13 - Waveform Compare for more
information

Constants, generics, and parameters are not viewable in the Wave windows.

The datain the item vaues paneis very similar to the Signals window, except that the
values change dynamically whenever a cursor in the waveform pane is moved.

At the bottom of the waveform pane you can seeatimeline, tick marks, and the time value
of each cursor’s position. Asyou click and drag to move a cursor, the time value at the
cursor location is updated at the bottom of the cursor.

Y ou can resi ze the window panes by clicking on the bar between them and dragging the bar
to anew location.

Waveform and signal-name formatting are easily changed via the Format menu (Um-342).
Y ou can reuse any formatting changes you make by saving aWavewindow format file, see
"Adding items with a Wave window format file" (uM-339).

Adding items in the Wave window

Before adding items to the Wave window you may want to set the window display
properties (see " Setting Wave window display properties’ (UM-352)). Y ou can add itemsto
the Wave window in several ways.

Adding items from other window with drag and drop

Y ou can drag and drop itemsinto the Wave window from theList, Process, Signals, Source,
Structure, or Variables window. Select the itemsin the first window, then drop them into
the Wave window. Depending on what you select, al itemsor any portion of the design can
be added.

Adding items from the command line
To add specific items to the window, enter (separate the item names with a space):

VSI M> add wave <item name> <item nane>

You can add all theitemsin the current region with this command:
VS| M> add wave *

Or add all theitemsin the design with:
VS| M> add wave -r /*

Adding items with a Wave window format file

Select File > Open > Format and specify a previously saved format file. See " Saving the
Wave window format" (UM-340) for details on how to create a format file.
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Saving the Wave window format

By default all Wave window information is forgotten once you close the Wave window. |f
you want to restore the Wave window to a previously configured layout, you must save a
Wave window format file. Follow these steps:

1 Add the items you want to the Wave window.

2 Edit and format the items, see "Editing and formatting items in the Wave window" (UM-
347) to create the view you want.

3 Savetheformat to afile by selecting File > Save > Format (Wave window).

To use the format file, start with a blank Wave window and run the DO file in one of two
ways:

* Invoke the do command (CR-156) from the command line:

VSI M> do <ny_wave_f or mat >
» Sdlect File > Open > Format (Wave window).

P Note: Wave window format files are design-specific; use them only with the design you
were simulating when they were created.

The Wave window menu bar

This section provides information on select menu commands available in the Wave
window. Many of these commands are also available viaa context menu by clicking your
right mouse button within the Wave window itself.

File menu

Open Format — run aWave window format (DO) file previously saved with
Save Format; see " Saving the Wave window format” (Um-340)

Save Format — save the current Wave window display and signal
preferences to a DO (macro) file; see " Saving the Wave window
format" (UM-340)

Image — saves a bitmap file of the Wave window

Page Setup configure page setup for printing; see "Printer Page Setup” (UM-366)

Print Postscript save or print the waveform display as a Postscript file; see "Printing
and saving waveforms' (uM-363) for details
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Edit menu
Edit Cursor open adialog to specify the location of the selected cursor
Delete Cursor delete the selected cursor from the window
Delete Window delete the selected window pane
Pane

Remove All (Panes

removes all signals and additional window panes, leaving the

and Signals) window inits original state

Find find the specified item label within the pathname pane or the
specified value within the value pane

Search search the waveform display for a specified value, or the next
transition for the selected signal; see: "Searching for item values
in the Wave window" (UM-356)

View menu
Mouse Mode toggle mouse pointer between Select Mode (click left mouse

button to select, drag with middle mouse button to zoom) and
Zoom Mode (drag with left mouse button to zoom, click middle
mouse button to select)

Signal Declaration

open the sourcefilein the Source window and highlight the signal
declaration for the currently selected signal

Cursors choose a cursor to go to from alist of available cursors

Bookmarks choose a bookmark to go to from alist of available bookmarks

Goto Time scroll the Wave window so the specified timeisin view; "g"
hotkey produces the same result

Sort sort the top-level itemsin the pathname pane; sort with full path
or viewed name; use ascending or descending order

Justify Values justify valuesto the left or right margins of the window pane

Refresh Display clear the Wave window, empty the file cache, and rebuild the
window from scratch

Signal Properties set properties for the selected item; see "Editing and formatting

items in the Wave window" (UM-347)
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Insert menu

Divider

insert adivider at the current location

Breakpoint

add abreakpoint on the selected signal; see " Signal breakpoints'
(UM-391)

Bookmark

add a bookmark with the current zoom range and scroll location;
see " Saving zoom range and scroll position with bookmarks' (Um-
361)

Cursor

add a cursor to the waveform pane

Window Pane

split the pathname, values and waveform window panes to
provide room for a new waveset

Format menu

Radix

set the selected items' radix

Format

set the waveform format for the selected items — Literd, Logic,
Event, Analog

Color

set the color for the selected items from a color palette

Height

set the waveform height in pixels for the selected items

Tools menu

Waveform
Compare

see "Waveform Compare menu" (UM-468)

Breakpoints

add, edit, and delete signal breakpoints; see "Creating and
managing breakpoints' (UM-391)

Bookmarks

add, edit, delete, and goto bookmarks; see " Saving zoom range
and scroll position with bookmarks' (UM-361)

Dataset Snapshot

enable periodic saving of simulation datato a WLF file

Combine Signals

combine the selected items into a user-defined bus; see
"Combining itemsin the Wave window" (UM-345)

Window
Preferences

set various display properties; see" Setting Wave window display
properties’ (UM-352)

Window menu

The Window menu isidentical in al windows. See "Window menu" (UM-268) for a
description of the commands.
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Dividers serve as avisua aid to signal debugging, allowing you to separate signals and

waveforms for easier viewing. Dividing lines can be placed in the pathname and values
window panes by selecting Insert > Divider (Wave window). Or, you can add a divider
using the -divider argument to the add wave command (CR-64).

Dividing lines can be assigned any name or no name at al. The default nameis"New
Divider." In theillustration bel ow, two datasets have been separated with a Divider called
"gold." Notice that the waveforms in the waveform window pane have been separated by

the divider as well.

===t wave - default

File Edit igw
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After you have added a divider, you can move it, change its properties (name and size), or

deleteit.

To moveadivider — Click and drag the divider to the location you want.

To change adivider’sname and size— Click the divider with the right (Windows) or
third (UNIX) mouse button and select Divider Properties from the pop-up menu.

To deleteadivider — Select the divider and either press the <Delete> key on your

keyboard or select Delete from the pop-up menu.
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Splitting Wave window panes

The pathnames, values, and waveforms panes of the Wave window display can be split to
accommodate signal s from one or more datasets. Selecting I nsert > Window Pane (Wave
window) creates a space below the selected dataset and makes the new window pane the
selected pane. (The selected wave window pane isindicated by awhite bar along the left
margin of the pane.)

In theillustration bel ow, the Wave window is split, showing the current active simulation
with the prefix "sim," and a second view-mode dataset, with the prefix "gold."

For more information on viewing multiple simulations, see Chapter 9 - WLF files
(datasets) and virtuals.
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Combining items in the Wave window

Y ou can combine signalsin the Wave window into busses. A busisa collection of signals
concatenated in aspecific order to create anew virtual signal with aspecific value. Y ou can
also do this from the Model Sim prompt using the virtual signal command (CR-339).

To create abus, select one or more signalsin the Wave window and then choose Tools >
Combine Signals.

Combine Selected Signals kS

—Rezult Mame

—Order to combine selected items

f* Topdown € Bottomup

—Order of Reszult Indexes

" Ascending ™ Descending

[~ Femove selected signals after combining
[~ Reverse bit order of bus items in result
¥ Flatten amays

[ Flatten recards

ok LCancel

The Combine Selected Signals dialog box includes these options:

* Result Name
Specifies the name of the newly created bus.

» Order to combine selected items
Specifies the order in which to combine the selected signals. "Top down" specifies that
the selected signals are ordered as they appear top-to-bottom in the Wave window.
"Bottom up" reverses the order.

* Order of Result Indexes
Specifiesin which order the selected signals are indexed in the bus. If set to Ascending,
the first signal selected in the Wave window will be assigned an index of 0. If set to
Descending, the first signal selected will be assigned the highest index number.

* Remove selected signals after combining
Specifies whether you want to remove the sel ected signals from the Wave window once
the busis created.
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» Reversebit order of busitemsin the result
If checked, the bits of each selected signal are reversed in the newly created bus. The
order of the signalsin the busis not affected.

» Flatten arrays
If checked, Model Sim combines the signalsinto one big array. If unchecked, Model Sim
combines signals together without merging them into one array. The signals become
elements of arecord and retain their original names. When expanded, the new signal
looks just like agroup of signals.

 Flatten records
If checked, causes elements of arecord type signal to be pulled up to the top level. This
option isthe reverse of "Flatten arrays."

Intheillustration below, three signal's have been combined to form anew bus called "bus’.
Note that the component signals are listed in the order in which they were selected in the
Wavewindow. Also notethat the value of the busis made up of the values of its component
signals, arranged in a specific order. Virtual objects are indicated by an orange diamond.

=i wave - default ' =10 x|
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Other virtual items in the Wave window

See"Virtual Objects (User-defined buses, and more)" (uM-248) for information about other
virtual items viewable in the Wave window.
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Displaying drivers of the selected waveform

Y ou can automatically display in the Dataflow window the drivers of asignal selected in
the Wave window. Y ou can do this three ways:

* Select awaveform and click the Show Drivers button on the toolbar. 34-
* Select awaveform and select Show Drivers from the shortcut menu

» Double-click awaveform edge (you can enable/disable this option in the display
properties dialog; see " Setting Wave window display properties’ (UM-352))

Thisoperation will open the Dataflow window and display thedriversof the signal selected
in the Wave window. The Wave pane in the Dataflow window will also open showing the
selected signal with acursor at the selected time. The Dataflow window will show the
signal(s) values at the current time cursor position.

Editing and formatting items in the Wave window

Once you have the items you want in the Wave window, you can edit and format thelist in
the pathname and val ues panes to create the view you find most useful. (See aso, " Setting
Wave window display properties’ (UM-352).)

To edit an item:

Select theitem’ slabel in the pathname pane or its waveform in the waveform pane. Move,
copy, or remove the item by selecting commands from the Wave window Edit menu (UM-
341).

Y ou can a'so click+drag to move items within the pathnames and values panes:

* to select several items:
control+click to add or subtract from the selected group

* to move the selected items:
re-click and hold on one of the selected items, then drag to the new location

To format an item:

Select the item’ s label in the pathname pane or its waveform in the waveform pane, then
select View > Signal Properties(Wavewindow) or use the selectionsin the For mat menu.
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When you select View > Signal Propertiesthe Wave Signal Properties dialog box opens.
It has three tabs: View, Format, and Compare.

“Wave Signal Properties

Signal: w=im: Atop/paddr
— Dizplay Mame

— Fadix —wave Color

 Sumbolic € Unsigned I I:::uh:urs...l

' Binamy ' Hexadecimal

" Octal  ASCI —Mame Color———————

= Decimal * Default I Eu:ulu:urs...l

Qlk | Cancel Apply |
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The View tab includes these options:

» Display Name
Specifies anew name (in the pathname pane) for the selected signal.

* Radix
Specifies the Radix of the selected signal(s). Setting this to default causesthe signal’s
radix to change whenever the default is modified using the radix command (CR-235).
Item values are not trandated if you select Symbolic.

It
Specifiesthe waveform color. Select anew color from Sl
the color palette, or enter a color name. The Default -~ Palette

button in the Colors palette allows you to return the
selected item’s color back to its default value.

» Name Color
Specifies the signal name's color. Select anew color
from the color palette, or enter a color name. The
Default button in the Colors palette allows you to
return the selected item’ s color back to its default
value.

Drefault

YWave Signal Properties

Signal: weirn: Atop/paddr

— Format

= Lieral  Logic " Event " Analog

——Analog Dizplay

[Heighj € Analog Step Offset: [00
|1? € Analog Interpolated
€ Analog Backstep Sl |1'D

Ok | Cancel Apply |

The Format tab includes these options:

» Format: Literal
Displays the waveform as a box containing the item value (if the value fits the space
available). Thisisthe only format that can be used to list arecord.
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» Format: Logic

ModelSim SE User’'s Manual

DisplaysvaluesasU, X,0,1,Z, W, L, H, or -.

Format: Event
Marks each transition during the ssmulation run.

Format: Analog [Step | Interpolated | Backstep]
Analog Step
Displays the waveform in step style.

Analog Interpolated
Displays the waveform in interpol ated style.

Analog Backstep
Displays the waveform in backstep style. Often used for power calculations.

Offset and Scale

Allowsyouto adjust the scale of theitem asit is seen on thedisplay. Offset isthe number
of pixels offset from zero. The scale factor reduces (if lessthan 1) or increases (if greater
than 1) the number of pixels displayed.

Only the following types are supported in Analog format:

VHDL types.
All vectors - std logic vectors, bit vectors, and vectors derived from these types
Scalar integers
Scalar reals
Scalar times

Verilog types:
All vectors
Scalar reals
Scalar integers

SystemC types:
Vector types (sc_int<>, sc_higint<>, etc.)
Scalar integers (char, short, int, long, etc.)
float, double



===t wave - default Bi=

Wave window UM-351

The signalsin the following illustration demonstrate the various signal formats.
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» Height
Allows you to specify the height (in pixels) of the waveform.

The Compar etab includes the same options asthose in the Add Signal Options dial og box
(see "Comparison Method tab" (UM-463)).
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Setting Wave window display properties

Y ou can define display properties of the Wave window by selecting Tools > Window
Prefer ences (Wave window). Y ou can make these changes permanent by selecting T ools
> Save Preferences (Main window). See "Preference variables located in Tcl files' (UM-
631) for details on changing window properties permanently.

The dialog box has two tabs-Display and Grid & Timeline.

Window Preferences |

Display | Grid & Timeline |

—Dizplay Signal Path—————— —Snap Distance
0 [# elements] 10 [pixels]
Usze 0 for full path ~Fow Margin

4 [pixelz]

—Child B owe b argin——

@ |eft ¢ Right 2 [pinels)

—Enable/Dizable

—Justify W alue

¥ ‘“wWaveform Popup Enabled

[ “wWaveform 5 election Highlighting E nabled

¥ Double-Click to Show Drivers [Dataflow Window)
[ On Clase Warn for Save Format

—Datazet Prefiz Display
£ Always Show Datazet Prefises
& Show Datazet Prefizes if 2 or more

" Mever Show D atazet Prefizes

] Cancel

The Display tab includes the following options:

 Display Signal Path
Sets the display to show anything from the full pathname of each signal (e.g., sim:/top/
clk) to only itsleaf element (e.g., sm:clk). A non-zero number indicates the number of
path elements to be displayed. The default is Full Path.

» Jugtify Value
Specifieswhether the signal valueswill bejustified to the left margin or theright margin
in the values window pane.
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Snap Distance
Specifies the distance the cursor needs to be placed from an item edge to jump to that
edge (a 0 specification turns off the snap).

Row Margin
Specifies the distance in pixels between top-level signals.

Child Row Margin
Specifies the distance in pixels between child signals.

Waveform Popup Enable
Toggles on/off the popup that displays when you rest your mouse pointer on asignal or
comparison object.

Waveform Selection Highlighting Enabled
Toggleson/off waveform highlighting. When enabled the waveformishighlighted if you
select the waveform or its value.

Double-Click to Show Drivers (Dataflow Window)
Toggles on/off double-clicking to show the drivers of the selected waveform. See
"Displaying drivers of the selected waveform" (Um-347) for more details.

On Close Warn for Save Format

Toggles on/off a message that prompts you to save the Wave window format when you
close the window. See "Displaying drivers of the selected waveform" (Um-347) for more
details.

Dataset Prefix
Specifies how signals from different datasets are displayed.

Always Show Dataset Prefixes

All dataset prefixes will be displayed along with the dataset prefix of the current
simulation ("sim™).

Show Dataset Prefixesif 2 or more

Displaysall dataset prefixesif 2 or more datasetsare displayed. "sim" isthe default prefix
for the current simulation.

Never Show Dataset Prefixes
No dataset prefixeswill be displayed. This selection is useful if you are running only a
single simulation.

UM-353
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Window Preferences il

Dizplay  Grid & Timeline |

— Gnd Configuration
—Gnd Offget———— "Minimum and Spacing
]—‘

0 nsz 40 [pirelz

—Gnd Period

1 s Feszet to Diefault |

— Timeline Configuration

&+ Display simulation time in imeline area

" Display gd period count [eycle count]

The Grid & Timedinetab is used to configure grid lines and the horizontal axisin the
waveform pane. Y ou can also access this tab by right-clicking in the cursor tracks at the
bottom of the Wave window and selecting Grid & Timeline Properties. The tab has the
following options:

» Grid Offset
Specifies the time (in user time units) of thefirst grid line. Default is 0.

» Grid Period
Specifies the time (in user time units) between subsequent grid lines. Default is 1.

* Minimum Grid Spacing
Specifiestheclosest (in pixels) two grid lines can be drawn before intermediate lines will
be removed. Default is 40.

» Timeline Configuration
Specifies whether to display simulation time or grid period count on the horizontal axis.
Default isto display simulation time.
Sorting a group of items

Select View > Sort to sort the items in the pathname and values panes.

Setting signal breakpoints

Y ou can set "Signal breakpoints' (UM-391) in the Wave window. When asignal breakpoint
is hit, amessage appears in the Main window Transcript stating which signal caused the
breakpoint.

Toinsert asignal breakpoint, right-click asignal and select Insert Breakpoint. A
breakpoint will be set on the selected signal. See"" Creating and managing breakpoints” (UM-
391) for more information.
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Finding items by name or value in the Wave window

The Find dialog box —
allowsyoutosearchfor  LELLAUIRIEVE A
text stringsin the Wave

window. Select Find: | Find Mest

Edit > Find (Wave

window) to bring up Field Direction Cloze
the Find dialog box. = Mame = Down

! [T Exact
Choose either the " Valus  Up
Nameor Valuefield to W Auto Wrap

search and enter the
valueto search for in
the Find field. Find the
item by searching Down or Up through the Wave window display.

Check Exact if you only want to find items that match your search exactly. For example,
searching for "clk" without Exact will find /top/clk and clk1.

Check Auto Wrap to continue the search at the beginning of the window.
The find operation works only within the active pane.
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Searching for item values in the Wave window

Select an item in the Wave window and then select Edit > Sear ch to bring up the Wave
Signal Search dialog box.

|:;-.__1"1|I|I’ave Signal Search [window wave]

—Signal Hamels]
Mo Signalz Selected

—Search Type
= Ay Transition

" Rising Edge

" Falling Edge

" Search for Signal Yalue "-.-"alue:l

™ Search for Expression E:-:pressi-:un:l Builder

—Search Options

I'I bl atch Count

—5Search Aesults
Status:

Time: Cane

Search Fomward

Search Beverse

The Wave Signal Search dialog box includes these options:

Y ou can locate values for the Signal Name(s) shown at the top of the dialog box. The
search is based on these options:

» Search Type: Any Transition
Searches for any transition in the selected signal (s).

 Search Type: Rising Edge

Searches for rising edges in the selected signal (s).
* Search Type: Falling Edge

Searches for falling edges in the selected signal(s).
» Search Type: Search for Signal Value

Searches for the value specified in the Value field; the value should be formatted using
VHDL or Verilog numbering conventions; see "Numbering conventions' (CR-21).

P Note: If your signal valuesaredisplayed in binary radix, see" Searching for binary signal
valuesinthe GUI" (CR-30) for details on how signal val ues are mapped between abinary
radix and std_logic.
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» Search Type: Search for Expression
Searches for the expression specified in the Expression field evaluating to a boolean
true. Activatesthe Builder button so you can use" The GUI Expression Builder" (Um-395)
if desired.

The expression can involve more than one signal but is limited to signals logged in the
Wave window. Expressions can include constants, variables, and DO files. If no
expression is specified, the search will give an error. See"Expression syntax” (CR-24) for
more information.

» Search Options. Match Count
Y ou can search for the nth transition or the nth match on value; Match Count indicates
the number of transitions or matches to search for.

The Search Results are indicated at the bottom of the dialog box.
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Using time cursors in the Wave window

=4 wave - default : 10| x|

File Edit Wew Insert Format Tools  Window
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click name or value to interval measurement
select or double-click to
jump to that cursor locked cursor is red selected cursor is bold

When the Wave window isfirst drawn, there is one cursor located at time zero. Clicking
anywhere in the waveform display brings that cursor to the mouse location. Y ou can add
cursors to the waveform pane by selecting Insert > Cursor (or the Add Cursor button
shown below). The selected cursor isdrawn asabold solid line; all other cursors are drawn

with thin lines. Remove cursors by selecting them and selecting Edit > Delete Cursor (or
the Delete Cursor button shown below).

Insert Cursor Delete Cur sor
E? add acursor to the ,Pé delete the selected cursor
waveform window from the window

Naming cursors

By default cursors are named "Cursor <n>". To rename a cursor, click the namein the left-

hand cursor pane with your right mouse button. Type a new name and press the <Enter>
key on your keyboard.

ModelSim SE User’'s Manual



Wave window UM-359

Locking cursors

Y ou can lock acursor in position so it won’t move. Select the cursor you wish to lock and
select Edit > Edit Cursor (Wave window). In the dialog that appears, check L ock cur sor
to specified timeand click OK. The cursor turns red and you can no longer drag it with the
mouse.

As aconvenience, you can hold down the <shift> key and click-and-drag alocked cursor.
Onceyou let go of the cursor, it will be locked in the new position.

Tounlock acursor, select Edit > Edit Cursor and uncheck L ock cur sor to specified time.

Finding cursors

The cursor value correspondsto the simul ation time of that cursor. Choose a specific cursor
view by selecting View > Cursors.

Y ou can also access cursors by clicking a name or value in the left-hand cursor pane.
Single-clicking selects a cursor; double-clicking jumpsto a cursor. Alternatively, you can
click avalue with your second mouse button and type the val ue to which you want to scroll.

Making cursor measurements

Each cursor is displayed with atime box showing the precise simulation time at the bottom.
When you have more than one cursor, each time box appearsin a separate track at the
bottom of the display. Model Sim & so adds a delta measurement showing the time
difference between two adjacent cursor positions.

If you click in the waveform display, the cursor closest to the mouse position is selected
and then moved to the mouse position. Another way to position multiple cursorsisto use
the mouse in the time box tracks at the bottom of the display. Clicking anywherein atrack
selects that cursor and brings it to the mouse position.

Cursorswill "snap" to awaveform edge if you click or drag a cursor to within ten pixels of
awaveform edge. Y ou can set the snap distance in the Window Preferences dialog (select
Tools > Window Preferences). You can position a cursor without snapping by dragging
in the cursor track below the waveforms.

Y ou can al'so move cursors to the next transition of a signal with these toolbar buttons:

Find Previous Find Next Transition
Transition locate the next signal

—lt locate the previous signal ﬂ— value change for the
value change for the selected signal
selected signa
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Examining waveform values

Y ou can use your mouse to display a dialog that shows the value of awaveform at a
particular time. Y ou can do this two ways:

Rest your mouse pointer on awaveform. After a short delay, a dialog will pop-up that
displaysthe value for the time at which your mouse pointer is positioned. If you'd prefer
that this popup not display, it can be toggled off in the display properties. See " Setting
Wave window display properties’ (UM-352).

Right-click awaveform and select Examine. A dialog displays the value for the time at
which you clicked your mouse.

Zooming - changing the waveform display range

Zooming lets you change the simulation range in the waveform pane. Y ou can zoom using
the context menu, toolbar buttons, mouse, keyboard, or commands.

Y ou can access Zoom commands from the View menu on the toolbar or by clicking the
right mouse button in the waveform pane.

The Zoom menu options include:

Zoom Full
Redraws the display to show the entire simulation from time O to the current simulation
time.

Zoom In
Zooms in by afactor of two, increasing the resolution and decreasing the visible range
horizontally.

Zoom Out
Zooms out by afactor of two, decreasing the resolution and increasing the visible range
horizontally.

Zoom Last
Restores the display to where it was before the last zoom operation.

Zoom Range
Bringsup adialog box that allowsyou to enter the beginning and ending timesfor arange
of time unitsto be displayed.

Zooming with toolbar buttons

These zoom buttons are available on the toolbar:

&

Zoom In 2x
zoom in by afactor of two
from the current view

Zoom Out 2x
zoom out by afactor of
two from current view

Zoom Full

zoom out to view the full
range of the simulation
from time 0 to the current
time

Zoom Mode
change mouse pointer to
zoom mode; see below
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Zooming with the mouse

To zoom with the mouse, first enter zoom mode by selecting View > M ouse M ode > Zoom
M ode (Wave window). The left mouse button (<Button-1>) then offers 3 zoom options by
clicking and dragging in different directions:

*  Down-Right or Down-Left: Zoom Area (In)
* Up-Right: Zoom Out
*  Up-Left: Zoom Fit

The zoom amount is displayed at the mouse cursor. A zoom operation must be more than
10 pixelsto activate.

Y ou can al so enter zoom mode temporarily by holding the <Ctrl> key down whilein select
mode.

With the mouse in the Select M ade, the middle mouse button will perform the above zoom
operations.

Zooming keyboard shortcuts

See "Wave window mouse and keyboard shortcuts® (um-363) for a complete list of Wave
window keyboard shortcuts.

Saving zoom range and scroll position with bookmarks

Bookmarks allow you to save a particular zoom range and scroll position. Thisletsyou
return easily to aspecific view later. Y ou save the bookmark with a name, and then access
the named bookmark from the Bookmark menu.

Bookmarks are saved in the Wave format file (see "Adding items with a Wave window
format file" (UM-339)) and are restored when the format file isread. Thereisno limit to the
number of bookmarks you can save.

Bookmarks can also be created and managed from the command line. See the bookmark
add wave command (CR-77) for details.

To add a bookmark, select Insert > Bookmark (Wave window).

Bookmark Properties (.wave! #

——Baookmark Mame

|I:u:u:ukmark[l

—=oom Hange Top Indes—
|EI hs tol 315 ns ’E

¥ Save zoom range with bookmark:

¥ iS5 ave seroll location with boalk mark

Ok | Cancel
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The Bookmark Properties dialog includes the following options.

Bookmark Name
A text label to assign to the bookmark. The name will identify the bookmark on the
View > Bookmarks menu.

Zoom Range
A starting value and ending value that define the zoom range.

Top Index
Theitem that will display at thetop of the Wavewindow. For instance, if you specify 15,
the Wave window will be scrolled down to show the 15th item in the window.

Save zoom range with bookmar k
When checked the zoom range will be saved in the bookmark.

Save scroll location with bookmark
When checked the scroll location will be saved in the bookmark.

Once the bookmark is saved, select it by name from the View > Bookmar ks menu, and the
Wave window will be zoomed and scrolled accordingly.

To edit or delete a bookmark, select Tools > Bookmarks (Wave window).

Bookmark Selection X
bookmarkd
ookmark 1 Add
Fodify. ..
Delete
Gotko

Bookmark Configuration
Mame: biookmark 1
Zoom Range: {0 nz} {628 st
Top Indes: 1]
(] 3 Cancel

The Bookmark Selection dialog includes the following options.

Add (bookmark add wave)
Add anew bookmark.

M odify
Edit the selected bookmark.

Delete (bookmark delete wave)
Delete the selected bookmark.

Goto (bookmark goto wave)
Zoom and scroll the Wave window using the sel ected bookmark.
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Wave window mouse and keyboard shortcuts

See "Wave window mouse and keyboard shortcuts' (Um-643).

Printing and saving waveforms

Saving a .eps file and printing under UNIX

Select File > Print Postscript (Wave window) to print all or part of the waveform in the
current Wave window in UNIX, or save the waveform as a .eps file on any platform (see
also thewrite wave command (CR-397)). Printing and writing preferences are controlled by

the dialog box shown below.
Wite Postseript _—_______________________________________H|
—Frinter

" PFrint command: |I|:| -dIp1 ;I
Setup... |
% File name: |E:a’w’INNTa’Perilesfcharleya’E Browse... |

—Signal Selection —Time Range
Al signals " Full Bange O ns 2820 ns
% Current view % Cumentviews 1869 ns 2869 nz

" Selected " Custom From: j’ To: j’

Ok | Cancel |

The Write Postscript dialog box includes these options:

Printer

* Print command
Enter aUNIX print command to print the waveform in a UNIX environment.

» Filename
Enter afilename for the encapsulated Postscript (.eps) file to be created; or browse to a
previously created .epsfile and use that filename.

Signal Selection

» All signals
Print al signals.

» Current View
Print signalsin the current view.

» Selected
Print all selected signals.

ModelSim SE User’s Manual



UM-364 10 - Graphic interface

Time Range

* Full Range
Print al specified signalsin the full simulation range.

» Current view
Print the specified signals for the viewable time range.

» Custom
Print the specified signals for a user-designated From and To time.

Setup button
See "Printer Page Setup" (UM-366)

Printing on Windows platforms

Select File> Print (Wavewindow) to print all or part of the waveformin the current Wave
window, or save the waveform as a printer file (a Postscript file for Postscript printers).
Printing and writing preferences are controlled by the dialog box shown below.

—Printer

Mame:  [MALINKAGE'HP Lasenlet 5L r|  Propeities |
Statusz: Ready
Type: HF Lazerlet 5L Setup... |

YWhere: Local
Comrment; ™ Print ta file
—Signal Selection——————— —Time Range
Al signals " FulRange 0 ns 2820 nz
% Cument wiew = Cument view 1869 ns 2869 nz

" Selected " Custom Fram: j’ Ta j’

Ok Cancel
Printer
* Name
Choose the printer from the drop-down menu. Set printer properties with the Properties
button.
» Status

Indicates the availability of the selected printer.
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* Type
Printer driver name for the selected printer. The driver determines what type of fileis
output if "Print to file" is selected.

* Where
The printer port for the selected printer.

» Comment
The printer comment from the printer properties dialog box.

* Print tofile
Make this selection to print the waveform to afileinstead of aprinter. The printer driver
determines what type of fileis created. Postscript printers create a Postscript (.ps) file,
non-Postscript printers create a.prn or printer control language file. To create an
encapsulated Postscript file (.eps) use the File > Print Postscript menu selection.

Signal Selection

» All signals
Print all signals.

» Current View
Print signalsin current view.

* Selected
Print all selected signals.

Time Range

* Full Range
Print al specified signalsin the full simulation range.

» Current view
Print the specified signals for the viewable time range.

» Custom
Print the specified signals for a user-designated From and To time.

Setup button
See "Printer Page Setup” (UM-366)

UM-365
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Printer Page Setup

Clicking the Setup button in the Write Postscript or Print dialog box allows you to define
the following options (thisis the same dialog that opens via File > Page setup).

Page Setup 3
—Paper TUnitz——— 1 Marginz
Faper size: Tap: Irﬁ
Letter hd ¥ inches Bottom: [05 =
Wit BB - . Lef:  [05 =
Height: [0 = Righe o5 =
~ Label width ~Curzors ~Grid ~ Calar
" Color
& Auto Adjust & 0if O
€ Fiwedwidh: [15 = £ On & On . o
* BEW

~Scaling ~Onientation

" Figed: |500ns ﬁ per page " Porhrait
f Fitta: |1 i’ page(s] wide {* Landscape

ok | Cancel

» Paper Size
Select your output page size from a number of options; aso choose the paper width and
height.

* Units
Specify whether measurements are in inches or centimeters.
e Margins
Specify the page margins; changing the M ar gin will change the Scale and Page
specifications.
» Label width
Specify Auto Adjust to accommodate any length label, or set afixed label width.

» Cursors
Turn printing of cursors on or off.
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Grid
Turn printing of grid lines on or off.

Color
Select full color printing, grayscale, or black and white.

Scaling

Specify aFixed output time width in nanoseconds per page — the number of pages output
is automatically computed; or, select Fit to to define the number of pages to be output
based on the paper size and time settings; if set, the time-width per page is automatically
computed.

Orientation
Select the output page orientation, Portrait or Landscape.

UM-367
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Compiling with the graphic interface

Y ou can use aproject or the Compile Sour ce Files dialog box to compile VHDL or Verilog
designs. For information on compiling in aproject, see " Getting started with projects’ (UM-
34). To open the Compile Source Files dialog, select Compile> Compile (Main window).

Compile HDL Source Files i d
Library: Iwnrk j
Lok in: | 2l dataflow ~| « & ef B
| 1demos set.vhd
_Jwork I:l:up.vhl:l
yw|andz.vhd I:n:p_n:rig.vhu:l
v |cache, v tDp_Sp';.-'.'«.-'hd
WL|Memary v util.vhd
Eprnc.v

File name: | Compile

Files of type:  |HDL Files [v" vl vhd: vho hdlve) 7] Dane

Default Optionz. . Edit Source |

From the Compile Source Files dialog box you can:

* select source files to compile in any language combination

« specify the target library for the compiled design units

» select among the compiler options for VHDL, Verilog, or SystemC

Select the Default Options button to change the compiler options, see " Setting default
compile options' (UM-370) for details. The same Compiler Options dialog box can also be
accessed by selecting Compile > Compile Options (Main window) or by selecting
Compile Properties from the context menu in the Project tab.

Select the Edit Sour ce button to view or edit a source file viathe Compile dialog box. See
"Source window" (Um-325) for additional source file editing information.
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Locating source errors during compilation

If acompiler error occurs during compilation, ared error message is printed in the Main
transcript. Double-click on the error message to open the source file in an editable Source

window with the error highlighted.

ﬁMDdElSiI‘I‘I

=10 x|

File= Edit

View Compile Simulake  Tools

Window Help

z=B||cng

“Workspace

X

Mame

-l vital2000

MStd
A .

e

Library

#t -- Compiling entity adder

#t -- Compiling architecture rtl of adder

# = Enor: [voom-11] Could not find wark. gates.

# * Emor: C:/modeltech/examplzes adder. vhd[24):

. . cannat find expanded name: work. gates
m 1"eE . L!I:ur-: # = Enar: C:/modeltech/exanmples/adder. vhd[24]:
m radelzim_lib Librz
Libre

Uk gawn field: gates.
;ﬁmr: C:/modeltelchs/examples/adder. vhd[25]:
OL

Compiler exiting
# Co/modeltechdwind2vcom faled.

MadelSim: |

B source - adder.vhd

=

|=:ND Desigh Loaded= ‘{Nn Context: File \Edit View Tools Window
SEHS L DB OWoOx B[ W
double-click on the error in the Main window * | In 1\:t\l C:/modeltech/examples/add
and the error is highlighted and ready 1 sum <= {(a xar b} xar ein;
to edit in the Source window 13 cont <= (a and b) or (cin and a) or (e
ED end rtl;
zl
ZE
z3 —- scription of adder using component in
Z4 use work.gates.all;
25 architecture structural of adder is
G signal xorl out,
A andl_ out,
g and? out,

4| Irl proc.y | adder.vhd ]
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Setting default compile options

Select Compile > Compile Options (Main window) to bring up the Compiler Options
dialog.

A 'mportant: Note that changes made in the Compiler Options dialog box become the
default for all future smulations.

VHDL compiler options tab

Compiler Options " £l

WHOL ] Yerilog ] Coverage ] System[ﬁ]

— Language Syntar—— [ Don't put debugging info in librany
= Usze 1076-1987 V' Use explicit declarations anly
= sze 10761993 I™ Dizable loading messages
f* |z 1076-2002 I~ Show source lines with errors

[ Dizable all optimizationz

— Check for————— —Report Warnings On:

[T Sunthesiz
v Unbound component

¥ WITAL Compliance _
¥ Process without & 'WAIT statement

o ¥ Mull range
— Optimize far:
W Mo zpace in time literal [e.g. Bnz)
¥ StdLogic1164

v WITAL

FD ther WHDOL Options

<

W Hultiple drivers on unresolved signals

ak. Cancel Apply

The VHDL compiler options tab includes the following options:

» Language Syntax
Specifies which version of the 1076 standard to use when compiling. The default for
versions 5.8 and later is2002. Y ou can also set this with arguments to the vcom
command (CR-303) or by editing the VHDL standard (Um-630) variable in the
modelsim.ini file. Changing the setting in the modelsim.ini file will make the setting
permanent.
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» Don’t put debugging infoin library
Models compiled with this option do not use any of the Model Sim debugging features.
Conseguently, your user will not be able to see into the model. This also means that you
cannot set breakpoints or single step within this code. Don’t compile with this option
until you are done debugging. Same as the -nodebug argument to the vcom command
(CR-303). Edit the NoDebug (uM-619) variable in the modelsim.ini file to set a permanent
defaullt.

» Useexplicit declarations only
Used to ignore an error in packages supplied by some other EDA vendors; directs the
compiler to resolve ambiguous function overloading in favor of the explicit function
definition. Same as the -explicit argument to the vcom command (CR-303). Edit the
Explicit (um-619) variable in the modelsim.ini file to set a permanent defaullt.

Although it isnot intuitively obvious, the = operator isoverloaded in thestd_logic_1164
package. All enumeration datatypesin VHDL get an “implicit” definition for the =
operator. So while thereis no explicit = operator, thereisan implicit one. Thisimplicit
declaration can be hidden by an explicit declaration of = in the same package (LRM
Section 10.3). However, if another version of the = operator is declared in a different
package than that containing the enumeration declaration, and both operators become
visible through use clauses, neither can be used without explicit naming, for example:

ARITHVETIC. " =" (l eft, right)
This option allows the explicit = operator to hide the implicit one.

 Disable loading messages
Disables |oading messages in the Main window. Same as the -quiet argument for the
vcom command (CR-303). Edit the Quiet (UM-619) variable in the modelsim.ini file to set
apermanent default.

» Show sourcelineswith errors
Causes the compiler to display the relevant lines of code in the transcript. Same as the
-sour ce argument to the vcom command (CR-303). Edit the Show_source (UM-619)
variable in the modelsim.ini file to set a permanent default.

 Disable all optimizations
Instructs the compiler to remove al optimizations. Same as the -O0 argument to the
vcom command (CR-303). Useful when running "Code Coverage" (Um-419), where
optimizations can skew results.

Check for:

* Synthesis
Turnson limited synthesis-rule compliance checking. Checks only signalsused (read) by
aprocess; also, checks understand only combinational logic, not clocked logic. Edit the
CheckSynthesis (UM-619) variable in the modelsim.ini file to set a permanent default.

 Vital Compliance
Toggle Vital compliance checking. Edit the NoVital Check (Um-619) variable in the
modelsim.ini file to set a permanent default.
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Report Warnings on:

Unbound component

Flags any component instantiation in the VHDL source code that has no matching entity
inalibrary that is referenced in the source code, either directly or indirectly. Edit the
Show_Warningl (Um-619) variable in the modelsim.ini file to set a permanent default.

Process without a WAIT statement
Flags any process that does not contain await statement or a sensitivity list. Edit the
Show_Warning2 (Um-619) variable in the modelsim.ini file to set a permanent default.

Null range
Flags any null range, such as 0 down to 4. Edit the Show_Warning3 (UmM-620) variablein
the modelsim.ini file to set a permanent default.

No spacein timeliteral (e.g. 5ns)
Flags any timeliteral that is missing a space between the number and the time unit. Edit
the Show_Warning4 (Um-620) variable in the modelsim.ini file to set apermanent default.

Multiple driverson unresolved signals
Flags any unresolved signals that have multiple drivers. Edit the Show_Warning5 (Um-
620) variable in the modelsim.ini file to set a permanent default.

Optimize for:

StdL ogic1164

Causes the compiler to perform specia optimizations for speeding up simulation when
the multi-value logic package std_logic 1164 is used. Unless you have modified the
std_logic_1164 package, this option should always be checked. Edit the Optimize 1164
(UM-619) variable in the modelsim.ini file to set a permanent default.

Vital

Toggle acceleration of the Vital packages. Edit the NoVital (uM-619) variable in the
modelsim.ini file to set a permanent default.

Other VHDL options
Enter any other valid vcom arguments. See the vcom command (CR-303) intheModelSm
Command Reference for a completelist.
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Verilog compiler options tab

Compiler Dptions |

WHOL Werilog ] Coverage ] SystemE]

[” Enable runtime hazard checks [T Dizable loading messages
[T Dizable debugging data [ Show source lines with ermors
[T Corvert identifiers to upper-case [ Dizable all optimizations

[ “erlog 1995 Compatible [ Enable “protect uzage

— Other Yerlog Ophions

Library Search...

Extenzion.. —

Library File...

Inchude Directony...

kacro...

(] LCancel Apply

» Enableruntime hazard checks
Enables the run-time hazard checking code. Same as the -hazar ds argument to the viog
command (CR-345). Edit the Hazard (Um-618) variable in the modelsim.ini fileto set a
permanent default.

 Disable debugging data
Models compiled with this option do not use any of the Model Sim debugging features.
Consequently, your user will not be able to see into the model. This also means that you
cannot set breakpoints or single step within this code. Don’t compile with this option
until you are done debugging. Same as the -nodebug argument for the viog command
(CR-345). Edit the NoDebug (UM-619) variable in the modelsim.ini file to set a permanent
default.

» Convert identifiersto upper-case
Converts regular Verilog identifiers to uppercase. Allows case insensitivity for module
names. Same asthe -u argument to theviog command (CR-345). Edit the UpCase (UM-618)
variable in the modelsim.ini file to set a permanent default.
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Verilog 1995 Compatible

Some requirementsin Verilog 2001 conflict with requirementsin the 1995 LRM. Use of
this option ensures that code that was valid according to the 1995 LRM can till be
compiled. Same asthe -vlog95compat argument to the viog command (CR-345). Edit the
vlog95compat (UM-618) variable in the modelsim.ini file to set a permanent default.

Disable loading messages

Disables |oading messages in the Main window. Same as the -quiet argument for the
vlog command (CR-345). Edit the Quiet (UM-619) variable in the modelsim.ini fileto set a
permanent default.

Show sourcelineswith errors

Causes the compiler to display the relevant lines of code in the transcript. Same as the
-sour ce argument to the viog command (CR-345). Edit the Show_source (Um-619) variable
in the modelsim.ini fileto set a permanent default.

Disable all optimizations

Instructs the compiler to remove all optimizations. Same asthe-O0 argument to the vliog
command (CR-345). Useful when running "Code Coverage" (UM-419), where
optimizations can skew results.

Enable “protect usage

Enables encryption of regions of your Verilog source code. See "Model Sim compiler
directives' (UM-152) for more details. Same as the +protect argument for the viog
command (CR-345). Edit the Protect (Um-618) variable in the modelsim.ini file to set a
permanent default.

Other Verilog Options:

Specify any valid vlog command (CR-345) arguments. When you specify Other Verilog
Options, they are saved into afile called viog.opt. If you do thiswhile aproject is open, an
OptionFile entry iswritten into your project file. If you do this when aproject is not open,
an OptionFile entry iswritten into the modelsim.ini file that you are currently using.

* Library Search
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Specifies the Verilog source library directory to search for undefined modules. Same as
the -y <library_directory> argument for the viog command (CR-345).

Extension
Specifies the suffix of filesin the library directory. Multiple suffixes can be used. Same
as the +libext+<suffix> argument for the vlog command (CR-345).

Library File
Specifiesthe Verilog source library file to search for undefined modules. Same asthe -v
<library_file> argument for the viog command (CR-345).

Include Directory
Specifies adirectory for filesincluded with the ‘include filename compiler directive.
Same as the +incdir +<directory> argument for the vilog command (CR-345).

Macro

Defines amacro to execute during compilation. Same as the compiler directive: ‘ define
macro_name macro_text. Also the same as the

+definet<macro_name> [ =<macro_text> ] argument for the viog command (CR-345).
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Coverage compiler options tab
The options on this tab are described in the section "Enabling Code Coverage" (Um-423).

SystemC compiler options tab

»¢ Compiler Options ] x|

VHOL | Werilog | Coverage System( |

[~ Enahble compilation log file

File path: Browse.., |

[ Include SystemC verification librarny

[~ Enahle verbose sccom messages

— Other CPP Options

Include Directory...

flacro...

[ Enable Debug hode Optimization Level  =none= — |

(0] Cancel | Apply |

» Enable compilation log file
Writesthe compilation output to afile name, specifiedintheFile path field. Same asthe
-log argument to the sccom command (CR-248).

* Include SystemC verification library
Includes the SystemC verification library. Same as the -scv argument to the sccom
command (CR-248).

» Enable verbose sccom messages
Echoes subprocess invocations with command arguments. Same as the -verbose
argument to the sccom command (CR-248).

Other CPP Options

Specify any valid g++/aCC compiler options. All options are accepted, with the exception
of the -0 and -c options.

* Include Directory
Includes a directory that contains source files. Same as the -I argument to g++/aCC.

* Macro
Defines amacro. Same as the -D argument to g++/aCC.
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» Enable Debug Mode
Compiles SystemC code with debugging information. By default SystemC codeis
compiled without debugging information. Same as the -g argument to g++/aCC.

» Optimization level
Specify optimization value you wish to use. By default, no optimization is performed.
Same as the -O# argument to g++/aCC.

Setting SystemC link options

Before you can simulate a SystemC design, you must link the design. The SystemC linking
collects the abject files created in the different design libraries, and uses them to build a
shared library (.s0) in the current work library. To link the design using the GUI, select
Compile-> SystemC Link. A dialog box opens, allowing you to enter any g++/aCC
linking options your design requires.

SystemC Link | x|

[ Include SystemC verification library

—SysternC Link Options

Link LCancel

* Include SystemC verification library
Includes the SystemC verification library. Same as the -scv argument to the sccom
command (CR-248).

» SystemC Link Options
Specify any valid g++/aCC linking options (e.g. -I, -L, etc.). All options are accepted.
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Simulating with the graphic interface

Design tab

Y ou can use the Library tab in the workspace or the Simulate dialog box to simulate a
compiled design. To simulate from the Library tab, simply double-click adesign unit. To
open the Simulate dialog, select Simulate > Simulate (Main window).

Six tabs - Design, VHDL, Verilog, Libraries, SDF, and Options - allow you to select
various simulation options. Y ou can switch between tabs to modify settings, then begin
simulation by selecting the OK button.

B 'Simulate _ o] %]

Design | WHOL | Werilog | Libraries | SDF | Options |

M ame | Tupe | Path fovst
m ik, Libramn Sdatafhow Aok,
Ill test Library C: Adataflow/test

m wital2000 Library FRMODEL_TECH/. Mvital2000

m ieee Library FMODEL_TECH/!.. fiees

M modelzinn_lib Library $MODEL_TECH/.. /modelzim_lib

m ztd Library FMODEL_TECH/. f2td

m ztd_developerzkit Library $MODEL_TECH/.. fetd_developer:

M ZUNOPEYE Libramn FMODEL_TECH!.. /eynopsus

M werlog Library FMODEL_TECH/... Mverlog s
1] | i
— Simulate Rezolution
I ’;ault ZI Optimize

. | Cancel

The Design tab includes these options:

» Simulate
Specifies the design unit(s) to simulate. Y ou can simulate your Verilog top-level
module(s), a VHDL top-level design unit, or your SystemC top-level module(s) in one
of two ways:

- Type adesign unit name (configuration, module, or entity) into the field, separate
additional names with a space. Specify library/design units with the following syntax:

[<l'ibrary_name>.]<design_unit>

- Select adesign unit from thelist. Y ou can select multiple design units from the list by
using the control key when you click.

ModelSim SE User’s Manual



UM-378 10 - Graphic interface

* Resolution
(-t [<multiplier>]<time_unit>)
The drop-down menu sets the simulator time units.

Simulator time units can be expressed as any of the following:

Simulation time units

1fs, 10fs, or 100fs femtoseconds
1ps, 10ps, or 100ps picoseconds
1ns, 10ns, or 100ns nanoseconds
1us, 10us, or 100us microseconds
Ims, 10ms, or 100ms milliseconds
1sec, 10sec, or 100sec seconds
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See also, "Simulator resolution limit" (UM-77).

* Optimize
Recompile the selected Verilog design unit using +opt optimizations. Please read
"Compiling for faster performance" (Um-127) before using this option.



VHDL tab

Simulate

Simulating with the graphic interface  UM-379

Design WHOL | Werilog | Libraries | SDF | Options |

— [aenenics
Mame I Walue I Overide Add.
Fd cdify. ..
Delete
1 | *
— WITAL —  TEXTIO Files
— STO_IMPUT
[ Dizable Timing Checks I Browss
r Ilze "v"ite!l 2._2I:| SOF Mapping
[default is Wital 95) ——5TD_OUTPUT
[T Dizable Glitch Generation | Browsze. ..

k. | Cancel |

The VHDL tab includes these options:

Generics

The Add button opens a dialog box (shown below) that allows you to specify the value of
generics within the current simulation; generics are then added to the Genericslist. You

can also select ageneric on the listing to Delete or Edit.

From the Specify a

Genericdialogbox youcan

set the following options.

Generic Name (-g
<Name>=<Vaue>)

The name of the generic
parameter. Typeitinasit
appearsinthe VHDL
source (case isignored).

Generic Value
Specifiesavalue for all
genericsin the design

B 'specify a Generic

— Genenc Mame

=10 x|

— Genenc Yalue

[T Owvenide Instance-specific % alues

0k Cancel

with the given name
(above) that have not

received explicit values in generic maps (such as top-level generics and generics that
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would otherwise receive their default value). The value must be appropriate for the
declared data type of the generic. No spaces are allowed in the specification (except
within quotes) when specifying a string value.

» Override Instance - specific Values (-G <Name>=<Vaue>)
Select to override generics that received explicit valuesin generic maps. The name and
value are specified as above. The use of thisswitch isindicated in the Override column
of the Genericslist.

VITAL

 Disable Timing Checks (+notimingchecks)
Disables timing checks generated by VITAL models.

» UseVital 2.2b SDF M apping (-vital2.2b)
Selects SDF mapping for VITAL 2.2b (default is Vital95).

* Disable Glitch Generation (-noglitch)
Disables VITAL glitch generation.

TEXTIO files

o STD_INPUT (-std_input <filename>)
Specifies the file to use for the VHDL textio STD_INPUT file. Use the Browse button
to locate afile within your directories.

e STD_OUTPUT (-std_output <filename>)
Specifiesthefileto usefor the VHDL textio STD_OUTPUT file. Usethe Browse button
to locate afile within your directories.
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Simulate

Simulating with the graphic interface UM-381

Design | WHOL Werllog | Libraries | SDF | Options |

— Pulze Optionz

Digable pulze emar and
Warning messages
[+ho_pulze_rmzg]

— Fiejection Limit

I & [+pulze_r]

—Ermor Limit

I Z [+pulze_g]

— Other Options

r Enable Hazard Checking
[-hazards]

Digable Timing Checks in
[T Specify Blocks
[+notimingchecks]

— Delay Selection

default :I

FLI zer Defined Arguments [+<plusarg:]

Optimize Preferences... |

k. | Cancel

The Verilog tab includes these options:

Pulse Options

 Disable pulseerror and warning messages (+no_pulse_msg)

Disables path pulse error warning messages.

* Regjection Limit (+pulse_r/<percent>)
Sets the modul e path pulse rejection limit as a percentage of the path delay.

e Error Limit (+pulse_e/<percent>)

Sets the modul e path pulse error limit as a percentage of the path delay.
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Other Options

Libraries tab

Enable Hazard Checking (-hazards)
Enables hazard checking in Verilog modules.

Disable Timing Checksin Specify Blocks (+notimingchecks)
Disables the timing check system tasks ($setup, $hold,...) in specify blocks.

Delay Selection (+mindelays | +typdelays | +maxdelays)
Use the drop-down menu to select timing for min:typ:max expressions.

User Defined Arguments (+<plusarg>)

Arguments are preceded with “+", making them accessible through the Verilog PLI
routinemc_scan_plusargs. The values specified in this field must have a"+" preceding
them or Model Sim may parse them incorrectly.

Optimize Preferences (-fast +acc)
Enable design unit access for certain modules. See "Enabling design object visibility in
optimized simulations' (UM-389) for details.

Simulate 7 |
Design | WHOL | Werlog  Libraries | SDF | Options |
—Search Libraries [ -L ]
Add...
b dify. .
Delete
— Search Libranes First [ -LF ]
Add...
kA odifu. ..
Delete
] | Caticel |

The Librariestab includes these options:
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Search Libraries(-L)
Specifiesthe librariesto search for design units instantiated from Verilog.

Search LibrariesFirst (-Lf)
Same as Search Libraries but these libraries are searched before ‘usdlib.



SDF tab
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Design | WHOL | Werlog | Libraries SDF | Options |

— SDF Filez
Add...
b odify...
Delete
—5DF Options b ulti-5ource delay
[ Dizable 5DF warnings
O latest € min © max
[ Feduce SOF emors to warnings

OF. |

Cancel |

The SDF (Standard Delay Format) tab includes these options:

SDF Files

Click the Add button to specify the SDF filesto load for the current ssimulation; files are
then added to the SDF Fileslist. You may also select afile on the listing to Delete or

M odify (opens the dialog box below).

s Add SDF Entry - 10| x|
—5DF File
| Browsze... |
—Apply to Reagion Delap—
; o s

[k | Cancel
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From the Add SDF Entry dialog box you can set the following options.

» SDF file ([<region>] = <sdf_filename>)
Specifiesthe SDF fileto use for annotation. Use the Br owse button to locate afile within
your directories.

» Apply toregion ([<region>] = <sdf_filename>)
Specifies the design region to use with the selected SDF options.

» Delay (-sdfmin | -sdftyp | -sdfmax)
The drop-down menu selects delay timing (min, typ, or max) to be used from the
specified SDF file. See a'so, " Specifying SDF files for simulation” (UM-544).

SDF options

* Disable SDF war nings (-sdfnowarn)
Select to disable warnings from the SDF reader.

» Reduce SDF errorsto warnings (-sdfnoerror)
Change SDF errors to warnings so the simulation can continue.

» Multi-Source Delay (-multisource_delay <sdf_option>)
Select max, min, or latest delay. Controls how multiple PORT or INTERCONNECT
constructs that terminate at the same port are handled. By default, the Module | nput Port
Delay (MIPD) is set to the max value encountered in the SDF file. Alternatively, you can
choose the min or latest of the values.
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Design | WHOL | Werilog | Libraries | SDF Options |

[~ Enable code coverage

[ Treat non-existent WHOL filez opened for read az empty

r Do not ghare file dezcriptors for WHOL files opened

for write or append that have identical names

—WLF File

Browse...

Fﬂssert File

Browsze...

— Other optionz

| Cancel |

The Options tab includes these options:

» Enable code coverage (-coverage)
Turn on collection of Code Coverage statistics. Y ou must aso specify which type of
statistics you want when you compile the design. See Chapter 12 - Code Coverage for

more information.

» Treat non-existent VHDL files ... (-absentisempty)
Cause VHDL files opened for read that target non-existent files to be treated as empty,
rather than Model Sim issuing fatal error messages.

» Do not sharefiledescriptors... (-nofileshare)
By default Model Sim shares afile descriptor for al VHDL files opened for write or
append that have identical names. This option turns off file descriptor sharing.

* WLF File (-wlIf <filename>)
Specify the name of the wave log format (WLF) file to create. The default is vsim.wif.

» Assert File (-assertfile <filename>)
Designate an alternative file for recording assertion messages. By default assertion
messages are output to the file specified by the TranscriptFile variable in the

modelsim.ini file (see "Creating atranscript file" (UM-628)).

» Other options

Specify any other vsim command (CR-357) arguments.
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Setting default simulation options

Select Simulate > Simulation Options (Main window) to bring up the Simulation
Options dialog box shown below. Changes made in the Simulation Options dialog box
arethedefault for the current simulation only. Options can be saved asthe default for future
simulations by editing the simulator control variablesin the modelsim.ini file; the variables
to edit are noted in the text below.

Defaults tab

m Simulation Options

=] E3

—Default Badix —Suppress Warnings:
&+ Sumbolic [ From Synopsys Packages
™ Binary [ From IEEE Mumeric 5td Packages
" Octal
 Decimal ~Default Bun ~Default Force Type——
" Unsigned ’ " " Freeze
£ Hexadecind Iteration Lirnit £ Dive
 asol 000 " Deposit
ok LCancel Apply

The Defaults tab includes these options:

» Default Radix

Sets the default radix for the current simulation run. Y ou can also use theradix (CR-235)
command to set the same temporary default. A permanent default can be set by editing
the DefaultRadix (UM-623) variable in the modelsim.ini file. The chosen radix is used for
all commands (for ce (CR-176), examine (CR-167), change (CR-87) are examples) and for
displayed valuesin the Signals, Variables, Dataflow, List, and Wave windows.

* SuppressWarnings

Selecting From Synopsys Packages suppresses warnings generated within the
accelerated Synopsys std_arith packages. Edit the StdArithNoWarnings (UM-625)

variable in the modelsim.ini file to set a permanent default.

Selecting From | EEE Numeric Std Pack ages suppresseswarnings generated within the
accelerated numeric_std and numeric_bit packages. Edit the NumericStdNoWarnings
(UM-624) variable in the modelsim.ini file to set a permanent default.

e Default Run

Sets the default run length for the current simulation. Edit the RunL ength (UM-625)

variable in the modelsim.ini file to set a permanent default.
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* Iteration Limit
Sets alimit on the number of deltas within the same simulation time unit to prevent
infinite looping. Edit the IterationLimit (UM-624) variablein the modelsim.ini fileto set a
permanent iteration limit default.

» Default Force Type
Selects the default force type for the current simulation. Edit the DefaultForceKind (Um-
623) variable in the modelsim.ini file to set a permanent default.

Assertions tab

[¥] Simulation Dptions =]

—Break on Aszertion ~lgnore Azsertions For—
& Fatal [ Failure
" Failure ™ Enor
™ Emar [T waming
& Warning [T Mate
" HNote

ok Cancel Apply

The Assertions tab includes these options:

» Break on Assertion
Selects the assertion severity that will stop simulation. Edit the BreakOnA ssertion (UM-
622) variable in the modelsim.ini file to set a permanent default.

* Ignore Assertions For
Selects the assertion type to ignore for the current simulation. Multiple selections are
possible. Edit the IgnoreFailure, IgnoreError, IgnoreWarning, and IgnoreNote (UM-624)
variablesin the modelsim.ini file to set permanent defaults.

When an assertion type isignored, no message will be printed, nor will the simulation
halt (even if break on assertion is set for that type).

P Note: Assertions that appear within an instantiation or configuration port map clause
conversion function will not stop the simulation regardless of the severity level of the
assertion.
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WLF Files tab

m Simulation Options M=l
—%WLF File Size Limit—————  ——"LF File Time Limit
& Mo Size Limit € Mo Time Limit
" Size Limit [0 © Time Limit [0 [hs 7]
—WLF Attibutes———— — Design Hierarchy
¥ Comprezs WLF data. {* Save regions containing logged signals.
[T Delete "WLF file on exit. " Save all regions in design.
ok LCancel Apply

The WLF Filestab includes these options:

* WLF File Size Limit
LimitstheWLFfileby size(asclosely aspossible) to the specified number of megabytes.
If both size and time limits are specified, the most restrictiveisused. Setting it to O results
in no limit. Edit the WLFSizeLimit (uM-626) variable in the modelsim.ini fileto set a
permanent default.

* WLF FileTimeLimit
Limitsthe WLF file by size (as closely as possible) to the specified amount of time. If
both time and size limits are specified, the most restrictive is used. Setting it to O results
in no limit. Edit the WLFTimeLimit (UM-626) variable in the modelsim.ini fileto set a
permanent default.

* WLF Attributes
Specifies whether to compress WLF files and whether to delete the WLF file when the
simulation ends. Y ou would typically only disable compression for troubleshooting
purposes. Edit the WLFCompress (UM-626) variable in the modelsim.ini fileto set a
permanent default for compression. Edit the WLFDeleteOnQuit (Um-626) variable in the
modelsim.ini file to set a permanent default for WLF file deletion.

» Design Hierarchy
Specifieswhether to save al design hierarchy inthe WLF file or only regions containing
logged signals. Edit the WL FSaveAllRegions (UM-626) variable in the modelsim.ini file
to set a permanent default.
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Enabling design object visibility in optimized simulations

Designs simulated with -fast have limited access to design objects. See "Enabling design
object visibility with the +acc option" (UM-133) for more details. On the "Verilog tab" (uUm-
381) of the Simulate dialog, you can select Optimize Preferencesto selectively enable
design object visihility.

Optimization Preferences . £l

— Diesign Object Yisibiliby [+acc)
" Mo Design Object Yisibiliy
' Apply to Al Modules

—Wizibilty S pecifications
W Access to Registers ¥ Access to Ports
¥ AccesstoMets V¥ Access to Bits of Vector Nets
V' fccess to Tasks and Functions W Access to Cells

W Access to Line Debugging

" Specify Modules

b odule IT_I,IpE Children I I Add

b iy, ..

Delete

k. | Eancell

The Optimization Preferences dialog includes these options:

* No Design Object Visibility
Default behavior where Model Sim optimizes at will without concern for underlying
design object visibility.

* Apply to All Modules (+acc)
Specifies visibility settings for al modulesin your design. Please see "Enabling design
object visibility with the +acc option” (UM-133) for more details. Options include:

Access to Registers (+acc=r) Enable access to registers (including
memories, integer, time, and real types).

Access to Nets (+acc=n) Enable access to nets.

Accessto Tasks and Functions (+acc=t) Enable access to tasks and functions.
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Access to Line Debugging (+acc=l)

Enable line number directives and process
names for line debugging, profiling, and code
coverage.

Access to Ports (+acc=p)

Enable access to ports.

Access to Bits of Vector Nets (+acc=b)

Enable access to individual bits of vector nets.

Access to Cells (+acc=c)

Enable accessto library cells.

» Specify Modules (+acc[ =<spec>] [ +<nodul e>[.]])
Specifiesvisibility settings for individual modulesin your design. Click Add to open the

Add Access Entry dialog.

Add Access Enktry k|

— Module Mame
—Vizibilty Specifications

¥ Access to Registers W Access to Porks

¥ Access toMets W Access to Bits of Wector Mets

¥ Accessto Tasks and Functions [ Acoess to Cells

¥ Access to Line Debugging

[ Apply Visibility to Sub-Modules
] Cancel

The Add Access Entry dialog includes these options:

* Module Name
Specifies the module to which the visibility settings will apply.

* Visibility Specifications

See above.

» Apply Visibility to Sub-Modules
Specifies that the settings apply to al sub-modules of the specified Module Name.
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Creating and managing breakpoints

Model Sim supports both signal (i.e., when conditions) and file-line breakpoints.
Breakpoints can be set from multiple locations in the GUI or from the command line.
Breakpoints within SystemC portions of the design can only be set using File-line
breakpoints (UM-391).

Signal breakpoints

Signal breakpoints (when conditions) instruct Model Sim to perform actions when the
specified conditions are met. For example, you can break on asignal value or at a specific
simulator time (see the when command (CR-375) for additional details). When abreakpoint
is hit, amessage in the Main window transcript identifies the signal that caused the
breakpoint.

Setting signal breakpoints from the command line

Y ou use the when command (CR-375) to set asignal breakpoint from the VSIM> prompt.
See the Command Reference for further details.

Setting signal breakpoints from the GUI

Signal breakpoints are most easily set in the Signals window (Um-316) and the Wave
window (UM-337). Right-click asignal and select | nsert Breakpoint from the context
menu. A breakpoint is set on that signal and will be listed in the Breakpoints dialog.

Alternatively you can set signal breakpoints from the Breakpoints dialog (UM-392).

File-line breakpoints

File-line breakpoints are set on executable linesin your source files. When the line is hit,
the simulator stops.

Since C Debug is invoked when you set a breakpoint within a SystemC module, your C
Debug settings must be in place prior to setting a breakpoint. See Setting up C Debug (UM-
475) for more information. Once invoked, C Debug can be exited using the C Debug menu.

Setting file-line breakpoints from the command line

Y ou use the bp command (CR-81) to set afile-line breakpoint from the VSIM> prompt. See
the Command Reference for further details.

Setting file-line breakpoints from the GUI

File-line breakpoints are most easily set using your mouse in the Source window (UM-325).
Click on ablue line number at the left side of the Source window, and a red diamond
denoting a breakpoint will appear. The breakpoints are toggles — click once to create the
colored diamond; click again to disable or enable the breakpoint. To delete the breakpoint
completely, click the red diamond with your right mouse button, and select Remove
Breakpoint.

Alternatively you can set file-line breakpoints from the Breakpoints dialog (Um-392).
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Breakpoints dialog

The Breakpoints dialog box alows you to create and manage both Signal breakpoints (Um-
391) and File-line breakpoints (uM-391). Select Tools > Breakpoints from the Main,
Signals, Source, or Wave windows to open the dialog.

Modify Breakpoints A

— Breakpointz

@] . Adataflowe/proc. wLine: 44
-@] C: Adataflowproc. vLine: 30 Add

% zim: Atop/zstrb

M sim:Atop/pry tadify...

Enable

‘| ILI Delete

— Label

zim; Ahopdzstib

— Condition

zim: ftopszztrb

— Command

echo "Break on gim:ftopdestib” [ stop

] | Cancel

The Breakpoints dialog includes these options:

* Breakpoints
List of al existing breakpoints. Breakpoints set from anywhere in the GUI, or from the
command line, arelisted. A red ' X’ through the hand icon means the breakpoint is
currently disabled.

« Add
Create anew signal or file-line breakpoint. See below for more details.

* Modify
Change properties of an existing breakpoint. See below for more details.

» Disable/Enable
De-activate or activate the selected breakpoint.

» Delete
Delete the selected breakpoint.

» Label
Text label of the selected breakpoint.
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» Condition
The condition under which the breakpoint will be hit.

» Command
The command that will be executed when the breakpoint is hit.

Adding a breakpoint
Click Add to add a new breakpoint, and you will see the Add Breakpoint dialog.

Add Breakpoint a El

Breakpaint Type

£ Based on a Signal or Signal Y alue

" Bazed on a File and Line number

I et | Cancel

Choose whether to create asignal breakpoint or afile-line breakpoint and then select Next.
Depending on which type of breakpoint you’re creating, you'll see one of the two dialogs
below. These are the same dialogs you'll seeif you modify an exiting breakpoint.

Signal Breakpoint i El

— Breakpoint Label

— Breakpoint Condition

Breakpoint Commands

.........................

The Signals Breakpoint dialog includes these options:

* Breakpoint Label
Specify an optional text label for the breakpoint.

» Breakpoint Condition
Specify condition(s) to be met for the command(s) to be executed. See the when
command (CR-375) for more information on creating the condition statement.
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Breakpoint Commands

Specify command(s) to be executed when the condition is met. Any ModelSim or Tcl
command or series of commands are valid, with one exception —the run command (CR-
246) cannot be used.

File Breakpoint - £l

|| Browsze... |
— Line—— Instance Mame——————
| |

— Breakpoint Condition

— Breakpoint Commands

0k Cancel

The File Breakpoint dialog includes these options:
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File

Specify the filein which to set the breakpoint.

Line

Specify the line number on which to set the breakpoint. Note that breakpoints can be set
only on executable lines.

Instance Name
Specify aregion in which to apply the breakpoint. If left blank the breakpoint affects
every instance in the design.

Breakpoint Condition
Specify a condition that determines whether the breakpoint is hit.

Breakpoint Commands

Specify command(s) to be executed when the breakpoint is hit. Any ModelSim or Tcl
command or series of commandsis valid, with one exception — the run command (CR-
246) cannot be used.
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Miscellaneous tools and add-ons

Several miscellaneous tools and add-ons are available from Model Sim menus. Follow the
links below for more information.

» The GUI Expression Builder (UM-395)
Edit > Search > Search for Expression > Builder (List or Wave window)
Helps you build logical expressions for use in Wave and List window searches and
several simulator commands. For expression format syntax see
"GUI_expression_format" (CR-23).

» HDL language templates (UM-397)
View > Show language templates (Source window)
Helps you write VHDL or Verilog code.

» The Button Adder (UM-400)
Window > Customize (any window)
Allows you to add atemporary function button or toolbar to any window.

» The Macro Helper (UM-401)
Tools> Macro Helper (Main window)
Creates macros by recording mouse movements and key strokes. UNIX only (excluding
Linux).

» The Tcl Debugger (UM-402)
Tools> Tcl Debugger (Main window)
Helps you debug your Tcl procedures.

» Debug Detective™
Debug Detective is an add-on tool that lets you view any level of your design as block
diagrams, Interface-Based Design™ (IBD™) tables, state machines, or flow charts.
Enhanced debugging featuresinclude graphical breakpoints, signal probing, graphicsto
text source cross-highlighting, animation, and cause analysis.

Thetool isaccessed directly from within Model Sim. Assuming you have purchased and
installed Debug Detective, anew menu and tool bar button will appear in Model Sim when
you load a design. Complete documentation for Debug Detective is available from the
Start Menu once the product isinstalled. Please see www.mentor.com/debugdetective
for more information.

The GUI Expression Builder

The GUI Expression Builder isafeature of the Wave and List Signal Search dialog boxes,
and the List trigger properties dialog box. It aidsin building a search expression that
follows the "GUI_expression_format" (CR-23).

To locate the Builder:
* select Edit > Search (List or Wave window)
* select the Sear ch for Expression option in the resulting dialog box

ModelSim SE User’s Manual


http://www.mentor.com/hdldesigner/debugdetective/

UM-396 10 - Graphic interface

ModelSim SE User’'s Manual

 select the Builder button

5 'Expreszion Builder

FEHpressinn

— Expression Builder
[nzert Selected Signal [ 1 ==
'event 'rising 'falling Bk I I=
aMD|  OR ] 1 b ¥= <
X0OR| SLL b z €= +
SEL| SHa H L * ¢ %
Clear Save Test | Ok | Cancel

The Expression Builder dialog box provides an array of buttons that help you build a GUI
expression. For instance, rather than typing in asignal name, you can select the signal in
the associated Wave or List window and press Insert Reference Signal in the Expression
Builder. Theresult will bethefull signal name added to the expression field. All Expression
Builder buttons correspond to the "Expression syntax™ (CR-24).

To search for when a signal reaches a particular value

Select the signal inthe Wavewindow and click I nsert Selected Signal and ==. Then, click
the value buttons or type avalue.

To evaluate only on clock edges

Click the & & buttonto AND this condition with therest of the expression. Then select the
clock in the Wave window and click I nsert Selected Signal and ‘rising. Y ou can also
select the falling edge or both edges.

Operators

Other buttonswill add operators of various kinds (see " Expression syntax" (CR-24)), or you
can typethemin.
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Model Sim language templates help you write VHDL or Verilog code. They areacollection
of wizards, menus, and dialogs that produce code for new designs, language constructs,

logic blocks, etc.

A 'mportant: The language templates are not intended to replace thorough knowledge of

coding. They are intended as an interactive "reference” for creating small sections of
code. If you are unfamiliar with VHDL or Verilog, you should attend atraining class or
consult one of the many books available on HDL languages.

To use the templates, either open an existing HDL file in the Source window (UM-325), or
select File> New (Source window) to create anew file. Oncethefileis open, select View
> Show language templates. This displays a pane that shows the available templates.

@ source - Untitled-1.¥
File Edit Wiew Tools

=101 x|

EE2EE ) BRER DM oY EF 0HELELEE = & o m =

‘Ilnﬂl

Untitled-1.v =

1

Templates
ﬁ‘l\ Mew Design et
EHT) Language Constructs
m Library Definitions
E] E rtity
A Architecture

Declarations
Statements
EFo= Stimulus Generators L
— I Clock
j 123 Counber j
4| o] Untitled-1.v | R I
I_I ILn: 1.Cal: 0O

The templates that appear depend on the type of file you create. For example Module and
Primitive templates are available for Verilog files, and Entity and Architecture templates
areavailable for VHDL files.

UM-397
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Double-click anitemin thelist to begin creating code. Some of theitems bring up wizards
while others insert code into your HDL file. The dialog below is part of the wizard for
creating anew design. Simply follow the directionsin the wizards.

|55 'Create New Design Yizard : ;lgl EI

Thiz page allows you to add each port of the block. Type the port
name in the zignal box and then select the port's twpe. |f the twpe iz
a vector then fill in the range in the boxes provided.

f'ou can delete ping by zelecting them an the diagram.

After pyou have completed each port uze the Add button to have
the port added ta the block. Once all the portz have been entered
gelect the Finizh buttor,

— Puort to Add/Delete

Signal: |b ZI
Range: |7 Z ll:l_il

Bitechion s e
F In € Ow © InOut

Add|  Delete |

Codeinserted into your source file may contain yellow or gray highlighted "fields'. Y ellow
highlighting identifies an object that needs a name. Double-click the yellow object to enter
aname. Notethat all yellow objectswith the samelabel (e.g., "configuration_name" below)
will change to whatever name you enter. This ensures matching fields remain in synch.

B source - Untitled-1.vhd . [=]
File Edit Wiew Tools Sindow

e HS % BB DM O EF i

o d ||” 1il Urtitled-1.vhd |L Templates

1 ﬁ‘l\ Mew Design
£ CONFIGURATION configuration name 0F entits E_Dl Language Constructs
3 configuration declaratiwve part Li .

- + ibrary Definitions
4 block configuration [}J;Il . ¥
§ END comnfiguration name; _ﬂ Entity
&

— A Architecture
P Fackage

E-C] Configuration
%g Declaration

1 Specification
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Gray highlighting indicates that a context menu with additional commandsis available. In
the example below, right-clicking "configuration_declarative_part" givesyou three options
for continuing the definition of the Configuration.

@ source - Untitled-1.vhd =]

File Edit Wiew Tools window

CEHS H BB OMXON T 0

® |int Untitled-1.vhd [ =] Templates

BN Mew Design
HT Language Constructs
MLihrar}l Drefinitions
{E] Entity
A Architecture
{P] Package

Configuration
%g Declaration
IC] Spesification

Declaration:
Statements

CONFIGURATION configuration name 0F entits
configuration deglaratiwve part
hlnu:]-:_u:unfigurat% DELETE

END conficuration hame: aipais

Attribute Specification
group_declaration

TN o M

— = Cheeohoe s ke

=l
Iﬂ__bﬂLIntitledJ.vhd] S B |
|

i 2 Cak 16 - modified

Thefirst menuitem isalways "DELETE." This allows you to remove unwanted objects
from the HDL code, such as optional fields.

Keyboard shortcut
<control - p> editsayellow field and expands a gray field at the current cursor location.
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The Button Adder

The Button Adder creates a single button or a combined button and toolbar in any
currently opened Model Sim window. The button exists only until you close the window
unless you add the button code to the window’ s user hook variabl e (see "M aking the button
persistent” (UM-400) below).

Invoke the Button Adder from any Model Sim window menu: Window > Customize.
Y ou have the following

options for adding a button: |1;; Customize Toolbar 3 =10 x|
» Window Nameisthe name @ Right | “indowMName
; : & ToolBar -

of the window to which you [main Z"

want to add the button. & Left B
. ?:bt(talon Nameisthebutton’s o o |

’ Function

 Function can be any add | pore || © Bottom |

command or macro you

might execute from the
Model Sim command line. For example, you might want to add a Run or Step button to
the Wave window.

L ocate the button within the window with these selections:

» Tool Bar places the button on a new toolbar.

 Footer adds the button to the window’ s status bar.

Justify the button within the toolbar/footer with these selections:
 Right places the button on the right side of the toolbar/footer.
L eft adds the button on the Ieft side of the toolbar/footer.

» Top places the button at the top/center of the toolbar/footer.

Bottom places the button at the bottom/center of the toolbar/footer.

Making the button persistent

When you create a button with the Button Adder, the underlying commands are echoed in
the transcript. Y ou can use these commands to make the button appear every time you
invoke the window. Follow these steps:

1 Create abutton using the Button Adder.
2 Copy the commands from the transcript into a Tcl procedure in the modelsim.tcl file. If
you don’'t have amodelsim.tcl file already, create a new text file with that name and set

the MODELSIM_TCL environment variable to the full path of the modelsim.tcl file.

3 Append the procedure name to the window' s user_hook Tcl variable. See "Preference
variableslocatedin Tcl files' (Um-631) for moreinformation on Tcl preference variables.
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An examplewill help clarify. Say you create a button in the Wave window that adds all
signalsfrom the sel ected region to the Wave window. The button code will |ook something
likethis:

_add_nenu .wave controls right SystenButtonFace bl ack Addwaves {add wave *}

Y ou would insert that code into a Tcl procedure in the modelsim.tcl file and then append
the procedure to the PrefWave(user_hook) variable. The entire entry in the modelsim.tcl
file would look as follows:

proc AddWaves w nnane {
_add_nenu .wave controls right SystenButtonFace bl ack Addwaves {add wave *}

}

| append PrefWave(user_hook) AddWaves

Now, any time you start Model Sim and open the Wave window, it will have a button
labeled "AddWaves' that executes the command "add wave *".

The Macro Helper

Thistool isavailable for UNIX only (excluding Linux).

The purpose of the Macro Helper is to aid macro creation by recording a simple series of
mouse movements and key strokes. The resulting file can be called from a more complex
macro by using the play (CR-214) command. Actions recorded by the Macro Helper can
only take place within the Model Sim GUI (window sizing and repositioning are not
recorded because they are handled by your operating system’s window manager). In
addition, therun (CR-246) commands cannot be recorded with the Macro Hel per but can be
invoked as part of a complex macro.

Select Tools> Macro Helper (Main
window) to access the Macro Helper. - macro s |

) e e

» Record amacro
by typing a new macro file name into
the field provided, then press Record.
Use the Pause and Stop buttons as
shown in the table below.

» Play amacro
by entering the file name of a Macro Helper fileinto the field and pressing Play.

Files created by the Macro Hel per can be viewed with the notepad (CR-207).

Button Description

Record/Stop Record begins recording and toggles to Stop once arecording
begins

Insert Pause insertsa.5 second pause into themacro file; pressthe button more

than once to add more pause time; the pause time can
subsequently be edited in the macro file

Play plays the Macro Helper file specified in the file name field
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See the macro_option command (CR-191) for playback speed, delay, and debugging
options for completed macro files.

The Tcl Debugger

We would like to thank Gregor Schmid for making TDebug available for usein the public
domain.

This program is distributed in the hope that it will be useful, but WITHOUT ANY
WARRANTY ; without even the implied warranty of FITNESS FOR A PARTICULAR
PURPOSE.

Starting the debugger

Select Tools> Tcl Debugger (Main window) to run the debugger. Make sure you use the
Model Sim and TDebug menu selections to invoke and close the debugger. If you would
like more information on the configuration of TDebug see Help > Technotes > tdebug.

The following text is an edited summary of the README file distributed with TDebug.

How it works

TDebug works by parsing and redefining Tcl/Tk-procedures, inserting callsto “td_eval' at
certain points, which takes care of the display, stepping, breakpoints, variables etc. The
advantages are that TDebug knows which statement in which procedure is currently being
executed and can give visual feedback by highlighting it. All currently accessible variables
and their values are displayed as well. Code can be evaluated in the context of the current
procedure. Breakpoints can be set and deleted with the mouse.

Unfortunately there are drawbacksto this approach. Preparation of large proceduresissiow
and due to Tcl's dynamic nature there is no guarantee that a procedure can be prepared at

al. Thisproblem has been alleviated somewhat with the introduction of partial preparation
of procedures. Thereis still no possibility to get at code running in the global context.

The Chooser

Select Tools > Tcl Debugger (Main window) to open the TDebug chooser.
The TDebug chooser hasthree parts. At

thetopthecurrent interpreter, vsim.op_, % TDebug-Choose M=l

is shown. In the main section there are

two list boxes. All currently defined Interp: __ viim |
procedures are shown in the left list Mormal Prepared

box. By clicking the |eft mouse button i - -
on a procedure name, the procedure A bouty systernn —

gets prepared for debugging and its & ddA dditionallus

name is moved to the right list box. AddCmdTollueue

Clicking anamein the right list box igggg;‘;ﬁ?w

returns a procedure to its normal state. A aveCursorhd e

Press the right mouse button on a A avek dittden

procedure in either list box to get its Addw/aveiletden. |
program code displayed in the main Addv/avePropMer - i
debugger window. Rezcan | Fopup | E it |
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The three buttons at the bottom let you force a Rescan of the available procedures, Popup
the debugger window or Exit TDebug. Exiting from TDebug doesn't terminate Model Sim,
it merely detaches from vsim.op_, restoring all prepared procedures to their unmodified

UM-403

stete.

The Debugger

Select the Popup button in the Chooser to open the debugger window.

%.| TDebuq for vsim [_ O] =]
Debugger Optionz Selection W arables Help
Proc : |.ﬁ.pp|yWaveF'er {hreenarne) Yanables:
S A freename: wave.tree |
global wsimPriv _ _ _ : _| waimPriv zignals:[): 1
ftreename waveconfig -zsignalnamewidth $vaimPrivwaveprop_sigwi wimPriv]. signals: 0] 1
$treename waveconfig -shapdistance  $vsimPriviwaveprop_shapdi weimPriv signalz:]: 1

<]

wzimPriv] zignals:i): 1

waimPriv] D ataflostadindoms]
wzimPriv] D efault nit ame):
vzimPriv[DizableButtonbist]:
wzimPriv[Draglrop_DropHa
= |eaimPriv[Draghop_DropHa

I 3 I s inire D T mmlMeme T vk

e vsimF’riv[DragDmp_Drana_I

Reszult: | | ‘| LI
Ewal : | || Delay: 300 | - | +
" Shop | = Mest = Slow " Fast | ™ Monstop | " Break

The debugger window is divided into the main region with the name of the current
procedure (Proc), alisting in which the expression just executed is highlighted, the Result
of this execution and the currently available Variables and their values, an entry to Eval
expressionsin the context of the current procedure, and some button controls for the state
of the debugger.

A procedure listing displayed in the main region will have adarker background on all lines
that have been prepared. Y ou can prepare or restore additional lines by selecting aregion
(<Button-1>, standard selection) and choosing Selection > Prepar e Proc or Selection >
Restor e Proc from the debugger menu (or by pressing P or *R).

When using "Prepare’ and "Restore, try to be smart about what you intend to do. If you
select just asingle word (plus some optiona white space) it will beinterpreted asthe name
of aprocedure to prepare or restore. Otherwise, if the selection is owned by thelisting, the
corresponding lines will be used.

Be careful with partial prepare or restore! If you prepare random lines inside a “switch' or
“bind' expression, you may get surprising results on execution, because the parser doesn't
know about the surrounding expression and can't try to prevent problems.
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There are seven possible debugger states, onefor each button and an “idl€ or “waiting' state
when no button is active. The button-activated states are:

Button Description

Stop stop after next expression, used to get out of slow/fast/nonstop
mode

Next execute one expression, then revert toidle

Slow execute until end of procedure, stopping at breakpoints or when
the state changes to stop; after each execution, stop for 'delay’
milliseconds; the delay can be changed with the’+ and’-’
buttons

Fast execute until end of procedure, stopping at breakpoints

Nonstop execute until end of procedure without stopping at breakpoints or
updating the display

Break terminate execution of current procedure

Closing the debugger doesn't quit it, it only does “wm withdraw'. The debugger window
will pop up the next time a prepared procedureis called. Make sure you close the debugger
with Debugger > Close.

Breakpoints

To set/unset a breakpoint, double-click inside the listing. The breakpoint will be set at the
innermost available expression that contains the position of the click. Conditional or
counted breakpoints aren’t supported.

Debugger Dptionz

% TDebug for ¥sim

Selection Wariablez

Proc : |.-i‘-.ppI_I,IWaveF'er {hreename}
F
alobal wsimPri |
H ftreename waveconfig -sighalnamewidth $wzimPrivwaveprop_sigwi
ftreename waveconfig -shapdistance  $vsimPriviwaveprop_snapdi
breakpaint

The Eval entry supports a simple history mechanism available viathe <Up_arrow> and
<Down_arrow> keys. If you evaluate acommand while stepping through a procedure, the
command will be evaluated in the context of the procedure; otherwise it will be evaluated
at the global level. Theresult will be displayed in theresult field. Thisentry isuseful for a
lot of things, but especially to get access to variables outside the current scope.
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Try entering the line “global td_priv' and watch
the Variables box (with global and array
variables enabled of course).

Configuration

Y ou can customize TDebug by setting up afile
named .tdebugrc in your home directory. See the
TDebug README at Help > Technotes >
tdebug for moreinformation on the configuration
of TDebug.

TclPro Debugger

The Tools menu in the Main window contains a
selection for the TclPro Debugger from Scriptics
Corporation. This debugger and any available
documentation can be acquired from Scriptics.
Once acquired, do the following steps to use the
TclPro Debugger:

1 Make surethe TclPro bin directory isin your PATH.

Miscellaneous tools and add-ons

Yanables:

treename:; wave.tree
waimPriv signalz:1]: 1
vaimPriv. zignalz: 07 1
waimPriv. zignals=]: 1
wzimPriv]. zignalz:i): 1
wzimPriv D ataflowtadindows]
wzimPriv] D efaultl nit ame]: m
vzimPriv[DizableButtonbist]:
wzimPriv[Draglop_DropHa
wzimPriv[Draglrop_DropHa
wzimPrv[Draglop_DropHa

IRV m P | S PR R

RIN 2

£

Delay: 300

2 In TclPro Debugger, create a new project with Remote Debugging enabled.

3 Start ModelSim and select Tools > TclPro Debugger (Main window)

4 Pressthe Stop button in the debugger in order to set breakpoints, etc.

P Note: TclPro Debugger version 1.4 does not work with Model Sim.

UM-405

ModelSim SE User’s Manual



UM-406 10 - Graphic interface

ModelSim SE User’'s Manual



UM-407

11 - Performance Analyzer

Chapter contents

Introducing Performance Analysis. . . . . . . . . . UM-408
A statistical sampling profiler. . . . . . . . . . UM-408
Gettingstarted . . . . . . . . . . . . . . . UM-410
Interpreting thedata . . . .. . . . . . UM-411
Viewing Performance Analyzer results .. . . . . . UM-411
Interpreting the Name field . . . . .« . . . UM-413
Interpreting the Under(%) and In(%) f|eI ds .. . . . . UM-413
Differencesin theranked and hierarchical views. . . . . UM-414
Anayzing C code perfformance . . . . . . . . . . UM-415
Reportingresults . . . . . . . . . . . . . . UM-416
profilemenu . . . . . . . . . . . . . . . UM417
Performance Analyzer commands. . . . . . . . . . UM-417
Performance Analyzer preferencevariables . . . . . . . UM-417

Y ou can use the Performance Analyzer to easily identify areasin your simulation where
performance can be improved. The Performance Analyzer can be used at al levels of
design simulation — Functional, RTL, and Gate L evel —and has the potential to save hours
of regression test time. In addition, ASIC and FPGA design flows benefit from the use of
thistool.

P Note: If you need to run the Performance Analyzer under Windows on a design that
contains FLI/PLI/VPI code, add these two switches to the compiling/linking command:

/ DEBUG / DEBUGTYPE: COFF

These switches add symbolsto the .dll file that the profiler can use in its report.
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Introducing

Performance Analysis

The Performance Analyzer provides an interactive graphical representation of where
Model Sim is spending its time while running your design. This feature enables you to
quickly determine what is impacting the design environment’ s simulation performance.
Those familiar with the design and validation environment will be able to find first-level
improvements in a matter of minutes.

For example, the Performance Analyzer might show some or all of the following
» A non-accelerated VITAL library cell isimpacting simulation run time

* A processis consuming more time than necessary because of non-required itemsin its
sensitivity list

A testbench process is active even though it is not needed
* A Cmoduleisinefficient

A random number process is consuming simulation resources when in atestbench that is
running in non-random mode

With thisinformation, you can make changesto the VHDL or Verilog source code that will
speed up the simulation.

A statistical sampling profiler

ModelSim SE User’'s Manual

The Performance Analyzer is a statistical sampling profiler. It periodically samples the
current simulation at auser-determined rate and recordswhat isexecuting in the simulation.
The advantage of statistical analysisisthat an entire simulation may not have to be run to
get good information from the Performance Analyzer. A few thousand samples, for
example, can be accumulated before pausing the simulation to see where simulation time
is being spent.

The Performance Analyzer reports only on the samplesthat it can attribute to user code. For
example, if you used the -nodebug argument to vcom (CR-303) or vlog (CR-345), it could
not report sample resullts.



Introducing Performance Analysis UM-409

During sampling, the Samplesfield in the footer of the Main window displays the number
of profiling samples collected, and each sample becomes one data point in the simulation

profile.
-] Modelsim -0 =|
File Edit “iew Compile Simulate Tools  Window  Help
Workspace x| :
i | Diesign Uit | Design L = # = R Mark = at 24573400 rns Prirmary Chan j
- - - —— nel
= test_ringbuif test_ringbuf... Architec # = FDa Mark = at 24574000 nz Primary Chan
ring_inzt ringbLfrtl] Architec nel
B tertio bewtio Package # = B=DA Mark = at 24574400 nz Primany Chan
. . . riel
B std_logic_unsi.. std logic_u... Package # AxDis Mark ™ at 24574800 ns Primary Chan
B std logic_arth  std_logic_ar.. Package ™ ||nel
B std logic 1164 std_logic Package _I # == FxDA Mark = at 24575200 nz Primarny Chan
- = - = T | |rel
< I i
Libram | zim | Filez | | j
|N|:|w: 24 705 600 ns  Delta: 1 Frofile Samples: 1@ |5im:ftest_ring|:|uf o
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Getting started

Performance analysis occurs during the Model Sim run command To enable the
Performance Analyzer, select Tools > Profile> Profile On (Main window). After this
command is executed, all subsequent run commandswill have profiling statistics gathered
for them. With the Performance Analyzer enabled and arun command initiated, the
simulator will provide a message indicating that profiling has started.

You can turn off the Performance Analyzer by selecting Tools > Profile > Profile Off
(Main window). Any Model Sim run commands that follow will not be profiled.

Profiling results are cumulative. Therefore, each run command performed with profiling
ON will add new information to the data being gathered. To clear this data, select Tools >
Profile > Clear Profile Data (Main window).
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Interpreting the data

The Performance Analyzer helps most in cases where a high percentage of simulation time
is spent in one module/entity. For example, say Performance Analyzer shows the
simulation is spending 60% of its time in module X. Thisinformation can be used to find
where module X was implemented poorly and to implement a change that runs faster.

More commonly the Performance Analyzer will tell you, for example, that 30% of
simulation time was spent in model X, 25% in model Y, and 20% in model Z. In such
situations, careful examination and improvement of each model may result in overall speed
improvement.

There aretimes, however, when the Performance Analyzer tellsyou nothing better than that
the simulation has executed in several hundred different models and has spent less 1% or
2% of itstimein any one of them. In such situations, the Performance Analyzer provides
little helpful information and simulation improvement must come from a higher level
examination of how the design can be changed or optimized.

Viewing Performance Analyzer results

The Performance Analyzer providestwo views of the collected data— a hierarchical and a
ranked view. The hierarchical view is accessed by selecting Tools > Profile > View
hierarchical profile (Main window) or by typing view_profile at the VSIM prompt. The
ranked view is accessed by selecting Tools > Profile > View ranked profile or by typing
view_profile_ranked at the VSIM prompt.

Inthe Hierarchical Profile window, you can expand and collapse various|evelsto hide data
that is not useful and/or is cluttering the data display. Click on the '-' box to collapse all
levels beneath the entry. Click on the '+' box to expand an entry. By default, all levels are
fully expanded.

In the hierarchical view below, test_sm.v: 96 is taking the magjority of the simulation time.

|+ Hierarchical Profile =100 %]
o n Samples: 4227 ﬂl ZI Under % I‘l_ﬂ
| Name [Underiz) iz | zParent | [ =]
B test sma 96 47 20
Tel_Flush 22 0 46
L Ter_close 22 72 100
Teol_DooneEvent a 1 11
Tel_ServiceEvent 1 0 18
L Tel_MotifvChannel 1 0 a5
Tel_WaitForEvent 3 3 A9
B smwvEd a 3
Tel_DooneEvent 1 0 12
L Tel_waitForEvent 1 1 70
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In the Ranked Profile view the modules and code lines are ranked in order of the amount

of simulation time used.

|- 'Ranked Profile

© [E  samples 134 M| ZI In % |1_i’

=101 x|

Hame

| Underiz) (Iniz) | | 2

CUMODELTE CHIEXAMPLES profilercontral vhd 87 10 10
CUMODELTECHIEXAMPLESprofileristore_array.whd: 39
CUMODELTECHEXAMPLES profilerfcontrol whd: 93
CUMODELTECHEXAMPLES profilerretrieve_array vhd: 35
CUMODELTECHIEXAMPLE Sprofilertestring whd: 96

CUMODELTECHIEXAMPLE S profilericontrolvhid: 114
CUMODELTECHIEXAMPLE S profilertestring vhd: 137
CUMODELTECHIEXAMPLESprofilertestring whd: 98

CUMODELTECHIEXAMPLESprofilericontrolvhd: 1145

T
4
4
4
CUMODELTECHIEXAMPLE S profilericontrolvhid: 130 4
3
3
2
2
1

CUMODELTECHEXAMPLESprofilericontrol.vhd: 23

|

— k3 kS LD LD e ]

|-
il

The Hierarchical and Ranked profile windows share a similar toolbar. The table below
describes theicons.

Button Function
Provides access to a search function that can be used to search for a
ﬂ given string in the window. Typetext in the entry box and then press
Return or click the binocular icon.

Under % I'I_ %

Specifies a cutoff percentage for displaying the data. By default,
every entry in the profiling data that has spent at least 1% of the
simulation time under that entry will be displayed. In the Ranked
view, the value isfor the In%. See "Interpreting the Under(%) and
In(%) fields" (uM-413) for more information.

Thehier Cutoff and rank Cutoff variables provide asimilar function.
See "Performance Analyzer preference variables' (UM-417)

Causes the data to be reloaded from the simulator. If you change the
cutoff percentage or do an additional simulation run, the Ranked and
Hierarchical Profile windows are not updated automatically. You
should click on this button to update the data being displayed in these
windows.

=

=k

Allows the data to be saved to disk. Y ou will be prompted for the
output file name.

The profilereport command (CR-226) provides another way to save
profile data.
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Interpreting the Name field

The Name, Under (%), and In(%) fields appear in both the ranked and hierarchical views.
Thesefieldsareinterpreted identically in both views. Typically aName consists of an HDL
file and line number pair. Most useful names consist of aline of VHDL or Verilog source
code. If youuseaPLI/VPI or FLI routine, then the name of the C function that implements
that routine can also appear in the name field.

vsim is a stripped executablefile, so that any functionsinside of it will be credited to the
line of code that uses the function.

The hierarchical view opens with al levels displayed. Y ou can collapse the hierarchical
view by clicking the boxes next to the high-level names. At thistime, the hierarchical view
will not remember which levels are opened or closed when datais reloaded. By default,
hierarchical levels are opened every time datais rel oaded.

UM-413

Interpreting the Under (%) and In(%) fields

The In(%) and Under (%) columns describe the percentage of the total simulation time

spent in and under afunction listed in the Name field.

The distinction between In(%) and Under (%) is subtle but important. In(%) shows that x%
of the total simulation time was actually spent executing this one line of HDL code.
Under (%) shows that a particular line and all support routines it needed took x% of total

simulation time.

Inthe body of the Hierarchical Profile or Ranked Profile windows, you can double-click on
any VHDL/Verilog file and line-number pair to bring up that file in the Source window
with the selected line highlighted.

B -source - retrieve.vhd -0 =|
File Edit Yiew Tools window
2RSS BB OMYON ] wHELEIE (= ® P D
& Iln ﬂI retrigve. vhd |j

28 BEGIN

Z9

30 -- Produces the decode logic which pointers

31l -- to esach location of the shift register.

JE retriever : PROCESE (buffers,ramadrs({counter_size-—1) downto 0))

33 BEGIN

ad for i in ta (buffer =ize - 1) loop

25 IF (i = ramadrs({{counter size - | dowmto ) THEN

c1y rdla == buffersi{i);

a7 ENL IF;

38 end loop -

3% ENLD PROCESS;

40

4] rxda <= rdla and outstrobe; _:J
4|F| retrieve.vhd] | 1 |_>|
I_I ILn: 35, Col: 0 -readorly -
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Differences in the ranked and hierarchical views

The hierarchical view differs from the ranked view in two important respects.

» Entriesin the Name column of the hierarchical view areindented in order to show which
functions or routines call which others.

* A %Parent columninthehierarchical view allowsyou to see what percentage of a parent
routine’s simulation time is used in which subroutines.

Indentation in the Name column of the Hierarchical Profile window indicateswhichlineis
calling afunction.

The hierarchical view presents datain a call-graph style format that provides more context
than doesthe ranked view about where simulation timeis spent . For example, your models
may contain several instances of a utility function that computes the maximum of 3-delay
values. A ranked view might reveal that the simulation spent 60% of itstime in this utility
function, but would not tell you which routine or routines were making the most use of it.
The hierarchical view will reveal which lineis calling the function most frequently. Using
thisinformation, you might decide that instead of calling the function every time to
compute the maximum of the 3-delays, this spot in your VHDL code can be used to
compute it just once. Y ou can then store the maximum delay value in alocal variable.

The %Parent column provides the percent of simulation time a given entry used of its
parent’ s total simulation time. From this column, you can cal cul ate the percentage of total
simulation time taken up by any function. For example, if a particular parent entry used
10% of thetotal simulationtime, and it called aroutinethat used 80% of itssimulation time,
then the percentage of total simulation time spent in that routine would be 80% of 10%, or
8%.

In addition to these differences, the ranked view displays any particular function only once,
regardless of where it was used. In the hierarchical view, the function can appear multiple
times — each time in the context of where it was used.
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Analyzing C code performance

Y oucaninclude C codeinyour design viaSystemC, theVerilog PLI/VPI, or theModelSim
FLI. The Performance Analyzer can be used to determine the impact of these C modules
on simulator performance. For example, in theillustration below, the do_and C moduleis
using the magjority of simulation time.

haHierarchical Profile - U x
9 B samples: 335 !ﬁl _||_|nderat 1 |t

ame [ Uncter¢y |y |%Parent |
do_znd BN
nemory. w: 80

cache. w142

Stop/m/depth[14] Arideh[6] /c0/i1 foutl
proc. v:49
Ftop/m/depth[15] fwidth[14] /r0/11/outl
Frop/midepth(d] fwidth([3] Ar0/11 /oukl
Ftop/midepth[3] fwidth([5] Ar0/11 o0kl

(ol i e el = = ]
e N e T ]

I,..-—_l

Factorsthat can affect simulator performance when adesignincludes C codeare asfollows:

» PLI/FLI applications with large sensitivity lists

« Calling operating system functions from C code

* Calling the simulator’s command interpreter from C code
* Inefficient C code

In addition, the Verilog PL1/VPI requires maintenance of the simulator’ sinternal data
structures aswell asthe PL1/VPI data structures for portability. (VHDL does not have this
problem in Model Sim because the FLI gets information directly from the simulator.)
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Reporting results

Either click the saveicon on thetoolbar or usethe profilereport command (CR-226) to save
the Performance Analyzer results.

For exampl e, the command

profile report -hierarchical -file hier.rpt -cutoff 4

will produce a profile report in atext file caled hier.rpt, as shown here.

B source - hier.rpt i -10] =|
File Edit “iew Tools SWindow

2 EHES F BB DM} B wHEEERR BT D

& | I #l C:/modeltech/exramples/prafilerhier. ipt | L
1

Hierarchical profile generated Tue Now
Mawber of samples:

Mamber of samples in user code: [dad%)
Cutoff percentage: <%

Nane Tnder (%) Inni%) (Parent

Lou TR e VI £ T RN VN b

3 retriewve_array.wvhd:

10 control_vhd:

11 control_ wvhd:

12 store_array.wvhd: -

13 —

hd
1|Ir| hier.rpt] | + | +]
I_l |Ln: 13, Cal: 0 -read-orly -
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Profile menu

The following commands are available from the T ools > Profile menu (Main window).

Profile On turn on the Performance Analyzer

Profile Off turn off the Performance Analyzer

View hierarchical view ahierarchical report of simulation performance; see
profile "Interpreting the data" (Um-411)

View ranked profile | view aranked report of simulation performance; see"Interpreting
the data' (Um-411)

Clear Profile Data clear current profile data

Performance Analyzer commands

The table below provides a brief description of the profile commands. See the Model Sm
Command Reference for complete command details.

Command Description

profile clear (CR-221) clears any datathat has been gathered during previous run
commands; after this command is executed, dl profiling data
will be reset

profileinterval (CR-222) selects the frequency with which the profiler collects samples
during a run command

profile off (CR-223) disables runtime profiling

profile on (CR-224) enablesruntime analysis of where your simulation is spending
itstime

profile option (CR-225) changes various profiling options

profilereport (CR-226) produces textual output of the profiling statistics that have
been gathered up to the point at which you execute the
command

Performance Analyzer preference variables

Various Tcl variables control how the Hierarchical Profile and Ranked Profilewindows are
displayed.Y ou can set these preference variables by selecting Tools > Edit Preferences>
By Name > Profile (Main window). Use the Apply button to view temporary changes, or
Save the changes to alocal modelsim.tcl file. Once saved, the preferences will be the
default for subsequent simulations invoked from the same directory. See "Preference
variables located in Tcl files" (um-631) for more information.
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Introduction

Code Coverage givesyou graphical and report file feedback on which statements, branches,
conditions, and expressions in your source code have been executed. It also measures bits
of logic that have been toggled during execution.

With coverage enabled, Model Sim counts how many times each executable statement,
branch, condition, expression, and logic node in each instance is executed during
simulation. Statement coverage counts the execution of each statement on aline
individually, even if there are multiple statements in aline. Branch coverage counts the
execution of each conditional "if/then/else”" and "case" statement and indicates when atrue
or false condition has not executed. Condition coverage analyzes the decision madein "if"
and ternary statements and is an extension to branch coverage. Expression coverage
analyzes the expressions on the right hand side of assignment statements, and is similar to
condition coverage. And toggle coverage counts each time alogic node transitions from
one state to another.

Coverage statistics are displayed in the Main, Signal s, and Source windows and also can be
output in different text reports (see "Reporting coverage data' (UM-446)). Raw coverage
data can be saved and recalled, or merged with coverage data from the current simulation
(see"Saving and rel oading coverage data" (UM-450)).

Model Sim Code Coverage offers these benefits:

* Itistotally non-intrusive because it’ s integrated into the Model Sim engine — it doesn’t
require instrumented HDL code as do third-party coverage products.

* It hasvery little impact on simulation performance (typically 5 to 10 percent).

* |t allowsyou to merge sets of coverage data without requiring elaboration of the design
or asimulation license.

Usage flow for Code Coverage

The following is an overview of the usage flow for simulating with Code Coverage. More
detailed instructions are presented in the sections that follow.

1 Compilethe design using the -cover bcest argument to vcom (CR-303) or vlog (CR-345).
2 Simulate the design using the -cover age argument to vsim (CR-357).

3 Runthe design.

4 Analyze coverage statisticsin the Main, Signals, and Source windows.

5 Edit the source code to improve coverage.

6 Re-compile, re-simulate, and re-analyze the statistics and design.
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Supported types

Code Coverage supports only certain data types.

VHDL

Supported types are scalar std_ulogic/std_logic. The tool doesn’'t currently support bit or
boolean.

Vector and integer and real are not supported directly. However, subexpressions that
involve an unsupported type and arelational operator and produce a boolean result are
supported. These types of subexpressions are treated as an external expression that is first
evaluated and then used as a boolean input to the full condition. The subexpression needs
to look like:

(var <rel op> const)

where "var" could be of type std_logic_vector, integer, or real; "<relop>" isarelational
operator (e.g., <, >, >=); and "congt" isaconstant of the appropriate type. Thetool doesn’'t
currently support (varl <relop> var2).

Verilog

Supported types are net and one-bit register, but subexpressions of the form:

(varl <rel op> var?2)

are supported, where the variables may be multiple-bit registers or integer or real.
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Important notes about coverage statistics

Y ou should be aware of the following special circumstancesrelated to cal culating coverage

statistics:

» When Model Sim optimizes adesign, it "removes' unnecessary lines of code (e.g., code
in aprocedure that is never called). The lines that are optimized away aren't counted in
the coverage data, and this may cause misleading results. Asaresult, when you compile
with coverage enabled, Model Sim disables certain optimizations depending on which
coverage types you choose. This produces more accurate statistics but also may slow
simulation.

The table below shows the coverage types and what Model Sim does to optimizations.

Coverage type Effect on optimizations

statement optimizations not disabled automatically; specify -OO0 to get most
accurate statistics

branch case statement optimizations are disabled automatically

condition optimizations not disabled automatically

expression al optimizations disabled automatically

toggle optimizations not disabled automatically

* Package bodies are not instance-specific: Model Sim sums the counts for al invocations
no matter who the caller is. If you want separate statistics on each package, place them
in separate files rather than mixing them with entities or architectures. Also, al standard
and accel erated packages are ignored for coverage statistics calculation.
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Enabling Code Coverage
Enabling Code Coverage is a two-step process:

1 Usethe-cover argument to vcom or viog when you compile your design. Thisargument
tells Model Sim which coverage statistics to collect. For example:

vlog top.v proc.v cache.v -cover bcesx

Each character after the -cover argument identifies atype of coverage statistic: "b"
indicates branch, "c" indicates condition, "€" indicates expression, "'s" indicates
statement, "t" indicates 2-transition toggle, and "x" indicates extended 6-transition toggle
coverage (t and x are mutually exclusive). See "Enabling Toggle coverage" (Um-437) for
details on two other methods for enabling toggle coverage.

2 Usethe -coverage argument to vsim when you simulate your design. For example:

vsi m - coverage work.top

In Model Sim versions prior to 5.8, you didn’t have to enable coverage at compile time.
Code Coverage metrics (statement and branch coverage) were turned on just by using the
-cover age argument to vsim. For backwards compatibility, Model Sim will still display
statement statisticsif you simulate with coverage enabled, even if you don’t use the -cover
argument when you compile the design.
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To enable coverage from the graphic interface, first select Compile > Compile Options
(Main window) and select the Coverage tab. Alternatively, if you are using a project,
right-click on a selected design item (or items) and select Properties.

Compiler Options £

WHOL ] Werilog ; Coverage ] SystemE]

¥ Enable Statement Coverage

¥ Enable Branch Coverage

[T Enable Condition Coverage

¥ Enable Expression Coverage

[T Enable 041 Toggle Coverage

[~ Enable 041/</Z Toggle Coverage
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Next, select Simulate > Simulate (Main window) and check Enable sour cefile cover age
on the Options tab.

| Simulate 1] |

Design | YHDL | Verilog | Libraries | SOF Options |

¥ Enable source file coverage
[ Treat non-existent WHOL files opened for read as empty

r Do not zhare file dezcriptors for WHOL filez opened
for write or append that have identical namesz

—WLF Filz Azzert File
I Browsze. . | ’7 Browsze. .. |

—— Other optiohz

] | Caricel |
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Viewing coverage data in the Main window

When you simul ate adesign with Code Coverage enabled, coverage dataisdisplayedinthe
Main, Source, and Signals windows. In the Main window, coverage datadisplaysin five
window panes:. Workspace, Missed Coverage, Current Exclusions, Instance Coverage, and

Details.
l[;::'I\‘It:ideISim =] 4
File Edit WYiew Compile Simulate Tools ‘Window Help
|B’“I§H\‘;€e E@H‘I‘E 1us:¢|§?}ﬁl‘|é;T Threshold 4z ? x @
Workzpace |
"’l Instance I Dezign unit I Design unit type | Stk count | Stmnt hits | Stmt miszes I St % | Strnt graph =] | |¥ Loading project coverage d
" waim -coverage wark.test_sm
Eed test_sm test_sm Module 140 117 23 536% DN # veim -coverage work.test_sm
o hop test_sm Tazk # Loading wiork, best_sm
o chil test_sm Task # Loading work.sm_seq
- # Loading work.sm
& wiwd test_sm Task Works pace # Loading waork.beh_sram
& wi_blk test_sm Task WSIM 3> wm title . “ModelSim"
j _'”d—Wd :33:—3““ Iast VSIM 45 log 1/
_ap est_sm a3l
P sm_seqll sm_seq Madule 53 43 4 925% mm :S'M B '””:ﬁlue;; S
o zram_0 beh_sram Module 10 9 1 0% I ] # 95 outol = 00000000
# 455 outof = 0000003
| | 3|
Project | Library | sim | Files WS B3 E
Missed Coverage 2| Currert Exclusions Zlll Instance Coverage Z| Details =l
‘.-l e test_sm.v [pragma) ‘rI |nstance IDef File: C:/CodeCoverage5.s/ver
Line: 15
ftest_sm/zram_0 beh
E“Eﬂ LEesL_sm.w 9 J - ’ - Ofsm Statement Coverage for:
_)( 15 # o ftest_sm/zm_seq0ism_| Bl M
o Atest_smism_seql M ; A
into = {4'b0O0I & FEET e Hits: O
_)( . 16 endrask CU rrent Statement Coverage for:
—XMissed Caverage Exclusi into = ¢ . -
=X 70 into = { xclusions Hits: O
Instance
—)( 71 endtask C
LX 110 o overage Details
a Bt
8 s ol
-[Statement l Branch l Eonditionl Expressionl ToggIeJ o | _;l ] | | _.l | | _.l
Praject : coverage |N0w: 500 ns  Delta: 2 |sim:ﬁest_sm o
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Viewing coverage data in the Main window

The Workspace pane displays code coverage information in the Files tab and in the tabs
displaying structure for any datasets being simulated (e.g., the simtab). When coverageis
invoked, several columns for displaying coverage data are added to the Workspace pane.
Y ou can toggle columns on/off by right-clicking on a column name and selecting from the
context menu that appears. The following columns are relevant to the Workspace pane:

Column name

Description

Design unit the name of the design unit

Design unit type the type (e.g., Module, Entity, etc.) of the design unit

Stmt count the number of executable statementsin each file

Stmt hits the number of executable statements that have been
executed in the current simulation

Stmt misses the number of executable statements that were not
executed in the current simulation

Stmt % the current ratio of Stmt hits to Stmt count

Stmt graph abar chart displaying the Stmt %; if the percentageis

below 90%, the bar is red; 90% or more, the bar is green;
you can change this threshold percentage by editing the
Pref Cover age(cutoff) preference variable

Branch count

the number of executable branchesin each file

Branch hits

the number of executable branches that have been
executed in the current simulation

Branch misses

the number of executabl e branches that were not executed
in the current simulation

Branch %

the current ratio of Branch hits to Branch count

Branch graph

abar chart displaying the Branch %; if the percentageis
below 90%, the bar is red; 90% or more, the bar is green;
you can change this threshold percentage by editing the
PrefCover age(cutoff) preference variable

Condition rows

the number of conditionsin each file

Condition hits

the number of times the conditionsin afile have been
executed

Condition misses

the number of conditionsin afile that were not executed

Condition %

the current ratio of Condition hits to Condition rows

Condition graph

abar chart displaying the Condition %; if the percentageis
below 90%, the bar is red; 90% or more, the bar is green;
you can change this threshold percentage by editing the
PrefCover age(cutoff) preference variable

UM-427
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Column name

Description

Expression rows

the number of executable expressionsin each file

Expression hits

the number of times expressionsin afile have been
executed

Expression misses

the number of executable expressionsin afilethat were not
executed

Expression %

the current ratio of Expression hits to Expression rows

Expression graph

abar chart displaying the Expression %; if the percentage
isbelow 90%, the bar isred; 90% or more, the bar isgreen;
you can change this threshold percentage by editing the
PrefCover age(cutoff) preference variable

Toggle nodes

the number of pointsin each instance where the logic will
transition from one state to another

Toggle hits

the number of nodesin each instancethat havetransitioned
at least once

Toggle misses

the number of nodes in each instance that have not
transitioned at |east once

Toggle %

the current ratio of Toggle hits to Toggle nodes

Toggle graph

abar chart displaying the Toggle %; if the percentage is
below 90%, the bar is red; 90% or more, the bar is green;
you can change this threshold percentage by editing the
Pref Cover age(cutoff) preference variable

Thediagram below show aportion of the Workspace window panewith code coverage data

displayed.

IStmt Count IStthits |Stmtf’é IStthraph IBranu:h Covnt IBranch Hits |Branch3; IBranch Graph |

17 17 100,000 12 12 100,000
23 211 59.407 [ 51 47 5215 I
1 1 100,000
763 420 55.045 ] 17 21 6923
26 25 95154 ] 20 19 55.000 ]

Y ou can sort code coverage information for any column by clicking the column heading.
Clicking the column heading again will reverse the order.
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Workspace context menu

When you right-click in the Files tab of the Workspace pane, you open the following
context menu.

YWiew Source
Save List...
Coverage #

Froperties...

The menu includes the following options:

» View Source
Allows you to view the selected file in the Source window.

» Savelist
Opensthe Save File List dialog and allows you to save the coverage statistics for the
selected filein atext file.

* Coverage
Opens a submenu that allows you to generate coverage reports, exclude the selected file
from the coverage statistics (this selection will cause the file to appear in the Current
Exclusions pane), or clear coverage data.

Coverage Reports. .
Exclude Selected File

Clear Coverage Data

» Properties
Opens the File Properties dialog box, which displays the file name, location, MS-DOS
name (full pathname), file size, the last time the file was modified, and file attributes.

Coverage information in the Workspace pane is dynamically linked to the Missed
Coverage pane and the Current Exclusions pane. Click the left mouse button on any filein
the Workspace pane to display that file' s un-executed statements, branches, conditions,
expressions, and togglesin the Missed Coverage pane. Linesfrom the selected filethat are
excluded from coverage statistics are displayed in the Current Exclusions pane.

UM-429
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Missed Coverage pane

When you select afile in the Workspace pane, the Missed Coverage pane displays that
file's un-executed statements, branches, conditions, and expressions and signals that
haven't toggled. The pane includes atab for each item, as shown below.

Mizzed Coverage %]
"FI Mizzed Statements e
yL| test_sm.ow

- 15 &

X 15 into = { . b

—}( le endtask

¥ 0 I

X 70 dinta = { i b

—){ Tl endtask

-—K 110 repeat | 1

- 112 rd wdi'hol);

¥ 170 @ {posedge clk) 5
a | 1 . ]

QStatement l Branch l Condition l E:-:pressil:unl Tngglep

Each tab includes a column for the line number and a column for statement, branch,
condition, expression, or toggle on that line. The "X" indicates the item was not executed.

The Branch tab also includes a column for branch code (conditional "if/then/else" and
"case" statements). " X" indicates that only the true condition of the branch was not
executed. "X¢" indicates that only the false condition of the branch was not executed.
Fractional numbers indicate how many case statement labels were not executed. For
example, if only one of four case labels executed, the Branch tab would indicate "X 1/4."

Mizzed Coverage %]

"FI Mizzed Branches

43 case [state)

£l case fopcode)

< | ]
Statement | Branch l I:l:unl:litil:unl E:-:pressil:unl Tl:ngglej

When you right-click any item in the Statement, Branch, Condition, or Expression tabs an
Exclude Selection button will pop up, alowing you to exclude the item from coverage
statistics and make it appear in the Current Exclusions pane.
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Current Exclusions pane

The Current Exclusions pane lists al files and lines that are excluded from coverage
gtatistics. See "Excluding items from coverage" (UM-443) for more details.

=l

Current Exclugions

test_zm.w

Line: 70
Instance: fest_sm
L Line: 119

E—%test_sm.v [pragmal
Limes : 22-26

Line : 22

Line : 23

Line : 24

Line : 26

el i

The Current Exclusions pane offers a pop-up menu
with commands for controlling exclusions. Cancel Selected Exclusions
Right-click anywhere in the pane to access the
following commands:

» Cancel Selected Exclusions
Cancels exclusion filtering for selected lines or Hide Pragma E xcluzsions
files and places them back into the coverage
statistics.

Load Exclusion File
Save Excluzions File

» Load Exclusion File
Opens the Load Exclusion File dialog, allowing you to select a saved exclusion file for
loading. Eliminates the need to create a new exclusion file for every simulation run.

» Save ExclusionsFile
Opens the Save Current Exclusions dialog, allowing you to name and save all current
exclusionsin asinglefilefor later recall. Loading a saved exclusion file eliminates the
need to create a new exclusion file for every simulation run.

» Hide (Show) Pragma Exclusions
Toggles the Current Exclusions pane to hide or show VHDL and Verilog pragma
exclusions.
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Instance Coverage pane

The Instance Coverage pane displays coverage statistics for each instance in aflat, non-
hierarchical view. The Instance Coverage pane contains the same code coverage statistics
columns as in the "Workspace pane" (UM-427)

A partia view of the Instance Coverage paneis shown below.

Inztance Coverage

‘FI Inztance I Design unit | Design unit tpe I Strnt count I Strnt hits I Strnt rmisses I Strnt 2 I Strnt
oF Atest_smdzram_0 beh_sram M odule 10 2] 1 0%
o Atest_smdzm_seqddzm 0 sm b odule a0 27 3 0%
o Atest_smdarn_seql 2Mm_seq b odule 23 22 1 BE I
oF Atest_zm best_zm Module I 59 18 75.6E

Instance coverage pane context menu
Right-click any item in the Instance Coverage pane to open a pop-up menu that allows you
to create reports, set adisplay filter, or clear coverage data for the design.

Coverage reports...
Set filter...

Clear coverage data

» Coveragereports opens the Coverage Report dialog, which allows you to create a
number of different code coverage reports (see "Reporting coverage data" (Um-446) for
details).

» Set filter opensthe Filter instance list dialog, which allows you to filter coverage
statistics (see "Filtering coverage data" (Um-441) for details).

» Clear coverage data clears al coverage statistics for every item in the design.
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After code coverage is invoked and the simulation is loaded and run you can turn on the
Details pane by selecting View > Coverage > Detailsin the Main window. The Details
pane shows the details of missed coverage. When an item is selected in the Missed
Coverage pane, the details of that coverage are displayed in the Details pane. Truth tables

will be displayed for condition and expression coverage, as shown here.

Details =]
File: C:/CodeCoverageb.8/verilogs/beh sram. v
Line: 321
Truth table for:
if (rd_ || wr_)
rd
| wr_
I I fed_ ] wr_}
count [
& 1 -1
19 -11
u] ooao
1 urnkrot
Condition: Z out of 3 (66.7%) covered.
Toggle details are displayed as follows:
Detailz %]
Instance: /test_swm/sram 0O
Bigmal: dat
Node count: 32
IH->0L: 1
OL->1H: 2
OL->XZ: 134
XZ-A0L: 142
1H--XZ: Z6
XZ-+1H: 1%

Toggle Coverage: 2.1Z5%
01 Coverage: 10._943%
Full Coverage: <43_75%
XfZ Coverage: =0.1g%
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By clicking the left mouse button on the statement Hits column in the Source window, all
coverage information for that line will be displayed in the Detail s pane as shown here:

Details |
File: C:/CodeCoverageb.8/verilogs/beh sram. v
Line: 321
Truth table for:
if (rd_ || wr_)
rd
| wr
[ fed_ || wr_;
count [
[ 1 -1
13 -11
u] ooao

Condition: 2 out of 2 (EE.7%) covered.
Branch Coverage for:

if (rd_ || wr_)
Bramnch: True: Z5 False: 1

Statement Coverage for:
if (rd_ || wr_)
Hit=s: Z&
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Viewing coverage data in the Source window

The Source window (UM-325) includes two columns for code coverage statistics — the Hits
column and the BC (Branch Coverage) column. These columns provide an immediate
visual indication about how your source code is executing. The default code coverage
indicators are check marks and Xs.

* A green check mark indicatesthat the statements and/or branchesin aparticular line have
executed.

A red X indicates that a statement or branch was not executed.

An X+ indicates the true branch of an conditional statement was not executed.
» An Xg indicates the fal se branch was not executed.
» A green"E" indicatesaline of code that has been excluded from code coverage statistics.

B source - sm.¥ : -0l =|
File Edit W%iew Tools SWindow
S HS 4 BRROMYN B TeHEGEBR BTE D A
HitsI BC I & Iln #I zim: ftest_smdem_geqldzm_0: C/CodeCoverageb. 8 vernlog/zm. v Id
{ ,K 43 case (state) SSsynopsys full case parallel casze
o { &0 IDLE: /¢ IDLE
ZZ /B £l case[Mopcode) s synopsys parallel case
{ { Bz F onop
{ £z n state = IDLE;
Xz 54 P arael J
E 55 n_state = CTRL;
e v 15 £ wt_wd
v 57 n_state = WT_UD_1;
v Vi 58 £ wt_blk
{ s n _state = WT_ELE 1;
ra e — P j
ﬂ_b”test_sm.vl sm_seq.vl sm.v] a | |_>|
= Lr: 43 Cob 0 |Read| Byinst

When you hover the cursor over aline of code (see line 51 in the illustration above), the
number of statement and branch executions, or "hits," will be displayed in place of the
check marks and Xs. Notice, in thisillustration, five of six conditions have been executed.

Also, when you click in either the Hitsor BC column, the Detail s panein the Main window
updates to display information on that line.
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The Source window View menu provides five options for displaying coverage statistics:

- view IR
Show line numbers
Show language templates

Show coverage data

Show branch coverage
Show coverage humnbers
Show coverage By [nstance

Froperties. ..

» Show line number stoggles the In # column off and on.
» Show cover age data toggles the Hits column off and on.
» Show branch cover age toggles the BC column off and on.

» Show cover age number sdisplays the number of executionsin the Hits and BC columns
rather than checkmarks and Xs. When multiple statements occur on asingle line an
dlipsis ("...") replaces the Hits number. In such cases, hover the cursor over each
statement to highlight it and display the number of executions for that statement.

» Show coverage By | nstance displays only the number of executions for the currently
selected instance (in the Main window workspace).

Y ou canskipto"missed lines' threeways: select Edit > Previous Coverage Missand Edit
> Next Coverage Miss from the menu bar; click the Previous zero hits and Next zero hits
icons on the toolbar; or press <Shift> - <Tab> (previous miss) or Tab (next miss).
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Toggle coverage

Toggle coverage is the ability to count and collect changes of state on specified nodes,
including Verilog nets and registers and the following VHDL signal types: hit, bit_vector,
std_logic, and std_logic_vector. Toggle coverageisintegrated asametric into the coverage
tool so that the use model and reporting are the same as the other coverage metrics.

There aretwo modes of toggle coverage operation - standard and extended. Standard toggle
coverage only countsL ow or 0<-->High or 1 transitions. Extended toggle coverage counts
these transitions plus the following:

XorZ-->1orH
XorZ-->0orL
lorH-->Xorz
OorL->XorZ

This extended coverage allows amore detailed view of testbench effectivenessand is
especialy useful for examining coverage of tri-state signals. It hel psto ensure, for example,
that a bus has toggled from high'Z'toa'l' or ‘0", and a1’ or '0' back to ahigh 'Z'.

Enabling Toggle coverage

In the Enabling Code Coverage (UM-423) section we explained that toggle coverage could
be enabled during compile by using the 't’ or 'x’ arguments with vcom -cover or viog
-cover . This section describes two other methods for enabling toggle coverage:

1 using thetoggle add command (CR-271)

2 using the Tools > Toggle Coverage > Add or Tools > Toggle Cover age > Extended
selections in the Signals window menu.

Using the toggle add command

The toggle add command alows you to initiate toggle coverage at any time from the
command line. (See the Command Reference (CR-271) for correct syntax and arguments.)
Upon the next running of the simulation, toggle coverage datawill be collected according
to the arguments employed (i.e., the -full argument enables collection of extended toggle
coverage statistics for the six transitions mentioned above).
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Using the Signals window menu selections

Y ou can enable toggle coverage by selecting Tools > Toggle Coverage> Add or Tools >
Toggle Cover age > Extended from the Signal swindow menu. These selectionsallow you
to enable toggle coverage for Selected Signals, Signalsin Region, or Signalsin Design.

After making a selection, toggle coverage statistics will be captured the next time you run
the simulation.

Excluding nodes from Toggle coverage

Y ou can disable toggle coverage with the toggle disable command (CR-273). This
command disabl estoggl e statistics collection on the specified hodes and provides amethod
of implementing coverage exclusions for toggle coverage. It isintended to be used as
follows:

1 Enabletoggle statistics collection for all signals using the -cover t/x argument to vcom
or vlog.
2 Exclude certain signals by disabling them with the toggle disable command.

The toggle enable command (CR-274) re-enables toggle statistics collection on nodes
whose toggl e coverage has previously been disabled viathe toggle disable command. (See
the Command Reference for correct syntax.)
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Viewing toggle coverage data in the Signals window
Toggle coverage datais displayed in the Signals window in multiple columns, as shown
below. Thereis a column for each of the six transition types.
=10l x|

Fil= Edit Wiew Add Tools Window

H M EE “ Contains: ’7@‘

<

|sim:ftest_smfsm_squfam_D

Right click any column name to toggle that column on or off.

The following table provides a description of the available columns:

Column name

Description

Name

the name of each signal in the current region

Value

the current value of each signal

1H -> 0L

the number of times each signal has transitioned from a1
or aHigh stateto a0 or aLow state

OL ->1H

the number of times each signal has transitioned from a0
or aLow stateto 1 or aHigh state

oL -> XZ

the number of times each signal has transitioned from a0
or aLow state to an unknown (X) or ahigh impedance (Z)
State

XZ ->0L

the number of times each signal has transitioned from an
unknown or high impedance stateto a0 or aLow state

1H ->XZ

the number of times each signal has transitioned from a1
or aHigh state to an unknown or a high impedance state

XZ ->1H

the number of times each signal has transitioned from an
unknown or a high impedance state to 1 or a High state

# Nodes

the number of scalar bitsin each signal

# Toggled

the number of nodes that have transitioned at least once

% Toggled

the current ration of the # Toggled to the # Nodes for each
signal
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Column name Description

% 01 the percentage of 1H -> OL and OL -> 1H transitions that
have occurred (transitionsin the first two columns)

% Full the percentage of al transitions that have occurred (all six
columns)

% XZ the percentage of OL -> XZ, XZ ->0L, 1H -> XZ, and

XZ -> 1H transitions that have occurred (last four colmns)

Toggle coverage reporting

Thetoggle report command (CR-275) displaysalist of all nodes that have not transitioned
at least once. Also displayedisasummary of the number of nodes checked, the number that
toggled, the number that didn't toggle, and a percentage that toggled.

Thetoggle report command isintended to be used as follows:
1 Enable statistics collection with the toggle add command (CR-271).
2 Run the simulation with the run command (CR-246).

3 Produce the report with the toggle report command..

WS5IM B toagle report test_sm

#
§ Toggle Report Hode 1H-=0L 0L-=1H OL-=XE HE-+0L 1H-=¥2 HE-r1H

F*

ftest_sm/finto[31]
frest_sm/intol[Z7]
frest_sm/intol[Z6]
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frest_sm/intol[ZZ]
frest_sm/fintol[Zl]
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ftest_sm/into[l3]
frest_sm/into[l7]
ftest_sm/into[le]
ftest_sm/into[l5]
frest_sm/finto[l4]
frest_sm/into[l3]
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Y ou can produce this same information using the cover age report command (CR-137).
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Filtering coverage data

Y ou can specify a percentage above or below which you don’t want to see coverage
statistics. For example, you might set a threshhold of 85% such that only items with
coverage below that percentage are displayed. Anything above that percentage isfiltered.

Y ou can set afilter using either adialog or toolbar icons (see below). To accessthe dialog,
right-click any item in the Instance Coverage pane and select Set Filter.

Filter instance list ] |

— Filter method—— [ Cowverage Type—
¥ Statement
% Mafilkering v Branch
™ Filker above threshold ¥ Condition
™ Filter below threshold ¥ Expression
¥ Tooggle
— Threzhald level
100
aF. | Cancel |

The dialog has the following options:

* Filter method
Specifies whether you want to filter items that exceed the threshold or fall below the

threshold.

» Coverage Type
Determines which coverage statistics you want to filter.

» Threshold level
Specifies the percentage above or below which items are filtered.
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Covfilter toolbar

window.

When you simulate with Code Coverage enabled, the Covfilter toolbar isadded to theMain
Covfilter

3 1 T Thieshold 1003

= ? X |
The toolbar has the following buttons..

Covfilter toolbar buttons
Button

EnableFiltering
34

Threshold above
1

enables display filtering of coverage statistics in the Workspace and
Instance Coverage panes of the Main window

columns

Threshold below
T

displays all coverage statistics above the Filter Threshold for selected

columns

displays all coverage statistics below the Filter Threshold for selected
Filter Threshold

Statement

| 1003 specifiesthe display coverage percentage for the selected
coverage columns

applies the display filter to al Statement coverage columnsin the

Workspace and Instance Coverage panes of the Main window
Branch

-7

Condition
3

appliesthe display filter to al Branch coverage columnsin the
Workspace and Instance Coverage panes of the Main window

applies the display filter to all Condition coverage columnsin the

Workspace and Instance Coverage panes of the Main window
Expression

X

Workspace and Instance Coverage panes of the Main window
Toggle
=

applies the display filter to al Expression coverage columnsin the

appliesthe display filter to all Toggle coverage columnsin the
Workspace and Instance Coverage panes of the Main window
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Excluding items from coverage

Y ou can exclude any number of lines or entire files so Model Sim doesn’t collect statistics
on them. The line exclusions can be instance-specific or they can apply to all instancesin
the enclosing design unit. Y ou can also exclude nodes from toggl e statistics collection
using the toggle disable command (CR-273).

There are three methods for excluding lines and files:
» Use apopup menu command in the GUI

* Insert pragmas into your source code

 Create an exclusion filter file

Excluding lines/files via the GUI

There are several locationsin the GUI where you can access commands to exclude lines or
files:

» Right-click afilein the Main window Workspace pane and select Coverage > Exclude
Selected File from the popup menu.

* Right-click an entry in the Main window Missed Coverage pane and select Exclude
Selection or Exclude Selection For Instance <inst_name> from the popup menu.

* Right-click alinein the Hits column of the Source window and select Exclude Coverage
Linexxx, Exclude Coverage Linexxx For Instance <inst_name>, or Exclude Entire
File.

Excluding lines/files with pragmas

M odel Sim al so supportsthe use of source code pragmasto selectively turn coverage off and
on. In Verilog, the pragmas are:

/'l coverage off
/'l coverage on

In VHDL, the pragmas are:

-- coverage off
-- coverage on

Bracket the line or lines you want to exclude with these pragmas.

P Note: Pragmas cannot be used to exclude specific conditions or expressions within lines.
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Excluding lines/files with a filter file

Exclusion filter files specify files and line numbers that you wish to exclude from the
coverage statistics. Y ou can create thefilter file in any text editor or save the current filter
in the Source window by selecting File > Save > Exclusion File (Main window). To load
thefilter during afuture analysis, select File > Open > Exclusion File (Main window).

Syntax

<filename>..
[[<range> ...] [<line#> ...]] | al

or

begi n i nstance <i nstance_nane>..
<inst_filenane>...

[[<range> ...] [<line#> ...]] | al
end instance

Arguments

<fil ename>
The name of thefile you want to exclude. Required if you are not specifying an instance.
Thefilter file may include an unlimited number of filename entries, each onitsown line.
Y ou may use environment variables in the pathname.

begi n i nstance <i nstance_nanme>
The name of an instance for which you want to exclude lines. Required if you don’t
specify <filename>. The filter file may include an unlimited number of instances.

<inst_fil ename>
The name of the file(s) that compose the instance from which you are excluding lines.
Optional.

<range> ..
A range of line numbersyou want to exclude. Optional. Enter therangein "#- #' format.
For example, 32 - 35. Y ou can specify multiple ranges separated by spaces.

<line#> ..
A linenumber that you want to exclude. Optional. Y ou can specify multipleline numbers
separated by spaces.

al
Specifiesthat al linesin thefile should be excluded. Required if arange or line number
is not specified.

Example

control.vhd
72 - 76 84 93
testring.vhd
al
begi n instance /test_delta/chip/bid0l_inst
src/del ta/ buffers.vhd
45- 46
end instance
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Default filter file

The Tcl preference variable PrefCoverage(pref_InitFilter From) specifies adefault filter
file to read when adesign isloaded with the -cover age switch. By default thisvariableis
not set. See "Code Coverage preference variables' (um-454) for details on changing this

variable.

A file named workingExclude.cov appears in the design directory when you specify
exclusionsin the GUI. Thisfile remains after quitting simulation.

Excluding nodes from toggle statistics

To exclude nodes from toggle statistics collection, use the toggle disable command (CRr-
273).
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Reporting coverage data

To create reports on coverage statistics, use either the cover agereport command (CR-137),
the toggle report command (CR-275) (see Toggle coverage reporting (UM-440) in this
chapter), or the Coverage Report dialog.

To access the Coverage Report dialog, right-click any item in the Files tab of the
Workspace pane and select Cover age > Coverage Reports; or, select Tools > Coverage
> Reports (Main window).

|3 Coverage Repork o ] |

= Report on all files

™ Feport on allinstances

* Report on a specific instance

Inztance Namel Browse. ..

" Report on a source file

File: Namel Browse. .
Coverage Type

¥ Statement Coverage [ Ewpression Coverage

[ Branch Coverage [T Toggle Coverage

[T Condition Coverage [T Estended Toggle Coverage

— Other Options

L e R T [ Zero Coverage Only

i+ Mo Filtering [T Include Line Details

" Filter Above Percert I Coverage Tatals Only

" Filter Below Percent " Disable Source Annatation

Fercent I?E_ [ Recursive
[ wiite 3ML Farmat

Report Pathname

|repu:urt.t:-:l Browsze... |

[ append to file

Ok | Cancel |

The dialog contains these options:

* Report on all files
Saves atextual summary for each filein the design.

* Report on all instances
Saves atextual summary for each instance in the design.
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» Report on a specific instance
Saves atextua summary for the specified instance. The selected instance automatically
appears in the Instance Name field. Y ou can browse for other instances.

» Report on a sourcefile
Saves atextual summary for the specified source file. The selected file automatically
appears in the File Name field. Y ou can browse for other sourcefiles.

The Cover age Type section of the dialog allows you to select the type of coverage to be
reported — statement, branch, condition, expression, toggle, and extended toggle coverage.

The Coverage Report dial og includes optionsfor filtering report dataaccording to coverage
percent. The default is No Filtering.

» Zero Coverage Only
Saves atextual summary of statement and branch coverage that includes columnsfor the
number of statements and branches not executed.

* Include Line Details
Saves a detailed textual report of the statement and branch coverage for every line of
code.

* Include Coverage Totals
Saves atext report of the coveragetotals by filesand by instances. Includestotal hitsand
coverage percentages for all active statements and branches.

» Disable Source Annotation
Removes source code from coverage reports.

* Recursive
Reports on the specified instance, and al included instances, recursively.

* Write XML format
Produces output in an XM L-structured format. The following exampleisan abbreviated
"By Instance" report that includes line details:
<?xm version="1.0"?>

<report xm ns="http://nodel.confcoverage"
l'ines="1"

<instance path="/test_delta/chip/control _126k_i nst" du="node_two_control "

<source_table files="1">

</ sour ce_t abl e>

<statenents active="30" hits="17" percent="56.7"> </statenents>
<st at ement _dat a>

<stm fn="0" |In="39" st
<stm fn="0" |n="42" st
<stmt fn="0" |n="44" st

"1" hits="82"> </stnt>
"1" hits="82"> </stnt>
"1" hits="82"> </stnt>

"fn" stands for "filename", "In" standsfor "line number", and "st" stands for " statement.

UM-447
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Sample reports

Below are two abbreviated coverage reports with descriptions of select fields.

Zero counts report by file

+; Notepad - 0] x|

Fil= Edit ‘Window

=2 report bt =8|

# Coverage Report by file of statements with zero counts (non instance specific)

# Statement Coverage:

# File Stmts MNis=e= %

# L
C:/modelsim examples/coverage/Arb.vhd Z36 14 9.3

# Statement Coverage:

# File Jtmts Misszes 5

# S L Lo
C:/modelsim examples/coverage/Fifo.vhd 17 a 5z.9 s

# 3Jtatement Coverage:

# File Stmts Nisses %

# S L Lo
C:/modelsim examples/coverage,/Fs_add.vhd 4 1 75.0

# Statement Coverage:

# File Ftmta Mizzes e

# S L Lo
C:fmodelsim exawples/coverage/Micro.v Zh 15 4z .73

#fi Starsement CAtretracts s j

The "%" field shows the percentage of statementsin the file that had zero coverage.
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Instance report with line details

| ‘Motepad 1Ol x|

File Edit Window

=i report. kxt =8 x|

L

ﬁ Coverage Heport by Instance with line data

# Statement Coverage:

# Inst i) atmts Hits 5
# o i .
Jtest_deltafchip/control 126k inst mode two control 30 17 56.7
#
# Statewent Coverage for instance /test_deltad/chips/eontrol 126k _inst —-
#
# Line Stmt Count
# ———— N,
File C:/mwodelsim examples/coverage/Hodetwo.v
39 1 g2
42 1 g2
44 1 82
45 1 22
[line=s 46 through 54 rewowved for this example]
" £
<] | |

The"Stmt" field identifies the number of statements with zero coverage on that line.

Branch count report snippet
The following report snippet demonstrates two values that require explanation:

# Branches with Zeros

#
# Li ne St True Fal se
# - [ .
211 1 I NF 0
421 1 0 465, 987, 218
665 1 - 0
Value Meaning
INF coverage value has exceeded ~4 billion (232 -1)

- thefield isirrelevant to that particular line of code; for example, line
665 in the report above will never have an entry under the True column
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Saving and reloading coverage data

Raw coverage data can be saved and then reloaded later. Saved data can also be merged
with coverage statistics from the current simulation. Y ou can perform these operations via
the command line, the graphic interface, or the $coverage _save Verilog system task (see
"Model Sim Verilog system tasks" (UM-149)).

From the command line

The cover age save command (CR-140) saves current coverage statisticsto afile that can be
reloaded | ater, preserving instance-specific information.

The cover age reload command (CR-136) seeds the coverage statistics of the current
simulation with the output of a previous cover age save command. This allows you, for
example, to gather statistics from multiple simulation runs into a single report.

From the graphic interface
To save raw coverage data, select Tools > Coverage > Save (Main window).
To reload previously saved coverage data, select Tools > Coverage > L oad.

| Load Coverage Data 100 x|

— Cowerage Data Pathhame

| Browse. . |

—Inztall Fath

— Lewelz of Higrarchy ta Stip

[~ Merge

k. | Eann::ell

Loading a previously saved file clears all existing coverage data unless you check Merge.
If you check Mergein this dialog, Model Sim merges the saved coverage data with
coverage data in the current simulation.

Optionally, you can change the hierarchy of the file you are loading. Use the I nstall Path
field to add hierarchy, and L evels of Hierarchy to Strip to delete hierarchy. This allows
you to merge coverage results from simulations that have different hierarchies.
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With the vcover utility

The merge utility, vcover merge, allows you to merge sets of coverage data without
requiring elaboration of the design or asimulation license. It isastandard Model Sim utility
that can be invoked from within the GUI or from the command line.

Seethe vcover mer ge command (CR-311) in the Model Sm Command Reference for further
details.

ModelSim SE User’'s Manual



UM-452 12 - Code Coverage

Coverage statistics details

This section describes how condition and expression coverage statistics are calculated. In
general, condition and expression coverage is limited to boolean and std_logic types. The
coverage utility will analyze conditions and expressions of the form <integer variable>
<op> <integer constant>. It will not, however, produce coverage resultswhen, for example,
two variables are being compared.

Condition coverage

Condition coverage analyzes the decision made in "if" and ternary statementsand is an
extension to branch coverage. A truth table is constructed for the condition expression and
counts are kept for each row of the truth table that occurs. For example, the following IF
statement:

Line 180: IF (a or b) THEN x := 0; else x :=1; endif;

reflects this truth table.

Truth table for line 180

counts a |b |[[(aorb)
Row 1 5 1 - 1
Row 2 0 -1 1
Row 3 8 0 0 O
unknown | O

Row 1 indicatesthat (a or b) istrueif aistrue, no matter what b is. The "counts" column
indicates that this combination has executed 5 times. The'-' character means "don't care.”
Likewise, row 2 indicates that the result istrueif b is true no matter what ais, and this
combination has executed zero times. Finally, row 3 indicates that the result is always zero
when aiszero and b is zero, and that this combination has executed 8 times.

The truth table body only deals with boolean values. If any inputs are unknown, the result
is set to unknown and is counted.

Valuesthat are vectors are treated as subexpressions external to the table until they resolve
to aboolean result. For example, take the I F statement:

Line 38 IF ((e ='1') AND (bus = "0111")) ...
A truth table will be generated in which bus = "0111" is evaluated as a subexpression and

the result, which is boolean, becomes an input to the truth table. The truth table looks as
follows:

Truth table for line 38
counts e |(bus="0111") ||e="'1") AND (bus ="0111")

Row 1 0 0o - 0
Row 2 10 -0 0
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Truth table for line 38
counts e |(bus="0111") ||e='1") AND (bus="0111")

Row 3 1 1 1 1

unknown | O 0

Index expressions also serve as inputs to the table. Conditions containing function calls
cannot be handled and will be ignored for condition coverage.

If aline contains a condition that is uncovered - some part of its truth table was not
encountered - that line will appear in the Missed Coverage pane under the Conditions tab.
When that lineis selected, the condition truth table will appear in the Details pane and the
line will be highlighted in the Source window.

Condition coverage truth tables are printed in coverage reports when the Condition
Coverage typeis selected in the Coverage Reports dialog (see "Reporting coverage data’
(UM-446)) or when the -lines argument is specified in the cover age report command and
one or more of the rows has a zero hit count.

Expression coverage

Expression coverage analyzes the expressions on the right hand side of assignment
statements and counts when these expressions are executed. For expressions that involve
boolean operators, atruth table is constructed and counts are tabulated for conditions
matching rows in the truth table.

For exampl e, take the statement:
Line 236: x <= a xor (not b(0));

Thisresults arein the following truth table, with associated counts.

Truth table 236
counts a |b(0) |(axor (notb(0)) |||/(not b(0))
Row 1 1 0 O 1 1
Row 2 0 0 1 0 0
Row 3 2 1 0 0 1
Row 4 0 1 1 1 0
unknown | O

If aline contains an expression that is uncovered - some part of its truth table was not
encountered - that linewill appear in the Missed Coverage pane under the Expressions tab.
When that lineis selected, the expression truth table will appear in the Detail s pane and the
line will be highlighted in the Source window.

Aswith condition coverage, expression coverage truth tables are printed in coverage
reportswhen the Expression Coveragetypeis selected in the Coverage Reportsdialog (see
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"Reporting coverage data" (UM-446)) or when the -lines argument is specified in the
cover age report command and one or more of the rows has a zero hit count.

Code Coverage preference variables

ModelSim SE User’'s Manual

Various Tcl variables control how the coverage datais displayed. Y ou can set these
preference variables by selecting Tools > Edit Preferencesin the Main window; then, in
the Preferences dia og box select the By Name tab and expand the Cover age hierarchy.
Select aproperty and click the Change Value button to change values. Use the Apply
button to view temporary changes, or Save the changesto alocal modelsim.tcl file. Once
saved, the preferenceswill bethe default for subsequent simul ationsinvoked from the same
directory.
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Introduction

The Model Sim Waveform Compare feature allows you to compare the current live
simulation against a reference dataset (.wif file), compare two datasets, or compare
different parts of the current live simulation. Y ou can view the results of these comparisons
in the Wave and List windows and generate atext file of the results in the Main window.

With the Waveform Compare feature you can:

* gpecify the signals or regions to be compared

» define tolerances for timing differences

* set astart time and end time for the comparison

* limit the comparison to a specific number of timing differences

« step through a succession of timing differences via buttons in the Wave window

All differences encountered in the comparison are summarized and listed in the transcript
area of the Main window. Waveform differences are also displayed in the Wave and List
windows (see "Wave window display” (UM-466) and " Compare objectsin the List window"
(UM-470)). You can also write alist of the differencesto afile using the compareinfo
command (CR-112).
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Two modes of comparison

The Waveform Compare feature provides two modes of comparison: continuous and
clocked.

Continuous Compare

In the continuous mode, atest signal (or agroup of test signalswithin aregion) iscompared
to areference signal (or agroup of reference signals within aregion) at each transition of
the reference. Timing differences between the test and reference signals are highlighted
with rectangular red difference markersin the Wave window and yellow markersinthe List
window.

The continuous compare mode allows you to specify two edge tolerances for timing
differences. Theleading edge tol erance specifies how much earlier the test signal edge may
occur beforethereferencesignal edge. Thetrailing edge tol erance specifies how much later
the test signal edge may occur after the reference signal edge. The default value for both
tolerancesis zero. In addition, these tolerances may be specified differently for each signal
compared.

Clocked Compare

Clocked comparisons allow you to make acomparison only at or just after an edge on some
signal. In this mode, you define one or more clocks. The test signal is compared to a
reference signal and both are sampled relative to the defined clock. The clock can be
defined as the rising or falling edge (or either edge) of a particular signal plus a user-
specified delay. The design need not have any events occurring at the specified clock time.

Differences between the test signal (s) and clock are highlighted with red diamondsin the
Wave window.
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Comparing hierarchical and flattened designs

If you are comparing a hierarchical RTL design simulation against a flattened synthesized
design simulation, you may have different hierarchies, different signal names, and the
buses may be broken down into one-bit signalsin the gate-level design. All of these
differences can be handled by Model Sim’s Waveform Compare feature.

« If thetest design is hierarchical but the hierarchy is different from the hierarchy of the
reference design, you can use the compar e add command (CR-100) to specify which
region path in the test design corresponds to that in the reference design.

« If the test design isflattened and test signal names are different from reference signal
names, the compar e add command (CR-100) allows you to specify which signal in the
test design will be compared to which signal in the reference design.

« If, in addition, buses have been dismantled, or "bit-blasted", you can use the -r ebuild
option of thecompar eadd command (CR-100) to automatically rebuild the busin thetest
design. Thiswill allow you to look at the differences as one bus versus another.

If signalsinthe RTL test design are different in type from the synthesized signalsin the
reference design —registers versus nets, for example—the Waveform Compare feature will
automatically do the type conversion for you. If the type differences are too extreme (say
integer versus real), Waveform Compare will let you know.
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Graphic interface to Waveform Compare

Waveform Compare isinitiated from either the Main or Wave window by selecting Tools
>Waveform Compare > Start Comparison.

Opening dataset comparison

The Start
Comparison dialog
box allows you
define the
Reference and Test
datasets.

Reference
Dataset

The Reference
Dataset isthe .wif
file that the test
dataset will be
compared to. It can
be a saved dataset,
the current
simulation dataset,
or any part of the
current simulation
dataset.

Test Dataset

Start Comparison

— Reference Datazet

;I Browse. . |

— Test Dataset

€ Use Curent Simulation

I Update comparizon after each run

& Specify Dataset

;I Browsze... |

LCancel

The Test Dataset isthe .wif file that will be compared against the Reference Dataset. Like
the Reference Dataset, it can be a saved dataset, the current simulation dataset, or any part
of the current simulation dataset.

» Use Current Simulation
Selects the current simulation to be used as the Test Dataset. Provides for an optional
update on the comparison after each simulation run.

» Specify Dataset

Allows you to select any saved .wlif file to be used as the Test Dataset.

Y ou can specify either dataset by typing in a dataset name, by selecting a dataset from a
drop-down history of past dataset selections, or by clicking either of the Browse buttons.
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Both Browse buttons take you to the Select Dataset File dialog where you can browse for

the dataset you want.
Select Datazet File EHE |
Lockin: | ‘23 examples | | ﬁl |
datazets 3 widpoker
foreign 3 wpl
mixedHOL rnas. wif
profiler .
projects by lf
tel_tutorial

File narme: Imin.wlf Open I
Filez af type: IL::ug Files [ wif) j Cancel |

Oncethe Reference and Test Datasets have been specified, clicking "OK" in the Compare
Dataset dialog box will place a Comparetab in the project pane of the Main window. After
adding the signal's, regions, and/or clocks you want to use in the comparison (see "Adding
signals, regions, and clocks" (uM-461)) you'll be able to drag compare objects from this
project tab into the Wave and List windows.

-] Modelsim -0 =|
File Edit “iew Compile Simulate Tools  Window  Help

|s BB || &g || LRI B

Workspace S|
Inst Diesign Unit | Design Urit L
;s_anu: | esigh Lni | ssignUnit | {10 a0,

iy

l | B
[ Librany | zim Filesl gu:uldl COMmpare

| ||:|:|m_pare:ft|:|p

L |
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Adding signals, regions, and clocks

To designate the signal s, regions and/or clocksto be used in the comparison, click Tools>
Waveform Compare > Add in the Main or Wave window, then make a selection
(Compare by Signal (uMm-461), Compare by Region (uUM-462), Clocks) from the popup

menu.
Compare by signal :
p y Sig ( _{ol x|
Clicking Tools > ;
Waveform Compare > E_EF_ o
Add > Compare by Signal & F
in the Wave window opens 3 clk
the structure_browser ol 1y
window, where you can e addr
specify signalsto beusedin LD w
the comparison. L stib
You can aso set signa ) data
options by clicking the o addi_r
Options button. See ol data_r
"Comparison Method tab" L
(UM-463) for details. L strb_r
— verbose Ll
ol t_out
i test
i test?
. =
4| [ »
Optionz... (1] 8 | LCancel |

ModelSim SE User’s Manual



UM-462 13 - Waveform Compare

Compare by region

Clicking Tools > Waveform Compare > Add > Compare by Region in the Wave
window opens the Add Comparison by Region window, where you can specify signalsto
be used in the comparison.

Add Comparizon by Region

—  Reference Region

Browse. . |

— Test Region

[ Specily a different name for Test Region

| Browse. . |

— Compare Sighals of Type

¥ In v Ouw [V InQut
¥ Internal [+ Port

¥ PFecursive Search

ok Cancel

Region Data tab

» Reference Region
Allows you to specify the reference region that will be used in the comparison.

» Test Region
Allows you to specify atest region that might have a different name from that of the
reference region.

» Compare Signals of Type
Allows you to specify that All Types of signalswill be used in the comparison or only
Selected Types (In, Out, InOut, Internal, or Port).

* Recursive Search
Specifies whether to search for signals in the hierarchy below the selected region.
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Comparison Method tab

Allows you to select clocked or continuous comparison, and provides the capability to
specify a"When" expression.

Add Comparizon by Region
_ Comparizon tMethod \

" Clocked Comparizon

| default_clock 7| Clacks.. |

¥ Continuous Comparizon

Leading Tolerance Trailing Tolerance

o e | o e o

Specify When Exprezzion

| Builder... |

» Clocked comparison
Allowsyouto select aclock from
the drop-down history of past
clock selections. Or, you can
click the Clocks button to add a
new clock.

Comparizon Clocks

— LClacksz

Clicking the Clocks button opens Add
the Comparison Clocks dialog

box. Modify...
To add asignal, click the Add
button to open the Add Clock Cielete
dialog box, where you can define —_—
aclock signal name, a delay
signal offset, the signal upon
which the clock will be based,
and whether the compare strobe
edge will be the rising or falling Ok Cancel
edge or both. You can also use
the Expression Builder to specify
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awhen expression that must evaluate to "true” or 1 at the signal edge for the clock to
become effective.

Add Clock,

— Clock Mame——— Drelay Signal Offzet
| o s
— Based on Signal
| Browse. .
— Specify "When Expression
| Builder...
— Compare Strobe Edge

* Rising " Falling = Both

Ok Cancel

» Continuous comparison
With the Continuous Comparison method you can set leading and trailing edge
tolerances. The leading edge tolerance specifies how much earlier the test signal edge
may occur before the reference signal edge. The trailing edge tolerance specifies how
much later the test signal edge may occur after the reference signal edge. The default
value for both tolerances is zero. In addition, these tolerances may be specified
differently for each signal compared.

¥ Continuous Comparizon

Leading Tolerance Trailing Tolerance

[N 051 () O 351

* Specify When Expression
Allowsyou to use"The GUI Expression Builder" (um-395) to specify awhen expression
that must evaluate to "true” or 1 at the signal edge for the comparison to become
effective.

Specify When E sprezsion
|r Builder... |
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Setting compare options

Selecting Tools > Waveform Compar e > Optionsin either the Main or Wave windows
provides access to the Comparison Options dialog box. Thisdialog is divided into two
tabs — the General Optionstab and the Comparison Method tab (see "Comparison
Method tab" (Um-463) for a description).

=5 'Eumparisun Options = |EI|E|
General I:Ipti-:uns] Comparnizon Methu:n:l]
— Comparizon Limit Count
Tatal Limit: 1000 Per Signal Lirit; | 100
— WHDL Matching
—wmatches—— 2 matchez—— 1 matches—— [0 matches——
W U V= Crurl X I e Cu Cx
ol 1 C ol 1 o Wi Voo 1
[Tz v w Wzl w rzl w Czl w
CrLITCH CLICH L WH W LI H
v D v D v D ¥ D
— “erlog Matching
# matches £ matches 1 matches [ matches
ol 1 ol 1 o v i o A
W 2 IR e =] =
¥ lgnore Strength
v Automatically add comparizons to the wave window?
Save az Default... Rezet to Default aE. | Cancel

Comparison Limit Count — Allows you to limit the comparison to a specific number
of total differences and/or a specific number of differences per signal.

VHDL Matching— Allowsyou to designate which VHDL signal valueswill match X,
Z, 1, and 0 values.

Verilog Matching — Allows you to designate which Verilog signal values will match
X, Z, 1, and 0 values. It aso allows you to ignore the strength of the Verilog signal and
consider only logic values.

Automatically add comparisonstothewavewindow?— Specifieswhether new signal
comparison objects are added automatically to the Wave window.
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Save as Default — Allows you to save all changes as the new default settings for
subsegquent comparisons.

Reset to Default — Resets al settings to original default values.

Wave window display

=+t wave - default __'Jﬂl_ﬁ
File Edit “iew Insert Format Tools ‘Window

FHS F BRI N XN INmi @RI
e of +f »j

sim: /topdclk.

i/ bopdprv

i/ topy'pshib

sim:/top'pedy

sim:/top/paddr hi 01 Jooo00ii0 joo0ooiil |
iy /top/pdata b I (
i op' s

Eh 9 | e | fo fle

naomnm 0007007
zim:/topsdata FAFFFFF T FF 7777
compare; topfclkes. . | No Data:

compare: topApw., [-No Data-
compare: MopMpstib. . [ Mo Data
compare: MopMprdyc, .| -No Data:
compare: fop padd . |-No Data-
compare: fopfpdat.. |-Mo Data-

compare: MopMsmwd... |-No Data.

compare; fopfastb., [-No Data-

compare: topMardy<.. [ -Mo Dala-

compare: topMsadd. . | -No Data

compare: ftopMadata... | Mo Data:

m_ 2
d
i
-
EH
o ¥
B
E
-4
Ek
A
[=&
G-

Miowe 3B ns
Ons
|EE?I:I ns to 3670 ns |

The Wave window provides a graphic display of comparison results. Pathnames of all test
signalsincluded in the comparison are denoted by yellow triangles. Test signals that
contain timing differences when compared with the reference signals are denoted by ared
X over the yellow triangle.

The names of the comparison items take the form

<pat h>/\r ef Si gnal Nane<>t est Si gnal Name\
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If you compare two signal sfrom different regions, the signal namesinclude the uncommon
part of the path.

In comparisons of signals with multiple bits, you may display them in "buswise" or
"bitwise" format. Buswise format lists the busses under the compare item whereas bitwise
format lists each individua bit under the compare item. To select one format or the other,
click your right mouse button on the plus sign (' +’) next to a compare item.

Timing differences are also indicated by red bars in the vertical and horizontal scroll bars
of the waveform display, and by red difference markers on the waveforms themselves.
Rectangul ar difference markers denote continuous differences. Diamond difference
markers denote clocked differences. Placing your mouse cursor over any difference marker
will initiate a popup display that providestiming details for that difference. Y ou cantoggle
this popup on and off in the Wave Window Propertiesdialog (see " Setting Wave window
display properties’ (UM-352)).

Pathnames Values Waveform display

difference details difference markers

The values column of the Wave window displaysthe words "match” or "diff" for every test
signal, depending on the location of the selected cursor. "Match” indicates that the val ue of
the test signal matches the value of the reference signal at the time of the selected cursor.
"Diff" indicates a difference between the test and reference signal values at the selected
CUrsor.

Annotating differences

Y ou can tag differences with textual notesthat areincluded in the difference detail s popup
and comparison reports. Click a difference with the right mouse button, and select
Annotate Diff. Or, use the compar e annotate (CR-104) command.
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Compare icons

The Wave window includes six comparison icons that

let you quickly jump between differences. From left to ‘ HHE e o
right, the icons do the following: find first difference,
find previous annotated difference, find previous difference, find next difference, find next
annotated difference, find last difference. Use these icons to move the selected cursor.

These buttons cycle through differences on al signals. To view differencesfor just the
selected signal, press <tab> and <shift - tab> on your keyboard.

P Note: If you have differences on individual bits of abus, the compareiconswill stop on
those differences but <tab> and <shift - tab> will not.

A comparison is independent from any window in which you view it. Asaresult, if you
have two Wave windows displayed, each containing different comparison objects, the
compare icons will cycle through the differences displayed in both windows.

Waveform Compare menu

The Compar e menu provides anumber of optionsfor controlling waveform comparisons.

+ Start Comparison
Opens the Compar e Dataset dialog box where you can enter reference and test dataset
names.

» Comparison Wizard
Gives step-by-step assistance while you create a waveform comparison.

* Run Comparison
Computesthe number of differencesfrom timezeroto the end of the simulation run, from
time zero until the maximum total number of differences per signal limit is reached, or
from time zero until the maximum total number of differences for all signals compared
isreached. Thisinformation is posted to the Main window transcript. It is equivalent to
the compar e run (CR-120) command:

#

B wirite results to compare_info.txt

compare start

# Computing wavwefarm differences from time 0 ps o 10 us

# kaw total difference per zignal limit of 100 reached on zignal compare
Atet_preudodtol_min_exp_data

ﬂ ®
# Comparizon reached signal differencegTimit at time 3080 nz
# Found 438 differences.

s 3

» Ll

| | typ:ftst pseudo

* End Comparison
Stops difference computation and closes the currently open comparison.
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* Add

Compare by Signal — Opens the structure_browser dialog box and allows you to
designate signals for comparison.

Compar e by Region — Opens the Add Comparison by Region dialog box and allows
you to designate a reference region for comparison. Also allows you to designate a test
region of a different name.

Clocks— Opens the Comparison Clocks dialog box and allows you to define clocks to
be used in the comparison.

* Options
Opens the Comparison Options dialog box, which allows you to define a number of
waveform comparison options.

» Differences

Clear — Clears al differences from the Wave window and resets the waveform
comparison function. It is equivalent to the comparereset command (CR-119).

Show — Displays the differences in text format in the transcript area of the Main
window. It is equivalent to the compare info command (CR-112).

Save — Opens the Specify Differences File dialog box where you can save the
differences to afile that can be reloaded later in Model Sim. The default file nameis
"compare.dif”.

Write Report— Saves areport of the differences to atext file that you can view.
* Rules

Show — Displays the rules or instructions used to set up the waveform compare. It is
equivalent to the comparelist command (CR-113).

Save — Opens the Specify Rule File dialog box and allows you to assign a name to the
file that will contain all rules for making the comparison. The default file nameis
"compare.rul."

* Reload
Opens the Reload and Redisplay Compare Differences dialog box and allows you to
enter or browse for waveform rules and difference file names.

|1:-.__1'FIeluad and Redisplay Compare Differences

— W aveform Rules file name

||:|:|m|:|are.rul Browsze...

—waveform Difference file name

||:|:|m|:|are.u:|if Browsze. .. |

ak. | Cancel |
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Printing compare differences

Y ou can print the compare differences shown in the Wave window either to aprinter or to
a Postscript file. See "Printing and saving waveforms" (UM-363) for details.

Compare objects in the List window

Compare objects can be displayed in the List window too. Differences are highlighted with
ayellow background. Tabbing on selected columns moves the selection to the next
difference (actualy difference edge). Shift-tabbing moves the selection backwards.

File Edit Miew Tools  Window

ns— compare: ftop S olkarolkh— [ T SR o b e L ko
delta— compare: ftop/\pru<sprut—
compare: ftop/ipstrb<rpstrb\—

compare: SLop prdy<sprdyi—,
l1 1001111
l1 1001111
1l 1o0011aa8

OoooDo0l1a0a0 olool D100l

1 10011 0 o0 uelafapNlehmaialalaf¥aiakl
Y ol
2035 +0 11110011
z040 40 oo0llooll
z0s0 40 11110011
z055 +0 11111100
Z080 +0 0o01l11110a0
2l00 +0 11111100
2105  +0 11110011
z1lz0 +0 0Oo0l1lo011l1l

Annotate Diff, and | gnor e/Noignor e diff. With these options you can elect to display
difference information, you can ignore selected differences or turn off ignore, and you can
annotate individual differences.
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Waveform Compare commands

Thetable below provides a brief description of the compare commands. Seethe ModelSm
Command Reference for complete command details.

UM-471

Command

Description

compare add (CR-100)

defines a comparison between the signalsin a specified reference design
and the signalsin a specified test design

compar e annotate (CR-104)

annotates a difference with atextual note

compar e clock (CR-105)

defines aclock for clocked comparison; or, if -delete is specified, deletes
apreviousy-defined clock

compar e configur e (CR-107)

modifies options for compare signals or regions

compar e continue (CR-109)

continues difference computation that had been suspended

compar e delete (CR-110)

deletesasignal or region from the current open comparison

compare end (CR-111)

quits the comparison

compareinfo (CR-112)

writes out results of the comparison; writes to the transcript unless the
-write option is specified

comparelist (CR-113)

shows al the compar e add commands currently in effect

compar e options (CR-114)

sets values for various compare options on the Tcl parser side; when
subsequent commands are called, these values become the defaults

compare reload (CR-118)

reloads comparison differences to allow viewing without recomputation

comparereset (CR-119)

clears the current compare differences, allowing another compare start
to be executed

comparerun (CR-120)

runs the difference computation on the signal's sel ected for comparison;
reports the total number of errors found

compar e savediffs (CR-121)

savesthe comparison result differencesin aform that can bereloaded later

compar e saver ules (CR-122)

saves the comparison setup information (or "rules") to afile that can bere-
executed later as a command file; saves compare options and all clock
definitions and region and signal selections

compar e see command (CR-123)

causesthe specified compare differenceto be made visiblein the specified
wave window, using whatever horizontal and vertical scrollingis
necessary

compar e start command (CR-125)

initializes internal data structures for waveform compare

compar e stop command (CR-127)

used internally by the compar e stop button to suspend comparison
computations in progress

compar e update command (CR-128)

used internally to update the comparison differences when comparing a
live simulation against a .wlif file
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Waveform Compare preference variables

ModelSim SE User’'s Manual

Various Tcl variables control how the compare datais displayed. Y ou can set these
preference variables by selecting Tools > Edit Prefer ences> By Name> Compare(Main
window). Use the Apply button to view temporary changes, or Save the changesto alocal

modelsim.tcl file. Once saved, the preferences will be the default for subsequent
simulations invoked from the same directory.
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C Debug alowsyouto interactively debug FLI/PLI/VPI/SystemC C/C++ source code with
the open-source gdb debugger. Even though C Debug doesn’t provide accessto all gdb
features, you may wish to read gdb documentation for additional information.

A\ Please be aware of the followi ng caveats before using C Debug:

» C Debug is an interface to the open-source gdb debugger. We have not customized gdb
source code, and C Debug doesn’t remove any of the limitations or bugs of gdb.

» We assume that you are competent with C or C++ coding and C debugging in general .

» Recommended usage is that you invoke C Debug once for a given simulation and then
quit both C Debug and M odel Sim. Starting and stopping C Debug more than once during
a single simulation session may cause problems for gdb.

» The gdb debugger has a known bug that makes it impossible to set breakpoints reliably
in constructors or destructors. Be careful while stepping through code which may end up
calling constructors of SystemC objects; it may crash the debugger.

» Generally you should not have an existing .gdbinit file. If you do, make certain you
haven’t done any of the following: defined your own commands or renamed existing
commands; used 'set annotate...’, 'set height...", 'set width...", or 'set print..."; set
breakpoints or watchpoints.
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Supported platforms and gdb versions

M odel Sim ships with the gdb 6.0 debugger. Testing has shown this version to be the most
reliable for SystemC applications. However, for FLI/PLI applications, you can also use a
current installation of gdb if you prefer. C Debug has been tested on the these platforms
with these versions of gdb:

Platform Required gdb version
32-bit Solaris 2.6, 7, 8,9 gdb-5.0-s0l-2.6
32- and 64-bit HP-UX 11.0%, 11.11 wdb version 3.3 or later

64-bit HP-UX B.11.22 on Itanium 2 wdb version 4.2

32-bit AIX 4.2,4.3 gdb-5.1-aix-4.2

32-bit Redhat Linux 7.2 or later /usr/bin/gdb 5.2 or later

aYoumustingtall kernel patch PHKL 22568 (or alater patch that supercedes
PHKL_22568) on HP-UX 11.0. If you do not, you will seethefollowing error
message when trying to enable C Debug:

# Unable to find dynamic library list.

# error from C debugger

To invoke C Debug, you must have the following:
* A cdebug license feature; contact Model Technology sales for more information.

» The correct gdb debugger version for your platform.
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Setting up C Debug

Before viewing your SystemC/C/C++ source code, you must set up the C Debug path and
options. To set up C Debug, follow these steps:

1 Compileand link your C code with the -g switch (to create debug symbols) and without
-O (or any other optimization switches you normally use). See Chapter 7 - SystemC
simulation for information on compiling and linking SystemC code. See the FLI

Reference Manual or Chapter 6 - Verilog PLI / VPI for information on compiling and
linking C code.

2 Specify the path to the gdb debugger by selecting Tools > C Debug > C Debug Setup.

\\E Debug setup

Pl
C debugger path
i+ default
" gustom Erowse.. |
[ Stop on quit [ Keep user init bps [~ Show halloon QK | Cancel |

Select "default” to point at the Model Technology supplied version of gdb or "custom"
to point at a separate installation.

3 Start the debugger by selecting Tools> C Debug > Start C Debug. ModelSim will start
the debugger automatically if you set a breakpoint in a SystemC file.

4 |If you are not using gcc, or otherwise haven't specified a source directory, specify a
source directory for your C code with the following command:

Model Si n» gdb dir <srcdirpathl>[:<srcdirpath2>[...]]
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Setting breakpoints

Breakpointsin C Debug work much like norma HDL breakpoints. Y ou can set/delete and
enable/disable them with Model Sim commands (bp (CR-81), bd (CR-76), enablebp (CR-
163), disablebp (CR-153)) or viathe Source window inthe Model Sim GUI (see " Setting file-
line breakpoints from the GUI" (UM-391)). Some differences do exist:

» The Breakpoints dialog in the Model Sim GUI doesn't list C breakpoints.
» C breakpoint id numbers requirea"c." prefix when referenced in a command.

» When using the bp command (CR-81) to set a breakpoint in a C file, you must use the -c
argument.

Here are some example commands:

bp -c *0x400188d4
Setsa C breakpoint at the hex address 400188d4. Notethe'*’ prefix for the hex address.

bp -c or_checktf
Sets a C breakpoint at the entry to function or_checktf.

bp -c or.c 91
Sets a C breakpoint at line 91 of or.c.

enabl ebp c. 1
Enables C breakpoint number 1.

Thegraphic below showsaC filewith one enabled breakpoint (on line 40) and onedisabled
breakpoint (on line 59).

FAUFCE - Km'_ﬂ-!tl:.t .ﬂj.m.l_u).ﬂ
File Edit View Tools Window
SEH % BB DMK O0OH R MR R D %
Hits| BC | @ |In #] /uimichaelc/ modeltech/fli—plitor_gate.c | &S
& 40 vall = tf_getp(HOR_WVALL);
= 41 vald = tf_getp(HOR_VALZ):
42
43 A% Call © model =/
44 xor_gatel(sresult, wall, walZ);
45
46
47 /* Write the © model ocutputs onto the Verilog signals */
48 tf_putp(dOF_RESULT, result);
49
50 returni);
51}
52
53 K’*********k***k****k****k***i****ﬂ:*****kk************k****k*
54 * checktf routine - Verifies that $xor_ci() is used correctl
85 # that the task has the correct number and tyvpe of argument
56 I EE T EE RS E R RS E R RS FEESEEE RS S E R TSR R RS T EE RS RS RS T SR RS SRR S E
857 int mor_checktf()
58 {
O 59 bool err = FALSE;
Al /
4| fa_thv [xor_cv | xor_gatec| H I [~

jLn: 101, Col: 0 —- read-only
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Clicking the red diamonds with your right (third) mouse button pops up a menu with
commands for removing or enabling/disabling the breakpoints
Enable Breakpoint 59
Femove Breakpaoint 55
Edit Breakpoint 55...
Edit All Breakpoints...

P Note: The gdb debugger has a known bug that makes it impossible to set breakpoints
reliably in constructors or destructors. Do hot set breakpointsin constructors of SystemC
objects; it may crash the debugger.
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Stepping in C Debug

Stepping in C Debug works much like you would expect. Y ou use the same buttons and
commands that you use when working with an HDL-only design.

line-by-line; C functions are not
stepped into unless you have an
enabled breakpoint in the C file

Button Menu equivalent Other equivalents

Step Tools> C Debug > Run use the step command at the
F} steps the current simulation to > Step CDBG> prompt

the next statement; if the next

statement isacall toaC function see: step (CR-264) command

that was compiled with debug

info, Model Sim will step into the

function

Step Over Tools> C Debug > Run usethestep -over command at the
ﬁl statements are executed but > Step -Over CDBG> prompt

treated as simple statements

instead of entered and traced see: step (CR-264) command

Continue Run

continue the current smulation
run until the end of the specified
run length or until it hitsa
breakpoint or specified break
event

Tools> C Debug > Run
> Continue

usetherun -continuecommand at
the CDBG> prompt

SEe: run (CR-246)

Known problems with stepping in C Debug

The following are known limitations which relate to problems with gdb:

» The gdb debugger has a known bug that makes it impossible to set breakpoints reliably
in constructors or destructors. Be careful while stepping through code which may end up
calling constructors of SystemC objects; it may crash the debugger.

» With some platform and compiler versions, step may actually behave like run -continue
wheninaCfile. Thisisagdb quirk that results from not having any debugging
information whenin aninternal functionto VSIM (i.e., any FLI or VPI function). Inthese
situations, use step -over to move line-by-line.
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Finding function entry points with Auto find bp

Model Sim can automatically locate and set breakpoints at all currently known function
entry points (i.e., PLI/VPI system tasks and functions and callbacks; and FL| subprograms
and callbacks and processes created with mti_Cr eatePr ocess). Select Tools> C Debug >
Auto find bp to invoke this feature.

The Auto find bp command provides a"snapshot" of your design when you invoke the
command. If additional callbacks get registered later in the simulation, Model Sim will not
identify these new function entry points unless you re-execute the Auto find bp command.
If you want functions to be identified regardless of when they are registered, use
"ldentifying all registered function calls" (UM-480) instead.

The Auto find bp command sets breakpointsin an enabled state and doesn’t toggle that
state to account for step-over or run-continue commands. This may result in unexpected
behavior. For example, say you have invoked the Auto find bp command and you are
currently stopped on aline of code that calls a C function. If you execute a step -over or
run -continue command, Model Sim will stop on the breakpoint set in the called Cfile.
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Identifying all registered function calls

Auto step mode automatically identifies and sets breakpoints at registered function calls
(i.e., PLI/VPI system tasks and functions and callbacks; and FLI subprograms and
callbacks and processes created with mti_Cr eatePr ocess). Auto step modeis helpful when
you are not entirely familiar with adesign and its associated C routines. As you step
through the design, Model Sim steps into and displays the associated C file when you hit a
C function call inyour HDL code. If you execute astep -over or run -continue command,
Model Sim does not step into the C code.

When you first enable Auto step mode, Model Sim scans your design and sets enabled
breakpoints at all currently known function entry points. Asyou step through the
simulation, Auto step continues |ooking for newly registered callbacks and sets enabled
breakpoints at any new entry pointsit identifies. Once you execute a step -over or

run -continue command, Auto step disables the breakpointsiit set, and the simulation
continues running. The next time you execute a step command, the automatic breakpoints
are re-enabled and Auto step sets breakpoints on any new entry points it identifies.

Note that Auto step does not disable user-set breakpoints.

Enabling Auto step mode
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To enable Auto step mode, follow these steps:
1 Configure C Debug as described in " Setting up C Debug" (Um-475).
2 Select Tools> C Debug > Enable auto step (Main window).

3 Load and run your design.
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Example
The graphic below shows a simulation that has stopped at a user-set breakpoint on a PLI
system task.
SOUFCE - XOF_C.¥ .: _._In_lzl
File Edit Yiew Tools Window
CEH| SDROMXOX [ EF A BEBH MERD =
Hits| BC | @ |In #] HOT_CN [~
15
16 input inl, inZ;
17 output outl;
18 reg outl;
19
20 A eall the PLI application which interfaces to
21 A input changes
22 always 8(inl or ind)
s 23 foutl, inl, inZ);
24
25 endmodule
25 Fi
ay[fatby] xor_cv| | T P
kel Ln: 26, Col: 0 --read-only .

Because Auto step mode is enabled, Model Sim automatically sets a breakpoint in the
underlying xor_gate.cfile. If you click the step button at thispoint, Model Simwill stepinto

that file.
SOUrCE - Xor_gate.c .-ln]ﬁl
File Edit View Tools Window
B X BR DM NOX | T 00 HEIEE B I B 0 R D £l
Hits| BC | @ |In #] Jufmichaelc/ modeltech/fli-plifxor_gate.c |
30 * ealltf routine - Serves as an interface between ModelSim
31 = It is called whenever the inputs to the HOR gate change °
32 * the input walues, passes these values to the C model, an

33 * model*s output walue back intc ModelSim. -J

34 R R R R R R E R R E R R R R RS EE R R R R R R E R RS E R SRR E R SR SRR E LN

35 int xor_callcf()

36 |

37 int wall, wvalZ, result;

38

39 S* Read current wvaluss of C model inputs from Verilog =

™ 0 vall = tf_getp(HOR_WALL);

41 valZ = tf_getp(HOR_VALZ);

432

= o ok T | e T | - ’f
| fa_thv | xor_cv| xor_gate.c| N I -
ol [Ln: 1, Col: 0 —-read-only
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Auto find bp versus Auto step mode

ModelSim SE User’'s Manual

As noted in "Finding function entry points with Auto find bp" (UM-479), the Auto find bp
command also locates and sets breakpoints at function entry points. Note the following
differences between Auto find bp and Auto step mode:

* Auto find bp provides a"snapshot” of currently known function entry points at the time
you invoke the command. A uto step mode continues to locate and set automatic
breakpoints in newly registered function calls as the simulation continues. In other
words, Auto find bp is static while Auto step mode is dynamic.

 Auto find bp sets automatic breakpoints in an enabled state and doesn’t change that state
to account for step-over or run-continue commands. Auto step mode enablesand disables
automatic breakpoints depending on how you step through the design. In caseswhereyou
invoke both features, Auto step mode takes precedence over Auto find bp. In other words,
even if Auto find bp has set enabled breakpoints, if you then invoke Auto step mode, it
will toggle those breakpoints to account for step-over and run-continue commands.
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Debugging functions during elaboration

Initialization mode allows you to examine and debug functions that are called during
elaboration (i.e., whileyour designisin the process of loading). When you select thismode,
Model Sim sets special breakpoints for foreign architectures and PLI/V Pl modul es that
alow you to set breakpoints in the initialization functions. When the design finishes
loading, the special breakpoints are automatically deleted, and any breakpointsthat you set
are disabled (unless you specify Keep user init bpsin the C debug setup dialog).

To run C Debug in initialization mode, follow these steps:

1 Start C Debug by selecting Tools > C Debug > Start C Debug before loading your
design.

2 Select Tools> C Debug > Init mode.

3 Load your design.

Asthe design loads, Model Sim prints to the Transcript the names and/or hex addresses of
called functions. For example the Transcript below shows a function pointer to aforeign

architecture:
}A ModelSim SE PLUS 5.7 Alpha =101
File Edit \iew Compile Simulate Tools Window Help
he | eng| v (AUERLB I PPR
Workspace =
Name A # Shared object file " fand_gate sl A
////Ekﬁ%ﬁh@nn#ﬁrne*zﬂﬂj‘gfﬁe‘
e} work # Function ptr ‘0x4001b514" . Foreignoarchitecture,
-] vitalos tet
e[l iece # (x08140df3 in mti_cdbg_shared_objects_loaded ()
im i CDBG> bp —-c *0x4001b514
- |
- mrml dee sim_fi /| ||# C Breakpoint *0x4001b514°
# C breakpoint id ¢.5 has true location at
N = ||# file "/wmichaelc/ modeltech/fii-plifand_gate.c’ line *57" ]
Library run —continue /

| Loading.. |

To set abreakpoint on that function, you would type:
bp -c *0x4001b514

or

bp -c and_gate_init
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ModelSim in turn reports that it has set a breakpoint at line 37 of the and_gate.cfile. As
you continue through the design load using run -continue, Model Sim hits that breakpoint
and displaysthe file and associated line in the Source window.

¢ source - and_gate. il =10l x|
File Edit View Tools Window

CSE FRBOMNN] T IHUBUB I BPRA

@ |In# /wmichaele/ modeltech/fli-plifand_gate.c [|=
32 and _gate_init({region, param, generics, ports)
i3 mtiRegionIdT region;
34 chay *param;
3k mtilnterfacelistT *generics;
gl mtilnterfacelListT #*ports;
& 37 |
El inst_rec =ip;
39 mbifignal IdT ocutp; _J
40 mt iProcessIdT proc;
41 extern free();
42
i ] in = (inet rar 2 Tmallmnnlfeiranfliinet rami h- ,l"l
4| and_gate.c | | ]

| | lLn: 1, Col: 0 -- read-only

FLI functions in initialization mode

There are two kinds of FLI functions that you may encounter in initialization mode. The
first isaforeign architecture which was shown above. The second is aforeign function.
Model Sim produces a Transcript message like the following when it encounters aforeign
function during initialization:

# Shared object file './all.sl

# Function nanme 'in_parans

# Function ptr '0x4001a950'. Foreign function

# C breakpoint c.1

# 0x0814fc96 in nti_cdbg_shared_objects_I oaded ()

Y ou can set a breakpoint on the function using either the function name

(i.e., bp-cin_params) or thefunction pointer (i.e., bp -c * 0x4001a950). Note, however, that
foreign functions aren’t called during initialization. Y ou would hit the breakpoint only
during runtime and then only if you enabl ed the breakpoint after initialization was complete
or had specified Keep user init bpsin the C debug setup dialog.

PLI functions in initialization mode

There are two methods for registering callback functionsin the PLI: 1) using a veriusertfs
array to define all usertf entries; and 2) adding an init_usertfsfunction to explicitly register
each usertfs entry (see "Registering PLI applications’ (UM-155) for more details). The
messages Model Sim producesin initialization mode vary depending on which method you
use.
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Model Sim produces a Transcript message like the following when it encounters a
veriusertfs array during initialization:

# vsim-pli ./veriuser.sl nux_tb

# Loading ./veriuser.sl

# Shared object file './veriuser.sl

# veriusertfs array - registering calltf

# Function ptr '0x40019518'. $or_c.

# C breakpoint c.1

# 0x0814fc96 in nti_cdbg_shared_objects_Il oaded ()

cont
# Shared object file './veriuser.sl
# veriusertfs array - registering checktf

# Function ptr '0x40019570'. $or_c.
# C breakpoint c.1
# 0x0814fc96 in nti_cdbg_shared_objects_I oaded ()

cont
# Shared object file './veriuser.sl
# veriusertfs array - registering sizetf

# Function ptr '0x0'. $or_c.
# C breakpoint c.1
# 0x0814fc96 in nti_cdbg_shared_objects_I oaded ()

cont
# Shared object file './veriuser.sl
# veriusertfs array - registering msctf

# Function ptr '0x0'. $or_c.
# C breakpoint c.1
# 0x0814fc96 in nti_cdbg_shared_objects_I oaded ()

Y ou can set breakpoints on non-null callbacks using the function pointer
(e.g., bp -c *0x40019570). Y ou cannot set breakpoints on null functions. The sizetf and
misctf entries in the example above are null (the function pointer is '0x0").

Model Sim reports the entries in multiples of four with at least one entry each for calltf,
checktf, sizetf, and misctf. Checktf and sizetf functions are called during initialization but
calltf and misctf are not called until runtime.

The second registration method uses init_usertfs functions for each usertfs entry.
Model Sim produces a Transcript message like the following when it encounters an
init_usertfs function during initialization:

H*

Shared object file './veriuser.sl
# Function nanme 'init_usertfs

# Function ptr '0x40019bec'. Before first call of init_usertfs

# C breakpoint c.1

# 0x0814fc96 in nti_cdbg_shared_objects_I oaded ()

Y ou can set a breakpoint on the function using either the function name

(i.e., bp-cinit_usertfs) or the function pointer (i.e., bp -c *0x40019bec). Model Sim will hit
this breakpoint as you continue through initialization.
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VPI functions in initialization mode

VPI functions areregistered viaroutines placed in atable named vliog_startup_routines (see
"Registering VPI applications' (uM-157) for more details). Model Sim producesa Transcript
message like the following when it encounters avlog_startup_routines table during

initialization:
# Shared object file './vpi_test.sl
# vl og_startup_routines array

# Function ptr '0x4001d310'. Before first call using function pointer.
# C breakpoint c.1
# 0x0814fc96 in nti_cdbg_shared_objects_I oaded ()

Y ou can set a breakpoint on the function using the function pointer
(i.e., bp -c *0x4001d310). Model Sim will hit this breakpoint as you continue through
initialization.

Completing design load

If you are through looking at the initialization code you can select Tools > C Debug >
Completeload at any time, and Model Sim will continue loading the design without
stopping. The one exception to thisisif you have set a breakpoint in aLoadDone callback
and also specified Keep user init bpsin the C Debug Setup dialog (see " C Debug dialog
reference” (UM-490)).
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Debugging functions when quitting simulation

Stop on quit mode alows you to debug functions that are called when the simulator exits.
Such functions include those referenced by an mti_AddQuitCB function in FLI code,
misctf functions called by a quit or $finishin PLI code, or cbEndofSimulation functions
caled by aquit or $finishin VPI code.

To enable Stop on quit mode, follow these steps:
1 Start C Debug by selecting Tools > C Debug > Start C Debug.
2 Select Tools > C Debug > C Debug Setup.

3 Select Stop on quit in the C Debug setup dialog.

»¢ C Debug setup - x|

C debugger path
= default

" custom Browse... |
@ [ Keep user init bps [ Show balloon Ok | Cancel |

With this mode enabled, if you have set a breakpoint in a quit callback function, C Debug
will stop at the breakpoint after you issue the quit command in ModelSim. Thisallowsyou
to step and examine the code in the quit callback function.

Invoke run -continue when you are done looking at the C code.

Note that whether or not a C breakpoint was hit, when you return to the VSIM > prompt,
you'll need to quit C Debug by selecting Tools> C Debug > Quit C Debug beforefinally
quitting the simulation.
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C Debug menu reference

The following commands are available from the Tools > C Debug menu.

Start C Debug turns on C Debug so you can set breakpoints and step through C
code

C Debug setup specifies the location of your gdb installation

Enable auto step configures C Debug to run in "ldentifying all registered function
calls" (UM-480)

Run provides access to step, step-over, run-continue, and run-finish
commands

Quit C Debug turns off C Debug; do this before exiting ModelSim

Init mode configures C Debug to run in "Debugging functions during
elaboration" (UM-483)

Complete load cancels "Debugging functions during elaboration" (Um-483) and
completes loading the rest of your design

Auto find bp sets breakpoints at al the FLI/PLI/VPI function entry points that
are known (registered) when you make this menu selection

Info bp listsal currently set breakpointsincluding the source file names,
line numbers, and breakpoint ids

Show shows the values of the local variables and arguments of the
current C function

Traceback if known, identifies the HDL source line from which the C
function was called; when running in "Debugging functions
during elaboration” (UM-483), no HDL information is available,
and this command will list only the gdb traceback stack

C Interrupt "re-activates" the C debugger when you are stopped in HDL code

Command entry

opensacommand prompt dialog so you can enter commandseven
if the GUI prompt isinaccessible; the GUI prompt may become
inaccessible in certain situations (e.g., when debugging FL|
LoadDone callback functions)

Refresh

reopens a C source file if you close the Source window
inadvertently while stopped in the C debugger
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C Debug command reference

Thetable below provides a brief description of the commands that can be invoked when C
Debug is running. Follow the links to the Model Sm SE Command Reference for complete
command syntax.

Command Description Corresponding menu command
bd (CR-76) deletes apreviously set C breakpoint right click breakpoint in Source

window and select Remove Breakpoint
bp (Cr-81) - sets a C breakpoint click the desired line number in the

Source window

change (Cr-87)

changes the value of a C variable

none

describe (CR-152)

prints the type information of aC
variable

select the C variable nameinthe Source
window and select Tools > Describe or
right click and select Describe.

disablebp (CR-153)

disables aprevioudy set C breakpoint

right click breakpoint in Source
window and select Disable Breakpoint

enablebp (CR-163)

enables a previously disabled C
breakpoint

right click breakpoint in Source
window and select Enable Breakpoint

examine (CR-167)

prints the value of a C variable

select the C variable nameinthe Source
window and select Tools > Examine or
right click and select Examine

gdb dir (CR-179) sets the source directory search path for | none
the C debugger

pop (CR-215) moves the specified number of call none
frames up the C callstack

push (CR-231) moves the specified number of call none

frames down the C callstack

run (CR-246) -continue

continues running the simulation after
stopping

click the run -continue button on the
Main or Source window tool bar

run (CR-246) -finish

continues running the simulation until
control returnsto the calling function

Tools> C Debug > Run > Finish

show (CR-260)

displaysthe namesand types of thelocal
variablesand arguments of the current C
function

Tools > C Debug > Show

step (CR-264) single step in the C debugger tothenext | click thestep or step -over button onthe
executableline of C code; step goesinto | Main or Source window tool bar
function calls, whereas step -over does
not

tb (CR-266) displays a stack trace of the C call Tools > C Debug > Traceback
stack
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C Debug dialog reference

This section describes C Debug diaogs.

C Debug setup dialog

»{ C Debug setup |
. debugger path
i default
™ gustom Browse.. |
[ Stop on quit [ Keep user init bps [ Show halloon 0]:4 | Cancel |

Usage
Configuring C Debug

Field descriptions

» C debugger path
Specifies the path to the installed copy of gdb. Select "default” to point at the Model
Technology supplied gdb or "custom” to point at another installation of gdb. See
"Supported platforms and gdb versions' (UM-474) for the supported versions.

e Stop on quit
Allows you to debug functions that get called when the simulator is exiting. See
"Debugging functions when quitting simulation" (um-487) for details.

» Keep user init bps
L eaves enabled any breakpoints you set while running in initialization mode (see
"Debugging functions during elaboration” (UM-483)). Normally breakpoints set during
initialization mode are disabled once the design is finished loading.

» Show sour ce balloon
Enables name/value popup in the Source window when you hover your mouse pointer
over avariable name.
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Command entry dialog

> C-Debug-tool ) =10 =|
Enter command II Cancel |
Usage
Entering debugging commands when the CDBG> prompt in the Main window is
unavailable

Field descriptions

» Enter command
Specify the debugging command to execute.
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What are assertions?

Assertions have been around for along time but have recently garnered heightened
attention due to the increasing importance of verification in most design flows.
Additionally, the recent introduction of new languages such as PSL have made assertions
more powerful than they have been in the past.

Definition

An assertionisadesign property that isevaluated by atool. A property is a statement about
adesign that evaluatesto true or false. Propertiestell atool what the design should do, what
it should not do, or what limits exist onits behavior. In effect we are saying, assert that this
property istrue; if it isfalse, tell me.

Types of assertions

Broadly speaking there are three types of assertions: interface/system level assertions,
internal architecture assertions, and functional coverage assessment.

Interface/system-level assertions

Sometimesreferred to as"black-box," these types of assertionsare high-level properties of
adesign that describe only the inputs of a module or system. The interfaces are generally

between major blocks of a design that are owned by different designers. The assertions are
typically placed in an external file and then attached to a design unit.

Verification engineers typically apply this use model. Many organizations prohibit the
verification team from touching synthesizable RTL code. Therefore, they cannot embed
assertions. Also, assertionsthat are defined in a separate file are easier to reuse at multiple
abstraction levels (architectural, RTL and gate) asthe design objectsthat they referenceare
very likely to exist at all levels.

Internal architecture assertions

Cadlled "white-box™ or "clear-box," these types of assertions are specific to the internal s of
amodule. Internal assertions are typically written directly in the HDL code, and the
property verification occurs as the simulation proceeds. The is the most typical use of
assertions and is done for block/module-level verification. Designers typically apply this
use model asit is easy and natural for them to include PSL assertions directly in the HDL
code as the code is being written.

The advantage to internal assertionsis errors can be identified very early in asimulation.

PSL assertion language

Model Sim currently supports PSL assertions. PSL is an Accellera standard that was born
out of the Sugar language created at IBM. The syntax and semantics of PSL are described
in the Property Specification Language Reference Manual, Version 1.01, published April
25, 2003. We strongly encourage you to get a copy of this specification.

In the current implementation, Model Sim supports only the simple subset of PSL (refer to
Section 4.4.5, pg 25 of PSL LRM 1.01 for a description of this subset).
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Using assertions in ModelSim

Assertion flow

The following diagram gives avisual depiction of using assertions in Model Sim.

VHDL with

embedded assertions or assertionsfile

vcom vcom -pdfile

;

| Y

Wave Assertion
window Browser

Model Sim lets you embed assertions within your VHDL code or supply them in aseparate
file. If the assertions are embedded, vcom will compilethem automatically. If the assertions
arein aseparatefile, you add the -pdfile argument to vcom. Once compilation is complete,
you invoke the simulator vsim on the design. The simulator automatically handles any
assertionsthat are present in the design. From there you run the simulation and debug any
assertion failures.

Limitations

The current release has some limitations. Most of these features will be added in future
releases.

» Only the simple subset of PSL is supported except *within’ constructs. The PSL LRM
defines the simple subset in section 4.4.5 Pg 25 of PSL LRM 1.01.

» Thereisno Verilog support. PSL assertions can only be embedded inside VHDL code,
and external assertions can only be bound to aVHDL architecture.

 Vunits can only be bound to an entity or an architecture.
* A separate PSL file must be compiled with the entity or architecture to which it is bound.

» Thereisno support for verification unit inheritance—vunits cannot be derived from other
vunits.

» Embedded assertions cannot be placed inside VHDL generate statements.
» Thereisno support for replicated properties (i.e., PSL "forall" syntax).

» Thereisno support for endpoints.
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There is no support for parameterized named sequences and properties. For example,
'sequence sO(boolean rb, clock; const n) = ....."isillegal.

PSL limits vunitsto asingle default clock declaration. However, there are no restrictions
on the number of default clock declarations embedded within the HDL source.

The @ clock expression operator is supported but can only be used for asingle clock.
Multi-clock support is not yet available.

There is no support for %for and %if preprocessor commands.

Thereisno support for integer, structures, and union in the modeling layer. The only PSL
built-in functions currently supported are rose() and fell().

Only "assert" and "assume" assertion directives are supported. "Assume" directives are
treated functionally the same as "assert" directives.

Thereis no support for post-simulation run of assertions (i.e., users cannot run assertion
enginein post simulation mode). The Assertion Browser is not active in post-smulation
mode either.

Checkpoint/restore isn’'t currently supported with PSL assertions.
Vprop and vmode in the PSL modeling layer are not supported.
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Embedding assertions in your code

Oneway of looking at assertionsis as design documentation. In other words, anywhereyou

would normally write a comment to capture pre-conditions, constraints or other

assumptions as well as to document the proper functionality of amodule, process or

subprogram, use assertions to capture the information instead.

Syntax

PSL assertions are embedded using metacomments prefixed with 'psl'. For example:

-- psl sequence sO is {b0; bl; b2};

The PSL statement can be multiline. For example:

-- psl sequence sO is
-- {b0; b1; b2},

Note that the second line did not require a'pd’ prefix. Oncein PSL context, the parser will

remain there until a PSL statement is terminated with a semicolon (;').

Restrictions

Embedded assertions have the following restriction as to where they can be embedded:

 Assertions can be embedded only in declarative and statement regions of an entity or

architecture body.
* Assertions cannot be embedded in generate statements.

* |n astatement region, assertions can appear at places where concurrent statements may

appear. If they appear in a sequentia statement, Model Sim will generate an error.
* Assertions cannot be embedded in VHDL procedures and functions.

Example

I'i brary | EEE;
use | EEE. std_|l ogic_1164. all;
use | EEE. nuneric_std.all;
use WORK. constants. all;
entity dramcontrol is
generic ( BUG : Boolean := TRUE );

port ( clk : IN std_l ogic;
reset_n : IN std_l ogic;
as_n : IN std_|l ogi c;
addr_in : IN std_l ogi c_vector(AIN-1 downto 0);
addr _out: OUT std_l ogic_vector (AQUT-1 downto 0);
rw :IN std_logic; -- 1toread; Oto wite
we_n . QUT std_|l ogi c;
ras_n e std_l ogic;
cas_n o QUT std_|l ogi c;
ack e std_logic );

end entity dramcontrol;
architecture RTL of dramcontrol is

type menory_state is (IDLE, MEM ACCESS, SW TCH, RAS_CAS, OP_ACK,
REF2) ;
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signal memstate : menory_state := | DLE;

signal col _out : std_logic; -- Qutput columm address
-- =1 for columm address
= 0 for row address

signal count : natural range 0 to 2; -- Cycle counter
signal ref_count : natural range O to REF_CNT; -- Refresh counter
signal refresh : std_l ogic; -- Refresh request

--psl default clock is rising_edge(clk);
-- Check the wite cycle
-- psl property check_wite is always {fell(as_n) and not rw} |=> {

-- [*0 to 5];

-- (ras_n ='0" and cas_n = '1" and (addr_out = addr_in(7 downto 4)));

-- (ras_n ='0" and cas_n = '1" and (addr_out = addr_in(3 downto 0)))[*2];
-- (ras_n ='0" and cas_n = '0")[*2];

-- ack};

--psl assert check_wite;

begi n
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Writing assertions in an external file

Assertionsin an external file are grouped in vunits and bound to an architecture. The
external PSL statements are interpreted as if the text of the statement was inserted in the
architecture, immediately before the end of the architecture.

Syntax
vunit nanme (entity_nane[(<arch_nane>)])
{
default clock is <clock_decl >
<assertions>
}

name — The name of the vunit.

entity_name — The hierarchical path to the associated entity.
<arch_name> — The associated architecture.

<clock_decl> — The default clock declaration for the vunit.

<assertions> — Any number of verification directives or PSL statements.

Restrictions
The following restrictions exist when providing assertionsin a separate file.
» The vunits can be bound only to an entity or architecture.
» The PSL file and its corresponding VHDL file must be compiled together.

Example

The following is an example with three assertions in one vunit.

vuni t check_dramcontroller(dramcontrol (RTL))

{

default clock is rising_edge(clk);

-- declare refresh sequence
sequence refresh_sequence is
{not cas_n and ras_n and we_n; [*1]; (not cas_n and not ras_n and
we_n)[*2]; cas_n and ras_n};

-- Make sure the first refresh happened in 24 cycles period after reset
property check_refresh_rate is always {

(not reset_n)[+]; -- reset_n active for one or nore
rose(reset_n); -- reset_n deactivates
(rose(refresh))[->1 to inf]} -- wait for next refresh_start

| ->
{[*18 to 32]; refresh_sequence}

assert check_refresh_rate

-- Check the wite cycle
property check_wite is always {fell(as_n) and not rw} |=> {
[*O to 5];
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(ras_n ='0" and cas_n = '1" and (addr_out = addr_in(7 downto 4)));

(ras_n ='0" and cas_n = '1" and (addr_out = addr_in(3 downto
0))r~2;

(ras_n ="'0" and cas_n = '0")[*2];

ack};

assert check_wite;

-- check the read cycle
property check_read is always {fell(as_n) and rw} |=> {

[*O to 5];

(ras_n = '0" and cas_n = '1'" and (addr_out = addr_in(7 downto 4)));

(ras_n ='0" and cas_n = '1" and (addr_out = addr_in(3 downto
oni*2:

(ras_n ='0" and cas_n = '0")[*3];

ack};

assert check_read;
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Understanding clock declarations

All assertionsin M odel Sim must be associated with one and only one clock. Unclocked and
multiple clocked assertions are not currently supported.

Default clock

Any assertion that is not individually clocked will be clocked by the default clock. For
example:
default clock is rose(clk);

assert al ways sigbh@ose(cl kl)
assert al ways siga

The first assertion is sensitive to clkl. The second assertion is sensitive to clk (the default
clock).

When using embedded assertions, if you declare an unclocked assertion before defining
default clock, Model Sim produces an error. For example, the following code will produce
an error, assuming there is no other default clock statement above the assertion:

assert al ways siga
default clock is rose(clk);

Thisisnot truein the case of assertions|ocated in an external file. The default clock applies
to all unclocked statements regardless of their order within thefile.

Asnoted earlier in"Limitations" (UM-496), default clock declarations are associated with
directives not with named properties or sequences. For example:

default clock is clkl
property pO is always a->b
default clock is clk2
assert po

The property p0 is evaluated at every clk2.

Partially clocked properties
The default clock also appliesto partially clocked properties. For example:

default clock is rose(clk);
assert always (b0 |-> (bl@ose(clkl)))

In this case, only the RHS of the implication(|->) expression is clocked. The outermost
property is unclocked, so default clock appliesto this assertion. However, that makes the
property multiple clocked, which we do not currently support. Model Sim emits awarning
in such cases and only considers the outermost clock. So Model Sim will behave asif the
property was written like this:

assert always (bO |-> bl) @ose(cl k)

The warning produced will look something like this:

** WArning: [11] ./src/multiclk/test.vhd(34): The PSL expression possibly
contains nultiple clock domains. Miultiple clock domains are not supported
The outernost clock donmain will overide the inner clock domains
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Also, the complete assertion property must be clocked. For example, if you have the
following assertion:

assert always (b0 |-> (bl@ose(clkl)))

and no default clock preceding it, then since part of the property is unclocked, Model Sim
will produce an error.
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Understanding assertion names

PSL does not provide a method for naming directives. Model Sim must generate an
assertion name for reporting information about the assertion. If you want Model Sim to
generate predictable names, you should always assert on a named property. For example:

property pO is always a -> b;
assert poO;

The name generated for this assertion statement will beassert_ p0. Generically, the syntax
of the generated nameis:

assert__<property name>.

However, if you write the same assertion in this manner:

assert always a -> b;

thereisno property name, so Model Sim will generate anamelikeassert 0 (i.e., anumber
appended to "assert__ ).
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General assertion writing guidelines

Assertion writing can become complicated and confusing. If not written correctly,
assertions can also impact simulator performance. This section offers suggestions for how
to write assertions that are easy to debug and don’t slow down your simulation unduly.

» Keep directives simple. Create named assertions that you then reference from the
directive (e.g., assert checkl).

» Keep properties and sequences simple too. Build complex assertions out of simple, short
assertions/sequences.

» Do not use implication with never directives. Y ou will rarely get what you want if you
use implication with a never.

 Create named sequences so you can reuse them in multiple assertions.
» Be aware of "unexpected matches.” For example, the following assertion:

assert al ways a->next (b)->next(c);

will match all of the following conditions (as well as others):

a L aJ—L a4,—
bi b b
S [ S N  S—

 Keep time ranges specified in sequences as short as possible according to the actua
design property being specified. Avoid long time ranges as thisincreases the number of
concurrent 'in-flight' checks of the same property and thereby impacts performance.

Understanding operator precedence and curly braces
VHDL and PSL have conflicting operator precedence rulesthat necessitate the use of curly
bracesin some cases.
Rule

In general, whenever a PSL operation expects a PSL sequence as an operand, that PSL
sequence must appear within curly braces.

Exceptions
The following are exceptions to the above rule:

» Theaways, never, and eventually! operators can accept anamed segquence as an operand
without the requisite curly-braces (e.g., "adways myseq;" is equivalent to "always
{myseq};").

» The"trigger" operand of the within* operators can also accept a named sequence as an
operand without the requisite curly-braces (e.g., "within(myseq, bool){ myseq};" is
equivalent to "within({ myseg}, bool){ myseqg};").
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Compiling and simulating assertions

Embedded assertions

Embedded assertions are compiled automatically by default. If you have embedded
assertions that you don’t want to compile, use the -nopsl argument to the vcom command
(CR-303).

External assertions file

To compile assertions in an external file, invoke the compiler with the -pslfile argument
and specify the assertions file name. For example:

vcom t adder . vhd adder.vhd -pslfile adder. psl

The design and its associated assertions file must be compiled in the same invocation.

Making changes to assertions

After making any changes to embedded assertions, you need to re-compile the design unit.
After making changesin separate file assertions, you need to compile both the separate file
and the design unit file to which the vunit binds in the same vcom invocation.

Simulating assertions

If any assertions were compiled, the vsim command (CR-357) automatically invokes the
assertion engine at runtime. If you do not want to simulate the compiled assertions, use the
-nopd argument.

VHDL code inside PSL statements

VHDL statements may be placed in either embedded PSL metacomments or in external
vunits. For example, the following codeislegal:

--psl process(reg)

--psl
--psl end process
--psl assert always pO;

The VHDL statements are parsed along with the PSL statements when you compile the
design with vcom. If you compile the design using vcom -nopsl, then neither the VHDL
statements nor the PSL statements are parsed.
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Managing assertions

Y ou can manage your assertions viathe GUI or by entering commands at the VSIM >
prompt.

Viewing assertions in the Assertion Browser

| assertions - defaulk
File Edit Setkings Yiew Window

The Assertion Browser providesaconvenient interfaceto all of the assertionsin the current
simulation. To open the Assertion Browser, select View > Assertion Browser.

| Mame Failure Pazz Failure Count | Pazz Count

E- Ab/assert_ reset_state enabled  disabled 0 1]
E- Ab/assert_test read_responze enabled  dizabled 0 1]
E- Atb/assert_test_wite_responze enabled  dizabled 0 1]
E- Ab/assert_ check_az deassertz enabled  dizabled 0 1]
B Abicntdfassert_check_refresh dizabled  disabled 1 1]

\G] /tb/entr/default_clack_0
\P] Mtb/entil/check_refresh

E- Ablonil/asser_ refresh rate enabled  dizabled 0 1]
E- Abfonil/asser_ check_wite  enabled  dizabled 0 1]
E-& Abfonil/assert_ check_read  enabled  dizabled 0 1]

The Assertions Browser lists all embedded and external assertions that were successfully
compiled and simulated during the current session. The plus sign ('+’) to the left of the
Name field lets you expand the assertion hierarchy to show its elements (properties,
sequences, clocks, and HDL signals).

The window displaysfivefields by default, as detailed below. See "Hiding/showing fields
in the Assertion Browser" (UM-509) for details on how to hide or show fields.

The Assertions Browser includes the following fields:

» TheNamefieldliststhe PSL statement or vunit name you specified in the assertion code.
For vunits the individual assertion names are listed under the vunit name. Also, any
signal referenced in an assertion will be part of the hierarchy aswell. See"Understanding
assertion names' (UM-504) for more details on assertion names.

» The Design Unit field identifies the design unit to which the assertion is bound. Not
displayed by default.

» The Design Unit Typefield liststhe HDL type of the design unit. Not displayed by
defaullt.

» The Failurefield shows "enabled" when failure checking is enabled on the assertion. If
the field shows "disabled”, Model Sim isn’t checking that assertion's failures.

» The Passfield shows "enabled" when pass checking is enabled on the assertion. If the
field shows disabled, Model Sim isn’t tracking that assertion's checking.
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The Failure Count field counts the total number of times the assertion hasfailed in the
current simulation. These counts are maintai ned between runs unless you reset the count
for the assertion.

The Pass Count field counts the total number of times the assertions has passed in the
current simulation. These counts are maintai ned between runs unless you reset the count
for the assertion.

The Attempted field shows agreen checkmark when an assertion hastriggered and ared
"X’ when it has not triggered. Not displayed by default.

The Failure Action field lists the action that Model Sim takes when the assertion passes
or fails. Not displayed by default.

The Failure L og field shows "enabled" when failure messages will be logged to the
transcript. The field shows "disabled" when failure messages will not be logged to the
transcript. Not displayed by default.

The PassL og field shows"enabled" when pass messages will belogged to the transcript.
Thefield shows "disabled" when pass messages will not be logged to the transcript. Not
displayed by default.

The Failure Limit field shows the number of times Model Sim will respond to afailure
event on an assertion. Not displayed by default.

» ThePassLimit field showsthe number of timesModel Sim will respond to afailure event

Y

on an assertion. Not displayed by default.
ou can also view this same information in textual format using the assertion report

command (CR-73).
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Click here
to hide or
show a
field

Managing assertions UM-509

Y ou can hide or show any of thefields in the Assertion Browser. Click the drop-down
arrow on the left-hand side of the dialog and select afield name.

|;, assertions - default 10| x|
File Edit Settings Yiew Window
TIName Failure Fass Failure Count | Pass Count I I
|| _state enabled  dizabled 0 0
™ Design Unit read responze  enabled  dizabled 1 1
) ; wiite_responze  enabled  disabled 0 0
I Desian Unit Type k_az deasszerts enabled  dizabled 1 1
¥ Failure check_refrezh  digabled  dizabled 1 1]
[# Pass ulb_clock,_0
_ ck_refresh
IV Failure Court refresh_rate enabled  dizabled 0 0
¥ Pass Count check_wite  enabled  dizabled 1] 1]
check_read enabled  dizabled 1] 1]
[T attempted
™ Failure Action
[ Failure Lag
[T Paszlog
™ Failure Limit
[T Pass Limit
0k | Cancel |

The selection acts asatoggle. Select it onceto hide afield; select it again to show thefield.
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Enabling/disabling failure and pass checking

To enable or disable an assertion’ s failure or pass checking from the GUI, right-click an
assertion in the Assertion Browser and select Failure Checking or Pass Checking (or use
the Settings menu on the menu bar). The selection acts as atoggle.

To gain greater control over enabling and disabling, right-click an assertion and select
Change. This opens the Change Settings dial og.

Change Settings k|
— Selection
% Selected aszertion]s]
" &l assertions
™ Azsertions in |.-"t|:u.-""
. I Recursive
Click her
to enable/ ) -
disable ailure= | Pazzes
failure or Checking: ~ MoChange —— Checking: MNoChange ——
pass
checking i i
Logaing: Mo Change —— Logaing: Mo Change ——1
Lirnit; Mo Change —— Lirnit; Mo Change ——1
I'I Times I'I Times
Action; Mo Change ——

(] | LCancel | Apply |

Inthisdialog, you can enable/disable failure or pass checking for the selected assertion, all
assertions, or the assertionsin a particular instance. Select Recur sive when enabling/
disabling by instance to search for assertions in subregions of the instance.

Select Enable or Disable from the Checking drop downs in the middle of the dialog and
then click OK.

Y ou can al so enable or disablefailure and pass checking using the assertion fail command
(CR-69) or the assertion pass command (CR-71), respectively.
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Enabling/disabling failure and pass logging

To enable or disable an assertion’ s failure or pass logging from the GUI, right-click an
assertion in the Assertion Browser and select Failure L og or PassL og (or use the Settings
menu on the menu bar). The selection acts as atoggle.

Togain greater control over logging, right-click an assertion and select Change. Thisopens
the Change Settings dial og.

Change Settings k|

— Selection

% Selected aszertion]s]

= All assertions

" Assertions in |.-"t|:u.-""

I FRecursive
— Failures —  Paszes
Click herei Checking:  MoChange —— Checking:  MNoChange ——
to enable/ —
—

disable ® Mo Change —— Logaing: Mo Change ——1
failure or
pass Lirnit; Mo Change — Lirnit; Mo Change ——1
logging

I'I Timesz I'I Timesz

Action; Mo Change ——

(] | LCancel | Apply |

In this dialog, you can enable/disable failure or pass logging for the selected assertion, all
assertions, or the assertions in a particular instance. Select Recur sive when enabling/
disabling by instance to search for assertions in subregions of the instance.

Select Enable or Disable from the L ogging drop downs in the middle of the dialog and
then click OK.

Y ou can also enable or disable failure and pass logging using the assertion fail command
(CR-69) or the assertion pass command (CR-71), respectively.
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Setting failure and pass limits

The failure and pass limits determines how many times Model Sim processes an assertion
before disabling it for the duration of the simulation. By default the number is one for both
failure and passlimits. In other words, once an assertion passes or fails, Model Sim disables
for the duration of the simulation.

If you want to see more than one assertion failure or pass, right-click the assertion in the
Assertion Browser and select Change. This opens the Change Settings dialog.

Change Settings

— Selection

= Al aszertions

¥ Selected azzertion(s

= Aszzertions in |.-"t|:u.-""

I Recursive
— Failures — Paszes
Checking:  MNoChange —— Checking: Mo Change ——
Sigle(thereywnge — Logging: Mo Change ——
I)il\lslgehr?]?ti Linit: Mo Change —— \m MoChange —
I'I— Tirmes I'I— Tirmes
Action; Mo Change ——1

] | LCancel | Apply |

Y ou can set the failure and pass limits for the selected assertion, all assertions, or the
assertionsin aparticular instance. Select Recur sive when setting by instance to search for
assertionsin subregions of the instance.

Select Limited or Unlimited from the Limit drop downs at the bottom of the dialog. If you
select Limited, enter an integer in the field below the drop down and then click OK.

Once the limit is reached, Model Sim disables that assertion. Model Sim continues to
respond to others if their limit has not been reached. The limit applies to the entire
simulation session and not to any single simulation run command.

You can also set failure and pass limits using the assertion fail command (CR-69) or the
assertion pass command (CR-71), respectively.
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Setting failure action

Model Sim can take one of three actions when an assertion fails: it can log the failurein the
transcript and continue the simulation; it can break (pause) the simulation; or it can stop and
exit the simulation. By default the failure action is "continue."

To set assertion action in the GUI, right-click an assertion in the Assertion Browser and
select Failure Action and then Continue, Break, or Exit (or use the Settings menu on the
menu bar).

To gain greater control over setting failure action, right-click an assertion and select
Change. This opens the Change Settings dial og.

Change Settings k|
— Selection
% Selected azsertion]s)
™ &l assertions
™ Azsertions in |.-"t|:u.-""
™ Recursive
— Failurez — Paszes
Checking:  MNoChange —— Checking: Mo Change ——
Logaing: Mo Change ——1 Logaing: Mo Change ——
Click here Lirrit: Mo Change — Lirnit: Mo Change —
to select
failure I'I Tirnes I'I Tirnes
action _
Action; Mo Change ——1

] | LCancel | Apply |

Y ou can set the action for the selected assertion, all assertions, or the assertionsin a
particular instance. Select Recur sive when setting by instance to search for assertionsin
subregions of the instance.

Select Continue, Break, or Exit from the Action drop down in the bottom left corner of
the dialog and then click OK.

Y ou can also set failure action using the assertion fail command (CR-69).
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Reporting on assertions

Y ou can use the assertion report command (CR-73) to print to the transcript a variety of
information about assertions in the current design.

Specifying an alternative output file for assertion messages

ModelSim SE User’'s Manual

Y ou can specify an aternative output file for recording assertion messages. To do this,
invoke vaim with the -asser tfile <filename> argument. By default assertion messages are
output to the file specified by the TranscriptFile variable in the modelsim.ini file. Y ou can
set a permanent default for the alternative output file using the AssertFile (Um-621) variable
in the modelsim.ini file.
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Viewing assertions in the Wave window

Y ou can view assertions in the Wave window just like any other signal in your design.
Simply drag an assertion from the Assertion Browser and drop it in the Wave window or
right-click an assertion in the Assertion Browser and select Add Wave.

Assertion ’signals’

M odel Sim represents assertions as waveforms in the Wave window. The picture below
shows several assertionsin a Wave window.

= wave - default 0
File Edit View [nsert Format Tools Window

[cEa|| saem|| b x|\ B & Q@ 83| Lk

|| 1276 13 to 4143 s [

Assertion items are represented by a magenta triangle. The name of each assertion comes
fromthe assertion code. Theplussign (' +') to theleft of the nameindicatesthat an assertion
isacomposite trace and can be expanded to show its elements (properties, sequences,
clocks, and HDL signals).

The value in the value pane is determined by the active cursor in the waveform pane. The
valuewill beone of "ACTIVE", "INACTIVE", "PASS" or "FAIL".

The waveform for an assertion represents both continuous and instantaneous information.
The continuous information iswhether or not the assertion isactive. The assertionisactive
anytime it matches the first element in the directive. When active, the trace is raised and
painted green; when inactiveit islowered and painted blue. The instantaneousinformation
isapass or fail event on the assertion. These are shown asfilled circles above the trace at
the time of the event. A passisagreen circle and afail isared circle.

Graphic element Meaning

blueline assertion isinactive
green line assertion is active
green dot assertion passed
red dot assertion failed
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Example debugging session

The following example shows atypical debugging session for an assertion failure. The
exampleis based on aDRAM controller with a DRAM behavioral model and a
self-checking testbench (i.e., it writes to memory addresses and reads back the valuesto
compare to what was written). The design has a bug somewhere that we need to locate.

Thefilesfor this example are included in <install_dir>/modeltech/examples/psl.

How would you debug without assertions?

If you didn’t add assertions to the design, the first indication of a problem would come
when the testbench found a difference between awrite and aread. In the example design,
this error occurs at time 267,400 ns. Either awrong val ue was written to memory or the
memory location was corrupted after it was written.

To debug the error, you might first examine simulation waveforms and look for all writes
to the memory location and check the data on the bus and the actual memory contents at the
location after each write. If that didn’t identify the problem, you might then check all
refresh cycles to determine if arefresh corrupted the memory location.

Quite possibly, both debugging activities would be required depending on one's skill (or
luck) in determining the most likely cause of the error. Anyway you look at it, it’ satedious
exercise.

The example assertions file

Adding assertions to the design can ease the debugging task significantly. Here isthe
assertions file that we will compile and simulate with the design:

vunit check_top_unit(tb)
{

default clock is rose(clk);

/] Check for reset
sequence reset_state is {[*]; fell(reset); ras_n and cas_n and not ack}
assert always reset_state

/'l check for nenory response

sequence test_read_response is {[*]; rose(as) and rw, [*5 to 12]; ack}

sequence test_wite_response is {[*]; rose(as) and not rw; [*5 to 12]
ack};

assert always test_read_response
assert always test_wite_response

/] Check if address strobe is deasserted after acknow edge from nenory
sequence check_as_deasserts is {[*]; rose(as); [*5 to 12]; ack; not as}
assert al ways check_as_deasserts

}
vunit check_dramcontroller(tb.cntrl)
{

default clock is rose(clk);

/'l declare refresh sequence
sequence refresh_sequence is
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{not cas_n and ras_n and we_n; [*1]; (not cas_n and not ras_n and /
we_n)[*2]; cas_n and ras_n};

/'l Check if the refresh_sequence repeats in 24 to 30 cycles
property check_refresh_rate is {

(not reset_n)[+]; /'l reset_n active for one or nore
rose(reset_n); /'l reset_n deactivates
(rose(not cas_n and ras_n and we_n))[->0..]} // wait for next

refresh_start
| ->
{[*18..32]; refresh_sequence};

assert always check_refresh_rate

/Il Check the wite cycle
property check_wite is {fell(as_n) and not rw} |=> {
[*0..5];
not ras_n and cas_n and addr_out = addr_in[7 downto 4];
(not ras_n and cas_n and (addr_out = addr_in[3 downto 0]))[*2];
(not ras_n and not cas_n)[*2];
ack};

assert al ways check_wite;

/'l check the read cycle
property check_read is {fell(as_n) and rw} |=> {
[*0..5];
not ras_n and cas_n and addr_out = addr_in[7 downto 4];
(not ras_n and cas_n and (addr_out = addr_in[3 downto 0]))[*2];
(not ras_n and not cas_n)[*3];
ack};
assert al ways check_read

Debugging the assertion failure

Here are the steps to debug the assertion failure:

1 Once you compile and simulate the design with the assertions file, select Setting >
Action from the Assertion Browser and set the assertion action to break on failures.

2 Executerun -all and observe the error message in the transcript:

VSI M> run -al

# ** Error: Assertion tb.cntrl.assert_check _refresh_rate
(File:assertions.psl Line:38) failed at 3400 for startTime 100

#

# Tine: 3400 ns |Iteration: 1 Region: /tb File: drancon_simyv
# Simul ati on stop requested

Noticethat we caught the problem much earlier in the simulation than when we simul ated
without assertions. We a so know that the problem has something to do with the refresh
rate.
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3 When the failure occurs, the assertions file automatically opensin the Source window
with the line marker on the failed assertion.

}{'suurce - assertions.psl -10] x|
Eile Edit Miew Tools Window

EEE FREBOM O B s HELEEE PR

i =
iIIn #l sim:fth © assertions.psl |3
35 | —=
36 1[* 1; refresh_sequencej};
37
e assert always check_refresh rate;
39 [ ]
40 7/ cCheck the write oyole
41 property check write = {fellf(as n) & !rw} |==
42 [*0..51; /
4| dramcon_sim.v | assertions.ps! | I | -
ol ILn: 38 Col 0 |Read| o

Looking at the property definition in the Source window (lines 31-36), we seethat if reset
has completed and a refresh cycle has been detected, then refresh must successfully
complete every 18 to 32 clock cycles.

property check_refresh_rate is {

(not reset_n)[+]; /1 reset_n active for one or nore
rose(reset_n); /] reset_n deactivates
(rose(not cas_n and ras_n and we_n))[->0..]} // wait for next

refresh_start
| ->
{[*18 to 32]; refresh_sequence};

Therefresh_sequence (the last line of the property) is defined on lines 27 and 28:

/'l declare refresh sequence

sequence refresh_sequence is

{not cas_n and ras_n and we_n; [*1]; (not cas_n and not ras_n and we_n)[*2];
cas_n and ras_n};

The key part of the refresh protocol isthat we_n must be held high (write enable not
active) for the entire refresh cycle. Let’s check we_n in the Wave window to seeiif it
actually holds for the entire cycle.
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4 Right click the check_refresh_rate assertion in the Assertions Browser and select Add
Wave.

»¢ wave - default : =101 %]
Eile Edit Miew Insert Format Tools Window

| ZHE | s @ | KXl |[xmiQ QB |FiREE
# col out 5t0
ount 1000 01 Joo o1 Joo o

] B8] L S]]

' ref_count TOOOT 0. }11000,10111)107110,101081})10700/10011410010}10001

UL L U U SRR RN JUy
B

1em_stat IDLE JREF1 EEFZ IDLE JAC..

Ty A

ity

' ]
i St 7
Cursor 1 || 2400 ns I

b e o [ ] |
| 2542 ns to 3479 ns |

Virtual signal my_mem_state showstherefresh cycle. By dragging that signal soitisnext
to the assertion, we can easily see that we_n is high during REF1 only and not REF2.
Becausewe_nissupposed to be high through the entire refresh cycle, the assertion failed.

Next we need to access the source code for we_n to fix the problem. The easiest way to
do thisisviathe Dataflow window.
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5 Double-click on the we_n wave to open the Dataflow window.
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6 Scroll if necessary to find the component in the Dataflow pane and select the signal
assignment. The source code is now displayed in the Source window.

The bug is that the logic assigning we_n iswrong as it does not account for the REF2
